Subject: [dtn] I-D Action: draft-ietf-dtn-tcpclv4-00.txt

From: [email-masked]
Date: Wed, 19 Oct 2016 18:46:47 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Delay/Disruption Tolerant Networking of the IETF.

        Title           : Delay-Tolerant Networking TCP Convergence Layer Protocol Version 4 
        Authors         : Brian Sipos
                          Michael Demmer
                          Joerg Ott
                          Simon Perreault
	Filename        : draft-ietf-dtn-tcpclv4-00.txt
	Pages           : 31
	Date            : 2016-10-19

Abstract:
   This document describes a revised protocol for the TCP-based
   convergence layer for Delay-Tolerant Networking (DTN).  The protocol
   revision is based on implementation issues in the original [RFC7242]
   and updates to the Bundle Protocol contents, encodings, and
   convergence layer requirements in [I-D.ietf-dtn-bpbis].  The majority
   of this specification is unchanged from TCPCL version 3.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dtn-tcpclv4/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-dtn-tcpclv4-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian Sipos <[email-masked]>
Date: Thu, 27 Oct 2016 13:33:34 +0000

All,

I'm adding a few comments both for myself (to update the draft later) and for the list to know as sort of 'errata' on this I-D.

- The diagram in Figure 2 needs to be updated to include the now-mandatory LENGTH message immediately before the first DATA_SEGMENT message.

- The TLS best practices RFC7525 needs to move from the "informative" list to the "normative" list because it is cited from a requirement.

________________________________
From: dtn <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Wednesday, October 19, 2016 9:46:47 PM
To: [email-masked]
Cc: [email-masked]
Subject: [dtn] I-D Action: draft-ietf-dtn-tcpclv4-00.txt

Abstract:

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn