Subject: [dtn] draft-ietf-dtn-bpis CRC error handling

From: Lucas Kahlert <[email-masked]>
Date: Mon, 6 Feb 2017 18:31:32 +0100

Hello,

I am a German student implementiung the current draft-ietf-dtn-bpis in 
the context of the [µPCN project](http://upcn.eu/).

I came across the CRC validation and wonder what a bundle protocol agent 
should do if an CRC error occurs. Are there any development proposals 
for handling CRC errors. Currently µPCN siliently deletes any bundle 
with invalid CRC. Should the sender be notified about the transmission 
error?

Regrads,
Lucas Kahlert

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Tue, 7 Feb 2017 18:11:49 +0000

Hi, Lucas.  I think what µPCN already does is the right thing.  The most frequent cause of CRC errors will be transmission bit errors due to channel noise; dropping the bundle will silently trigger automatic retransmission, the right response.  Informing the source node of every channel bit hit would generate an awful lot of traffic, unnecessarily.

Scott

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Lucas Kahlert
Sent: Monday, February 6, 2017 9:32 AM
To: dtn <[email-masked]>
Subject: [dtn] draft-ietf-dtn-bpis CRC error handling

Hello,

I am a German student implementiung the current draft-ietf-dtn-bpis in the context of the [µPCN project](http://upcn.eu/).

I came across the CRC validation and wonder what a bundle protocol agent should do if an CRC error occurs. Are there any development proposals for handling CRC errors. Currently µPCN siliently deletes any bundle with invalid CRC. Should the sender be notified about the transmission error?

Regrads,
Lucas Kahlert

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn