Subject: [dtn] I-D Action: draft-ietf-dtn-tcpclv4-03.txt

From: [email-masked]
Date: Wed, 15 Nov 2017 19:35:16 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Delay/Disruption Tolerant Networking WG of the IETF.

        Title           : Delay-Tolerant Networking TCP Convergence Layer Protocol Version 4
        Authors         : Brian Sipos
                          Michael Demmer
                          Joerg Ott
                          Simon Perreault
	Filename        : draft-ietf-dtn-tcpclv4-03.txt
	Pages           : 37
	Date            : 2017-11-15

Abstract:
   This document describes a revised protocol for the TCP-based
   convergence layer (TCPCL) for Delay-Tolerant Networking (DTN).  The
   protocol revision is based on implementation issues in the original
   TCPCL Version 3 and updates to the Bundle Protocol contents,
   encodings, and convergence layer requirements in Bundle Protocl
   Version 7.  Several new IANA registries are defined for TCPCLv4 which
   define some behaviors inherited from TCPCLv3 but with updated
   encodings and/or semantics.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dtn-tcpclv4/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dtn-tcpclv4-03
https://datatracker.ietf.org/doc/html/draft-ietf-dtn-tcpclv4-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-tcpclv4-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian Sipos <[email-masked]>
Date: Thu, 16 Nov 2017 03:40:18 +0000

All,

This draft had been collecting dust since last week. It does not yet include any of Marious Feldman's comments, which I do plan to address, but does include several areas of change including adding the contact header 'extension items' size and also makes consistent some terms used throughout the draft (before there was a mix of "node" vs "endpoint").

Further changes will be coming to clarify some of the possible contact sequence logical paths and also shutdown logical paths.

Thanks and as always more comments welcome.

________________________________
From: dtn <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Wednesday, November 15, 2017 10:35:16 PM
To: [email-masked]
Cc: [email-masked]
Subject: [dtn] I-D Action: draft-ietf-dtn-tcpclv4-03.txt

Abstract:

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn