Subject: [dtn] IANA Media Type for BPbis (bpv7)

From: Brian Sipos <[email-masked]>
Date: Mon, 20 Nov 2017 17:18:05 +0000

All,

This is not a direct comment on the current BPbis I-D document, but a more general question while it is still in draft: Is there a benefit in having an IANA Media Type designated for BPv7 bundle content? The name could be something similar to "application/dtn-bundle+cbor".

I'm less concerned about the actual type name than having a type available. My interest is in archiving and serving opaque file content e.g. from a web service. It would be useful to have a more specific desgination than the more generic "application/cbor<https://www.iana.org/assignments/media-types/application/cbor>".

Would this be helpful to include in BPbis itself, while in-draft, or would this be too contentious and be better off in a separate I-D just to register a type with a specific use case?

---

From: "Clark, Gilbert" <[email-masked]>
Date: Mon, 20 Nov 2017 20:20:52 +0000

I personally think I'd be more inclined to target any media type specification to a bundle's content, rather than targeting a media type specification toward the bundle itself.  It does seem somewhat backwards to me to build a tight coupling between any one service output and an associated transport type.

Your mileage, of course, may vary :)

-Gilbert

________________________________
From: dtn <[email-masked]> on behalf of Brian Sipos <[email-masked]>
Sent: Monday, November 20, 2017 12:18:05 PM
To: [email-masked]
Subject: [dtn] IANA Media Type for BPbis (bpv7)

All,