Subject: [dtn] BPbis: Let's move a step further...

From: Marius Feldmann <[email-masked]>
Date: Wed, 15 Nov 2017 22:12:40 +0100

Hi all,

unfortunately, I will not be able to attend the DTN WG meeting tomorrow.

However, as maintainer of a DTN protocol implementation (uPCN) I would
like to state strong support for moving forward with BPbis and make it
finally a standard.

My team (including e.g. Lucas who has sent some results of our
discussions to this list) and I had a quite close look at BPbis during
the last months. We have created an implementation of BPbis which will
be hopefully space-tested in the beginning of 2019 and have decomposed
the protocol in a semi-formal manner (see e.g. [1]).

For sure there are always some aspects which are "a matter of taste" in
engineering results. There may be a few minor things that we still could
discuss eternally - partially on a philosophical level. However, in my
opinion the current version of BPbis is a fundamental solution to a well
understood problem. The spec is easy to understand and implementing it
is really straightforward.

Currently, quite some activity for further running BPbis code has
started. Yesterday, I had a quite long phone call with a guy from a
company named x-works working on a further BPbis implementation within a
commercial project. Besides this, JPL's ION implementation also seems to
move into the BPbis direction.

Thus, running code exists and further code is on its way. Let's really
move forward to the next step!

To emphazise this: BPbis first, everything else second (the other specs
may be a matter of further discussion).

Marius

[1] https://upcn.eu/Bundle_Protocol.png

---

From: Carlo Caini <[email-masked]>
Date: Thu, 16 Nov 2017 11:26:50 +0100

Dear friends and colleagues,
                I fully agree with Marius about the necessity of 
having the current BPbis draft approved.  Marius' phrase "A 
fundamental solution to a well understood problem" seems to me a 
perfect definition of the current situation. After many years of 
experiments with encouraging results on a wide variety of application 
fields, including space but also terrestrial applications, I believe 
that the BPbis draft fully deserves IETF approval.
Yours,
    Carlo

At 22:12 15/11/2017, Marius Feldmann wrote:
>_______________________________________________
>dtn mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dtn

---

From: <[email-masked]>
Date: Thu, 16 Nov 2017 13:11:02 +0000

Hey everyone,
I wholeheartedly agree with Marius. I believe that it is critical to focus on the standardization of BPBis, prioritizing that above any other workgroup tasks. We're at a moment where multiple DTN implementations are being spun up and utilized, either as a stand-alone application, or as a subset of larger projects.

Thanks,
Jeremy

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Marius Feldmann
Sent: Mittwoch, 15. November 2017 22:13
To: [email-masked]
Subject: [dtn] BPbis: Let's move a step further...

Hi all,

However, as maintainer of a DTN protocol implementation (uPCN) I would like to state strong support for moving forward with BPbis and make it finally a standard.

My team (including e.g. Lucas who has sent some results of our discussions to this list) and I had a quite close look at BPbis during the last months. We have created an implementation of BPbis which will be hopefully space-tested in the beginning of 2019 and have decomposed the protocol in a semi-formal manner (see e.g. [1]).

For sure there are always some aspects which are "a matter of taste" in engineering results. There may be a few minor things that we still could discuss eternally - partially on a philosophical level. However, in my opinion the current version of BPbis is a fundamental solution to a well understood problem. The spec is easy to understand and implementing it is really straightforward.

Currently, quite some activity for further running BPbis code has started. Yesterday, I had a quite long phone call with a guy from a company named x-works working on a further BPbis implementation within a commercial project. Besides this, JPL's ION implementation also seems to move into the BPbis direction.

Thus, running code exists and further code is on its way. Let's really move forward to the next step!

To emphazise this: BPbis first, everything else second (the other specs may be a matter of further discussion).

Marius

---

From: "Clark, Gilbert" <[email-masked]>
Date: Sun, 19 Nov 2017 23:57:54 +0000

Hi,

Out of curiosity, what implementations do presently exist for the draft specification?

I've seen uPCN, but this comment made me curious about others.

Cheers,

Gilbert

________________________________
From: dtn <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Thursday, November 16, 2017 8:11:02 AM
To: [email-masked]; [email-masked]
Subject: Re: [dtn] BPbis: Let's move a step further...

Hey everyone,

Thanks,
Jeremy

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Marius Feldmann
Sent: Mittwoch, 15. November 2017 22:13
To: [email-masked]
Subject: [dtn] BPbis: Let's move a step further...

Hi all,

Marius

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Tue, 21 Nov 2017 00:14:35 +0000

I think Jeremy's remark was with reference to DTN in general rather than to bpbis in particular.  Most of the current DTN work is based on RFC5050; that will change when there's an RFC for bpbis, but we're not there yet.  I don't know of any bpbis implementations beyond uPCN.

Scott

From: dtn [mailto:[email-masked]] On Behalf Of Clark, Gilbert
Sent: Sunday, November 19, 2017 3:58 PM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [dtn] BPbis: Let's move a step further...

Hi,

Cheers,

Gilbert

________________________________
From: dtn <[email-masked]<mailto:[email-masked]>> on behalf of [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, November 16, 2017 8:11:02 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [dtn] BPbis: Let's move a step further...

Hey everyone,

Thanks,
Jeremy

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Marius Feldmann
Sent: Mittwoch, 15. November 2017 22:13
To: [email-masked]<mailto:[email-masked]>
Subject: [dtn] BPbis: Let's move a step further...

Hi all,

Marius

_______________________________________________
dtn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dtn

_______________________________________________
dtn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dtn

---

From: "Clark, Gilbert" <[email-masked]>
Date: Tue, 21 Nov 2017 13:49:02 +0000

Got it - thanks!

And yup, that's kind of what I figured.

-Gilbert

________________________________
From: Burleigh, Scott C (312B) <[email-masked]>
Sent: Monday, November 20, 2017 7:14:35 PM
To: Clark, Gilbert; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [dtn] BPbis: Let's move a step further...

I think Jeremy’s remark was with reference to DTN in general rather than to bpbis in particular.  Most of the current DTN work is based on RFC5050; that will change when there’s an RFC for bpbis, but we’re not there yet.  I don’t know of any bpbis implementations beyond uPCN.

Scott

Hi,

Cheers,

Gilbert

Hey everyone,

Thanks,
Jeremy

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Marius Feldmann
Sent: Mittwoch, 15. November 2017 22:13
To: [email-masked]<mailto:[email-masked]>
Subject: [dtn] BPbis: Let's move a step further...

Hi all,

Marius

---

From: <[email-masked]>
Date: Tue, 21 Nov 2017 13:49:47 +0000

Hey,
Sorry for the silence, but that's exactly what I mean.

Thanks,
Jeremy

From: Clark, Gilbert [mailto:[email-masked]]
Sent: Dienstag, 21. November 2017 14:49
To: Burleigh, Scott C (312B); Mayer, Jeremy; [email-masked]; [email-masked]
Subject: Re: [dtn] BPbis: Let's move a step further...

Got it - thanks!

-Gilbert

________________________________
From: Burleigh, Scott C (312B) <[email-masked]<mailto:[email-masked]>>
Sent: Monday, November 20, 2017 7:14:35 PM
To: Clark, Gilbert; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [dtn] BPbis: Let's move a step further...

Scott

From: dtn [mailto:[email-masked]] On Behalf Of Clark, Gilbert
Sent: Sunday, November 19, 2017 3:58 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [dtn] BPbis: Let's move a step further...

Hi,

Cheers,

Gilbert

Hey everyone,

Thanks,
Jeremy

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Marius Feldmann
Sent: Mittwoch, 15. November 2017 22:13
To: [email-masked]<mailto:[email-masked]>
Subject: [dtn] BPbis: Let's move a step further...

Hi all,

Marius