Subject: [dtn] BPbis implementation at IETF Hackathon

From: Felix Walter <[email-masked]>
Date: Wed, 21 Mar 2018 22:32:34 +0100

Dear DTN Folks,

During last weekend's IETF Hackathon, the guys from X-works [1] and me
(as one of the developers of uPCN [2]) put together a proof-of-concept
Python implementation of the draft-ietf-dtn-bpbis-10 bundle format. We
further implemented TCPCL (though, still v3 in that case), and let it
"talk" to uPCN. Using available Python CBOR libraries, the bpbis
implementation was straightforward. As a result of the Hackathon, we
have shown interopability with uPCN and built a small Docker-based test
setup with two nodes. Additionally, the bpbis implementation inside uPCN
could be updated from bpbis draft version 06 to the current draft
version 10. All in all, it was great fun to work on this and we had very
productive discussions.

Furthermore, during the course of the Hackathon, I again had a close
look at the current bpbis draft. I think it has matured very well and is
ready to become a standard.

I'm looking forward to seeing you on Friday.

Best,
Felix

[1] https://x-works.sk/
[2] https://upcn.eu

-- 
Dipl.-Ing. Felix Walter

Technische Universität Dresden
Fakultät Informatik
Institut für Systemarchitektur
Professur Rechnernetze

Mail: [email-masked]
Tel.: +49 351 463-38233

Büro: Nöthnitzer Str. 46
      01187 Dresden
      Raum APB/3101

---

From: <[email-masked]>
Date: Thu, 22 Mar 2018 06:43:23 +0000

Felix,
Congratulations, that's awesome! Do you guys have any plans to release the PyDTN implementation in the coming days/weeks/months?

Thanks,
Jeremy

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Felix Walter
Sent: Mittwoch, 21. März 2018 22:33
To: [email-masked]
Subject: [dtn] BPbis implementation at IETF Hackathon

Dear DTN Folks,

During last weekend's IETF Hackathon, the guys from X-works [1] and me (as one of the developers of uPCN [2]) put together a proof-of-concept Python implementation of the draft-ietf-dtn-bpbis-10 bundle format. We further implemented TCPCL (though, still v3 in that case), and let it "talk" to uPCN. Using available Python CBOR libraries, the bpbis implementation was straightforward. As a result of the Hackathon, we have shown interopability with uPCN and built a small Docker-based test setup with two nodes. Additionally, the bpbis implementation inside uPCN could be updated from bpbis draft version 06 to the current draft version 10. All in all, it was great fun to work on this and we had very productive discussions.

Furthermore, during the course of the Hackathon, I again had a close look at the current bpbis draft. I think it has matured very well and is ready to become a standard.

Best,
Felix

[1] https://x-works.sk/
[2] https://upcn.eu

--
Dipl.-Ing. Felix Walter

Büro: Nöthnitzer Str. 46
      01187 Dresden
      Raum APB/3101

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn

---

From: Felix Walter <[email-masked]>
Date: Thu, 22 Mar 2018 09:41:34 +0100

Hi Jeremy,

Yes, we certainly do! We still need some time to sort out the details,
but there will be a release of the code plus a new version of uPCN
including the mentioned changes. I expect this to happen within the next
~2 months. We will be announcing the release on the list.

Felix

---

From: Rick Taylor <[email-masked]>
Date: Thu, 22 Mar 2018 11:48:04 +0000

Hi Felix,

Would you like to say a few words about it at the DTN session?  We have
a few minutes reserved at the end of the agenda for topics like this.

Cheers,

Rick

On Thu, 2018-03-22 at 09:41 +0100, Felix Walter wrote:
> > Congratulations, that's awesome! Do you guys have any plans to
> > release the PyDTN implementation in the coming days/weeks/months?
> > 
> > Thanks,
> > Jeremy
> > 
> > During last weekend's IETF Hackathon, the guys from X-works [1] and
> > me (as one of the developers of uPCN [2]) put together a proof-of-
> > concept Python implementation of the draft-ietf-dtn-bpbis-10 bundle
> > format. We further implemented TCPCL (though, still v3 in that
> > case), and let it "talk" to uPCN. Using available Python CBOR
> > libraries, the bpbis implementation was straightforward. As a
> > result of the Hackathon, we have shown interopability with uPCN and
> > built a small Docker-based test setup with two nodes. Additionally,
> > the bpbis implementation inside uPCN could be updated from bpbis
> > draft version 06 to the current draft version 10. All in all, it
> > was great fun to work on this and we had very productive
> > discussions.
> > 
> > Furthermore, during the course of the Hackathon, I again had a
> > close look at the current bpbis draft. I think it has matured very
> > well and is ready to become a standard.
> >

---

From: Felix Walter <[email-masked]>
Date: Thu, 22 Mar 2018 12:42:11 +0000

Hi Rick,

Sure, if there is some time at the end, I can happily give a short overview.

Felix

---

From: Martin Pilka <[email-masked]>
Date: Thu, 22 Mar 2018 21:55:11 +0100

Hello Jeremy,
as Felix said, we are planning to release code, however if you do not feel 
like waiting I can make it available for you immediately, just note that:

1) About 1/3 of the code was created on Hackaton and needs some cleaning, 
although it is not too bad
2) This is partial BP implementation, contains bundle encoding/decoding and 
IPND (which works but was not really used in final Docker setup)

If you are still interested, Felix can give you tomorrow *.tar.gz 
containing all the code.

@Scott: Btw. this is the Python implementation you suggested on our 
personal meeting in Prag last year, so I did not forget :-) anyway it does 
not implement whole BP.

Thanks,
Martin

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Fri, 23 Mar 2018 00:48:35 +0000

This really is terrific, Martin.  And much as I am in awe of you guys being able to put this code together so fast, I am personally gratified that the specification turned out to be implementable!

Scott

-----Original Message-----
From: dtn <[email-masked]> On Behalf Of Martin Pilka
Sent: Thursday, March 22, 2018 1:55 PM
To: [email-masked]; [email-masked]
Subject: Re: [dtn] BPbis implementation at IETF Hackathon

Hello Jeremy,
as Felix said, we are planning to release code, however if you do not feel like waiting I can make it available for you immediately, just note that:

1) About 1/3 of the code was created on Hackaton and needs some cleaning, although it is not too bad
2) This is partial BP implementation, contains bundle encoding/decoding and IPND (which works but was not really used in final Docker setup)

If you are still interested, Felix can give you tomorrow *.tar.gz containing all the code.

@Scott: Btw. this is the Python implementation you suggested on our personal meeting in Prag last year, so I did not forget :-) anyway it does not implement whole BP.

Thanks,
Martin

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 23 Mar 2018 01:54:56 +0000

Speaking as the responsible AD for DTN, I'm more thrilled than Scott is ;-)

Spencer

On Fri, Mar 23, 2018, 00:49 Burleigh, Scott C (312B) <
[email-masked]> wrote:

> This really is terrific, Martin.  And much as I am in awe of you guys
> being able to put this code together so fast, I am personally gratified
> that the specification turned out to be implementable!
>
> Scott
>

---

From: Brian Haberman <[email-masked]>
Date: Fri, 23 Mar 2018 04:03:04 -0400

I would highly recommend adding an RFC 7942 section to the BPbis draft
given the hard work done here.

Brian

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Fri, 23 Mar 2018 08:10:42 +0000

Thanks, Brian -- the BPbis draft has some RFC 7942 material in section 8, discussing the uPCN implementation, and I certainly agree that notes on the PyDTN work should be added there.

Scott

-----Original Message-----
From: dtn <[email-masked]> On Behalf Of Brian Haberman
Sent: Friday, March 23, 2018 1:03 AM
To: [email-masked]
Subject: Re: [dtn] BPbis implementation at IETF Hackathon

I would highly recommend adding an RFC 7942 section to the BPbis draft given the hard work done here.

Brian

On 3/22/18 9:54 PM, Spencer Dawkins at IETF wrote:
>> being able to put this code together so fast, I am personally 
>> gratified that the specification turned out to be implementable!
>>
>> Scott
>>
> 
> 
>

---

From: Rick Taylor <[email-masked]>
Date: Fri, 23 Mar 2018 09:19:28 +0000

I must admit that I am very proud that, unlike some WGs, we seem to
have rough consensus *and* running code for BPbis.

Well done guys, and thank you.

Rick

On Fri, 2018-03-23 at 08:10 +0000, Burleigh, Scott C (312B) wrote:
> Thanks, Brian -- the BPbis draft has some RFC 7942 material in
> section 8, discussing the uPCN implementation, and I certainly agree
> that notes on the PyDTN work should be added there.
> 
> Scott
> 
> > Speaking as the responsible AD for DTN, I'm more thrilled than
> > Scott 
> > is ;-)
> > 
> > Spencer
> >