Subject: [Dyncast] Fw: New Version Notification for draft-liu-dyncast-ps-usecases-00.txt

From: 刘鹏<[email-masked]>
Date: 01 Feb 2021 18:22:08 +0800

Dear all, 

Welcome all to the mailing list for the problem of and work on dynamic anycast, enabling the consideration of compute and network metrics in the decision to route a flow of packets among more than one service instance. We have now uploaded the use case and problem statement draft, outlining a few pertinent use cases for this work, as well as shortcomings of existing solutions and requirements for a desirable solution. It is the intention to use this draft to frame the discussion towards a possible solution proposal. To this end, we also plan on releasing a first version of an architecture draft soon.

In the meantime, any comments and discussion on the use case and problem statement draft is highly welcome!

Best,

Peng Liu

Peng Liu | 刘鹏

China Mobile | 移动研究院

mobile phone：13810146105

email:  [email-masked]

发件人: internet-drafts

时间: 2021/02/01(星期一)18:15

收件人: Dirk Trossen;Peng Liu;Peter Willis;

主题: New Version Notification for draft-liu-dyncast-ps-usecases-00.txt
A new version of I-D, draft-liu-dyncast-ps-usecases-00.txt
has been successfully submitted by Dirk Trossen and posted to the
IETF repository.

Name:draft-liu-dyncast-ps-usecases
Revision:00
Title:Dynamic-Anycast (Dyncast) Use Cases and Problem Statement
Document date:2021-02-01
Group:Individual Submission
Pages:14
URL:            https://www.ietf.org/archive/id/draft-liu-dyncast-ps-usecases-00.txt
Status:         https://datatracker.ietf.org/doc/draft-liu-dyncast-ps-usecases/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-liu-dyncast-ps-usecases
Htmlized:       https://tools.ietf.org/html/draft-liu-dyncast-ps-usecases-00

Abstract:
   Service providers are exploring the edge computing to achieve better
   response time, control over data and carbon energy saving by moving
   the computing services towards the edge of the network in 5G MEC
   (Multi-access Edge Computing) scenarios, virtualized central office,
   and others.  Providing services by sharing computing resources from
   multiple edges is an emerging concept that is becoming more useful
   for computationally intensive tasks. Ideally, services should be
   computationally balanced using service-specific metrics instead of
   simply  dispatching the service in a static way, e.g., to the
   geographically closest edge since this may cause unbalanced usage of
   computing resources at edges which further degrades user experience
   and system utilization. This draft provides an overview of scenarios
   and problems associated with realizing such scenarios.

   The document identifies several key areas which require more
   investigations in terms of architecture and protocol to achieve
   balanced computing and networking resource utilization among edges
   providing the services.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 1 Feb 2021 09:24:08 -0500

This problem statement draft seems to assume a particular approach to 
the solution.

It is not at all obvious, absent the assumptions, that one wants to put 
the information into routing at all.  There are multiple approaches that 
address the problem that do not require the use of anycast addressing or 
injecting the application placement dynamics into the underlying routing 
system.

Yours,
Joel

On 2/1/2021 5:22 AM, 刘鹏 wrote:
> Dear all,
> 
> 
> Welcome all to the mailing list for the problem of and work on dynamic 
> anycast, enabling the consideration of compute and network metrics in 
> the decision to route a flow of packets among more than one service 
> instance. We have now uploaded the use case and problem statement draft, 
> outlining a few pertinent use cases for this work, as well as 
> shortcomings of existing solutions and requirements for a desirable 
> solution. It is the intention to use this draft to frame the discussion 
> towards a possible solution proposal. To this end, we also plan on 
> releasing a first version of an architecture draft soon.
> 
> email: _ [email-masked]
> 
>     发件人: internet-drafts <mailto:[email-masked]>
>     时间: 2021/02/01(星期一)18:15
>     收件人: Dirk Trossen <mailto:[email-masked]>;Peng Liu
>     <mailto:[email-masked]>;Peter Willis
>     <mailto:[email-masked]>;
> Name: draft-liu-dyncast-ps-usecases
> Revision: 00
> Title: Dynamic-Anycast (Dyncast) Use Cases and Problem Statement
> Document date: 2021-02-01
> Group: Individual Submission
> Pages: 14
> Htmlized: 
> https://datatracker.ietf.org/doc/html/draft-liu-dyncast-ps-usecases

---

From: liupengyjy <[email-masked]>
Date: Tue, 02 Feb 2021 10:14:48 +0800

Hi Joel, 
The draft analyzes the gap of existing methods, and does not rule out other methods can be implemented, but the efficiency needs to be verified.  Moreover, in the edge computing scenario, many native services are deployed by operators, so we think that the method of using anycast is feasible.

Best, Peng Liu

发件人： "JoelM.Halpern" <[email-masked]>

发送日期： Mon Feb 01 22:24:08 GMT+08:00 2021

收件人： dyncast <[email-masked]>

主题： Re: [Dyncast] Fw: New Version Notification fordraft-liu-dyncast-ps-usecases-00.txt

Yours,
Joel

In the meantime, any comments and discussion on the use case and problem 
statement draft is highly welcome!

Best,

Peng Liu

Peng Liu | 刘鹏
China Mobile | 移动研究院
mobile phone：13810146105

Abstract:

The IETF Secretariat

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 1 Feb 2021 21:26:48 -0500

There are two quite separate issues.
As a new activity, a problem statement can be very useful.  But for it 
to be useful, it needs to avoid presupposing a solution.
So I would strongly recommend that all the solution oriented material be 
removed to a separate draft.

As a second matter, in any solution draft, any proposal that wants to 
make use of anycast and routing state needs to discuss the state and 
information propagation aspects of any such proposals.

Yours,
Joel

On 2/1/2021 9:14 PM, liupengyjy wrote:
> Hi Joel,
> 
> The draft analyzes the gap of existing methods, and does not rule out 
> other methods can be implemented, but the efficiency needs to be verified.
> Moreover, in the edge computing scenario, many native services are 
> deployed by operators, so we think that the method of using anycast is 
> feasible.
> 
> Best,
> Peng Liu
> 
> 
> 
> 
> ------------------------------------------------------------------------
> *发件人：* "JoelM.Halpern" <[email-masked]>
> *发送日期：* Mon Feb 01 22:24:08 GMT+08:00 2021
> *收件人：* dyncast <[email-masked]>
> *主题：* Re: [Dyncast] Fw: New Version Notification 
> fordraft-liu-dyncast-ps-usecases-00.txt
> 
> URL:https://www.ietf.org/archive/id/draft-liu-dyncast-ps-usecases-00.txt  <https://www.ietf.org/archive/id/draft-liu-dyncast-ps-usecases-00.txt>
> Status:https://datatracker.ietf.org/doc/draft-liu-dyncast-ps-usecases  <https://datatracker.ietf.org/doc/draft-liu-dyncast-ps-usecases>/
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-liu-dyncast-ps-usecases  <https://datatracker.ietf.org/doc/html/draft-liu-dyncast-ps-usecases>
> Htmlized:https://tools.ietf.org/html/draft-liu-dyncast-ps-usecases-00  <https://tools.ietf.org/html/draft-liu-dyncast-ps-usecases-00>
> 
> Abstract:
> until the htmlized version and diff are available attools.ietf.org  <http://tools.ietf.org>.
> 
> The IETF Secretariat
>