Subject: Re: [EAI] help

From: "arfan mansoor" <[email-masked]>
Date: Thu, 4 Sep 2008 09:04:05 +0500

Will Punycode converter work for EAI as it works for IDNs where we convert
IDN to ASCII string through Punycode algorithm?

Regards
Arfan

On Fri, Aug 29, 2008 at 6:38 AM, YAO Jiankang <[email-masked]> wrote:

>
> ----- Original Message -----
> From: "Stephane Bortzmeyer" <[email-masked]>
> To: "arfan mansoor" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, August 28, 2008 8:51 PM
> Subject: Re: [EAI] help
>
>
> > On Thu, Aug 21, 2008 at 11:50:47AM +0500,
> > arfan mansoor <[email-masked]> wrote
> > a message of 38 lines which said:
> >
> >> We are doing work for Urdu (Pakistan language) EAI.  I want to know
> >> progress about other languages, has any one implemented this
> >> successfully and at what level this implementation is possible?
> >
> > I feel confused. There is nothing language-specific in the EAI
> > standards, so any good EAI mail server should work for every language
> > on earth.
>
> yes, agree.
>
> arfan mansoor's meaning may be that whether some tests of the email address
> based on Urdu  has been done. is the email address of [Urdu Name]@[Urdu IDN]
> workable? or are there someone who configured the EAI email server to
> support [Urdu Name]@[Urdu IDN] ?
>
>
> >
> > May be you are talking about the development of a MUA, where,
> > certainly, language-specific issues are to be considered? But, if it
> > is the case, isn't it quite ott-topic for this group?
> > _______________________________________________
> > IMA mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ima
> >
_______________________________________________
IMA mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ima

---

From: "YAO Jiankang" <[email-masked]>
Date: Thu, 4 Sep 2008 12:56:29 +0800

a lot of issues you raised has been discussed; you'd better take a look at the  list 

(http://www.ietf.org/mail-archive/web/ima/current/index.html) and you will find an answer.

  ----- Original Message ----- 
  From: arfan mansoor 
  To: YAO Jiankang 
  Cc: Stephane Bortzmeyer ; [email-masked] 
  Sent: Thursday, September 04, 2008 12:04 PM
  Subject: Re: [EAI] help

  Will Punycode converter work for EAI as it works for IDNs where we convert IDN to ASCII string through Punycode algorithm? 

  Regards
  Arfan 

    ----- Original Message -----
    From: "Stephane Bortzmeyer" <[email-masked]>
    To: "arfan mansoor" <[email-masked]>
    Cc: <[email-masked]>
    Sent: Thursday, August 28, 2008 8:51 PM
    Subject: Re: [EAI] help

    yes, agree.

    arfan mansoor's meaning may be that whether some tests of the email address based on Urdu  has been done. is the email address of [Urdu Name]@[Urdu IDN] workable? or are there someone who configured the EAI email server to support [Urdu Name]@[Urdu IDN] ?

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 4 Sep 2008 09:59:57 +0200

On Thu, Sep 04, 2008 at 09:04:05AM +0500,
 arfan mansoor <[email-masked]> wrote 
 a message of 96 lines which said:

> Will Punycode converter work for EAI as it works for IDNs where we
> convert IDN to ASCII string through Punycode algorithm?

There are not many uses of Punycode in EAI. One is, for instance, the
initial greeting EHLO where you cannot (yet) use UTF-8 for the host
name. But, apart from a few cases like this one, why worrying about
Punycode?
_______________________________________________
IMA mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ima

---

From: "arfan mansoor" <[email-masked]>
Date: Wed, 10 Sep 2008 11:51:24 +0500

Dear Jiankang

> so any good EAI mail server should work for every language
> on earth.

Would you please list some examples of such EAI supported email servers? Is
there any community working on EAI support in ThunderBird?