Subject: [eap] Issue 44: Peer-to-Peer Operation of EAP

From: [email-masked] (Garces, Rodrigo)
Date: Wed, 27 Nov 2002 14:14:03 -0800

I do not think that 802.1X allows this switch.=20

Rodrigo

-----Original Message-----
From: Jari Arkko [mailto:[email-masked]]
Sent: Wednesday, November 27, 2002 10:53 AM
To: Bernard Aboba
Cc: [email-masked]
Subject: Re: [eap] Issue 44: Peer-to-Peer Operation of EAP

Bernard Aboba wrote:

> Since EAP is a peer-to-peer protocol, this should be added to the
> description of how the protocol operates.
>=20
> Add the following text to section 2:
>=20
> "[7] Since EAP is a peer-to-peer protocol, after authentication in one
> direction is complete, the direction of authentication
> MAY reverse, with the endpoint previously serving as the Authenticator
> assuming the Peer role, and the former Peer now taking on the
> Authenticator role. As with the original conversation, the reversal is
> signaled by the (new) Authenticator sending a Request."

Hmm... this has interesting implications for the state machine
design! Is there any possibility of having two "instances" of
EAP running in different directions instead of doing both for the
same EAP run? Can EAP "host" protocols such as PPP or 802.1X
allow more than one EAP "run"?

What about backwards compatibility? I suppose on PPP most =
implementations
would allow this, right? What about 802.1X?

Jari

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: [email-masked] (Bernard Aboba)
Date: Wed, 27 Nov 2002 13:43:32 -0800 (PST)

> I do not think that 802.1X allows this switch.

It's possible for a client to support both Supplicant and Authenticator
roles, and in fact this is required in 802.11i adhoc mode.