Subject: [Ecrit] Proposal to add "applicability" statement to -framework/-phonebcp

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 23 Mar 2009 19:17:16 -0400

In the meeting, there was not consensus on  having applicability
statements.  I would like to propose the following be added to both
documents:

This document describes a typical Internet environment where the
endpoint device bears most of the burden of implementing emergency
calls, and the origination network has a minor role.  The underlying
specifications permit the network to take a more expansive role in
emergency calls, which Is not covered extensively in this document.

---

From: Richard Barnes <[email-masked]>
Date: Mon, 23 Mar 2009 16:27:28 -0700

Editorial changes:

This document describes an architecture for emergency calling in the 
typical Internet environment, in which the calling device bears most of 
the burden of implementing emergency calls, and the caller's IP access 
network has a supporting role.  The underlying specifications allow for 
the network to take a more expansive role in emergency calls, but such 
cases are not covered extensively in this document.

Rosen, Brian wrote:
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 23 Mar 2009 19:30:35 -0400

Nah, it's not the access network (AN) it's the calling service provider
(SP) that is affected.  The examples are adding location (who adds the
Geolocation header) and the LoST query.  Both of those would be done by
the SIP calling network in, for example, an IMS system.

Brian

-----Original Message-----
From: Richard Barnes [mailto:[email-masked]] 
Sent: Monday, March 23, 2009 7:27 PM
To: Rosen, Brian
Cc: ECRIT
Subject: Re: [Ecrit] Proposal to add "applicability" statement to
-framework/-phonebcp

Editorial changes:

---

From: "James M. Polk" <[email-masked]>
Date: Mon, 23 Mar 2009 18:33:27 -0500

both versions beg the question:

         - so where are they covered?

(re: the end of the last sentence)

James

At 06:27 PM 3/23/2009, Richard Barnes wrote:
>typical Internet environment, in which the calling device bears most 
>of the burden of implementing emergency calls, and the caller's IP 
>access network has a supporting role.  The underlying specifications 
>allow for the network to take a more expansive role in emergency 
>calls, but such cases are not covered extensively in this document.
>
>
>
>Rosen, Brian wrote:

---

From: Richard Barnes <[email-masked]>
Date: Mon, 23 Mar 2009 16:34:41 -0700

In a future document.  I volunteer Ted.

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 23 Mar 2009 19:34:59 -0400

Some other document, in some other organization probably.

Brian

-----Original Message-----
From: James M. Polk [mailto:[email-masked]] 
Sent: Monday, March 23, 2009 7:33 PM
To: Richard Barnes; Rosen, Brian
Cc: ECRIT
Subject: Re: [Ecrit] Proposal to add "applicability" statement to
-framework/-phonebcp

James

---

From: Richard Barnes <[email-masked]>
Date: Mon, 23 Mar 2009 16:55:53 -0700

To be clear, it's the *Internet* Service Provider, not the *Voice* 
Service Provider, which may or may not be there.

In summary, s/IP access network/Internet Service Provider/

---

From: "Dawson, Martin" <[email-masked]>
Date: Mon, 23 Mar 2009 18:57:50 -0500

So - "Network operators and voice service providers may play a more
expansive role in the processing of emergency calls but any such
additional measures are outside the scope of this document"?

It feels like a pretty moot point to me. Why are we doing this?

Cheers,
Martin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Rosen, Brian
Sent: Tuesday, 24 March 2009 10:35 AM
To: James M. Polk; Richard Barnes
Cc: ECRIT
Subject: Re: [Ecrit] Proposal to add "applicability" statementto
-framework/-phonebcp

Brian

-----Original Message-----
From: James M. Polk [mailto:[email-masked]] 
Sent: Monday, March 23, 2009 7:33 PM
To: Richard Barnes; Rosen, Brian
Cc: ECRIT
Subject: Re: [Ecrit] Proposal to add "applicability" statement to
-framework/-phonebcp

James

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Dawson, Martin" <[email-masked]>
Date: Mon, 23 Mar 2009 18:58:49 -0500

Isn't that the other way around? The VSP may or may not be there?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Richard Barnes
Sent: Tuesday, 24 March 2009 10:56 AM
To: Rosen, Brian
Cc: ECRIT
Subject: Re: [Ecrit] Proposal to add "applicability" statementto
-framework/-phonebcp

> typical Internet environment, in which the calling device bears most
of

---

From: Richard Barnes <[email-masked]>
Date: Mon, 23 Mar 2009 17:03:53 -0700

That's what I meant:
-- ISP plays a role in Framework (i.e., it has requirements)
-- VSP does not (no requirements - may not be there)

---

From: "James M. Polk" <[email-masked]>
Date: Mon, 23 Mar 2009 19:04:21 -0500

>Some other document, in some other organization probably.

could that be said - to leave the read knowing we are purposely not 
answering the question "here".

---

From: Richard Barnes <[email-masked]>
Date: Mon, 23 Mar 2009 17:06:33 -0700

Updated proposal:

This document describes an architecture for emergency calling in the 
typical Internet environment, in which the calling device bears most of 
the burden of implementing emergency calls, and the caller's Internet 
Service Provider has a supporting role.  The underlying specifications 
allow for the network to take a more expansive role in emergency calls, 
but such cases are not covered extensively in this document (they are 
left for future study in other documents).

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 24 Mar 2009 01:20:16 +0100

Where you have said "network to take a more expansive role", I think generally we need to say we have not addressed the issues that may arise where it does so. That is essentially the crux of the difference between the two models, and we have agreed in the past that there is a framework/phonebcp phase 2 will attempt to address this issue.

Keith

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Richard Barnes
> Sent: Tuesday, March 24, 2009 12:07 AM
> To: James M. Polk
> Cc: Rosen, Brian; ECRIT
> Subject: Re: [Ecrit] Proposal to add "applicability" 
> statement to -framework/-phonebcp
> 
> Updated proposal:
> 
> This document describes an architecture for emergency calling 
> in the typical Internet environment, in which the calling 
> device bears most of the burden of implementing emergency 
> calls, and the caller's Internet Service Provider has a 
> supporting role.  The underlying specifications allow for the 
> network to take a more expansive role in emergency calls, but 
> such cases are not covered extensively in this document (they 
> are left for future study in other documents).
> 
> 
> 
> James M. Polk wrote:
> >> >>calls, and the origination network has a minor role.  The 
> >> >>underlying specifications permit the network to take a more 
> >> >>expansive role in emergency calls, which Is not covered 
> extensively in this document.
> >> >>
> >> >>
> >> 
> >>-------------------------------------------------------------------
> >> >>---
> >> --

---

From: Richard Barnes <[email-masked]>
Date: Mon, 23 Mar 2009 17:42:42 -0700

"but such cases (and any associated issues) are not covered extensively 
in this document; rather, they are left for future study in other 
documents."