Subject: [Ecrit] Reset 2: Framework text

From: Richard Barnes <[email-masked]>
Date: Wed, 25 Mar 2009 18:03:55 -0700

Proposal (trying to be more concrete):

This document focuses on the case in which all three steps in the 
emergency calling process -- location configuration, call routing, and 
call placement -- are performed by the calling endpoint, with the 
endpoint's Access Service Provider supporting the process by providing 
location information.  Calls may be routed via an application-layer 
Communications Service Provider (e.g., a Voice Service Provider), but 
need not be.  The underlying protocols can also be used to support other 
models in which parts of the process are delegated to the Communications 
Service Provider.  This document does not address in detail either these 
models or interoperability issues between them and the model described here.

---

From: "Dawson, Martin" <[email-masked]>
Date: Wed, 25 Mar 2009 20:15:28 -0500

+1 - I do like this better than anything else so far proposed.

Hopefully it can't be misrepresented - so we aren't dealing with an
"overcharge" button... :)

Cheers,
Martin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Richard Barnes
Sent: Thursday, 26 March 2009 12:04 PM
To: ECRIT
Subject: [Ecrit] Reset 2: Framework text

models or interoperability issues between them and the model described
here.

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 25 Mar 2009 20:35:51 -0500

This sounds more like the discussion in the room than previous versions, 
FWIW...

Spencer

---

From: "Edge, Stephen" <[email-masked]>
Date: Wed, 25 Mar 2009 22:39:55 -0700

I agree this may be heading in a mutually agreeable direction. But I have the following suggested changes. I am using a "**" to indicate the changes.

This document focuses on the case in which all three steps in the emergency calling process -- location configuration, call routing, and call placement - **can be and** are performed by the calling endpoint, with the endpoint's Access Service Provider supporting the process by providing location information.  Calls **in this case** may be routed via an application-layer Communications Service Provider (e.g., a Voice Service Provider), but need not be.  The underlying protocols can also be used to support other models in which parts of the process are delegated to the Communications Service Provider.  This document does not address in detail either these models or interoperability issues between them and the model described here.

The "can be" above automatically removes scenarios that cannot be supported (of course) without the need to elaborate on what these are - or even (for those with some views) whether they exist. The "in this case" applies the same restriction to CSP routing.

Kind Regards

Stephen
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Spencer Dawkins
Sent: Wednesday, March 25, 2009 6:36 PM
To: Dawson, Martin; Richard Barnes; ECRIT
Subject: Re: [Ecrit] Reset 2: Framework text

Spencer

---

From: "Dawson, Martin" <[email-masked]>
Date: Thu, 26 Mar 2009 00:50:04 -0500

These additions were implied in the original text and are redundant.
They only serve to convey some significance that isn't intended. I
prefer the clarity and economy of Richard's original.

Cheers,
Martin

-----Original Message-----
From: Edge, Stephen [mailto:[email-masked]] 
Sent: Thursday, 26 March 2009 4:40 PM
To: Spencer Dawkins; Dawson, Martin; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

I agree this may be heading in a mutually agreeable direction. But I
have the following suggested changes. I am using a "**" to indicate the
changes.

This document focuses on the case in which all three steps in the
emergency calling process -- location configuration, call routing, and
call placement - **can be and** are performed by the calling endpoint,
with the endpoint's Access Service Provider supporting the process by
providing location information.  Calls **in this case** may be routed
via an application-layer Communications Service Provider (e.g., a Voice
Service Provider), but need not be.  The underlying protocols can also
be used to support other models in which parts of the process are
delegated to the Communications Service Provider.  This document does
not address in detail either these models or interoperability issues
between them and the model described here.

The "can be" above automatically removes scenarios that cannot be
supported (of course) without the need to elaborate on what these are -
or even (for those with some views) whether they exist. The "in this
case" applies the same restriction to CSP routing.

Kind Regards

Stephen
-----Original Message-----
Of Spencer Dawkins

FWIW...

Spencer

> models or interoperability issues between them and the model described
------------------------------------------------------------------------
------------------------
> this email is prohibited.
------------------------------------------------------------------------
------------------------

---

From: "Edge, Stephen" <[email-masked]>
Date: Wed, 25 Mar 2009 23:36:50 -0700

Well it you want economy, the "can be and are" could be changed to just "can be" - there are plenty of "can be"s already in both drafts. But I think the wording below is more clear and only a couple of words longer. 

Kind Regards

Stephen
-----Original Message-----
From: Dawson, Martin [mailto:[email-masked]] 
Sent: Wednesday, March 25, 2009 10:50 PM
To: Edge, Stephen; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Cheers,
Martin

-----Original Message-----
From: Edge, Stephen [mailto:[email-masked]] 
Sent: Thursday, 26 March 2009 4:40 PM
To: Spencer Dawkins; Dawson, Martin; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Kind Regards

Stephen
-----Original Message-----

FWIW...

Spencer

---

From: "Dawson, Martin" <[email-masked]>
Date: Thu, 26 Mar 2009 02:51:45 -0500

No. I believe the original is clearer and more correct.

Cheers,
Martin

-----Original Message-----
From: Edge, Stephen [mailto:[email-masked]] 
Sent: Thursday, 26 March 2009 5:37 PM
To: Dawson, Martin; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Well it you want economy, the "can be and are" could be changed to just
"can be" - there are plenty of "can be"s already in both drafts. But I
think the wording below is more clear and only a couple of words longer.

Kind Regards

Stephen
-----Original Message-----
From: Dawson, Martin [mailto:[email-masked]] 
Sent: Wednesday, March 25, 2009 10:50 PM
To: Edge, Stephen; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Cheers,
Martin

-----Original Message-----
From: Edge, Stephen [mailto:[email-masked]] 
Sent: Thursday, 26 March 2009 4:40 PM
To: Spencer Dawkins; Dawson, Martin; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Kind Regards

Stephen
-----Original Message-----

FWIW...

Spencer

---

From: "Edge, Stephen" <[email-masked]>
Date: Thu, 26 Mar 2009 02:39:17 -0700

This means that about 95% of the wording could already be acceptable and that about 5% needs more discussion.

Is that too optimistic? If not, further views on the remaining 5% seem needed.

-----Original Message-----
From: Dawson, Martin [mailto:[email-masked]] 
Sent: Thursday, March 26, 2009 12:52 AM
To: Edge, Stephen; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Cheers,
Martin

-----Original Message-----
From: Edge, Stephen [mailto:[email-masked]] 
Sent: Thursday, 26 March 2009 5:37 PM
To: Dawson, Martin; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Kind Regards

Stephen
-----Original Message-----
From: Dawson, Martin [mailto:[email-masked]] 
Sent: Wednesday, March 25, 2009 10:50 PM
To: Edge, Stephen; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Cheers,
Martin

-----Original Message-----
From: Edge, Stephen [mailto:[email-masked]] 
Sent: Thursday, 26 March 2009 4:40 PM
To: Spencer Dawkins; Dawson, Martin; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Kind Regards

Stephen
-----Original Message-----

FWIW...

Spencer

---

From: "Dawson, Martin" <[email-masked]>
Date: Thu, 26 Mar 2009 05:54:56 -0500

I was discussing it?

I've expressed my view. The original is clearer and more correct.

Cheers,
Martin

-----Original Message-----
From: Edge, Stephen [mailto:[email-masked]] 
Sent: Thursday, 26 March 2009 8:39 PM
To: Dawson, Martin; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

This means that about 95% of the wording could already be acceptable and
that about 5% needs more discussion.

Is that too optimistic? If not, further views on the remaining 5% seem
needed.

-----Original Message-----
From: Dawson, Martin [mailto:[email-masked]] 
Sent: Thursday, March 26, 2009 12:52 AM
To: Edge, Stephen; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Cheers,
Martin

-----Original Message-----
From: Edge, Stephen [mailto:[email-masked]] 
Sent: Thursday, 26 March 2009 5:37 PM
To: Dawson, Martin; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Kind Regards

Stephen
-----Original Message-----
From: Dawson, Martin [mailto:[email-masked]] 
Sent: Wednesday, March 25, 2009 10:50 PM
To: Edge, Stephen; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Cheers,
Martin

-----Original Message-----
From: Edge, Stephen [mailto:[email-masked]] 
Sent: Thursday, 26 March 2009 4:40 PM
To: Spencer Dawkins; Dawson, Martin; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Kind Regards

Stephen
-----Original Message-----

FWIW...

Spencer

---

From: "Edge, Stephen" <[email-masked]>
Date: Thu, 26 Mar 2009 04:25:52 -0700

And I've discussed and expressed my view too - the new version is clearer and more correct.

That's why more discussion and other views are needed.

Kind Regards

Stephen
-----Original Message-----
From: Dawson, Martin [mailto:[email-masked]] 
Sent: Thursday, March 26, 2009 3:55 AM
To: Edge, Stephen; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

I was discussing it?

Cheers,
Martin

-----Original Message-----
From: Dawson, Martin [mailto:[email-masked]] 
Sent: Thursday, March 26, 2009 12:52 AM
To: Edge, Stephen; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Cheers,
Martin

-----Original Message-----
From: Edge, Stephen [mailto:[email-masked]] 
Sent: Thursday, 26 March 2009 5:37 PM
To: Dawson, Martin; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Kind Regards

Stephen
-----Original Message-----
From: Dawson, Martin [mailto:[email-masked]] 
Sent: Wednesday, March 25, 2009 10:50 PM
To: Edge, Stephen; Spencer Dawkins; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Cheers,
Martin

-----Original Message-----
From: Edge, Stephen [mailto:[email-masked]] 
Sent: Thursday, 26 March 2009 4:40 PM
To: Spencer Dawkins; Dawson, Martin; Richard Barnes; ECRIT
Subject: RE: [Ecrit] Reset 2: Framework text

Kind Regards

Stephen
-----Original Message-----

FWIW...

Spencer

---

From: "Stark, Barbara" <[email-masked]>
Date: Thu, 26 Mar 2009 11:22:28 -0400

I'm fine with Stephen's proposed wording.

The main thing I want to avoid is any suggestion that the IETF, in any
way, has the authority to impose this document on any entity. Statements
that try to say where or in which cases this document cannot be imposed,
suggest that such imposition could occur -- which is why I want to avoid
such statements.

The newest wording from Richard tells me about what case this document
was designed to be able to handle, without suggesting that it can or
must be imposed in that case (or not imposed in cases that differ from
the one described). That makes me happy.

Descriptions that help me understand what use case / model that the
editors had in mind are generally useful in understanding why the
requirements are what they are. Therefore, such descriptions are a
positive addition. That, too, makes me happy.

The revisions that Stephen proposes do not alter my reading of what the
paragraph says. It's obvious to me that endpoints that cannot perform
the steps in the doc, will not perform the steps; but I don't object to
saying that, if it helps us achieve consensus. I'm still happy.
Barbara

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Edge, Stephen
Sent: Thursday, March 26, 2009 1:40 AM
To: Spencer Dawkins; Dawson, Martin; Richard Barnes; ECRIT
Subject: Re: [Ecrit] Reset 2: Framework text

Kind Regards

Stephen
-----Original Message-----

FWIW...

Spencer

*****

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from all computers. GA622

---

From: "Brian Rosen" <[email-masked]>
Date: Thu, 26 Mar 2009 11:34:31 -0400

If this change is all we need to do to progress the document, then I am okay
with Stephen's addition.

If there are no more objections, I will release a rev ASAP.

Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stark, Barbara
Sent: Thursday, March 26, 2009 11:22 AM
To: Edge, Stephen; Spencer Dawkins; Dawson, Martin; Richard Barnes; ECRIT
Subject: Re: [Ecrit] Reset 2: Framework text

-----Original Message-----

Kind Regards

Stephen
-----Original Message-----

FWIW...

Spencer

*****

The information transmitted is intended only for the person or entity to
which it is addressed and may contain confidential, proprietary, and/or
privileged material. Any review, retransmission, dissemination or other use
of, or taking of any action in reliance upon this information by persons or
entities other than the intended recipient is prohibited. If you received
this in error, please contact the sender and delete the material from all
computers. GA622

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 26 Mar 2009 17:37:05 +0100

Do as you have said.

Keith 

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Brian Rosen
> Sent: Thursday, March 26, 2009 3:35 PM
> To: 'Stark, Barbara'; 'Edge, Stephen'; 'Spencer Dawkins'; 
> 'Dawson, Martin'; 'Richard Barnes'; 'ECRIT'
> If this change is all we need to do to progress the document, 
> then I am okay with Stephen's addition.
> 
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Stark, Barbara
> The main thing I want to avoid is any suggestion that the 
> IETF, in any way, has the authority to impose this document 
> on any entity. Statements that try to say where or in which 
> cases this document cannot be imposed, suggest that such 
> imposition could occur -- which is why I want to avoid such 
> statements.
> 
> The newest wording from Richard tells me about what case this 
> document was designed to be able to handle, without 
> suggesting that it can or must be imposed in that case (or 
> not imposed in cases that differ from the one described). 
> That makes me happy.
> 
> Descriptions that help me understand what use case / model 
> that the editors had in mind are generally useful in 
> understanding why the requirements are what they are. 
> Therefore, such descriptions are a positive addition. That, 
> too, makes me happy.
> 
> The revisions that Stephen proposes do not alter my reading 
> of what the paragraph says. It's obvious to me that endpoints 
> that cannot perform the steps in the doc, will not perform 
> the steps; but I don't object to saying that, if it helps us 
> achieve consensus. I'm still happy.
> Barbara
> 
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Edge, Stephen
> I agree this may be heading in a mutually agreeable 
> direction. But I have the following suggested changes. I am 
> using a "**" to indicate the changes.
> 
> This document focuses on the case in which all three steps in 
> the emergency calling process -- location configuration, call 
> routing, and call placement - **can be and** are performed by 
> the calling endpoint, with the endpoint's Access Service 
> Provider supporting the process by providing location 
> information.  Calls **in this case** may be routed via an 
> application-layer Communications Service Provider (e.g., a 
> Voice Service Provider), but need not be.  The underlying 
> protocols can also be used to support other models in which 
> parts of the process are delegated to the Communications 
> Service Provider.  This document does not address in detail 
> either these models or interoperability issues between them 
> and the model described here.
> 
> The "can be" above automatically removes scenarios that 
> cannot be supported (of course) without the need to elaborate 
> on what these are - or even (for those with some views) 
> whether they exist. The "in this case" applies the same 
> restriction to CSP routing.
> 
> Kind Regards
> 
> Stephen
> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > Of Richard Barnes
> > This message is for the designated recipient only and may contain 
> > privileged, proprietary, or otherwise private information.
> immediately 
> > and delete the original.  Any unauthorized use of this email is 
> > prohibited.
> >
> The information transmitted is intended only for the person 
> or entity to which it is addressed and may contain 
> confidential, proprietary, and/or privileged material. Any 
> review, retransmission, dissemination or other use of, or 
> taking of any action in reliance upon this information by 
> persons or entities other than the intended recipient is 
> prohibited. If you received this in error, please contact the 
> sender and delete the material from all computers. GA622
> 
>

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 26 Mar 2009 11:49:33 -0500

Agree...

Spencer

----- Original Message ----- 
From: "DRAGE, Keith (Keith)" <[email-masked]>
To: "Brian Rosen" <[email-masked]>; "'Stark, Barbara'" <[email-masked]>; 
"'Edge, Stephen'" <[email-masked]>; "'Spencer Dawkins'" 
<[email-masked]>; "'Dawson, Martin'" <[email-masked]>; 
"'Richard Barnes'" <[email-masked]>; "'ECRIT'" <[email-masked]>
Sent: Thursday, March 26, 2009 11:37 AM
Subject: RE: [Ecrit] Reset 2: Framework text

Do as you have said.

Keith

> On Behalf Of Spencer Dawkins

---

From: Randall Gellens <[email-masked]>
Date: Thu, 26 Mar 2009 10:17:43 -0700

At 11:22 AM -0400 3/26/09, Barbara Stark wrote:

>  way, has the authority to impose this document on any entity.

...

>  positive addition. That, too, makes me happy.

I think Barbara has said it very well.

Let's go with Stephen's proposed wording.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Nobody can be exactly like me. Even I have trouble doing it.
                                        --Tallulah Bankhead

---

From: "Roger Marshall" <[email-masked]>
Date: Thu, 26 Mar 2009 15:51:27 -0700

I'm also good with the Stephen worded version.

-roger.

> On Behalf Of Randall Gellens
> Sent: Thursday, March 26, 2009 10:18 AM
> To: Stark, Barbara; Edge, Stephen; Spencer Dawkins; Dawson, 
> Martin; Richard Barnes; ECRIT
> >  The main thing I want to avoid is any suggestion that the IETF, in 
> > any  way, has the authority to impose this document on any entity.
> 
> ...
> 
> that the  
> -------------- Randomly selected tag: --------------- Nobody 
> can be exactly like me. Even I have trouble doing it.
>                                         --Tallulah Bankhead 

CONFIDENTIALITY NOTICE: The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please notify the sender immediately, and delete it and all attachments from your computer and network.