Subject: Re: [Ecrit] Proposal to add "applicability" statementto -framework/-phonebcp

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 23 Mar 2009 22:36:02 -0400

No.

The ISP requirements are unwaivering.  The VSP requirements change.  The VSP, not the ISP adds location and route, not the ISP.

Brian
------Original Message------
From: Richard Barnes
To: Dawson, Martin
Cc: Brian Rosen
Cc: ECRIT
Sent: Mar 23, 2009 5:03 PM
Subject: Re: [Ecrit] Proposal to add "applicability" statementto	-framework/-phonebcp

That's what I meant:
-- ISP plays a role in Framework (i.e., it has requirements)
-- VSP does not (no requirements - may not be there)

Dawson, Martin wrote:
> Isn't that the other way around? The VSP may or may not be there?
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Richard Barnes
> Sent: Tuesday, 24 March 2009 10:56 AM
> To: Rosen, Brian
> Cc: ECRIT
> Subject: Re: [Ecrit] Proposal to add "applicability" statementto
> -framework/-phonebcp
> 
> To be clear, it's the *Internet* Service Provider, not the *Voice* 
> Service Provider, which may or may not be there.
> 
> In summary, s/IP access network/Internet Service Provider/
> 
> 
> Rosen, Brian wrote:
>> Nah, it's not the access network (AN) it's the calling service
> provider
>> (SP) that is affected.  The examples are adding location (who adds the
>> Geolocation header) and the LoST query.  Both of those would be done
> by
>> the SIP calling network in, for example, an IMS system.
>>
>> Brian
>>
>> -----Original Message-----
>> From: Richard Barnes [mailto:[email-masked]] 
>> Sent: Monday, March 23, 2009 7:27 PM
>> To: Rosen, Brian
>> Cc: ECRIT
>> Subject: Re: [Ecrit] Proposal to add "applicability" statement to
>> -framework/-phonebcp
>>
>> Editorial changes:
>>
>> This document describes an architecture for emergency calling in the 
>> typical Internet environment, in which the calling device bears most
> of 
>>

------Original Message Truncated------

--------------------------
Brian Rosen
NeuStar
(724) 382-1051
[email-masked]

---

From: "Dawson, Martin" <[email-masked]>
Date: Mon, 23 Mar 2009 21:47:34 -0500

Apart from Richard's original statement, which I think parses to be the
opposite of intent, I think we're all agreeing...

> Service Provider, which may or may not be there.

That statement actually says that the ISP may or may not be there. I
don't think anybody actually thinks an Internet emergency call can be
made without some access to the Internet... :-)

Cheers,

Martin

________________________________

From: Rosen, Brian [mailto:[email-masked]] 
Sent: Tuesday, 24 March 2009 1:36 PM
To: [email-masked]; Dawson, Martin
Cc: [email-masked]
Subject: Re: [Ecrit] Proposal to add "applicability" statementto
-framework/-phonebcp

No.

The ISP requirements are unwaivering.

[[MCD]] "requirements are unwaivering" = "it has requirements" in my
book. So I think we're saying the same thing.

The VSP requirements change.  The VSP, not the ISP adds location and
route, not the ISP.

[[MCD]] "requirements change" = "may not be there" by the same token.
The device may query the LIS and LoST and send the INVITE directly to
the PSAP URI... so, yes, the ISP doesn't do it but nor is it necessary
for some VSP to do it. I think that's what we're all saying.

Brian
------Original Message------
From: Richard Barnes
To: Dawson, Martin
Cc: Brian Rosen
Cc: ECRIT
Sent: Mar 23, 2009 5:03 PM
Subject: Re: [Ecrit] Proposal to add "applicability" statementto
-framework/-phonebcp

That's what I meant:

------Original Message Truncated------

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Richard Barnes <[email-masked]>
Date: Tue, 24 Mar 2009 10:25:41 -0700

Yes, I think we all agree, and agree that my original sentence was 
poorly constructed.

Updated proposal:

This document describes an architecture for emergency calling in the 
typical Internet environment, in which the calling device bears most of 
the burden of implementing emergency calls, and the caller's Internet 
Service Provider has a supporting role.  The underlying specifications 
allow for the network to take a more expansive role in emergency calls, 
but such cases (and any associated issues) are not covered extensively 
in this document; rather, they are left for future study in other 
documents.

---

From: Randall Gellens <[email-masked]>
Date: Tue, 24 Mar 2009 10:44:29 -0700

At 10:25 AM -0700 3/24/09, Richard Barnes wrote:

>  This document describes an architecture for emergency calling in 
> the typical Internet environment, in which the calling device bears 
> most of the burden of implementing emergency calls, and the 
> caller's Internet Service Provider has a supporting role.  The 
> underlying specifications allow for the network to take a more 
> expansive role in emergency calls, but such cases (and any 
> associated issues) are not covered extensively in this document; 
> rather, they are left for future study in other documents.

How about adding a sentence along the lines of what Keith proposed 
during the meeting, which, if I understood correctly, would be 
something like: "Note that this is one framework for placing 
emergency calls.  Other frameworks may exist, and there is no 
guarantee that an entity implementing this framework will be able to 
interoperate with an entity using a different framework."
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
There is something fascinating about science.  One gets such
wholesale returns of conjecture out of such a trifling investment
of fact.                                             --Mark Twain

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 24 Mar 2009 12:59:16 -0500

One point from the discussion that doesn't appear here - "in other 
documents" means "in other documents, probably produced by other SDOs", or 
something like that. Not sure what the right words are, but this was 
mentioned during the "high bar/heavy burden" discussion at the face-to-face 
meeting.

Just on style - "typical" doesn't seem necessary to me, but no one else has 
questioned it.

Thanks,

Spencer

> but such cases (and any associated issues) are not covered extensively in 
> this document; rather, they are left for future study in other documents.

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 24 Mar 2009 14:10:28 -0400

I don't want this "loophole" opened any wider than it has to be.  We
know that there are differences between endpoints rather than networks
doing location and routing functions.  Although there are other
differences, they mostly have to do with backwards compatibility with
existing PSTN oriented, nationally defined, existing emergency call
system.  I don't think that needs to be in the scope of the loophole.  

Brian

-----Original Message-----
From: Randall Gellens [mailto:[email-masked]] 
Sent: Tuesday, March 24, 2009 1:44 PM
To: Richard Barnes; Dawson, Martin
Cc: Rosen, Brian; [email-masked]; [email-masked]
Subject: Re: [Ecrit] Proposal to add "applicability" statementto
-framework/-phonebcp

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 24 Mar 2009 14:14:07 -0400

Richard

We're not communicating.  Where your sentence says "Internet Service
Provider", I want it changed to "calling network service provider".  It is
the network that would add location and route calls, not the ISP.  The ISP
supplies location in both scenarios.  The difference is to whom (the end
device or the proxy in the calling network).

Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Richard Barnes
Sent: Tuesday, March 24, 2009 1:26 PM
To: Dawson, Martin
Cc: Rosen, Brian; [email-masked]
Subject: Re: [Ecrit] Proposal to add "applicability" statementto
-framework/-phonebcp

Updated proposal:

> made without some access to the Internet... :-)
----------------------------------------------------------------------------
--------------------
> this email is prohibited.
----------------------------------------------------------------------------
--------------------
> [mf2]
_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Richard Barnes <[email-masked]>
Date: Tue, 24 Mar 2009 12:03:53 -0700

Aha, I get it.  So both types of service provider show up.
-- The ISP MUST provide location information (in either case)
-- The VSP MAY add location and route calls

Does the following capture it?  (Also added a call out to 
"interoperability issues" to address Mr. Gellens' concern):

This document describes an architecture for emergency calling in the 
typical Internet environment, in which the calling device bears most of 
the burden of implementing emergency calls, and the caller's Internet 
Service Provider has a supporting role.  The caller's Voice Service 
Provider plays a minor role, if such a provider is present at all.  The 
underlying specifications do allow for the Voice Service Provider to 
take a more expansive role in emergency calls.  However, such cases and 
any associated issues (e.g., interoperability issues) are not covered 
extensively in this document; rather, they are left for future study in 
other documents.

--Richard

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 24 Mar 2009 16:14:49 -0400

Better.  "Voice" is too limiting.

-----Original Message-----
From: Richard Barnes [mailto:[email-masked]] 
Sent: Tuesday, March 24, 2009 3:04 PM
To: Brian Rosen
Cc: 'Dawson, Martin'; Rosen, Brian; [email-masked]
Subject: Re: [Ecrit] Proposal to add "applicability" statementto
-framework/-phonebcp

--Richard

---

From: Richard Barnes <[email-masked]>
Date: Tue, 24 Mar 2009 13:27:40 -0700

"SIP"?  That's the charter scope.  The critical distinction is that it's 
at the application layer (where the application is whatever is being 
used to reach the PSAP).

---

From: "Stark, Barbara" <[email-masked]>
Date: Tue, 24 Mar 2009 16:35:43 -0400

I was doing fine with the course of this discussion till this
"interoperability" word came into the picture. I'm not convinced we have
an "interoperability issue". I do think that how this framework
"interconnects" to other networks is something that is not covered in
this document, and that it would be ok to say that this isn't covered.
Barbara

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Brian Rosen
Sent: Tuesday, March 24, 2009 4:15 PM
To: 'Richard Barnes'
Cc: 'Dawson, Martin'; [email-masked]; Rosen,Brian
Subject: Re: [Ecrit] Proposal to add"applicability" statementto
-framework/-phonebcp

-----Original Message-----
From: Richard Barnes [mailto:[email-masked]] 
Sent: Tuesday, March 24, 2009 3:04 PM
To: Brian Rosen
Cc: 'Dawson, Martin'; Rosen, Brian; [email-masked]
Subject: Re: [Ecrit] Proposal to add "applicability" statementto
-framework/-phonebcp

--Richard

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
of 

>> made without some access to the Internet... :-)
the
>> ------Original Message Truncated------
------------------------------------------------------------------------
----
------------------------------------------------------------------------
----

*****

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from all computers. GA621

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 24 Mar 2009 16:38:14 -0400

Phonebcp differentiates between the access network and a (generic) "service
provider".  Will that do?

Brian

-----Original Message-----
From: Richard Barnes [mailto:[email-masked]] 
Sent: Tuesday, March 24, 2009 4:28 PM
To: Brian Rosen
Cc: 'Dawson, Martin'; Rosen, Brian; [email-masked]
Subject: Re: [Ecrit] Proposal to add "applicability" statementto
-framework/-phonebcp

---

From: Richard Barnes <[email-masked]>
Date: Tue, 24 Mar 2009 13:43:10 -0700

Sure, as long as the document later makes a distinction later on.  May 
be good to have a pointer in this para.
--Richard

---

From: Marc Linsner <[email-masked]>
Date: Tue, 24 Mar 2009 14:07:36 -0700

Not married to it....just trying to find common ground (and make it a little
more IETF-ese).
"
This document describes an architecture for emergency calling contained
within the common Internet environment. In this environment, the originating
host bears most of the burden of implementing emergency calls, and the
caller's Access Network Provider may have a supporting role.  If such
exists, the caller's Application Service Provider plays a minor role.  The
underlying specifications do allow for the Application Service Provider to
take a more expansive role in emergency calls.  However, such cases and any
associated issues that arise outside this environment are for further study.
"

-Marc-

---

From: Randall Gellens <[email-masked]>
Date: Tue, 24 Mar 2009 14:32:23 -0700

>  this document, and that it would be ok to say that this isn't covered.

How about a sentence such as "Interworking between the framework 
described here and other frameworks is not currently specified."

-------------- Randomly selected tag: ---------------
Language is a virus from outer space.  --William S. Burroughs

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Tue, 24 Mar 2009 14:41:28 -0700

Btw, is the plan to put similar statements into 3GPP, etc. documents as
well? 

>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of Randall Gellens
>Sent: 24 March, 2009 14:32
>To: Stark, Barbara; Brian Rosen; Richard Barnes
>Cc: Dawson, Martin; [email-masked]; Rosen,Brian
>Subject: Re: [Ecrit] Proposal to add"applicability" 
>statementto -framework/-phonebcp
>
>> "interoperability" word came into the picture. I'm not convinced we 
>> have  an "interoperability issue". I do think that how this 
>framework  
>How about a sentence such as "Interworking between the 
>framework described here and other frameworks is not currently 
>specified."
>
>--
>Randall Gellens
>-------------- Randomly selected tag: --------------- Language 
>is a virus from outer space.  --William S. Burroughs

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 24 Mar 2009 16:41:40 -0500

That's what is commonly referred to as a "forward looking statement".  I don't like the use of "currently" or "at the time of writing", or anything like that.

I've watched this discussion with faltering interest.  My feeling is that this is an almost farcical waste of our time.

> Of Randall Gellens
> Sent: Tuesday, 24 March 2009 2:32 PM
> Subject: Re: [Ecrit] Proposal to add"applicability" statementto -
> framework/-phonebcp
> 
> have

---

From: "Stark, Barbara" <[email-masked]>
Date: Tue, 24 Mar 2009 17:59:49 -0400

I agree that "currently" isn't needed in the sentence. Something either is or isn't covered in the document. I also have a problem with specifically bringing up other "frameworks" as not being covered. There's so much that this document doesn't cover (which is fine, because otherwise we'd never finish it). Basically, this document doesn't describe interworking between this framework and anything external to this framework.
Barbara

-----Original Message-----
From: Thomson, Martin [mailto:[email-masked]] 
Sent: Tuesday, March 24, 2009 5:42 PM
To: Randall Gellens; Stark, Barbara; Brian Rosen; Richard Barnes
Cc: Dawson, Martin; [email-masked]; Rosen,Brian
Subject: RE: [Ecrit] Proposal to add"applicability" statementto -framework/-phonebcp

*****

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from all computers. GA625

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 25 Mar 2009 01:24:37 +0100

I think you will find that the stage 3 3GPP document already contains the statement of what it is applicable to. It does not in itself claim to solve the worlds problems.

That covers ETSI TISPAN and 3GPP2 as well.

regards

Keith

> On Behalf Of Hannes Tschofenig
> Sent: Tuesday, March 24, 2009 9:41 PM
> To: 'Randall Gellens'; 'Stark, Barbara'; 'Brian Rosen'; 
> 'Richard Barnes'
> Cc: 'Dawson, Martin'; [email-masked]; 'Rosen, Brian'
> Btw, is the plan to put similar statements into 3GPP, etc. 
> documents as well? 
> 
> >-------------- Randomly selected tag: --------------- Language is a 
> >virus from outer space.  --William S. Burroughs

---

From: "Dawson, Martin" <[email-masked]>
Date: Tue, 24 Mar 2009 19:33:48 -0500

Sure - but do they actually say "This framework may not address
requirements that are addressed by other frameworks"? Which is what is
actually being asked for here. And which, btw, I think is a pretty
pointless comment anyway.

Cheers,
Martin

-----Original Message-----
From: DRAGE, Keith (Keith) [mailto:[email-masked]] 
Sent: Wednesday, 25 March 2009 11:25 AM
To: Hannes Tschofenig; 'Randall Gellens'; 'Stark, Barbara'; 'Brian
Rosen'; 'Richard Barnes'
Cc: Dawson, Martin; [email-masked]; 'Rosen, Brian'
Subject: RE: [Ecrit] Proposal to add"applicability"
statementto-framework/-phonebcp

I think you will find that the stage 3 3GPP document already contains
the statement of what it is applicable to. It does not in itself claim
to solve the worlds problems.

regards

Keith

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 25 Mar 2009 01:39:55 +0100

As it does not provide the chance for meeting another framework, it doesn't need to. The ecrit documents do.

Keith 

> From: Dawson, Martin [mailto:[email-masked]] 
> Sent: Wednesday, March 25, 2009 12:34 AM
> To: DRAGE, Keith (Keith); Hannes Tschofenig; Randall Gellens; 
> Stark, Barbara; Brian Rosen; Richard Barnes
> Cc: [email-masked]; Rosen, Brian
> Sure - but do they actually say "This framework may not 
> address requirements that are addressed by other frameworks"? 
> Which is what is actually being asked for here. And which, 
> btw, I think is a pretty pointless comment anyway.
> 
> Cheers,
> Martin
> 
> To: Hannes Tschofenig; 'Randall Gellens'; 'Stark, Barbara'; 
> 'Brian Rosen'; 'Richard Barnes'
> I think you will find that the stage 3 3GPP document already 
> contains the statement of what it is applicable to. It does 
> not in itself claim to solve the worlds problems.
> 
> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > Of Hannes Tschofenig
> > To: 'Randall Gellens'; 'Stark, Barbara'; 'Brian Rosen'; 'Richard 
> > Barnes'
> Language is a

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 24 Mar 2009 19:48:53 -0500

So be clear then Keith you are saying that the 3GPP document clearly
state that unvetted Internet access MUST NOT be allowed through networks
that support these protocols?

Unless they say that then the 3GPP document absolutely do collide with
other frameworks and the same degree of applicability is there!

Cheers
James

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of DRAGE, Keith (Keith)
Sent: Wednesday, 25 March 2009 11:40 AM
To: Dawson, Martin; Hannes Tschofenig; Randall Gellens; Stark,Barbara;
Brian Rosen; Richard Barnes
Cc: Rosen, Brian; [email-masked]
Subject: Re: [Ecrit] Proposal toadd"applicability"
statementto-framework/-phonebcp

As it does not provide the chance for meeting another framework, it
doesn't need to. The ecrit documents do.

Keith

---

From: "Dawson, Martin" <[email-masked]>
Date: Tue, 24 Mar 2009 19:54:32 -0500

The apparent lack of logical symmetry in that comment baffles me.

Cheers,
Martin

-----Original Message-----
From: DRAGE, Keith (Keith) [mailto:[email-masked]] 
Sent: Wednesday, 25 March 2009 11:40 AM
To: Dawson, Martin; Hannes Tschofenig; Randall Gellens; Stark, Barbara;
Brian Rosen; Richard Barnes
Cc: [email-masked]; Rosen, Brian
Subject: RE: [Ecrit] Proposal to
add"applicability"statementto-framework/-phonebcp

Keith

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 25 Mar 2009 18:44:32 +0100

Well at the end of the day, we are discussing what we want in the ecrit document. 

3GPP is a member organisation, and indeed if I recall correctly Andrew is a supporting organisation of one of the relevant organisations. It is the member organisations who decide what the document says.

Go write your contribution.

Keith 

> Sent: Wednesday, March 25, 2009 12:55 AM
> To: Dawson, Martin; Hannes Tschofenig; Randall Gellens; 
> As it does not provide the chance for meeting another 
> framework, it doesn't need to. The ecrit documents do.
> 
> Keith 
> 
> > To: DRAGE, Keith (Keith); Hannes Tschofenig; Randall 
> Gellens; Stark, 
> > Barbara; Brian Rosen; Richard Barnes
> > requirements that are addressed by other frameworks"?
> > Which is what is actually being asked for here. And which, btw, I 
> > think is a pretty pointless comment anyway.
> > 
> > Cheers,
> > Martin
> > 
> > This message is for the designated recipient only and may contain 
> > privileged, proprietary, or otherwise private information.
> immediately 
> > and delete the original.  Any unauthorized use of this email is 
> > prohibited.