Subject: Re: [Ecrit] WGLC for draft-ietf-ecrit-lost-planned-changes - end date April 8

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 4 May 2018 15:17:46 -0600

On 4/25/18 9:40 AM, Peter Saint-Andre wrote:
> On 3/25/18 2:49 AM, Az Mankin wrote:
>>
>> This starts WGLC for  draft-ietf-ecrit-lost-planned-changes-01,
>> Validation of Locations Around a Planned Change
>>
>> Please send both comments and messages that you support advancement to
>> this mailing list before April 8.
> 
> Again, thanks for your patience with my tardy reply. I took another look
> at the schema. There are a few details I still want to check, but
> overall it seems to be in good shape.

I've looked again at the lost1 schema. This looks slightly off:

   <xs:attributeGroup name="expires">
     <xs:attribute name="expires" use="required">
       <xs:simpleType>
         <xs:union memberTypes="xs:dateTime">
           <xs:simpleType>
             <xs:restriction base="xs:token">
               <xs:enumeration value="NO-CACHE"/>
             </xs:restriction>
           </xs:simpleType>
           <xs:simpleType>
             <xs:restriction base="xs:token">
               <xs:enumeration value="NO-EXPIRATION"/>
             </xs:restriction>
           </xs:simpleType>
         </xs:union>
       </xs:simpleType>
     </xs:attribute>
   </xs:attributeGroup>

As far as I can see (I've never used xs:union before), the dateTime
facet would never get merged in. I think we want this:

   <xs:attributeGroup name="expires">
     <xs:attribute name="expires" use="required">
       <xs:simpleType>
         <xs:union>
           <xs:simpleType>
             <xs:restriction base="xs:dateTime"/>
           </xs:simpleType>
           <xs:simpleType>
             <xs:restriction base="xs:token">
               <xs:enumeration value="NO-CACHE"/>
               <xs:enumeration value="NO-EXPIRATION"/>
             </xs:restriction>
           </xs:simpleType>
         </xs:union>
       </xs:simpleType>
     </xs:attribute>
   </xs:attributeGroup>

The rest seems OK.

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 4 May 2018 15:42:21 -0600

> overall it seems to be in good shape.

And also feedback on the lostPlannedChange1 schema...

1. As I noted in my comments on the lost-rli1 schema, as far as I know
there's no way in XML schema to restrict the use of an extension to a
particular place in a structure defined by another schema. So a comment
like this in the schema really has no force:

<!-- extend the extensionPoint of commonRequestPattern of findService
                                                       to include:  -->

2. The schema does this import, but a prefix is never defined so we
can't actually use the imported constructs:

     <xs:import namespace="urn:ietf:params:xml:ns:lost1"/>

I suggest:

<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
           xmlns="urn:ietf:params:xml:ns:lostPlannedChange1"
           xmlns:lost="urn:ietf:params:xml:ns:lost1"
           targetNamespace="urn:ietf:params:xml:ns:lostPlannedChange1"
           elementFormDefault="qualified">

And then:

           <xs:element ref="lost:uri" type="xs:anyURI" />

           <xs:element ref="ttl" type="lost:expires" minOccurs="0" />

           <xs:element name="uriNotStored" type="lost:basicException"/>

3. The "invalidAsOf" and "ttl" elements are specified as references, but
the elements referenced are never defined:

           <xs:element ref="invalidAsOf" type="xs:dateTime" />

           <xs:element ref="ttl" type="lost:expires" minOccurs="0" />

Perhaps just change "ref" to "name" in each case? Or define the elements
somewhere in the schema.

4. I think we can simplify the "uriNotStored" content as follows:

OLD

<!-- extend the extensionPoint of extensionContainer to include: -->
           <xs:element ref="uriNotStored"/>
<!-- where -->
           <xs:element name="uriNotStored" type="basicException"/>

NEW

<!-- extend the extensionPoint of extensionContainer to include: -->
           <xs:element name="uriNotStored" type="lost:basicException"/>

5. And a nit, there is a "<" missing before xs:group here:

        xs:group ref="plannedChange" minOccurs="1"/>

Hope that helps,

Peter

---

From: Az Mankin <[email-masked]>
Date: Fri, 11 May 2018 10:14:15 -0400

Thanks to Peter and the others who responded to the WGLC.

I expect the authors will be updating shortly and include/address the
comments that came in through May 4.

On Fri, May 4, 2018 at 5:17 PM, Peter Saint-Andre <[email-masked]>
wrote:

> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit
>
>