Subject: Re: [Ecrit] Review of draft-ietf-ecrit-lost-planned-changes-04

From: "Caron, Guy" <[email-masked]>
Date: Wed, 1 Sep 2021 12:59:06 +0000

I think Randall is right about 'asOf' and 'invalidAsOf' being swapped in the schemas compared to the text.

Since the associated element name is changing to <revalidateLocation>, consider changing 'invalidAsOf' to 'revalidateAsOf'.

Guy

-----Message d'origine-----
De : Ecrit <[email-masked]> De la part de Brian Rosen
Envoyé : 31 août 2021 17:14
À : Randall Gellens <[email-masked]>
Cc : [email-masked]
Objet : [EXT]Re: [Ecrit] Review of draft-ietf-ecrit-lost-planned-changes-04

I’ll make TTL an attribute.

I’ll look at the AsOf and InvalidAsOf.  Might be a problem as you suggest.

I really think that there should be limits but I can soften the requirement to SHOULD.

Brian

> On Aug 31, 2021, at 5:01 PM, Randall Gellens <[email-masked]> wrote:
> 
> I haven't seen responses to the numbered items from my review:
> 
>> (1) Should the Time to Live information in a validation response be an attribute rather than an element? Logically, it seems more an attribute of the response, and also it mirrors the 'expires' attribute on which it is modeled.
>> 
>> (2) In the extension schema, are 'invalidAsOf' and 'asOf' swapped? ('AsOf' should be part of the <plannedChange> element but looks like maybe it is part of the response, while 'invalidAsOf' is part of <plannedChange>).
>> 
>> (3) I'm not sure that "The server MUST have policy that limits use of this mechanism by a given client" is warranted; I think using "SHOULD" is more easily justified.
> 
> --Randall
> 
> On 23 Aug 2021, at 14:12, Randall Gellens wrote:
> 
>> (1) Should the Time to Live information in a validation response be an attribute rather than an element?  Logically, it seems more an attribute of the response, and also it mirrors the 'expires' attribute on which it is modeled.
>> 
>> (2) In the extension schema, are 'invalidAsOf' and 'asOf' swapped? ('AsOf' should be part of the <plannedChange> element but looks like maybe it is part of the response, while 'invalidAsOf' is part of <plannedChange>).
>> 
>> (3) I'm not sure that "The server MUST have policy that limits use of this mechanism by a given client" is warranted; I think using "SHOULD" is more easily justified.
>> 
>> I have a number of suggested edits for clarification or language.  Attached are four files:
>> 
>> draft-ietf-ecrit-lost-planned-changes-04-rg.xml
>> 
>> The XML uploaded by Brian, with my edits.
>> 
>> draft-ietf-ecrit-lost-planned-changes-04-rg.txt
>> 
>> The TXT generated from the XML with my edits.
>> 
>> Diff-txt.html
>> 
>> An IETF tools diff showing my edits to the TXT, side by side.
>> 
>> Diff-xml.html
>> 
>> An IETF tools diff showing my edits to the XML, side by side.
>> 
>> 
>> --Randall

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit
------------------------------------------------------------------------------
External Email: Please use caution when opening links and attachments / Courriel externe: Soyez prudent avec les liens et documents joints

---

From: Brian Rosen <[email-masked]>
Date: Wed, 1 Sep 2021 09:07:11 -0400

Okay

> On Sep 1, 2021, at 8:59 AM, Caron, Guy <[email-masked]> wrote:
>

---

From: Brian Rosen <[email-masked]>
Date: Fri, 3 Sep 2021 15:53:28 -0400

I was editing the text and I believe that the “asOf” in the findServiceResponse shouldn’t be there at all.

It’s in the request to specify when you want validation considered.
It’s in the notification to tell you when the planned change occurs.

It isn’t in the findServiceResponse at all.  Only the TTL is there.  The response to Planned Change is store the URI, and that’s it.

So, I deleted it, and the one in the request is asOf.

Brian

> On Sep 1, 2021, at 9:07 AM, Brian Rosen <[email-masked]> wrote:
> 
> Okay
>