Subject: [Ecrit] I-D Action: draft-ietf-ecrit-similar-location-10.txt

From: [email-masked]
Date: Thu, 02 Sep 2021 16:48:42 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Emergency Context Resolution with Internet Technologies WG of the IETF.

        Title           : A LoST extension to return complete and similar location info
        Authors         : Brian Rosen
                          Roger Marshall
                          Jeff Martin
	Filename        : draft-ietf-ecrit-similar-location-10.txt
	Pages           : 18
	Date            : 2021-09-02

Abstract:
   This document introduces a new way to provide returned location
   information in LoST responses that is either of a completed or
   similar form to the original input civic location, based on whether
   valid or invalid civic address elements are returned within the
   findServiceResponse message.  This document defines a new extension
   to the findServiceResponse message within the LoST protocol [RFC5222]
   that enables the LoST protocol to return in it's response a completed
   civic address element set for a valid location response, and one or
   more suggested sets of similar location information for an invalid
   location.  These two types of civic addresses are referred to as
   either "complete location" or "similar location", and are included as
   a compilation of CAtype xml elements within the existing LoST
   findServiceResponse message structure.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ecrit-similar-location/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-ecrit-similar-location-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ecrit-similar-location-10

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian Rosen <[email-masked]>
Date: Thu, 2 Sep 2021 19:50:00 -0400

This version fixes all reported issues in -09

Brian

> On Sep 2, 2021, at 7:48 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Caron, Guy" <[email-masked]>
Date: Thu, 9 Sep 2021 21:38:24 +0000

I gleaned through -10 and can say that most of my comments and proposed changes are addressed. Thank you.

The one exception is in section 4, the last sentence of the 3rd paragraph, which says: "However, if a subsequent request includes the Complete Location, the corresponding request MAY include elements in the unchecked list."

In my proposed changes, I suggested changing "corresponding request" to "corresponding response" but that change was not accepted. Unless I'm missing something, the sentence as currently stated makes no sense.

Other than that, this draft is good to go.

Guy

-----Message d'origine-----
De : Ecrit <[email-masked]> De la part de Brian Rosen
Envoyé : 2 septembre 2021 19:50
À : ECRIT <[email-masked]>
Objet : [EXT]Re: [Ecrit] I-D Action: draft-ietf-ecrit-similar-location-10.txt

Brian

> Internet-Draft directories: http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit
------------------------------------------------------------------------------
External Email: Please use caution when opening links and attachments / Courriel externe: Soyez prudent avec les liens et documents joints

---

From: "Caron, Guy" <[email-masked]>
Date: Fri, 10 Sep 2021 12:59:51 +0000

There is also this one that seems not addressed:

The document does not use a convention to express XML types such as <blablabla> for elements, 'boobooboo' for attributes, "heyheyhey" for values, etc. in the text. Should it?

Guy

-----Message d'origine-----
De : Ecrit <[email-masked]> De la part de Caron, Guy
Envoyé : 9 septembre 2021 17:38
À : Brian Rosen <[email-masked]>; ECRIT <[email-masked]>
Objet : [EXT]Re: [Ecrit] I-D Action: draft-ietf-ecrit-similar-location-10.txt

Guy

-----Message d'origine-----
De : Ecrit <[email-masked]> De la part de Brian Rosen Envoyé : 2 septembre 2021 19:50 À : ECRIT <[email-masked]> Objet : [EXT]Re: [Ecrit] I-D Action: draft-ietf-ecrit-similar-location-10.txt

Brian

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 27 Sep 2021 13:01:28 -0700

In checking RFC 5222, it does seem to follow a convention of angle 
brackets enclosing element names and single quotes enclosing both values 
and attribute names, so I agree the drat should follow such a 
convention.

--Randall

On 10 Sep 2021, at 5:59, Caron, Guy wrote:

> The document does not use a convention to express XML types such as 
> <blablabla> for elements, 'boobooboo' for attributes, "heyheyhey" for 
> values, etc. in the text. Should it?
>
> Guy
>
> I gleaned through -10 and can say that most of my comments and 
> proposed changes are addressed. Thank you.
>
> The one exception is in section 4, the last sentence of the 3rd 
> paragraph, which says: "However, if a subsequent request includes the 
> Complete Location, the corresponding request MAY include elements in 
> the unchecked list."
>
> In my proposed changes, I suggested changing "corresponding request" 
> to "corresponding response" but that change was not accepted. Unless 
> I'm missing something, the sentence as currently stated makes no 
> sense.
>
> Envoyé : 2 septembre 2021 19:50 À : ECRIT <[email-masked]> 
> External Email: Please use caution when opening links and attachments 
> / Courriel externe: Soyez prudent avec les liens et documents joints
>
> External Email: Please use caution when opening links and attachments 
> / Courriel externe: Soyez prudent avec les liens et documents joints
>

---

From: Brian Rosen <[email-masked]>
Date: Mon, 27 Sep 2021 17:12:28 -0400

Ah, I misunderstood the comment.  I will fix it.  It’s editorial, so you can decide if you want to WGLC -10 and treat the comments from Dwight and Guy as WGLC comments, or have me spin an -11

Brian

> On Sep 27, 2021, at 4:01 PM, Randall Gellens <[email-masked]> wrote:
> 
> In checking RFC 5222, it does seem to follow a convention of angle brackets enclosing element names and single quotes enclosing both values and attribute names, so I agree the drat should follow such a convention.
> 
> --Randall
>

---

From: "Caron, Guy" <[email-masked]>
Date: Mon, 27 Sep 2021 21:45:22 +0000

Will this one that was left without a response be addressed before WGLC?

>>In my proposed changes, I suggested changing "corresponding request" to "corresponding response" but that change was not accepted. Unless I'm missing something, the sentence as currently stated mak…

Thanks,

Guy

-----Message d'origine-----
De : Brian Rosen <[email-masked]> 
Envoyé : 27 septembre 2021 17:12
À : Randall Gellens <[email-masked]>
Cc : Caron, Guy <[email-masked]>; ECRIT <[email-masked]>
Objet : [EXT]Re: [Ecrit] I-D Action: draft-ietf-ecrit-similar-location-10.txt

Brian

>> De : Ecrit <[email-masked]> De la part de Caron, Guy Envoyé : 
>> 9 septembre 2021 17:38 À : Brian Rosen <[email-masked]>; ECRIT 
>> <[email-masked]> Objet : [EXT]Re: [Ecrit] I-D Action: 
>> draft-ietf-ecrit-similar-location-10.txt
>> 
>> De : Ecrit <[email-masked]> De la part de Brian Rosen Envoyé 
>> : 2 septembre 2021 19:50 À : ECRIT <[email-masked]> Objet : [EXT]Re: 
>> [Ecrit] I-D Action: draft-ietf-ecrit-similar-location-10.txt
>> 
>>> to the findServiceResponse message within the LoST protocol 
>>> [RFC5222]  that enables the LoST protocol to return in it's response 
>>> a completed  civic address element set for a valid location 
>>> response, and one or  more suggested sets of similar location 
>>> information for an invalid  location.  These two types of civic 
>>> addresses are referred to as  either "complete location" or "similar 
>>> location", and are included as  a compilation of CAtype xml elements 
>>> within the existing LoST  findServiceResponse message structure.
>>> 
>>> 
>>> https://datatracker.ietf.org/doc/html/draft-ietf-ecrit-similar-locat
>>> io
>>> n-10
>>> 
>> ---------------------------------------------------------------------
>> --------- External Email: Please use caution when opening links and 
>> attachments / Courriel externe: Soyez prudent avec les liens et 
>> documents joints
>> 
>> ---------------------------------------------------------------------
>> --------- External Email: Please use caution when opening links and 
>> attachments / Courriel externe: Soyez prudent avec les liens et 
>> documents joints
>>

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 27 Sep 2021 15:08:13 -0700

How long would it take you to fix these and do an -11?  I think that 
would be cleaner (and I don't expect any further comments until IETF LC, 
so we can just advance -11 then).

--Randall

On 27 Sep 2021, at 14:12, Brian Rosen wrote:

> Ah, I misunderstood the comment.  I will fix it.  It’s editorial, so 
> you can decide if you want to WGLC -10 and treat the comments from 
> Dwight and Guy as WGLC comments, or have me spin an -11
>
> Brian
>
>> brackets enclosing element names and single quotes enclosing both 
>> values and attribute names, so I agree the drat should follow such a 
>> convention.
>>
>> --Randall
>>
>>> <blablabla> for elements, 'boobooboo' for attributes, "heyheyhey" 
>>> for values, etc. in the text. Should it?
>>>
>>> Guy
>>>
>>> paragraph, which says: "However, if a subsequent request includes 
>>> the Complete Location, the corresponding request MAY include 
>>> elements in the unchecked list."
>>>
>>> Envoyé : 2 septembre 2021 19:50 À : ECRIT <[email-masked]> Objet : 
>>> [EXT]Re: [Ecrit] I-D Action: 
>>>> [RFC5222]
>>> External Email: Please use caution when opening links and 
>>> External Email: Please use caution when opening links and

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 27 Sep 2021 15:27:28 -0700

Yes, I believe Guy is correct and it should be changed.

--Randall

On 27 Sep 2021, at 14:45, Caron, Guy wrote:

>>> Envoyé

---

From: Brian Rosen <[email-masked]>
Date: Mon, 27 Sep 2021 19:02:39 -0400

Yes

> On Sep 27, 2021, at 6:27 PM, Randall Gellens <[email-masked]> wrote:
>