Subject: [edu-team] Draft newcomers page for comment

From: Brian E Carpenter <[email-masked]>
Date: Thu, 17 Dec 2009 11:34:22 +1300

I foolishly volunteered to draft a newcomers page for the
IETF site. Here's a draft:

http://www.cs.auckland.ac.nz/~brian/newcomers.html

Comments (both fundamental and detailed) are welcome.

I've copied Paul because there is a clear relationship to the
Tao. Of course, the first resource I list is the Tao itself,
and the second is EDU.

Because all the details for newcomers are (or should be) in
the Tao, my feeling is that this new page should be kept short.

-- 
Regards
   Brian Carpenter

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 17 Dec 2009 18:38:12 +0100

Hi Brian,

I think your draft newcomers page is great. It explains in simple terms 
what is important
when you enter the IETF world for the first time without going too much 
into details.

I am sure this will be very helpful for newcomers, including the ISOC 
fellows 
(please let me know when it is ready to be published, so the ISOC folks 
can link to
it from the fellows page).

I wonder if there are any other meetings or events at the IETF specially 
interesting for
newcomers. Recently the secretariat started to organise a special 
Newcomers reception
just before the reception on Sunday evening. But I think all newcomers 
get subscribed
to a list where such announcements are posted.

Mirjam

---

From: Ray Pelletier <[email-masked]>
Date: Thu, 17 Dec 2009 17:05:52 -0500

Brian

I stared at it and thought there was too much text.  Might have  
started with a TOC and links to material below and beyond.  Let them  
choose
what's of interest instead of wading through text.  Perhaps more like  
this iesg wiki page on the tools server: http://tools.ietf.org/group/iesg/trac/

Perhaps we could run this by some of the 1st Timers over the last year  
for feedback?

Ray

On Dec 17, 2009, at 12:38 PM, Mirjam Kuehne wrote:

> Hi Brian,
>
> I think your draft newcomers page is great. It explains in simple  
> terms what is important
> when you enter the IETF world for the first time without going too  
> much into details.
>
> I am sure this will be very helpful for newcomers, including the  
> ISOC fellows (please let me know when it is ready to be published,  
> so the ISOC folks can link to
> I wonder if there are any other meetings or events at the IETF  
> specially interesting for
> just before the reception on Sunday evening. But I think all  
> newcomers get subscribed
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 18 Dec 2009 11:27:04 +1300

Ray,

Something like that part of the IESG wiki would be excellent as an
extension of the resources section, for sure. Something similar for
WG chairs would be good too, but the WG chairs wiki never took off
as far as I know.

I can add a bit of structure to my page, of course. But I think that for
true newcomers, some descriptive words are needed too; not too many,
because the real source is the Tao. I can try to trim it down.

Getting a few real first timers to review it is a wonderful idea.
Do you have a list? (The problem with Hiroshima is that we had a lot
of one-timers, who will probably never come back.)

    Brian

On 2009-12-18 11:05, Ray Pelletier wrote:
> Brian
> 
> I stared at it and thought there was too much text.  Might have started
> with a TOC and links to material below and beyond.  Let them choose
>> fellows (please let me know when it is ready to be published, so the
>> ISOC folks can link to

---

From: Mirjam Kuehne <[email-masked]>
Date: Mon, 21 Dec 2009 11:12:40 +0100

Hi Brian,

I agree: some descriptive text is useful, especially for a newcomer. And 
I found your text quite interesting and informative to read.

As for a set of newcomers, you could ask ISOC if they can pass it on to 
the first-time fellows and/or the returning fellows. They are a pretty 
mixed group and very enthusiastic and helpful. Just an idea.

Cheers,
Mirjam

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 28 Dec 2009 13:20:40 +1300

Paul,

Yes, excellent point. I wonder if Alice has any such intro already,
or if it can be built quickly from the RFC Editor tutorial. Otherwise,
feel free to send text (or even, send HTML :-).

Regards
   Brian Carpenter

On 2009-12-28 10:55, Paul Hoffman wrote:
> This looks like a great intro for newcomers, and definitely belongs on the IETF web page.
> 
> One comment, though: the proposed page fails a large set of newcomers the same way that the Tao fails them. These folks are software developers, integrators, tech support folks, and so on, who are told to read an RFC and have no idea what it is or who created it. They absolutely do not want to get involved in the IETF: they have to understand a spec.
> 
> I did a few runs at trying to restructure the Tao to handle these people early, but gave up. The Tao really is for people wanting to be (at least a bit) involved. Your newcomer's page, however, could help them understand the context in which RFCs come to being and are updated. Given that you said you might add structure to the page, I propose that this group be addressed first, in their own section. Topics these people seem to care about are:
> - Who creates RFCs
> - What the standards levels means <sigh>
> - How RFCs are updated
> - How to find RFCs on the same topic
> 
> I'm happy to write this up if you want.
> 
> --Paul Hoffman, Director
> --VPN Consortium
>

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 27 Dec 2009 13:55:04 -0800

--Paul Hoffman, Director
--VPN Consortium