Subject: Re: [edu-team] [rfc-i] Kramdown lovers lunch today

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 12 Mar 2015 10:16:45 +0100

Hi Carsten,

Can you please send us the slides you are planning to use for the
kramdown tutorial.

Thank you,
Mirjam

On 27/1/15 10:31, Mirjam Kuehne wrote:
> Hi Carsten,
> 
> The tutorial slot is scheduled from 15:00 - 17:00, so you should have
> enough time. Maybe clarify to the audience before you start that you
> plan to end around 16:30, so people don't start running out at 15:00.
> 
> I'll pass the amended description on to the secretariat.
> 
> Cheers,
> Mirjam
> 
> On 26/1/15 20:18, Carsten Bormann wrote:
>> Hi Alice,
>>
>> thank you for these good suggestions.
>>
>>> When using kramdown-rfc2629, is there an XML file created that runs
>>> with xml2rfc? If so, I suggest adding a sentence about that because
>>> it's a selling point. (Having an XML file is to the authors'
>>> advantage, especially in the future.)
>>
>> Yes, kramdown-rfc2629 converts into RFCXML.
>> Indeed, this information should be added.
>> (What is today's correct, but reasonable short way to say RFCXML?
>> "XML file that runs with xml2rfc" is unambiguous, but long.)
>>
>>>> Tools have emerged that also allow writing I-Ds in markdown.
>>>
>>>> We'll look at what's available and then focus on the "kramdown" set
>>>
>>> Specifically, does this tutorial cover using markdown as in Pandoc2rfc
>>> (RFC 7238)?  I suggest listing any specific tools that will be
>>> covered.
>>
>> How long is this paragraph supposed to be?
>> Yes, the RFC 7328 solution will be covered in principle, but working
>> with it is not in focus.
>> I have updated the text below to make this clearer.
>>
>> Mirjam: I'm no longer so sure 1 hour will be enough.
>> Can you schedule this for 15-16:30, so I still have a fighting chance to
>> see at least some of meet and greet?
>>
>>> Nit: I suggest changing "RFC" to "I-D" in the title & description, as
>>> this is a tool to help authors write I-Ds.  (Only a portion of I-Ds
>>> are approved and become RFCs.) Updated text below.
>>
>> While this is undoubtedly true, people do seem to think they are writing
>> I-Ds in order for them to become RFCs.  So from a tutorial marketing
>> point of view, I think it is better to say "writing RFCs".
>> RFC 7328 meets in the middle with "Writing I-Ds and RFCs"; I'll follow
>> that compromise for now.  So this updates the announcement as below.
>>
>> Grüße, Carsten
>>
>>
>>
>> Writing RFCs and I-Ds in markdown and a bit of YAML
>> ===================================================
>>
>> Speaker: Carsten Bormann
>>
>> Time: IETF 92, Sunday 15:00..16:30
>>
>> Writing I-Ds has traditionally involved some finicky Word templating or
>> typing up hard-to-use (and read!) XML.  Recently, it has become more
>> popular in a wide range of communities to write text in the
>> plaintext-like "markdown" format.  Tools have emerged in the IETF that
>> allow writing I-Ds in markdown, automatically converting into the XML
>> format accepted by the RFC editor (and performing a number of chores in
>> the process that used to be manual work).
>>
>> We'll look at what's available and then focus on the "kramdown" set of
>> tools, which enhances markdown with a bit of structured YAML for the
>> management of references.  We'll also look at popular workflows that
>> minimize manual work while optimizing collaboration with co-editors and
>> contributors.  Bring a laptop with a current version of the programming
>> language Ruby (≥ 1.9) -- we'll do some exercises, and hands-on questions
>> are welcome!
>>
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 12 Mar 2015 12:44:34 +0100

I plan to have a first version available tomorrow.
How often do you want me to send updates after that :-)?

Grüße, Carsten

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 12 Mar 2015 14:23:09 +0100

> How often do you want me to send updates after that :-)?

I think the first draft and the final would be sufficient :-)

Thanks,
Mirjam

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 14 Mar 2015 19:00:32 +0100

> I plan to have a first version available tomorrow.

Long Friday.

As I said, I do expect these to grow a bit more based on user feedback,
which I'm now going to solicit next.

Grüße, Carsten

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 15 Mar 2015 07:54:21 +1300

Distraction-free writing?

With that font and colour?

Honestly these slides hurt my eyes and I just can't concentrate
on the content.

Regards
   Brian

On 15/03/2015 07:00, Carsten Bormann wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Sat, 14 Mar 2015 15:35:38 -0400

bold!  (in appearance at least)

Scott

> On Mar 14, 2015, at 2:00 PM, Carsten Bormann <[email-masked]> wrote:
> 
> Carsten Bormann wrote:
> <kramdown.pdf>_______________________________________________
> edu-team mailing list
> [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 14 Mar 2015 21:26:16 +0100

> With that font and colour?

I didn't say "distraction-free slide reading", did I? :-)

(The students actually told me they like a bit of a wake-up effect on my
slides.)

> Honestly these slides hurt my eyes and I just can't concentrate

Thanks for the feedback -- maybe you like the below better.
(I have much better ones -- in the other direction...)

Grüße, Carsten

PS.: In case you wondered -- yes, these were made with a markdown tool.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 20 Mar 2015 23:39:49 -0500

> I think the first draft and the final would be sufficient :-)

Fine -- the slides are up at:

http://slides.rfc.space

If I find time to update them some more, I'll update them there in
place.  So please pull them as often as you like :-)
(The wiki could point right there.)

Grüße, Carsten

PS.: Your browser may have problems recognizing .space as a top-level
domain unless you type the http:// as well.  For me, .space simply seems
to be the cheapest top level domain available at this time :-)

---

From: Mirjam Kuehne <[email-masked]>
Date: Sat, 21 Mar 2015 16:11:43 +0100

Thanks, Carsten. Good luck tomorrow.

Mirjam