Subject: [edu-team] Fw: Minutes of Remote Hubs "Bar Bof" : IETF 94 - Yokohama

From: <[email-masked]>
Date: Tue, 1 Dec 2015 16:45:44 +0000 (UTC)

FYI.    If folks on the EDU team have interest in the topic of Remote Hubs that was discussed at IETF94 Thanks,
Nalini ElkinsInside Products, Inc.www.insidethestack.com(831) 659-8360
    ----- Forwarded Message -----
  From: "[email-masked]" <[email-masked]>
 To: Robert Lychev <[email-masked]>; Marius Georgescu <[email-masked]>; Lee Howard <[email-masked]>; Michael Ackermann <[email-masked]>; Alexa Morris <[email-masked]>; Alvaro Retana (aretana) <[email-masked]>; Christian O'Flaherty <[email-masked]>; Carlos M. Martinez <[email-masked]>; Anand Raje <[email-masked]>; Alia Atlas <[email-masked]>; Simon Pietro Romano <[email-masked]>; Ray Pelletier <[email-masked]>; Hui Deng <[email-masked]>; Scott O. Bradner <[email-masked]>; Scott O. Bradner <[email-masked]>; Avri Doria <[email-masked]>; John C. Klensin <[email-masked]>; Dhruv Dhody <[email-masked]> 
Cc: Vinayak Hegde <[email-masked]>; Romascanu Dan (Dan) <[email-masked]>; Kevin Chege <[email-masked]>; EDU Team <[email-masked]>; Wesley Eddy <[email-masked]>; Gowri Visweswaran <[email-masked]>; Gabriel Montenegro <[email-masked]>; Gabriel Montenegro <[email-masked]>; Bill Jouris <[email-masked]>
 Sent: Tuesday, December 1, 2015 8:44 AM
 Subject: Minutes of Remote Hubs "Bar Bof" : IETF 94 - Yokohama
   
Folks,
I have written up the discussion at the Remote Hubs "Bar BOF" in Yokohama.  I have tried to organize this somewhat for coherency.  I will also post to the vmeet email list.  That is the email list used for discussion on remote access.   Please subscribe to the [email-masked] email list for discussion on this topic.   I am copying the EDU and mentoring teams on this so that they stay informed about this topic.  If I have forgotten to send this email to someone who was in the meeting or is interested, please forward the email to them.  If there are any corrections or additions, please let me know.
The next steps as I see them:
1.  Add something to the IETF web site for Remote Hubs.   Please let me know if someone wants to help with this.
2.  Create an I-D out of the discussion below.  This will serve as community memory.  If anyone is interested in helping with this, please let me know.  At a minimum, we should have one participant from each of the major geographic regions.
3.  It occurs to me that to schedule a remote hub, we need to know what the agenda is.  For example, I am talking with one group in the U.S. that may be interested in only attending the TLS WG session.  But, we don't know when it is!  So, how do we schedule and publicize?
Thank you all for your help & please let me know any comments.
Nalini Elkins
  ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------Minutes:
The meeting started with a question was posed by ScottBradner.   "Before we go anyfurther, what is a remote hub?  Let'sdefine it."
Various answers were given to this:
·        A remote hub can be anything where more than oneperson gathers to listen / participate in IETF sessions.  It can be as simple as someone's living roomto major hubs with 7 rooms, telepresence and many people in each.  (Such large remote hubs do not actually existat this point – but they could in the future.)·        It is NOT necessarily an entire set of IETFsessions viewed in real time.·        A remote hub for a full IETF meeting may not bepractical.   Remote hub for a workinggroup or a few sessions may work better. At least in the beginning.·        There also appear to be regional differences inhow hubs are organized.   Latin Americahas previously run quite a few remote hubs as does India.  The two regions are different in how theyarose, where they meet, and what they do.·        Templates for remote hubs may not work becausehubs may be very different across cultures and of very different sizes. ·        Alia Atlas added “I am delighted to see efforts.It doesn't have to be a large community. The remote hubs serve as socializationto spread the IETF culture and to build a sense of community.”·        Lee Howard noted that “There is nobody fromAfrica in the room. We [Time Warner Cable] can help with 5 conference rooms”.
·        Goals for remote hubs:o  Networking: hallway conversations and localconnections  o  Get more people working with the IETF o  Not just attend, but participate.   Get more workdoneo  Build community             
Remote hubs seem to be springing up organically in quite afew regions.  Some history of remotehubs:•                   Alvaro Retano stated “We started in LACNIC.  The first one was in the Hawaii IETF. 50people attending from hubs.   In DallasIETF, we had 100  - 200 people and 20hubs.”   Latin America has many remotehubs and plans for many more.  They areorganic and may be quite small with only a few individuals interested in aparticular topic•                   Christian O'Flaherty from the LACNIC regionadded: “We haven't spent any money at all. Many don't even have a projector.Just a PC.   Having 3-4 people discussingis more interesting than attending a meeting by themselves.”•                   Anand Raje reported that India has 23 hubs andover 500 members participating remotely at large universities as a part of theIndian IETF Capacity Building program. See “IICB.org”
The qualities sought for remote hubs:•                   The hubs should be self-sustaining and organizethemselves.  (That is not necessarilydriven by  a central group)        
The pros for remote hubs are: •                   Not everyone can come to the meetings.   Provide that experience.  •                   A remote hub can help to create localcommunities.   Some felt that buildingthe related communities is the most important benefit.  •                   Some felt that increasing participation in IETFis the most important benefit •                   There may be topics of local interest. •                   The remote hub can continue to work outside ofthe IETF meetings.  •                   A remote hub should be a better experience thanattending remotely alone.    Provides agroup of interested individuals or community with opportunities fornetworking.  
The cons for remote hubs:•                   What if the quality of the network connection ispoor?   If I have important work to do, Imay just attend from home where I can better control the connection.•                   What if others do not want to attend the samesessions that I do?  •                   John Klensin: brought up two observations:1.      This is logistically a complicated deal.   Need space or conference room for the hub. 2.      Time zone can be quite challenging
Questions yet to be answered for remote hubs:•                   What if interest in a given hub spans manytracks??  Especially if simultaneoussession demand exists.  Between 5-7 roomsmay be needed to cover various areas. Should there be a hub and “Spoke”arrangement for different rooms/interests? •                   Will people travel within their country (air andhotel) as a “cheaper’ alternative to travelling internationally? •                   Why would people travel domestically anysignificant distance, rather than just set up another remote location?•                   How far should we expect someone to travel to aremote hub?   Should staying overnight beassumed viable?  •                   Would someone travel to the remote hub for justone session?  May need to schedule sothat everyone at that hub would attend two or three consecutive sessions tomake the travel worthwhile.•                   Scheduling across time zones could be anissue,  especially if time zone ofmeeting is Asia.  Can remote hubs userecordings and watch together to address time zone differences.  •                   Can remote hubs be a viable alternative forACTIVE participants?    What about achair or director?   •                   Does IETF sponsor any remote hubs?     •                   Can remote hubs approach the experience ofattending the meetings? •                   Is there a cost to participate in a IETF meetingat a remote hub?   Physical meeting attendeespay $800, will remote hub attendees have any expenses?                •                   Are there any costs involved in running a remotehub?  •                   Is any training or certification needed to be a hub?  
How should IETF support / help remote hubs?•                   Web pages to get information out about remotehubs and what they are covering, schedules and other details/logistics.  •                   Potentially providing emails lists.•                   Ray Peltier offered complete support for remotehubs and to facilitate.  Maybe regionalhosts are needed. Thanks,
Nalini ElkinsInside Products, Inc.www.insidethestack.com(831) 659-8360

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Mon, 14 Dec 2015 22:41:50 +0000

On 12/14/15, 11:31 AM, "Vinayak Hegde" <[email-masked]> wrote:

Vinayak:

Hi!

I've worked (along w/others cc'd: Christian, Carlos) on the Latin American
piece..

>I missed this meeting. I just wanted some feedback on some questions
>to improve the experience of Indian hubs from our Latin American /
>China / Other countries's peers.
>
>1. Was there a common place where people could register signup /
>meetup ? or were these just organic.

In general they have been organic.  Christian has done a great job
collecting information about what/when/where and publishing it to a
regional list.

>2. Was these publicised in some of the regional forums ? What did they
>do to get outreach ?

Yes...everything we could. :-)

We have a Task Force chartered under LACNOG for the purpose of educating
and evangelizing about the IETF to attract people from the region.  So we
do outreach at every LACNOG and LACNIC meetings or course, but take
advantage of every local activity we can get to (lots of travel!), from
local operator group meetings and academic conferences, to regional
efforts such as Red Clara (LATAM NREN network).

>3. Were there any logistical issues that we need to be aware of or is
>just a internet connection and some people is all that they need.

For how our hubs have grown, an internet connection and people is all that
is needed.  Locally there are some efforts to get people
interested/involved, but the start is always with a group that already has
common interests.

>4. Were there any special arrangements done for IETF plenaries ?

No.  Most (probably all) of the hubs have been organized around specific
WGs/topics (IPv6, SDN, IoT, etc.), and not around the plenaries..

>The biggest problems we faced were time zone (which we cannot get rid
>of). Another issue we faced was outreach. Any other ideas /
>suggestions are welcome.

My answers were short..but we would be happy to talk about our experience
any time.

Thanks!

Alvaro.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Mon, 14 Dec 2015 22:46:27 +0000

On 12/1/15, 11:44 AM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

Hi!

Yes, that is a challenge.

What we do is evangelize all we can, ask people to join our regional list and get them thinking about common topics of interest.  When the agenda does come out, we generally publish it to the list and in some cases help people by pointing out interesting meetings.  A good example was the last meeting in Yokohama, where attendance was going to be hard because of the time difference; we made a point of pointing at sessions we thought were of interest that occurred in the morning (still early evening in most of the region).

The scheduling itself has been distributed and organic.  Even so, there is clearly a sprint in the last few weeks before a meeting.

Alvaro.

---

From: <[email-masked]>
Date: Tue, 15 Dec 2015 03:46:03 +0000 (UTC)

On 12/1/15, 11:44 AM, "[email-masked]" <[email-masked]> wrote:
Hi!

>What we do is evangelize all we can, ask people to join our regional list and get them thinking about common topics of interest.  When the agenda does come out, we generally publish it >to the list and in some cases help people by pointing out interesting meetings.  A good example was the last meeting in Yokohama, where attendance was going to be hard because of the >time difference; we made a point of pointing at sessions we thought were of interest that occurred in the morning (still early evening in most of the region).
If I am not incorrect, the schedule for when WGs are presenting seems to be available about two weeks before the meeting itself.  I know I am always looking at the last minute for the days when I am presenting to make sure there are no conflicts.   This kind of late availability of scheduling is going to be very difficult for remote hubs.  People need to make travel plans.
What if the schedule (or 80%) was available earlier.  I mean, I think we know about quite a few WGs that are going to need time.  Do we really think that v6ops, lmap or tls will not need time?   So, maybe there can be a partial schedule available. 
To speak of my own selfish concerns,  I have a hard enough time getting large enterprises interested in the IETF without having no idea of the schedule.  Just FYI, 2 of my co-authors in a number of drafts as well as a part of my study group are from large enterprises.  And, we want to get more involved.  They have a lot to add to the IETF as well as a lot to learn.
Nalini

---

From: Vinayak Hegde <[email-masked]>
Date: Mon, 14 Dec 2015 22:01:25 +0530

Thanks
Vinayak

On Tue, Dec 1, 2015 at 10:14 PM,  <[email-masked]> wrote:
> Folks,
>
> I have written up the discussion at the Remote Hubs "Bar BOF" in Yokohama.
> I have tried to organize this somewhat for coherency.  I will also post to
> the vmeet email list.  That is the email list used for discussion on remote
> access.   Please subscribe to the [email-masked] email list for discussion
> on this topic.   I am copying the EDU and mentoring teams on this so that
> they stay informed about this topic.  If I have forgotten to send this email
> to someone who was in the meeting or is interested, please forward the email
> to them.  If there are any corrections or additions, please let me know.
>
> 2.  Create an I-D out of the discussion below.  This will serve as community
> memory.  If anyone is interested in helping with this, please let me know.
> At a minimum, we should have one participant from each of the major
> geographic regions.
>
> 3.  It occurs to me that to schedule a remote hub, we need to know what the
> agenda is.  For example, I am talking with one group in the U.S. that may be
> interested in only attending the TLS WG session.  But, we don't know when it
> is!  So, how do we schedule and publicize?
>
> The meeting started with a question was posed by Scott Bradner.   "Before we
> go any further, what is a remote hub?  Let's define it."
>
> ·         A remote hub can be anything where more than one person gathers to
> listen / participate in IETF sessions.  It can be as simple as someone's
> living room to major hubs with 7 rooms, telepresence and many people in
> each.  (Such large remote hubs do not actually exist at this point – but
> they could in the future.)
> ·         It is NOT necessarily an entire set of IETF sessions viewed in
> real time.
> ·         A remote hub for a full IETF meeting may not be practical.
> Remote hub for a working group or a few sessions may work better.  At least
> in the beginning.
> ·         There also appear to be regional differences in how hubs are
> organized.   Latin America has previously run quite a few remote hubs as
> does India.  The two regions are different in how they arose, where they
> meet, and what they do.
> ·         Templates for remote hubs may not work because hubs may be very
> different across cultures and of very different sizes.
> ·         Alia Atlas added “I am delighted to see efforts. It doesn't have
> to be a large community. The remote hubs serve as socialization to spread
> the IETF culture and to build a sense of community.”
> ·         Lee Howard noted that “There is nobody from Africa in the room. We
> [Time Warner Cable] can help with 5 conference rooms”.
>
> ·         Goals for remote hubs:
> o   Networking: hallway conversations and local connections
> o   Get more people working with the IETF
> o   Not just attend,  but participate.   Get more work done
> o   Build community
>
> Remote hubs seem to be springing up organically in quite a few regions.
> Some history of remote hubs:
> •                    Alvaro Retano stated “We started in LACNIC.  The first
> one was in the Hawaii IETF. 50 people attending from hubs.   In Dallas IETF,
> we had 100  - 200 people and 20 hubs.”   Latin America has many remote hubs
> and plans for many more.  They are organic and may be quite small with only
> a few individuals interested in a particular topic
> •                    Christian O'Flaherty from the LACNIC region added: “We
> haven't spent any money at all. Many don't even have a projector. Just a PC.
> Having 3-4 people discussing is more interesting than attending a meeting by
> themselves.”
> •                    Anand Raje reported that India has 23 hubs and over 500
> members participating remotely at large universities as a part of the Indian
> IETF Capacity Building program.  See “IICB.org”
>
> The qualities sought for remote hubs:
> •                    The hubs should be self-sustaining and organize
> themselves.  (That is not necessarily driven by  a central group)
>
> The pros for remote hubs are:
> •                    Not everyone can come to the meetings.   Provide that
> experience.
> •                    A remote hub can help to create local communities.
> Some felt that building the related communities is the most important
> benefit.
> •                    Some felt that increasing participation in IETF is the
> most important benefit
> •                    There may be topics of local interest.
> •                    The remote hub can continue to work outside of the IETF
> meetings.
> •                    A remote hub should be a better experience than
> attending remotely alone.    Provides a group of interested individuals or
> community with opportunities for networking.
>
> The cons for remote hubs:
> •                    What if the quality of the network connection is poor?
> If I have important work to do, I may just attend from home where I can
> better control the connection.
> •                    What if others do not want to attend the same sessions
> that I do?
> •                    John Klensin: brought up two observations:
> 1.       This is logistically a complicated deal.   Need space or conference
> room for the hub.
> 2.       Time zone can be quite challenging
>
> Questions yet to be answered for remote hubs:
> •                    What if interest in a given hub spans many tracks??
> Especially if simultaneous session demand exists.  Between 5-7 rooms may be
> needed to cover various areas. Should there be a hub and “Spoke” arrangement
> for different rooms/interests?
> •                    Will people travel within their country (air and hotel)
> as a “cheaper’ alternative to travelling internationally?
> •                    Why would people travel domestically any significant
> distance, rather than just set up another remote location?
> •                    How far should we expect someone to travel to a remote
> hub?   Should staying overnight be assumed viable?
> •                    Would someone travel to the remote hub for just one
> session?  May need to schedule so that everyone at that hub would attend two
> or three consecutive sessions to make the travel worthwhile.
> •                    Scheduling across time zones could be an issue,
> especially if time zone of meeting is Asia.  Can remote hubs use recordings
> and watch together to address time zone differences.
> •                    Can remote hubs be a viable alternative for ACTIVE
> participants?    What about a chair or director?
> •                    Does IETF sponsor any remote hubs?
> •                    Can remote hubs approach the experience of attending
> the meetings?
> •                    Is there a cost to participate in a IETF meeting at a
> remote hub?   Physical meeting attendees pay $800, will remote hub attendees
> have any expenses?
> •                    Are there any costs involved in running a remote hub?
> •                    Is any training or certification needed to be a hub?
>
> How should IETF support / help remote hubs?
> •                    Web pages to get information out about remote hubs and
> what they are covering, schedules and other details/logistics.
> •                    Potentially providing emails lists.
> •                    Ray Peltier offered complete support for remote hubs
> and to facilitate.  Maybe regional hosts are needed.
>
> Thanks,
>
> Nalini Elkins
> Inside Products, Inc.
> www.insidethestack.com
> (831) 659-8360

---

From: John C Klensin <[email-masked]>
Date: Tue, 15 Dec 2015 09:48:40 -0500

--On Tuesday, December 15, 2015 03:46 +0000
[email-masked] wrote:

>> The scheduling itself has been distributed and organic.
>>  Even so, there is clearly a sprint in the last few weeks
>> before a meeting.

> If I am not incorrect, the schedule for when WGs are
> presenting seems to be available about two weeks before the
> meeting itself. 

You mean the _tentative_ schedule.  We (the IETF) still operates
in a model in which changes are still possible up to the time
the meeting starts and even during the meeting week... and that
option is used often enough to be disruptive for any plans based
on travel, etc., to attend single or particular WGs.    Looking
for presentation times is even worse because agendas are often
not posted until a few days or hours before the sessions (and
sometimes not then) and the IESG rarely, if ever, responds to
that in a way that would discourage bad behavior or encourage
good behavior.

<rant -- see last part of note before reacting>

If you think that enough information to do advanced scheduling
-- to me, that means agendas and schedules that are available
and fixed significantly in advance and not changed unless there
are emergencies that can be explained to the community -- is
important, then try to persuade the IESG.  If the IESG cannot be
persuaded, tell it to the Nomcom and tell them this is important
enough to open their schedule back up.   On the other hand, if
you think the present flexibility is more important, then we
should not make plans that depend on stable schedule information
being available well before IETF meetings.   

That, of course, takes me back to my repeated questions about
just what we expect remote hubs to accomplish and for whom.  If
the goal is bringing newcomers and less-active participants
together for group discussions and a social event rather than
the expectation of making real contributions to the IETF
program, the above issues may not be particularly important.
</rant>

 I know I am always looking at the last
> minute for the days when I am presenting to make sure there
> are no conflicts.   This kind of late availability of
> scheduling is going to be very difficult for remote hubs.

yep.

>  People need to make travel plans. What if the schedule (or
> 80%) was available earlier.  I mean, I think we know about
> quite a few WGs that are going to need time.  Do we really
> think that v6ops, lmap or tls will not need time?   So, maybe
> there can be a partial schedule available.  To speak of my
> own selfish concerns,  I have a hard enough time getting
> large enterprises interested in the IETF without having no
> idea of the schedule.  Just FYI, 2 of my co-authors in a
> number of drafts as well as a part of my study group are from
> large enterprises.  And, we want to get more involved.  They
> have a lot to add to the IETF as well as a lot to learn. 

Nalini, having been part of the scheduling process, it is really
hard (the comments above notwithstanding).  There is a real, and
important, effort to reduce significant conflicts and allow more
openness and broad-perspective (including but not limited to
"cross-area") review and discussion.  In an ideal world,
schedules would not be set until agendas are in hand, but, if a
WG is really doing a lot of work on its mailing list (as it
should be), setting an agenda more than a couple of weeks in
advance may require the ability to foretell the future as well
as being disruptive of work during those weeks.   The result is
that the flexibility really is important and includes scheduling
tradeoffs within and across areas, not just the two of three WGs
that some large enterprise wants to target.   

IMO, we don't do a good enough job of that now and still end up
with WG sessions in conflict for particular key individuals.  It
may be impossible to get it "right".  Whether it is or not,
adding more constraints --such as stable schedules (and agendas)
early enough to plan travel around them -- isn't going to make
it any easier.  We should be careful what we wish for.  And,
while I think remote hubs are an interesting and probably-useful
idea, we need, IMO, to keep IETF effectiveness in getting work
done as our first priority.

    john

---

From: <[email-masked]>
Date: Tue, 15 Dec 2015 15:32:02 +0000 (UTC)

John,
First, thank you for your thoughtful comments and actually love the rant.   More inline.
Nalini
--On Tuesday, December 15, 2015 03:46 +0000

>program, the above issues may not be particularly important.
John, you point out correctly that this is key.   Let me backup for one minute to tell you exactly why I think that more and different people need to be involved in the IETF.  Then, as this all develops, I am thinking that remote hubs, valuable as they are, will not be the solution for all the issues that I am about to bring up.
1. First goal: To design and maintain a good protocol, IMHO, feedback is needed from the users of that protocol in reality (operators, large enterprises, etc), as well as people who are implementing the protocol.   And, this needs to happen on an ongoing basis.   Sometimes, in some groups, this happens.  (Having open source more involved for example, is totally wonderful.)  But, just from what I have seen, all too often, it does not.   Designing in a vacuum-ish environment is not a super good idea.   Any organism needs good feedback in order to survive.   This was my reason for wanting to have large enterprises involved.
My hope was that with remote hubs, we could get more such people to participate.   But, now I am not so sure.   I actually also think that a different format may be needed for such meetings.  I think it would be difficult to drop these people into a WG session and to have them get much out of it or be able to contribute.  
However, I do think this issue is important.   I will put this in the back of my mind and think about how this may work.  (But, actually, I want to get regional mentoring & remote hubs going first & then maybe by IETF 97 or 98, something will come to me or to someone else in the community, if someone else also thinks this is important.)

2.  Second goal: this, I think is more do-able.   People who regularly attend IETF cannot always do so because of financial constraints.  Remote hubs can be one solution.

3.  Third goal: also, I think do-able.  People who WANT to be involved in IETF and have some level of support (ex. in Latin America, India, etc) with an ongoing group who can help prepare for the WG session(s).    These people would attend actual IETF meetings, if they could afford it, but they can't - so remote hub it.

4.  Fourth goal: possibly do-able but will need effort.  There are many valuable people in the academic world who could participate and are doing potentially relevant work but do not know so much about IETF.   Here, support and an ongoing group first needs to be built who can help prepare for the WG session(s).    These people down the road At may want to attend actual IETF meetings, but to start, go to a remote hub.
This actually applies to the start-up community as well.  I was contacted the other day by a Silicon Valley developer doing sensor stuff and wanting down the road to be involved in ROLL.   He could not afford to attend live.  I definitely know how that is.   At my own start-up, for many years, I could not have afforded to attend IETF meetings live.  If I had had the option to be involved in a remote hub in Silicon Valley, I would definitely have taken advantage of that.

> And, while I think remote hubs are an interesting and probably-useful idea, we need, IMO, to keep IETF effectiveness in getting work done as our first priority.

Of course, I agree with you in this.   I get caught up and sometimes overly enthusiastic sometimes.   Thanks for the reality check.   This is why I value the community and collaboration of IETF so much!
Nalini

---

From: Vinayak Hegde <[email-masked]>
Date: Wed, 16 Dec 2015 02:34:40 +0530

Thanks Alvaro. Let me talk with the organizers of SANOG - our regional
NOG. I have done a talk of talks about IETF at SANOG but nothing
structured and regularly. I think this is good feedback to do this in
a more structured manner, now that we have more contributors from the
region.

We did a short meetup of all local contributors in Bangalore recently
and are looking to do a bootcamp soon.

Thanks
Vinayak