Subject: [edu-team] newcomer's tutorial

From: Michael StJohns <[email-masked]>
Date: Fri, 10 Jun 2016 14:30:30 -0400

Hi -

I'm in the process of making a pass over the last version to see what 
needs to be done for this upcoming meeting.  I sort of had a thought - 
why don't we break this down into two parts.  The first part is "what do 
I need to know immediately to gain the most benefit from attending this 
meeting?"  and the second is "where do I need to go to drill down into 
the background and nitty gritty of the IETF?"

The first part would cover things like basic IETF culture; the 
difference between the IETF and other SDOs; the difference between a WG 
and a BOF; who's who (decoding the dots); the IETF's view of consensus; 
general ettiquette (e.g. don't hog the microphone and do let others get 
their share of the munchies at the welcome reception); the location of 
the Agenda and WG agendas; why the heck the IRTF is meeting in the same 
location; suggestions NOT to volunteer as scribes for their first 
meeting (so they can listen and learn); and a brief overview of the 
people that make the meeting and IETF work - the secretariat, RFC-Editor 
and IANA. There would be a page or two of QR codes that would point 
people to the various websites for more details.

The second part - which it may make sense *not* to do this time around - 
is the deeper dive on IETF history, organization, relationship to the 
ISOC, ICANN. A description of how WGs are formed; the process for 
getting RFCs through the standards process; pointers to the tool set; 
how we're funded; the nomcom etc.  All things they may need to know, 
just not *right now*.

I'm still considering adding a panel discussion to the end of the 
presentation - but haven't quite decided.

The reason for doing this is that the current presentation is just too 
damn long.  I'd like a shorter and more immediately useful set of data.

Thoughts?

Mike

---

From: <[email-masked]>
Date: Fri, 10 Jun 2016 19:36:05 +0000 (UTC)

>damn long.  I'd like a shorter and more immediately useful set of data.

I think the current presentation does take about 2 hours, if I remember correctly.  I sat in on it at IETF93 or 94.  Just to see what Scott was saying.

I think it is a lot for people to absorb all at once.   So, what would be done with the part that you don't immediately present?

Nalini

---

From: Michael StJohns <[email-masked]>
Date: Fri, 10 Jun 2016 15:59:47 -0400

> I think the current presentation does take about 2 hours, if I remember correctly.  I sat in on it at IETF93 or 94.  Just to see what Scott was saying.
It's scheduled for 90 minutes and Scott did it this last time in about 
80.  I'd really like that to be closer to 30 or 40 minutes. With maybe 
another 15-20 of panel discussion and QA.
> I think it is a lot for people to absorb all at once.   So, what would be done with the part that you don't immediately present?

Maybe archive it or just provide a pointer (URL) to it for now. I'd have 
to see what's left over.

Mike

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 11 Jun 2016 08:48:58 +1200

Hi Mike,

On 11/06/2016 06:30, Michael StJohns wrote:
> Hi -
> 
> I'm in the process of making a pass over the last version to see what needs to be done for this upcoming meeting.  I sort of had
> a thought - why don't we break this down into two parts.

Of course, Scott's videos already break it down into N parts. For self-study
purposes, that is definitely much better. If you do split the live show,
it should be correlated, i.e. tell people at the end of Part I "Now you
can jump into the videos at such-and-such a point."

> The first part is "what do I need to know immediately to gain the most
> benefit from attending this meeting?"  and the second is "where do I need to go to drill down into the background and nitty
> gritty of the IETF?"
> 
> The first part would cover things like basic IETF culture; the difference between the IETF and other SDOs; the difference
> between a WG and a BOF; who's who (decoding the dots); the IETF's view of consensus; general ettiquette (e.g. don't hog the
> microphone and do let others get their share of the munchies at the welcome reception); the location of the Agenda and WG
> agendas; why the heck the IRTF is meeting in the same location; suggestions NOT to volunteer as scribes for their first meeting
> (so they can listen and learn); and a brief overview of the people that make the meeting and IETF work - the secretariat,
> RFC-Editor and IANA. There would be a page or two of QR codes that would point people to the various websites for more details.
> 
> The second part - which it may make sense *not* to do this time around - is the deeper dive on IETF history, organization,
> relationship to the ISOC, ICANN. A description of how WGs are formed; the process for getting RFCs through the standards
> process; pointers to the tool set; how we're funded; the nomcom etc.  All things they may need to know, just not *right now*.

It make sense, as long as there are pointers for anyone who *does* need to know
right now. Making it take less time is good for other reasons; Sundays are getting
to be busy.

> 
> I'm still considering adding a panel discussion to the end of the presentation - but haven't quite decided.

Something to encourage Q/A is good. Not sure about a formal panel, but maybe
persuade a few ADs and WG Chairs to drop in and assist in Q/A?

Regards
    Brian

> 
> The reason for doing this is that the current presentation is just too damn long.  I'd like a shorter and more immediately
> useful set of data.
> 
> Thoughts?
> 
> 
> Mike
> 
> 
> 
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: <[email-masked]>
Date: Sat, 11 Jun 2016 13:17:48 +0000 (UTC)

Michael,
Mentoring does a number of email blasts to the 1st timers email list as well as the 96attendees email list to tell them about mentoring events (speed mentoring, etc).  It is getting near time to start those.
Mirjam suggested letting them know about the Newcomer's tutorial.  (Great idea!).   Is there anything you would like for me to say?
For IETF97, we can coordinate email blasts that have all EDU / mentoring information, if that sounds good to everyone.   Maybe for IETF96, we can continue our usual behavior of having mentoring team email blasts and change for IETF97, if needed
Please let me know what you think. Thanks,
Nalini ElkinsInside Products, Inc.www.insidethestack.com(831) 659-8360

---

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 14 Jun 2016 10:44:35 +0200

Hi Mike,

I think it is a good idea to split this up into shorter parts. We'd have
to think about what to do with the second part as other have said. I
also like Brian's idea to refer to some of Scott's videos for further
information where ever appropriate. An hour for the newcomers tutorial
is probably enough.

Eventually we might want to point first-timers to online material before
the meeting and then use the newcomers slot mostly for Q&A (even though
I am not sure yet how we will get first-timers to ask questions).

What do others think?

Mirjam

---

From: Michael StJohns <[email-masked]>
Date: Tue, 14 Jun 2016 13:16:33 -0400

> I am not sure yet how we will get first-timers to ask questions).
I don't think that we totally want to go to a Q&A.  Even if you read the 
IETF mailing list and have worked on documents, the IETF in person 
really requires some introduction.

Especially after reading the IETF mailing list!!

Seriously, I swear I'm going to have "Standards by Combat" T-Shirts made 
up.   Two geeks, each holding a very thick (300 page or so) internet 
drafts raised above their heads ready to hit someone facing each other 
with a referee between them that looks something like Fred Baker with a 
conversation balloon that says "... and my God Defend the Right!"

---

From: Benoit Claise <[email-masked]>
Date: Sun, 19 Jun 2016 04:24:58 -0700

On 6/14/2016 10:16 AM, Michael StJohns wrote:
> I don't think that we totally want to go to a Q&A.  Even if you read 
> the IETF mailing list and have worked on documents, the IETF in person 
I would agree.
So the best combination is to point first-timers to online material 
before the meeting (so that they think about their questions) and still 
present it.

Regards, B.

> Seriously, I swear I'm going to have "Standards by Combat" T-Shirts 
> made up.   Two geeks, each holding a very thick (300 page or so) 
> internet drafts raised above their heads ready to hit someone facing 
> each other with a referee between them that looks something like Fred 
> Baker with a conversation balloon that says "... and my God Defend the 
> Right!"
>
>>
>> What do others think?
>>
>> Mirjam
>>
> .

---

From: Michael StJohns <[email-masked]>
Date: Sun, 19 Jun 2016 19:13:49 -0400

On 6/19/2016 7:24 AM, Benoit Claise wrote:
> before the meeting (so that they think about their questions) and 
> still present it. 

The last time I saw anyone do any homework before a class was a graduate 
level course in computers and ethics.

Seriously though, while I think its a good idea to point new folk to 
on-line stuff, basing a presentation on the home that maybe someone 
actually read it... well, probably a waste of time.

Later, Mike

---

From: Mirjam Kuehne <[email-masked]>
Date: Mon, 20 Jun 2016 15:27:27 +0200

> before the meeting (so that they think about their questions) and still

Yes, absolutely. Sorry if that wasn't clear. My main point was that it
would be great if we could point newcomers (first-timers) to some online
material before they attend the meeting so they feel a bit prepared. I
agree we should still give a newcomers tutorial.

Mirjam