Subject: [edu-team] GitHub Tutorial

From: Russ Housley <[email-masked]>
Date: Tue, 11 Apr 2017 13:02:48 -0400

In the hallway, I heard some people asking for a Sunday tutorial about GitHub.  Maybe we can find someone to talk about that.  Martin and Mark are on the IAB, so they are probably not available on Sunday afternoon.  Who else could do it?

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 12 Apr 2017 10:48:43 +0200

Hi Russ,

Thanks for the suggestion. We had a GitHub training for WG chairs some
time ago which was well receive. I also thought it would be a good time
to provide that for the larger IETF community.

On the other hand, at IETF 98 there was a GitHub BoF (organised by Paul
Hoffman) which was also discussed during the WG chairs session. I had a
chat with Paul Hoffman afterwards. He thought it would be too early for
a tutorial at this point until we have all the processes in order (how
to integrate email discussions with discussions on GitHub etc.). I am
not sure I am convinced however. People won't stop using GitHub in the
meantime and it wouldn't hurt to provide some tips and tricks.

At the WG chairs session it was also suggested to possibly combine this
with other tools and provide a training on travis(?), circl and GitHub
for instance.

What do others think?

Mirjam

On 11/04/17 19:02, Russ Housley wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: Russ Housley <[email-masked]>
Date: Wed, 12 Apr 2017 10:22:07 -0400

I think it would be a good time for an advocate to share the reasons that they like to use GitHub.  There are of course other options, but GitHub seems to be gaining momentum.

I do not think we should wait until everything is polished.  Letting people use GitHub and sharing their experiences will help the community make the right decisions.  As you know, I believe in incremental improvement.

Russ

> On Apr 12, 2017, at 4:48 AM, Mirjam Kuehne <[email-masked]> wrote:
> 
> Hi Russ,
>

---

From: Niels ten Oever <[email-masked]>
Date: Wed, 12 Apr 2017 16:30:01 +0200

Hi all,

I think this could be different kind of workshops:

1. Github 101 (how does Github work)
2. How to collaborate on a draft using Github
	- kramdown
	- xml2rfc
	- automated building on Github with Travis / Circle
	- Receiving pull requests & mapping issues
3. How to setup a repository for a WG

I think 3. would be controversial (and maybe hard to do without Mark
because the HTTPbis WG website is currently pretty much the furthest you
can go where it comes to Github integration and use of it functionality)

1. and 2. should probably be doable in two hours?

Best,

Niels

Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint    2458 0B70 5C4A FD8A 9488
                   643A 0ED8 3F3A 468A C8B3

On 04/12/2017 04:22 PM, Russ Housley wrote:
> I think it would be a good time for an advocate to share the reasons
> that they like to use GitHub.  There are of course other options, but
> GitHub seems to be gaining momentum.
> 
> I do not think we should wait until everything is polished.  Letting
> people use GitHub and sharing their experiences will help the
> community make the right decisions.  As you know, I believe in
> incremental improvement.
> 
> Russ
> 
> 
>> Thanks for the suggestion. We had a GitHub training for WG chairs
>> some time ago which was well receive. I also thought it would be a
>> good time to provide that for the larger IETF community.
>> 
>> On the other hand, at IETF 98 there was a GitHub BoF (organised by
>> Paul Hoffman) which was also discussed during the WG chairs
>> session. I had a chat with Paul Hoffman afterwards. He thought it
>> would be too early for a tutorial at this point until we have all
>> the processes in order (how to integrate email discussions with
>> discussions on GitHub etc.). I am not sure I am convinced however.
>> People won't stop using GitHub in the meantime and it wouldn't hurt
>> to provide some tips and tricks.
>> 
>> At the WG chairs session it was also suggested to possibly combine
>> this with other tools and provide a training on travis(?), circl
>> and GitHub for instance.
>> 
>> What do others think?
>> 
>> Mirjam
>> 
>> 
>>> In the hallway, I heard some people asking for a Sunday tutorial
>>> about GitHub.  Maybe we can find someone to talk about that.
>>> Martin and Mark are on the IAB, so they are probably not
>>> available on Sunday afternoon.  Who else could do it? 
>>> _______________________________________________ edu-team mailing
>>> list [email-masked] 
> _______________________________________________ edu-team mailing
> list [email-masked]