Subject: [Emu] Agenda items for EMU @ IETF 111

From: Mohit Sethi M <[email-masked]>
Date: Fri, 4 Jun 2021 07:44:44 +0000

Dear all,

We have a requested a 1 hour session for EMU @ IETF 111. Please send the 
chairs ([email-masked]) requests for presentation slots.

Don't forget to include the title of your presentation, related drafts, 
and the approximate amount of time needed. Even if you don't have all 
the information ready, at least let us know about your intention to 
present. It would let us gauge if a 1 hour session is sufficient.

Joe and Mohit

---

From: "Meiling Chen" <[email-masked]>
Date: Fri, 4 Jun 2021 16:49:53 +0800

Hi Mohit,
I need 5-10minites to introduce our changes for the new version draft-chen-emu-eap-tls-ibs-02,
https://datatracker.ietf.org/doc/draft-chen-emu-eap-tls-ibs/ 

Best,
Meiling
 
From: Mohit Sethi M
Date: 2021-06-04 15:44
To: [email-masked]
Subject: [Emu] Agenda items for EMU @ IETF 111
Dear all,

 
Joe and Mohit
 
_______________________________________________
Emu mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/emu

---

From: John Mattsson <[email-masked]>
Date: Tue, 8 Jun 2021 08:53:21 +0000

Hi Meiling,

I just looked through this draft quickly.

- draft-ietf-tls-dtls13 specifies DTLS 1.3 which is not used in EAP-TLS. You likely want to reference RFC8446 or RFC8446bis.

- I don't really understand why a new EAP method is needed here, this just seems like ordinary EAP-TLS to me...

- TLS 1.2 was made obsolete in 2018. It should be phased out, not expanded with new fuctionality. This a -00 draft and would not be published as an RFC for a while, when TLS 1.2 would be even more obsolete.

- As TLS 1.3 mandates ephemeral diffie-hellman, the privacy is good. If new TLS 1.2 is really needed, ephemeral diffie-hellman should be mandated as is done in RFC 7540. Otherwise the Private Key Generator (PKG) https://en.wikipedia.org/wiki/Identity-based_encryption can passivle eavesdrop on all encrypted application data (This matters for TLS and most TLS based EAP types, but not EAP-TLS).

Cheers,
John

From: Emu <[email-masked]> on behalf of Meiling Chen <[email-masked]>
Date: Friday, 4 June 2021 at 10:49
To: Mohit Sethi M <mohit.m.sethi=[email-masked]>, emu <[email-masked]>
Subject: Re: [Emu] Agenda items for EMU @ IETF 111
Hi Mohit,
I need 5-10minites to introduce our changes for the new version draft-chen-emu-eap-tls-ibs-02,
https://datatracker.ietf.org/doc/draft-chen-emu-eap-tls-ibs/

Best,
Meiling

From: Mohit Sethi M<mailto:mohit.m.sethi=[email-masked]>
Date: 2021-06-04 15:44
To: [email-masked]<mailto:[email-masked]>
Subject: [Emu] Agenda items for EMU @ IETF 111
Dear all,

Joe and Mohit

---

From: "Meiling Chen" <[email-masked]>
Date: Fri, 11 Jun 2021 15:13:41 +0800

Hi John,
Thanks for sharing your opinion. 
The reference to draft-ietf-tls-dtls13 was wrote by mistake since version 01, I will correct it next version.
I'm not against your point of view, EAP-TLS-IBS is based on the procedure of EAP-TLS, but the certificate has been extended with IBS, so we consider it as a new EAP method.
TLS1.2 was originally considered for compatibility, if it is all based on tls1.3 in the future, then this part will be deleted according to practicability.

Best,
Meiling

From: John Mattsson
Date: 2021-06-08 16:53
To: Meiling Chen; Mohit Sethi M; emu
Subject: Re: [Emu] Agenda items for EMU @ IETF 111
Hi Meiling,

 

 
Cheers,
John

Best,
Meiling
 
From: Mohit Sethi M
Date: 2021-06-04 15:44
To: [email-masked]

 
Joe and Mohit