Subject: Re: FW: [ESDS] ESDS vs x.509

From: Robert LISIAK <[email-masked]>
Date: Tue, 27 Nov 2007 16:20:45 +0100

Bonjour Messieurs,
Bonjour Frank,

OK! I see, but how the ESDS interacts with PKI CRL?

What is / are the mechanism(s) in charge of these interactions?

Are they (mechanisms) IPv4 compliant or these are native IPv6?

In fact there are a lot of ipv6 project throughout the world but a  
huge amount of work remain to accomplish and most, event IT, people  
know not enough the ipv6
The ipv4 is well known but still complex to implement, outside the  
http;smtp etc…, the signed key exchange (x.509).

Many thanks for your explications :-)
-- 
robert.lisi@k
+33 687.77.65.73
ICQ UIN : 179675117
<><
----------------------------------
system and network security advise
not another RFID company member
----------------------------------

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.

_______________________________________________
ESDS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/esds

---

From: Frank Thompson <[email-masked]>
Date: Tue, 27 Nov 2007 21:26:37 +0000 (UTC)

> OK! I see, but how the ESDS interacts with PKI CRL?

ESDS uses SOAP/HTTP(s) as one of it's bindings and it would be the HTTPS 
provider that would handle the CRL (certificate revoke list) as part of 
the PKI at the server side.

> What is / are the mechanism(s) in charge of these interactions?

these would depend on the SSL provider used by the implementation (ie: 
OpenSSL crl.pem)

> Are they (mechanisms) IPv4 compliant or these are native IPv6?

these are more reasons why not to have X509 in the spec as it is handled 
in the lower OSI layers.

cheers
frank

> 
> In fact there are a lot of ipv6 project throughout the world but a huge amount
> of work remain to accomplish and most, event IT, people know not enough the
> ipv6
> The ipv4 is well known but still complex to implement, outside the http;smtp
> etc…, the signed key exchange (x.509).
>

---

From: Robert Lisiak <[email-masked]>
Date: Wed, 28 Nov 2007 21:45:57 +0100

Althoug the SOAP, WSDL and UDDI are content-oriented protocols and do
not really fit in the OSI network oriented stack I have prepare the
OSI like ESDS proto chain.

Please tell me if I well understood yours intentions?

ESDS (ascii) Proto chain:
7 Application - ESDS Consuming business logic (XML Object binding)  ->
6 Presentation - SOAP Outbound Handlers ->
5 Session - HTTP(s), SSL ->
4 Transport - TCP <->
3 Network - IP <->
and so...
server side (Demultiplexing TCP/IP)
3, 4 TCP/IP
5 Session - HTTP(s), SSL <-
6 Presentation - Soap Inbound Handlers <-
7 Application - ESDS Publishing business logic (XML Object binding) <-

Please find also as attachment the graphical ESDS proto chain.

Salutations
- --

robert.lisi@k
+33 687.77.65.73
ICQ UIN : 179675117
<><
- ----------------------------------
system and network security advise
not another RFID company member
- ----------------------------------

>> In fact there are a lot of ipv6 project throughout the world but a
huge amount
>> The ipv4 is well known but still complex to implement, outside the
http;smtp

---

From: Frank Thompson <[email-masked]>
Date: Wed, 28 Nov 2007 21:10:36 +0000 (UTC)

Hi Robert,

Yes that is the idea a WSDL which represents the interface to the system 
it is the interface and the semantics of the interface that we are 
primarily concerned with.  The implementation details like X509 do not 
belong inside the interface. 

frank

On Wed, 28 Nov 2007, Robert Lisiak wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.6 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
> 
> iD8DBQFHTdOFBTgR9iI/KukRAmnxAJoD45kVGAxHD5/tGL4EWA+l/lg9NACdEHRQ
> YmQFfcijadZMcEi0BetEL/U=
> =9hvQ
> -----END PGP SIGNATURE-----
> 
>