Subject: [Extra] Fwd: I-D Action: draft-bosch-imap-status-size-00.txt

From: Stephan Bosch <[email-masked]>
Date: Fri, 15 Sep 2017 22:16:07 +0200

Hi,

A while back, I created a specification for an existing, vendor-specific
Dovecot IMAP feature that was supported implicitly (without a capability
identifier). It is called STATUS=SIZE.

I submitted it as a draft now in an effort to get it standardized. See
the attached I-D announcement.

Please let me know what you think.

Regards,

Stephan.

Subject: I-D Action: draft-bosch-imap-status-size-00.txt
From: [email-masked]
To: <[email-masked]>
Date: Fri, 15 Sep 2017 13:05:36 -0700
List-Id: Internet Draft Announcements only <i-d-announce.ietf.org>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Internet Message Access Protocol (IMAP) - STATUS=SIZE Extension
        Author          : Stephan Bosch
	Filename        : draft-bosch-imap-status-size-00.txt
	Pages           : 5
	Date            : 2017-09-15

Abstract:
   This document adds a new capability called "STATUS=SIZE" to the
   Internet Message Access Protocol (IMAP).  It allows retrieving the
   total storage size of a mailbox with a single STATUS command rather
   than retrieving and summing the sizes of all individual messages in
   that mailbox.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-bosch-imap-status-size/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-bosch-imap-status-size-00
https://datatracker.ietf.org/doc/html/draft-bosch-imap-status-size-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Bron Gondwana <[email-masked]>
Date: Sun, 17 Sep 2017 01:14:01 +1000

Makes sense.  We expose this in Cyrus IMAPd as a metadata item:

/shared/vendor/cmu/cyrus-imapd/size

Cleanly that's not very standard-like - but it does raise a question
whether we want to standardise some per-mailbox metadata items rather
than define extra capabilities.
Bron.

On Sat, 16 Sep 2017, at 06:16, Stephan Bosch wrote:
> Hi,
> 
> A while back, I created a specification for an existing, vendor-
> specific> Dovecot IMAP feature that was supported implicitly (without a
> capability> identifier). It is called STATUS=SIZE.
> 
> I submitted it as a draft now in an effort to get it standardized. See> the attached I-D announcement.
> 
> _________________________________________________
> Extra mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/extra
> Email had 1 attachment:

>  * I-D Action: draft-bosch-imap-status-size-00_txt.eml 4k
>    (message/rfc822)
--
  Bron Gondwana, CEO, FastMail Pty Ltd
  [email-masked]

---

From: Lyndon Nerenberg <[email-masked]>
Date: Sat, 16 Sep 2017 08:23:23 -0700

> On Sep 16, 2017, at 8:14 AM, Bron Gondwana <[email-masked]> wrote:
> 
> Cleanly that's not very standard-like - but it does raise a question whether we want to standardise some per-mailbox metadata items rather than define extra capabilities.

I agree.  The possibilities for exposing standardized metadata are pretty open ended.  The potential to overwhelm the capability list is quite high once you start factoring in all the possible metadata variations.

We could ponder defining a standard metadata namespace (a table of contents, I guess you could call it) that defines other standardized metadata namespaces presented by the server.  That could be flagged with a capability (METATOC ?), directing clients to do the indirect lookup through the TOC.

--lyndon

---

From: Stephan Bosch <[email-masked]>
Date: Sat, 16 Sep 2017 20:29:18 +0200

> than define extra capabilities.

I agree having a METADATA subtree for all kinds of mailbox properties
like this is useful.

Still, for storage size, I like a STATUS data item better, particularly
because it can be queried for several mailboxes at the same time using a
single LIST command. And it pairs quite well with the existing MESSAGES
item (with QUOTA in mind).

Also, I am hoping that this is simple enough that it can be part of
IMAP4rev2 once we get there, thereby removing it from the capability list.

Regards,

Stephan.
>> [email-masked] <mailto:[email-masked]>
>>  *
>>     |I-D Action: draft-bosch-imap-status-size-00_txt.eml|
>>       4k (message/rfc822)
>>
>
> --

-- 
Stephan Bosch
Senior Developer 

Phone: +49 2761 75252 00  Fax: +49 2761 75252 30
Email: [email-masked]

-------------------------------------------------------------------------------------
Open-Xchange AG,  Rollnerstr. 14, 90408 Nuremberg, District Court Nuremberg HRB 24738
Managing Board: Rafael Laguna de la Vera, Carsten Dirks, Michael Knapstein 
Chairman of the Board: Richard Seibt

Dovecot Oy, Lars Sonckin Kaari 10, 02600 Espoo, Finland
Managing Director: Markku Kentta
Chairman of the Board: Timo Sirainen
Board Member: Carsten Dirks

-------------------------------------------------------------------------------------

---

From: Bron Gondwana <[email-masked]>
Date: Mon, 25 Sep 2017 12:36:40 +1000

I've created https://github.com/ietfextra/tracking/issues/2 to track the
status of adding this draft.

On Sun, 17 Sep 2017, at 04:29, Stephan Bosch wrote:
>> Cleanly that's not very standard-like - but it does raise a question>> whether we want to standardise some per-mailbox metadata items rather>> than define extra capabilities.
> 
> I agree having a METADATA subtree for all kinds of mailbox properties> like this is useful.
> 
> Still, for storage size, I like a STATUS data item better,
> particularly> because it can be queried for several mailboxes at the same
> time using a> single LIST command. And it pairs quite well with the existing
> MESSAGES> item (with QUOTA in mind).
> 
>>> specific>>> Dovecot IMAP feature that was supported implicitly (without a
>>> capability>>> identifier). It is called STATUS=SIZE.
>>> 
>>> I submitted it as a draft now in an effort to get it
>>> standardized. See>>> the attached I-D announcement.
>>> 
>>> ___________________________________________________
>>> Extra mailing list
> ----------------------------------------------------------------------
> ---------------> Open-Xchange AG,  Rollnerstr. 14, 90408 Nuremberg, District Court
> Nuremberg HRB 24738
> ----------------------------------------------------------------------
> --------------->