Subject: RE: Capability terminology

From: "McIntyre, Lloyd" <[email-masked]>
Date: Fri, 13 Nov 1998 13:10:45 -0800

> -----Original Message-----
> From:	Dan Wing [SMTP:[email-masked]]
> Sent:	Friday, November 13, 1998 11:50 AM
> To:	Graham Klyne
> Cc:	conneg WG; [email-masked]
> Subject:	Re: Capability terminology
> 
> On Fri, 13 Nov 1998, Graham Klyne wrote:
> 
> > I do not see the sender disclosing any of its capabilities to the
> recipient
> > in G3 fax.  
> 
> Doesn't the DIS go one directiona and the DCS the other direction
> (sender->recipient and recipient->sender)?  I'm not a fax person and
> my
> copy of T.30 is at home (of course) and I'm at work.  I've certainly
> been wrong before and am likely to be wrong again.
	[McIntyre, Lloyd]  The DCS does not provide capability
information. It sets the session parameters based on the capabilities
defined in the DIS.

> > In eifax, the existence of certain MDN request extensions might
> > give some clues, but I still see no two-way transaction here.  I
> think that
> > is "capability identification".  But it is also called "capability
> > exchange" by some, hence my definition.
> > 
> > Anyway, do you wish to propose an alternative definition for
> "capability
> > exchange"?
> 
> Your original definition is fine, but I'd just like an additional
> sentence
> or embedded phrase which clarifies that an "exchange" it isn't
> necessarily
> a bi-directional exchange (per the dictionary definition of the word
> "exchange").
> 
> -Dan Wing
> 
>

---

From: Dan Wing <[email-masked]>
Date: Fri, 13 Nov 1998 13:35:38 -0800 (PST)

> information. It sets the session parameters based on the capabilities

So:  "DIS: This is what I can receive", and "DCS: This is what I'm going
to send".  Right?  

That's an exchange.

-Dan Wing