Subject: RE: [VPIM] Analogy to Content-Duration for Faxes

From: Tony Kueh <[email-masked]>
Date: Mon, 7 Feb 2000 17:40:05 -0800

From an UM perspective, you could potentially have multiple faxes within one
message. How would one calculate the total length in the subject field? If
it was really part of the subject, then changing the content of a message
(ie. forward a fax) would require the update of the subject field.
 
Sounds like a lot of work.
 
Why not just keep the Content-Length header on the body part and have the
clients that wish to render a total length to dynamicallly pre-pend it or
set it on the rendered subject field on the fly?
 
-----Original Message-----
From: Glenn Parsons [mailto:[email-masked]]
Sent: Monday, February 07, 2000 8:07 AM
To: IETF VPIM List
Cc: [email-masked]
Subject: RE: [VPIM] Analogy to Content-Duration for Faxes

At one point we had proposed a 'Content-Length' header specifically for fax
page count.  I cannot remember if it was ever included in an RFC or not.

In practice, we have found it more practical to put thie information in the
Subject field.  Then the user will see the info in their GUI. 

Cheers, 
Glenn. 

	---------- 
From:   Murray, Doug 
Sent:   Thursday, February 3, 2000 6:11 pm 
To:     'Neystadt, John'; [email-masked] 
Subject:        RE: [VPIM] Analogy to Content-Duration for Faxes 

	Yes, it is very useful to have content duration in meaningful units
such as 
seconds of audio (or video), pages of fax, etc. Most e-mail clients will not

display this information, however. 

	The place that this information is most useful is within a TUI where
it is 
useful to announce the number of pages in a fax, Word document or whatever 
so the recipient can decide whether to forward the document to a fax 
machine. 

	-----Original Message----- 
From: Neystadt, John [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Thursday, January 27, 2000 3:27 AM 
To: [email-masked] 
Subject: [VPIM] Analogy to Content-Duration for Faxes 

	Hi! 

	I wonder if anybody came to need of Analogy to Content-Duration for
Faxes to 
indicate the number of pages. This is handy to present GUI idication of fax 
size in pages (as in seconds for voice) instead of KBs. 

	Does somebody needs this in addition to us? 

	Regards, 

	John Neystadt

---

From: Keith Moore <[email-masked]>
Date: Tue, 08 Feb 2000 10:50:01 -0500

> set it on the rendered subject field on the fly?

please don't call it Content-Length.  That field name is already in use.

Keith