Subject: Re: I-D ACTION:draft-maeda-faxwg-fax-processing-status-00.txt

From: "Toyoda, Kiyoshi" <[email-masked]>
Date: Mon, 12 Mar 2001 20:04:32 +0900

Tanimoto-san,

Your e-mail below was not sent to this mailing list. 
I forward it to this ML with my comment which I sent
to Maeda-san.

Yoshifumi Tanimoto wrote:
>Toyoda-san,
>
>>In case the receiver has memory and store data before printing,
>>it can keep data in the memory when it has no paper or paper jam.
>>The receiver will print after paper is setted by someone and then
>>processing will be done completely. The time lag between receiving
>>and printing may be too long for keeping one session.
>>So,I think MDN which means processing confirmation should be returned
>>on another session after receiving.
>I may have misunderstanding.If so, I am sorry.
>If a processing result is the thing of a print result, it is right.
>However,at least,I want to know whether there was any communication error,
>when communication is completed.
>So, in the fax processing status, I think that "success" means receiving is
>successful, "failure" means receiving is failed.
>(illegal MIME format,illegal TIFF format,...)

IFAX can check whether the format is suitable for printing in the first 
SMTP session, and if the format is not suitable receiver can return a error 
such as 5xx to the sender. It is a rough confirmation in the first session.
After printing, IFAX can send an accurate confirmarion including the result
of printing.

>
>Of course, this is a talk about the case of E2E communication.
>
>In the case of FFPIM,I think that the last processing result should be
>returned as Toyoda-san's indication.
>
>Regards,
>
>Yoshifumi Tanimoto
>Murata Machinery, Ltd.
>[email-masked]

Kiyoshi Toyoda

---

From: "Yoshifumi Tanimoto" <[email-masked]>
Date: Mon, 12 Mar 2001 21:15:06 +0900

Toyoda-san,

>Your e-mail below was not sent to this mailing list.
I am sorry. It was my mistake.

>I forward it to this ML with my comment which I sent
Thank you very much.

Regards,

Yoshifumi Tanimoto
Murata Machinery, Ltd.
[email-masked]