Subject: RE: MDN usage question.

From: "McIntyre, Lloyd" <[email-masked]>
Date: Mon, 12 Mar 2001 11:49:26 -0800

Please see my thoughts below.

Lloyd

> -----Original Message-----
> From: Kassmann, Gary 
> Sent: Monday, March 12, 2001 8:21 AM
> To: [email-masked]
> Cc: McIntyre, Lloyd; Kassmann, Gary
> Subject: MDN usage question.
> 
> 
> All,
> My name is Gary Kassmann and I am a Systems Engineering 
> Manager at Xerox Corporation.  I have been a long time reader 
> of this DL but this is my first post.  I have a question 
> about the usage of MDN's which I don't think has been addressed here.
> 
> The recent DSN & MDN discussions makes me wonder about the 
> case of receiving TIFF-FX Profile C on an IFax device which 
> is capable of interpreting the file but only prints B&W.  In 
> interest of increasing interoperability, I can envision a B&W 
> device having the ability to read and a color file.  Does the 
> ability to read the file invoke a positive MDN or does the 
> inability to process the file in color invoke a negative MDN? 
>  What is the recommended MDN usage to support this case?
You are poking at a GRAY area<-:)
My desirable black-and-white answer would be an MDN with
    disposition= processed/error: image rendered as gray 
This implies registration of a new disposition type modifier of "error:
image rendered as gray", conveying the message that the image was not
processed faithfully.

If the receiver had informed the sender of its ability to only render gray
and the sender chose to send color, assuming consent of the user to have
gray rendered, then there is an argument for 
    disposition= dispatched

With this said, if we were to follow the T.30 model faithfully then the
sender should always send an image encoding that is consistent with what the
receive consumes and is capable of rendering. The receive should not take on
the task of image transformations since the delivered image is no longer a
facsimile (faithful representation) of what was transmitted. An appropriate
MDN would contain
    disposition= processed/error

This is a very good question for which a consensus position is needed.
> 
> Regards,
> Gary
> 
> ____________________
> Gary Kassmann   [email-masked]
> Xerox Corporation
> GMO/OSG/CDDU - System Architecture & Technology Delivery
>

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 12 Mar 2001 13:00:25 -0800

I don't understand your comment about being faithful to the T.30 model.

On my work and home fax machines (which are from different manufacturers) if I
select 'photo' or 'super fine' as the resolution it will be transmitted
successfully even if the receiving machine can only accept a lower-quality
image.

Perhaps better business-class fax machines behave differently and refuse to
send a fax if the sender selected 'super fine' but the receiving machine is
incapable of 'super fine'?

[I know many machines don't interoperate with 'super fine', but the gist of my
question remains if you replace 'super fine' with 'fine', which is well
standardized]

-d

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of McIntyre, Lloyd
> Sent: Monday, March 12, 2001 11:49 AM
> To: Kassmann, Gary; [email-masked]
> Subject: RE: MDN usage question.
>
>