Subject: Re: I-D ACTION:draft-maeda-faxwg-fax-processing-status-00.txt

From: [email-masked]
Date: Thu, 8 Mar 2001 12:57:46 +0900

Toyoda-san,

>But, the sender doesn't know whether the processing such as
> printing was be done correctly. Usually, there is time lag to
> complete printing after IFAX received data.
As for it, the same will be said of usual T.30 communication.

>So, I think MDN should be returned on another session after E2E
communication.
>If the sender doesn't request MDN, the receiver doesn't reply MDN.
Since it is E2E communication, I think that a communication result should
be known
at the time of a communication end.

Regards,

Yoshifumi Tanimoto
Murata Machinery, Ltd.
[email-masked]

---

From: Hiroshi Tamura <[email-masked]>
Date: Thu, 08 Mar 2001 17:52:00 +0900 (JST)

Tanimoto-san, Welcome!

I hope you continue to contribute it.

> at the time of a communication end.

Specifically, how do you realise?

Regards,
--
Hiroshi Tamura, Ricoh Company, LTD.
E-mail: [email-masked]

---

From: "Toyoda, Kiyoshi" <[email-masked]>
Date: Fri, 09 Mar 2001 16:05:52 +0900

Tanimoto-san,

>at the time of a communication end.

In case the receiver has memory and store data before printing, 
it can keep data in the memory when it has no paper or paper jam. 
The receiver will print after paper is setted by someone and then 
processing will be done completely. The time lag between receiving 
and printing may be too long for keeping one session.  
So, I think MDN which means processing confirmation should be returned 
on another session after receiving.

Regards,

Kiyoshi Toyoda

---

From: MAEDA toru <[email-masked]>
Date: Mon, 12 Mar 2001 15:37:55 +0900

Toyoda-san

>on another session after receiving.

When the classic FAX with memory receives fax data in PSTN
and returns its confirmation within T.30 session before printing,
when the data is checked on its integrity such as suitable for printing
and stored into the memory for printing.

>Kiyoshi Toyoda

-----------------------------------
キヤノン株式会社
映像事務機MIE推進センター
映像事務機MIE第２開発部
前田　徹
146-8501　東京都大田区下丸子３−３０−２
電話　03-3757-9738、FAX　03-3757-8205
-----------------------------------

---

From: "Toyoda, Kiyoshi" <[email-masked]>
Date: Mon, 12 Mar 2001 16:00:47 +0900

Maeda-san,

>and stored into the memory for printing.

IFAX can check whether the format is suitable for printing in the first 
SMTP session, and if the format is not suitable receiver can return a error 
such as 5xx to the sender. It is a rough confirmation in the first session.
After printing, IFAX can send an accurate confirmarion including the result
of printing.

regards,

Kiyoshi Toyoda

---

From: MAEDA toru <[email-masked]>
Date: Mon, 12 Mar 2001 19:29:17 +0900

Toyoda-san

>such as 5xx to the sender. It is a rough confirmation in the first session.

Yes.
After sending 250 to the sender for success of reception
and before closing the SMTP session,
the receiver will send an accurate confirmation in MDN.

>After printing, IFAX can send an accurate confirmarion including the result

You can do so, but classic fax terminal does not work like this.
The receiver may return the confirmation within T.30 session before printing.
Usually classic fax terminals do not receive confirmation in another session.
One of exception is fax gateways which sends separate confirmation sheet 
after forwarding.
Continuing the SMTP session, IFAX can send an accurate confirmation same as 
classic fax.

Regards,

Toru Maeda

---

From: "Toyoda, Kiyoshi" <[email-masked]>
Date: Mon, 12 Mar 2001 19:52:21 +0900

Maeda-san,

>Continuing the SMTP session, IFAX can send an accurate confirmation same as 

The confiramtion of classic fax is not processing confirmation because
it dosen't include the result of printing.
I think that accurate confirmation should include the result of printing. 
But there is time lag between receiving and printing and it may be too
long for continuing sesseion. So, MDN confirmation including the result 
of printing should be separated from the data communication session. 

regards,

Kiyoshi Toyoda

---

From: MAEDA toru <[email-masked]>
Date: Mon, 12 Mar 2001 21:04:25 +0900

Toyoda-san

Do you mean the confirmation of classic fax is not enough?

Regards.

Toru Maeda

>of printing should be separated from the data communication session.

--------------------
MAEDA TORU
MIE Development Div. 2
CANON Inc.
--------------------