Subject: RE: MDN disposition status

From: "McIntyre, Lloyd" <[email-masked]>
Date: Tue, 13 Mar 2001 17:11:56 -0800

> -----Original Message-----
> From: Hiroshi Tamura [mailto:[email-masked]]
> Sent: Tuesday, March 13, 2001 4:49 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: MDN disposition status
> 
> 
> Interesting.
> 
> I do not have enough time to check in detail now, but
> there are two things I would like to comment now.
> 
> 1. disposition format
> 
> > Given the RFC 2298 disposition format
> > Disposition: action-mode/sending-mode; 
> disposition-type/disposition-modifier
> 
> The exact format is below.
> 
> -------------------------------------------------------------------
> 
>    disposition-field = "Disposition" ":" disposition-mode ";"
>                        disposition-type
>                        [ '/' disposition-modifier
>                          *( "," dispostion-modifier ) ]
> 
>    disposition-mode = action-mode "/" sending-mode
> 
>    action-mode = "manual-action" / "automatic-action"
> 
>    sending-mode = "MDN-sent-manually" / "MDN-sent-automatically"
> 
>    disposition-type = "displayed"
>                     / "dispatched"
>                     / "processed"
>                     / "deleted"
>                     / "denied"
>                     / "failed"
> 
>    disposition-modifier = ( "error" / "warning" )
>                         / ( "superseded" / "expired" /
>                             "mailbox-terminated" )
>                         / disposition-modifier-extension
> 
>    disposition-modifier-extension = atom
> 
> -------------------------------------------------------------------
> 
> Therefore, 
> 
> >   disposition-type = processed/error:pages
> 
> It cannot be expressed.
> If you use this field("Disposition"), your only choice is
> to extend "dispostion-modifier-extension".
Yes, it is the "dispostion-modifier-extension" that would be extended.

> 
> Or, "dispostion-modifier-extension" is "error:pages"?
> 
> The definition of this extension or somthing is necessary.
> 
> 2. Similar proposal by Maeda-san
> 
> Your proposal;
> Ex1:
> > "pages" reflects totalpages and comma separate errorpages 
> or errorpages 
> >    pages= totalpages=N,errorpages=a,b,c
> 
> >   error-modifier= 
> >      unsupported file format/
> >         - where the file format is not supported or recognized 
> >      unsupported compression/
> >         - where the compression type is not supported or recognized
> >      unsupported resolution/
> >         - where the resolution is not supported or recognized
> >      unsupported image size/
> >         - where the image size is not supported
> >      unsupported parameters/
> >         - where there may be a combination of unsupported encoding
> 
> Ex2:
> > Example
> >   disposition = automatic-action/MDN-sent-automatically;
> > processed/error:unsupported file format
> 
> Maeda-san's proposal(fax-processing-status-01.txt.):
> 
> > MDN extension field:
> > Fax-Report:
> >             ; Fax-Pages = received total page number
> >             ; Fax-Errorpage = error page number, Fax-Results = code
> > 
> > "Fax-Pages" will be returned to indicate received total page number
> > from the receiver, so the transmitter confirms the total page.
> > 
> > "Fax-Errorpage" will be returned to indicate error page number(s)
> > from the receiver, so the transmitter identifies the error page(s).
> > 
> > "Fax-Results" will be returned to indicate the detailed 
> error status of
> > processing in the receiver.
> > These codes will be defined by fax wg discussion.(TBD)
> > 
> >       "01"     does not support the scan line length
> >       "02"     does not support the resolution
> >       "03"     does not support the Full color mode
> >       "04"     does not support the No subsampling
> >       "05"     does not support the other Illuminant
> >       "06"     does not support the other gamut range
> >       "07"     does not support the MRC page
> 
> I think these two proposal should be merged.
> 
> Regards,
> --
> Hiroshi Tamura, Ricoh Company, LTD.
> E-mail: [email-masked]
>

---

From: "McIntyre, Lloyd" <[email-masked]>
Date: Wed, 14 Mar 2001 11:25:49 -0800

> From: Dan Wing [mailto:[email-masked]]
> Sent: Wednesday, March 14, 2001 10:49 AM
> To: Hiroshi Tamura; [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: MDN disposition status
> 
> 
> ...
> Agreed.  I would like to reiterate my desire that the 
> returned MDN indicate
> success/failure of each MIME attachment.
I am in full agreement and as the proposal is addressing status for each
MIME part independently.
> -d