Subject: RE: Page and page number in the status

From: "McIntyre, Lloyd" <[email-masked]>
Date: Thu, 8 Mar 2001 15:03:50 -0800

Dan,
I believe we are in sync.
Please see my few clarifications below.

Lloyd

> -----Original Message-----
> From: Dan Wing [mailto:[email-masked]]
> Sent: Thursday, March 08, 2001 1:03 PM
> To: McIntyre, Lloyd; MAEDA toru; IETF Internet Fax WG
> Cc: fax=[email-masked]
> Subject: RE: Page and page number in the status
> 
> 
> See below.
> 
> > > I would really prefer we have the ability to indicate, per
> > > MIME part, which
> > > parts were transmitted and how many pages were transmitted.
> > This appears to be calling for a "Content-IDs" summary (i.e. an
> > equal number
> > of comma separated distinct IDs to the number of contents) to be
> > included in
> > the MIME header summary and the corresponding "Content-IDs" 
> included with
> > the
> >
> 
> I don't think the original message needs to be different at 
> all, except to
> include Content-ID on each MIME part.  No need for a summary 
> at the top at
> all.
I agree that the summary is not necessary and can accept its removal. It
does, however, provide added value of signaling the number of parts within
the message.
> 
> The returned MDN would need some way to indicate which Content-ID it
> transmitted, and how many pages of each part were transmitted.
> 
> 
> 
> The MDN could be something like this.  I haven't reviewed the 
> MDN spec in
> about a year, so bear with me.  The following is line 
> numbered for ease of
> discussion.
> 
Allow me to modify your examples to be more consistent with my
interpretation of the MDN spec and the Implementers Guide.
>   1  message-status: succeeded
   Original-Message-ID: <[email-masked]>
   Disposition: automatic-action/MDN-sent-automatically; processed

Here I changed succeeded to processed because the entire message was not
disposed of successfully, if it were then I would suggest dispatched at this
location.
>   2  message-part-status-1: content-id=1234@abc; 
> message-status=succeeded;
>            pages=1
    2  message-part-disposition-1: content-id=1234@abc
   Disposition: automatic-action/MDN-sent-automatically; dispatched

Here dispatched is appropriate. I have removed the page count since it adds
no value when the entire part is successfully processed.
>   3  message-part-status-2: content-id=859@abc; 
> message-status=succeeded;
>            pages=8
    3  message-part-disposition-2: content-id=859@abc;
   Disposition: automatic-action/MDN-sent-automatically; dispatched

Same as above.
>   4  message-part-status-3: content-id=2895@abc; 
> message-status=failed;
>            pages=0; reason=no-support-on-sender
    4  message-part-disposition-3: content-id=2895@abc; 
   Disposition: automatic-action/MDN-sent-automatically; processed/error

Here processed with the error modifier is appropriate. I have removed the
page count since it adds no value when the entire part was unsuccessfully
processed.
> 
> Above, the first line is from a normal MDN (using the 
> existing MDN spec) and
> lines 2, 3, and 4 are the new detail which describe the 
> specific MIME parts
> which were transmitted.
For clarity allow me to add a 5th part example reflecting mixed processing
results and where page indication adds value.
    5  message-part-disposition-4: content-id=3703@abc; 
   Disposition: automatic-action/MDN-sent-automatically;
processed/error:pages=2,5

Here since portions of the part were processed successfully while others
were not, then processed with the error modifier and an indication of pages
with error may be appropriate. There is not need to indicate the pages
successful since the sender knows the total page count.
> -d

---

From: MAEDA toru <[email-masked]>
Date: Mon, 12 Mar 2001 19:42:41 +0900

Wing-san, McIntyre-san

Thank you very much for the detailed draft for fax status.
I will attached to the next version of ID, fax-processing-status-01.txt.

Regards,

Toru Maeda

>successful since the sender knows the total page count.

--------------------
MAEDA TORU
MIE Development Div. 2
CANON Inc.
--------------------