Subject: Draft ForCES Meeting Minutes, IETF 55

From: "Putzolu, David" <[email-masked]>
Date: Sat, 7 Dec 2002 19:45:13 -0800

All,

Please find below the draft minutes for the ForCES
meeting at IETF 55.  Please send any corrections or
comments to the list or to myself or Patrick by
Thursday, Dec 12.

Cheers,
David

--- cut here ---

Forwarding and Control Element Separation (forces)

Monday, November 18 at 0900-1130
==================================

CHAIRS: Patrick Droz <[email-masked]>
        David Putzolu <[email-masked]>

Scribe: George Jones <[email-masked]>

Agenda bashing: nothing changed

Completed Last Calls

  draft-ietf-forces-framework-03.txt
  draft-ietf-forces-requirements-07.txt
  draft-ietf-forces-netlink-03.txt

Discussion of draft-ietf-yang-model-01

  - authors, history presented
  - motivation
    FE == Forwarding Element
    CE == Control Element
    * FE tells CE capabilities
    * FE tells CE current config
    * CE tells FE desired state
  - what is in the model
    * FE block (abstract base class)
    * Block library (Forwarding, QoS, filters, etc.)
    * Example FE Blocks
    * FE stage and directed graph
    * Two approaches in graph modeling
    * Topological (DiffServ)
      + No info carried forward
    * Topological (DiffServ) vs. Encoded State (QDDIM model)
      + Explicit info (preamble) carried forward to subsequent
        stages
  - open issues
    * Data modeling language: representation
      + SMI/SPPI/ASN.1/XML/UML ?
    * Topological vs. Encoded State approach
    * Modeling of actual functions
      + identify minimal categories/set of functions
      + model for each one
  - next steps
    * WG document
    * Data modeling language
    * define small set of functions

Q: Is your intent to specify the way that the FE and CE
   communicate ?  If so, it's very important to get right.
A: yes.

Q: (statement) Topological model is easier to reason about.
A: We can take it on a case-by case basis.

Q: (statement) We need to be aware that we don't just want to
   encode the a snapshot of the current state of the world
A: We need help from the chairs to avoid this.

Chair: show of hands, who's read ?
Answer: not enough.  Need more discussion to accept as a WG model.
        Abstract, not easy to discuss.

Chair: We'd like people to start submitting actual protocol drafts.
       Easier to actually talk about/discuss.

Action: model will not be WG document yet.

Status of other drafts

Closing:
  Do protocol submissions.

End of meeting.

---

From: Patrick Droz <[email-masked]>
Date: Tue, 17 Dec 2002 13:12:26 +0100

David,

sorry I was on vacation and did not have e-mail access.
Thanks for doing this.

Regards,
Patrick

--
   Dr. Patrick Droz                     | [email-masked]
   IBM Zurich Research Laboratory       | http://www.zurich.ibm.com/~dro
   Saumerstrasse 4                      | Tel. +41-1-724-85-25 CH-8803
   Rueschlikon/Switzerland              | Fax. +41-1-724-85-78