Subject: Re: [issue 7] All PL messages addressed to only LFBs?

From: Jamal Hadi Salim <[email-masked]>
Date: Mon, 22 Nov 2004 21:26:42 -0500

Hormuzd,

The piece of text you edited out states how:

a) the grammar changes (you claim below it doesnt)
I am cut n pasting here again for your convinience.

--
i.e grammar stays (forever) as:

PL level PDU : = MAINHDR<LFBselect>+
LFBselect := LFBCLASSID LFBInstance <OPER>+
OPER:= <OPERATION [<path-data>]*>+

instead of:

PL level PDU : = MAINHDR <HB>|<ASSOC>|<YETTOBEDEFINED>|<LFBselect>+
LFBselect := LFBCLASSID LFBInstance <OPER>+
OPER:= <OPERATION [<path-data>]*>+
HB := ...
ASSOC := ...
YETTOBEFEFINED1 := ...
YETTOBEFEFINED2 := ...
-----

Hopefully the difference is clear.

b) in the case of parsing, piece you edited out said:

-----
You save almost nothing in terms of parsing in processing cycles by
keeping it that way. And you loose in elegance/consistency departments
by having exceptions to the rule.
----

I should add that from experience you have a lot less code to write
in the first grammar (where termination is at the LFB) because of
reusability reasons than in the second where you have speacial cases.
You claim below quiet the opposite of what i state.

Please address these issues in your response.

cheers,
jamal

On Mon, 2004-11-22 at 18:33, Khosravi, Hormuzd M wrote:
> Jamal,
>
> -----Original Message-----
>
> The whole point of having FE Object and FE protocol Object is so that
> messages aimed at the "FE" can go to one of those. This should be an
> opportunity to justify CE complemantary entities (CE object and CE
> protocol objects).
>
> [HK] The two things are actually not related. I am not sure why you are
> confusing these points. The grammar doesn't change in order for a
> message to be targeted to a CE/FE instead of a LFB.
>
> This keeps the grammar lean and mean. You dont need exceptions just for
> keepalives to the FE, let them go to the FE protocol object, You dont
> need to have associations go to the "CE", let them go to the CE object.
>
> [HK] We have probably exchanged couple of dozen emails before we decided
> to have HB messages as exceptions that just contain a header. This has a
> big advantage in terms of parsing, etc. This was not something which was
> up for discussion at this point. It was more of an example of what we
> already have in the protocol which is not addressed to a LFB. The same
> thing applies to Event Reports as well. Again, I don't think the grammar
> enforces all messages to be addressed to LFBs...if there is another
> reason that you have, let us know.
>
> regards
> Hormuzd

---

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Mon, 22 Nov 2004 15:33:53 -0800

Jamal, 

-----Original Message-----

regards
Hormuzd