Subject: Re: [issue 7] All PL messages addressed to only LFBs?

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Fri, 26 Nov 2004 23:26:03 -0800

Robert,

I don't question the content of the latest protocol draft at all, not
sure what makes you think that? The clarification I asked for is just
relevant to the HB message which we all agreed on, is an exception. It
is not meant to invalidate any of the sections you have listed.

I was raising the issue of PL messages addressing only LFBs, which we
had discussed towards the end of our last conference call and it is
being confused with the protocol grammar. I don't think they are related
and I am very fine with the grammar as is (with exception of HB msg).

All the grammar states is that the messages consist of a main header,
followed by LFB Select TLVs. I am not sure why this is being confused
with all messages being addressed to LFBs. You had a similar opinion on
the conf call, it would be helpful if you can clarify this as well.

Hope this helps and clarifies my position,

Regards
Hormuzd

-----Original Message-----
From: Forwarding and Control Element Separation
[mailto:[email-masked]] On Behalf Of Robert Haas
Sent: Thursday, November 25, 2004 8:57 AM
To: [email-masked]
Subject: Re: [FORCES] [issue 7] All PL messages addressed to only LFBs?

Hormuzd,
Could you please explain why you now question the content of the latest
protocol draft that we prepared together ? I think that your "small
clarification"  invalidates sections 6.2.1, 6.2.2, 6.2.3, 6.5.1, and
6.5.2, at least.
Regards,
-Robert

Khosravi, Hormuzd M wrote:

>Jamal,
>
>I don't think I made myself clear :)
>I understand what you're trying to say below however I don't think
there
>are 2 grammars.
>There may be a small clarification needed to the grammar,
>I am not sure if MAINHDR<LFBselect>+ means we have a MainHdr followed
by
>0 or more LFB selects, or 1 or more LFB selects. If it is the latter we
>need to use a different BNF notation, other than that the grammar is
>still the same.
>
>Let me reiterate the Event example, the Event Report message will
>consist of...
>MAINHDR<LFB1 Event1 info><LFB1 Event2 info>, etc. This message is sent
>from the FE to the CE, it is addressed to the entire CE, it however
>contains information about events in different LFBs. There is no
>co-relation in the grammar and where the message is addressed.
>
>The pseudo English example which you have given below looks more like
>the implementation and in that case it would need to parse the message
>Type in the main header before decapsulating the LFBs. This is required
>either ways, I am sure you would know this since you have some
>implementation.
>
>Anyways, at this point if this is still not clear, I would like to hear
>what others think. Robert, Joel have expressed their
>opinions...hopefully other protocol team members will chime in soon.
>Weiming, Avri, Ram ...let us know your thoughts??
>
>
>regards
>Hormuzd
>
>-----Original Message-----
>From: Forwarding and Control Element Separation
>[mailto:[email-masked]] On Behalf Of Jamal Hadi Salim
>Sent: Tuesday, November 23, 2004 5:37 AM
>To: [email-masked]
>Subject: Re: [FORCES] [issue 7] All PL messages addressed to only LFBs?
>
>Hormuzd,
>
>On Tue, 2004-11-23 at 02:13, Khosravi, Hormuzd M wrote:
>
>
>>Jamal,
>>
>>I maintain that the grammar does not change. Let me reiterate an
>>
>>
>example
>
>
>>that we have discussed several times before,
>>
>>HB msg = MAINHDR only...that does not change the grammar.
>>
>>Another example,
>>
>>Event Report msg = MAINHDR<LFBselect>+...it is addressed to the entire
>>CE for example, but still contains event information in terms of LFBs.
>>
>>Msgs containing information in terms of LFBs does not require them to
>>
>>
>be
>
>
>>addressed to LFBs.
>>
>>
>
>I dont think i made my point clear,
>Let me describe this a different way.
>
>There are two grammars
>
>The first one:
>PL level PDU : = MAINHDR <HBexception>|
>                         <ASSOCexception>|
>                         <YETTOBEDEFINEDexception>|
>                         <LFBselect>+
>LFBselect := LFBCLASSID LFBInstance <OPER>+
>OPER:= <OPERATION [<path-data>]*>+
>HBexception := ...
>ASSOCexception := ...
>YETTOBEFEFINED1exception := ...
>YETTOBEFEFINED2exception := ...
>
>The second one:
>PL level PDU : = MAINHDR<LFBselect>+
>LFBselect := LFBCLASSID LFBInstance <OPER>+
>OPER:= <OPERATION [<path-data>]*>+
>
>Or lets put it in pseudo-english:
>
>The first one:
>
>"for all incoming messages,
>     if it is a heartbeat, speacial process
>     if it is a association, ...
>     if it is a TBD1 ...
>     if it is a TBD2 ...
>        else
>            look at LFB selector ...
>"
>
>And as you keep adding new ones, you add more exception
>handles in message processing loop.
>
>vs, the second one:
>"for all incoming messages,
>    look at LFB selector ...
>"
>
>So question to you:
>
>a) do you agree they are different?
>and, if yes:
>b) which one do you think is better?
>
>
>cheers,
>jamal
>
>
>
>

---

From: Jamal Hadi Salim <[email-masked]>
Date: Sat, 27 Nov 2004 09:56:26 -0500

> and I am very fine with the grammar as is (with exception of HB msg).

So all that you are(or have been) asking for is:

Instead of:

Note, These are two different grammars.
BTW, are you dropping the Association message from that list?

> with all messages being addressed to LFBs.

The main header + lfb selectors are de/mux points or otherwise known as
addressing entities. There are no LFBs on the CE - other than what is
being proposed for the two core LFBs. No claim has been made anywhere in
this thread that there were LFBs on the CE; i went back and reread all
messages.
Nobody has stated that the fact that LFBselector exists on the PL
message from FE->CE implies LFBs exist on the CE.  That does not equate
there are no LFB mux points on the CE - but thats an implementation
detail which we dont need to discuss here.

If this is the "confusion" all along (disappointing) then we need to
clarify it in the text. We need to make progress.
I think we may need to add text that when the message comes from the
FE->CE that infact the LFB selector refers to the source LFB+instance
and not destination.  Would this help?

>  You had a similar opinion on

Yes, It is true that Robert did ask for an exception for hearbeats
as well in that concal. But instead we went onto a wildgoose chase of
whether the grammar changes or not in the last 10 emails or so. The
grammar changes. So lets not discuss that any further, please.

We may be back on track - and hopefully we can make progress.

If you take the LFBSelector out of the message description for certain
specific messages - you are creating an exception in the grammar. My
points against this as i stated earlier (in my first email on this
thread infact) are:
You save almost nothing in terms of parsing in processing cycles by
keeping the exceptions. And you loose in elegance/consistency
departments by having unnecessary exceptions to the rule.
For those reasons i ask that we have no exceptions.

cheers,
jamal