Subject: Re: path data textt update

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Thu, 27 Jan 2005 10:02:57 -0800

Hi Jamal,

Thanks a lot for putting this together, it is very useful for making
progress!
(Sorry, I have been unable to send in comments earlier)
I had a few initial comments on the path-data layout....

Why do we need Flags in the PATH ? Isn't this something that should be
part of the Operation itself ? I remember Joel also had some comments on
this before.

Opcodes for Operations which have been defined so far include..
ADD, DEL, UPDATE/REPLACE, DEL ALL, EVENT SUBSCRIBE, EVENT UNSUBSCRIBE,
CANCEL
I don't see you having included all of these...what am I missing here ?

Let me know your thoughts,
I will send more details comments soon.

Thanks again!
Hormuzd 

-----Original Message-----
From: Forwarding and Control Element Separation
[mailto:[email-masked]] On Behalf Of Jamal Hadi Salim
Sent: Wednesday, January 26, 2005 10:32 AM
To: [email-masked]
Subject: [FORCES] path data textt update

Changelog:
---------
$Log: data_path2.txt,v $
Revision 1.7  2005/01/26 06:27:10  hadi
fixed INDINFO definition as caught by Weiming
Added FIELDINFO
Added example on selective setting based on posting from Weiming.

Diff and text both attached.

Please read it. 

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 27 Jan 2005 15:59:38 -0500

> part of the Operation itself ? I remember Joel also had some comments on

The flags on the path are further refinements on the path or data itself
(and not on the general msg type/command). Infact you can have multiple
repetitions of the flags within the same operation. Look at the BNF. 
I cant recall what Joels comment was but its probably obsoleted now.

> I don't see you having included all of these...what am I missing here ?

We are not really touching the operations details other than the obvious
ones at the moment; i do expect some of the operations we defined
already would disapear. DEL vs DEL all; ADD vs UPDATE replace.
But thats such small potato that i dont think we should be spending any
cycles discussing it right now. Lets resolve the the path data encoding
all others will fall easily.

cheers,
jamal