Subject: Ftp-WG: Compressions and conversions

From: Pat LaVarre <[email-masked]>
Date: Thu, 3 Oct 2002 09:52:54 -0500

> > Sun's `jar -xvf` and Microsoft's Win XP
> > choked over these .Z and .gz compressions,
> > but Mac OS X just plain worked. 

> Subject: Ftp-WG: Compressions and conversions
> ... Winzip and several other tools
> handle .Z quite comfortably, ...

I'm thinking Windows doesn't work out of the box with
.Z and .gz, and can't be quickly & freely upgraded to
cope.

Is that wrong?

Last I checked, Winzip was now even less free than it
used to be?

Just now I tried renaming .Z and .gz to .zip, which in
some versions of Windows invokes auto .zip handling
... here Windows says "invalid or corrupt" archive.

Last time I inflated .Z on Windows, I think I
downloaded, in multiple steps involving multiple
megabytes, a version of Cygwin, possibly over the
19.2K line I had in the Grand Tetons.  I hear a thing
termed Mingw is now more in vogue: we wouldn't want
technique learned to be valid for an extended period
of time, would we.

Once upon a time I found my way to a free zip effort,
named something like InfoZip, out of which I heard the
free Sun jar tool grew?  InfoZip didn't work too well
for me then: I commonly encountered .zip's it couldn't
handle.

As far as I know, all the legitimate distributions of
the free Sun jar also involve multiple megabytes and
trusting an installation utility.  Currently on
Windows I use a local copy of a 21 megabyte subset of
a normal Sun JavaDevelopmentKit, with drag & drop
installation.

It's not that I can't defeat the popular compression
schemes.  I just can't do so easily, in a hassle free
way I can share with technically illiterate friends
across the globe.

Pat LaVarre

P.S. I tend to think the browser should cope, anyhow. 
Like I care how the data is compressed.

__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com

---

From: Alun Jones <[email-masked]>
Date: Thu, 3 Oct 2002 10:39:47 -0500

>Last I checked, Winzip was now even less free than it

http://www.winzip.com, click on "Download Evaluation Version" - I didn't 
see anything about it being any less free to try out - the nag screen is 
still there.  Maybe you mean it's more expensive if you do decide to 
register?  It's $29 - hardly "break the bank".

>... here Windows says "invalid or corrupt" archive.

Because it's not a .zip file.  Microsoft's handling of zip files is only 
for zip files.

>technique learned to be valid for an extended period

There's any number of uncompress tools available for Windows, both in GUIs 
(many zip, RAR, ACE, etc extractors will also handle other formats 
including Unix compress) and command lines - for instance, the GNUish 
project, and any number of DOS utilities found at archives such as Simtel, 
etc.  Presumably there's similar tools for other platforms.  But discussing 
how to find tools that you need is more appropriate on other forums than 
this one.

Alun.
~~~~

--
Texas Imperial Software   | Try WFTPD, the Windows FTP Server. Find us at
1602 Harvest Moon Place   | http://www.wftpd.com or email [email-masked]
Cedar Park TX 78613-1419  | VISA/MC accepted.  NT-based sites, be sure to
Fax/Voice +1(512)258-9858 | read details of WFTPD Pro for NT.