Subject: Ftp-WG: in mlst-16, only Dos Eol excluded from pathnames?

From: Pat LaVarre <[email-masked]>
Date: Wed, 2 Oct 2002 16:03:16 -0500

> Subject: Ftp-WG: to mlst-16 from mlst-15

ftp://munnari.oz.au/internet-drafts/draft-ietf-ftpext-mlst-16.txt.gz

> = 2.2. Pathnames
> ...
> + Note: for pathnames transferred over a data
> + connection, there is no way to represent a
> + pathname containing the characters CR and LF in
> + sequence, and distinguish that from the end of
> + line indication.

This is a clear, limited statement, thank you.

Am I correct to think this says, by omission, that
there is a correct protocol for the transmission, by
control and data connection, of filenames that contain
LF, or CR, or LF CR, just not CR LF?  We exclude only
CR LF, aka the MS Dos Eol, aka the Telnet Eol.  We do
not exclude the isolated LF aka Unix Eol.  We do not
exclude the isolated CR aka Mac Eol.  We do not
exclude mixtures thereof, except for CR followed
directly by LF.

> > there is a correct protocol

And someone on Earth knows what that protocol is?

> > there is a correct protocol

And we don't think exercising that protocol would in
fact confuse most actual Ftp clients, Ftp servers, and
Ftp firewalls?

Curiously yours, thanks in advance, Pat LaVarre

__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com

---

From: Robert Elz <[email-masked]>
Date: Thu, 3 Oct 2002 01:53:16 -0500

Date:        Wed, 2 Oct 2002 16:03:16 -0500
    From:        Pat LaVarre <[email-masked]>
    Message-ID:  <[email-masked]>

  | Am I correct to think this says, by omission, that
  | there is a correct protocol for the transmission, by
  | control and data connection, of filenames that contain
  | LF, or CR, or LF CR, just not CR LF?

Yes, because CR LF is the ascii mode ftp file transfer EOL signal.

  | We exclude only
  | CR LF, aka the MS Dos Eol, aka the Telnet Eol.  We do
  | not exclude the isolated LF aka Unix Eol.  We do not
  | exclude the isolated CR aka Mac Eol.  We do not
  | exclude mixtures thereof, except for CR followed
  | directly by LF.

Correct.   But nor do we require anyone to actually support those
oddities.   They're just possible to transmit according to the
protocol, should some filesystem be odd enough to use them.

  | And someone on Earth knows what that protocol is?

Yes, you send the bytes.

  | And we don't think exercising that protocol would in
  | fact confuse most actual Ftp clients, Ftp servers, and
  | Ftp firewalls?

Yes, I do expect that it would confuse some.   They're all broken and
always have been.   There's nothing now in FTP that prohibits any of
these odd filenames, other than what the servers happen to support.

As long as servers go on supporting the same basic kinds of filenames
that they currently support, and clients keep on expecting what they
currently expect, the abstract possibility of weird characters appearing
in filenames will continue to exist with about the same possibility
of actually being encountered in the wild as now does.

kre