Subject: [gaia] Update about recent and upcoming GAIA activities to participate

From: Leandro Navarro <[email-masked]>
Date: Sat, 21 Apr 2018 14:44:46 +0200

Dear members of the GAIA WG, a few items to share:

* Call for topics to discuss in the next GAIA WG meeting at IETF 102 Montreal (14 Jul 2018 - 20 Jul 2018) https://www.ietf.org/how/meetings/102/ <https://www.ietf.org/how/meetings/102/>
Tell us (can be off-list) about topics/presentations/documents you’d like to share/discuss by mid may (Friday 18).

A reminder for upcoming calls for papers and participation:

* The ANRW ’18 takes place in Montreal, Quebec, Canada, the venue of the IETF-102 meeting , on Monday, July 16, 2018.
Paper submission deadline (extended) 	April 23, 2018 (really close!)
https://irtf.org/anrw/2018/ <https://irtf.org/anrw/2018/> 

* 14th Asian Internet Engineering Conference (AINTEC), Thailand, 12-14 November 2018, (after IETF 103 https://www.ietf.org/how/meetings/103/ <https://www.ietf.org/how/meetings/103/> also there)
Abstract registration  18 August 2018
Full paper submission 2 September 2018
Conference	12-14 November 2018  
https://interlab.ait.ac.th/aintec2018/ <https://interlab.ait.ac.th/aintec2018/>  

Notes and links from IETF 101:

 * The IETF 101 plenary: The Future of Internet Access https://www.ietf.org/live/ietf101-techplenary/ <https://www.ietf.org/live/ietf101-techplenary/>
A panel of experts in community networks, the use of spectrum, and satellite access networks discussed recent developments in these areas and their implications for the Internet’s future development. Moderated by Jane Coffin, responsible for development strategy at the Internet Society.
 
The slides:
Go local: community networks (Leandro Navarro)  <https://datatracker.ietf.org/meeting/101/materials/slides-101-ietf-sessb-go-local-community-networks-leandro-navarro-00>
How To Connect Everyone (Steve Song)  <https://datatracker.ietf.org/meeting/101/materials/slides-101-ietf-sessb-how-to-connect-everyone-steve-song-00>
The Future is Up in the Sky (Jonathan Brewer) <https://datatracker.ietf.org/meeting/101/materials/slides-101-ietf-sessb-the-future-is-up-in-the-sky-jonathan-brewer-00>
 
* GAIA WG IETF 101 meeting: (agenda and slides: https://datatracker.ietf.org/meeting/101/session/gaia )

Raw notes of the meeting: (thanks for the anon contributions to the notes during the session)

Insights into RIFE field trial
Dirk Trossen, RIFE Project
A description of the RIFE field trial, as part of the guifi.net <http://guifi.net/> network, of an ICN, DTN network
Deployment flexibility; Service routing; Dual stack: IP, ICN
Deployments: 
    - Tarragona (Catalonia): WiFi based, 6 supernodes, 15 AP 
    - laboratory (Barcelona): 3 supernodes WiFi + Eth

Connecting the edges. The UMOBILE project
Sotiris Diamantopoulos, Research Associate, Athena Research Center
Information centric & delay-tolerant networking, edge, new application models & services
Avoid centralisation, move services close to the user, facilitate mobility
Routing: DABBER protocol, contextualization: social awareness, 

PiCasso:  Information-Centric Edge Computing Platform for Community Mesh Networks
Mesh Networking Experience:  qMp case
Adisorn Lertsinsrubtavee & Mennan Selimi, Cambridge University
QMP mesh network in Barcelona, a 80 node mesh of about 200 nodes
Focus: is it possible to run a lot of services in the network?
network went from 30 to 80 nodes within 2 years
discovered highly skewed bandwidth distribution, reason: some users are changing transmission power/?? of their devices
solution: deploy additional devices in strategic places
Distribute services to the edge with lightweight virutalization (Docker based) with the Picasso service. Automated decision about service location, monitoring system, smart forwarding.
Results: reduction in latency of service delivery

Questions:
    Q??: how did you measure the bandwidth capacities?
    A: we measured with a linux command ?? It's a production network so we were careful not to cause overhead
    Q: ??, univ of essex: are .. (sorry, didn't catch that)
    Q: V. Chryssos: what kind of services did you deploy & why these
    A: first was TahoeLAFS, second was videostream (peerstreamer)

Vassilis Chryssos, Administrator, Sarantaporo.gr <http://sarantaporo.gr/>
"Empowering local communities to build, maintain and expand their community network"
Social aspects of the Sarantaporo.gr <http://sarantaporo.gr/> community network.
Sarantaporo: isolated area, no telcos present
villagers started building community mesh network, soon 15 neighbor villages joined
vision: eradicate digital divide, give young ppl a motvation to stay in their region (by giving them opportunities)
network: 24 backbones connecting 11 villages, 3 farms & 1 camp; 95 access points in the villages; >50 active community memebers (the villagers building & maintaining their network)
Q juliusz chroboczek: what's the scale of the map on the picture? A: -> map shows ~60 km range
suggestions for improvements through drawings on maps
org provides training for villagers to empower them to DIY their network
Example: Workshop in Flamboro (for farmers, elderly ppl etc, mots >50 yrs old) on how to make an ethernet cable, what is a p2p link, how to troubleshoot their own network
=> Why do they do this? If they don't have internet, their grandchildren won't come!
Do planning in paper maps from sat images
Good practices: Support via Instant Messaging app. Celebration, Support, update on progress
WiFi and Internet connectivity quality very important
Important: what services can ppl use, what do they need? (don't just deploy ~something~)
Participants gained awareness on privacy, personal data, surveillance possibilities by learning how the internet works
The magic? Local riding club expanded the network on their own; older community members support new members, autonomously organize workshops, women participate, farmers use it for their work, collectively buy fertilizer; doctors use it for precriptions, 
Next: more workshops, expand

Questions:
Q: Luis Martinez: How are costs of the network covered (Internet connection, maintenance)?
A: through EU funding, ISOC(?), local people (node owners) contributing 60 €/year. Also voluntary work (everybody's volunteering).
A: Hybrid model: ppl in athens cooperate with locals when there's a problem. Internet: Local university provides their internet

Q Adison: sustainability of the network as people join or leave.
A: As the community grows, more contributions are expected (individual contribs, fests), but they haven't solved the sust problem

Q Richard ??: RE: workshops, What do ppl have difficulties with, has your model been replicated?
A: things they can't visualized, they can't comprehend. => visualize backbone using maps, don't overcomplicate things.
A: But! 90% of problems can be solved with basic knowledge on how to make cables, alogn links, position nodes
A: Regarding "export" of the idea: Hasn't happened yet, but next(this?) summer, they'll migrate to a new village(? not sure if I caught that)
A: Don't make the partiticpants feel like they're on their own when you leave.

Q: Gareth Thyson: Are there many participants or does the system rely on a few very engaged ppl? What do you do if these peolpe leave?
A: We've worked w many ppl who have come & gone; we see that in each village there's 1-2 ppl championing the project and inspire others to join. If somebody leaves, someone ese will usually take over, but it takes a lot of community building effort.

Community Cellular Network:  Towards 5G
Mohamed Kassem, University of Edinburgh, Scotland
>40% of world population is living in rural areas, often unconnected (52% of world population)
reason: infrastructure costs (for minimum revenue bc not densely populated or low-income area), non-affordability
but! universal internet is not just a problem of developing countries: rural areas in UK (for example) are often affected too
one objective of 5G: close this gap. other ideas: google baloons, leveraging low frequencies (700 mHz), etc.
New deployment model for the cellular net in rural areas simplicity, scalability, applicablility to new emerged services, cost efficient, adaptability
Three main components: access nets (LTE small cells), TVWS backhaul (8 MHz channel), Core in the cloud
TVWS usability:
selected area in scotland (60 Km) to assess whether TV Whitespace an be used to build low-cost middle mile infrastructure
usually, availability is used as metric whether TVWS is usable. But this is often inaccurate/overly optimistic! => look at TVWS *usability* instead. Usability is a metric that denotes quality, not quantity
Problem: TVWS spectrum is fragmented. For high capacity, the possible 6/8 mHz channels aren't sufficient. Solution: aggregate too-small channels into usable ones
Idea was deployed recently in Balquhidder. Focus not so much on distance (1 Km), but on high-quality link.

Questions:
Q Andres, Cambridge: In DBs, models usually overestimate ??; how (didn't catch that, sry)
A: In our analysis, we focus on the receiver side. it might be that channel is very interfered with on receiver,, which explains the

Q: Andres, Cambrdige: Have you ot any experience with transport protocols
A: No, main focus is on PHY performance
Q: Adisorn, Cambridge: relationship with 5G?
A: we are thrying to resolve the bottleneck
A: work with any regulator? No

Q: ?? Richard: The high bandwidth that you need, is that p2p?

IoT Networks and TTN Community IoT
Jon Brewer, NSRC
IoT protocols are designed with device & network constraints in mind: low poer/cpu/size; radio propagation issues, etc
Unfortunately, wifi is still the most popular iot protocol. wifi devices are cheap, but problematic in terms of security, battery consumption...
Enter IEEE 802.15.4(n): star/tree/mesh topologies, power saving, 128-bit encryption keys, PAN/LAN solution w/out mobility, can be set up by anyone. But! not low-cost because no economics of scale.
Bad Stuff: 
- Lo-Fi, Motenio etc-- cheap toys run unencrypted serial across 433, 868, 915 MHz
- sigfox-- low power, proprietary, limited to 140 12-byte msgs/day, optional encryption, mobility possible (when channel persistent), only sigfox can run rigfox network!
- weightless/nbIoT ("5G")-- open standard, low power, public key encrypted, mobility scaling, only mobile operators can operate it.
- LTE-M ("5G")-- uses LTE bse stations, possibly periodic transmissions, can only be run by mobile operators
- LoRa/LoRaWAN-- bidirectional comms, star-only, multiple levels of encryption, anyone can run a LoRaWAN network. The Thing network builds cmmunity IoT networks all over the world
Questions:
    Jon, Cambridge: There's a cool measurement of IoT homes, alarming in terms of data (??)... If you run a lorawan network you'll find you're not alone. we found 12 in london last year, but there's an issue with networks coexisting.
    J. Ignacio, QMUL: Openness: LoRa one chipset company, IP issues, SigFox: closed
    Security of the infrastructure.

Discussion of informational best practices document and next steps for GAIARG
Chairs/All
No time left, further comments in the mailing list.

Your comments are welcome :-)

--
Jane Coffin and Leandro Navarro (GAIA WG co-chairs)

---

From: Vasilis Chryssos <[email-masked]>
Date: Sat, 21 Apr 2018 16:45:09 +0300

Some clarifications on Leandro's questions about the Sarantaporo.gr
presentation, below..

cheers!

2018-04-21 15:44 GMT+03:00 Leandro Navarro <[email-masked]>:

> * *Call for topics to discuss in the next GAIA WG meeting* at IETF 102
> Montreal (14 Jul 2018 - 20 Jul 2018) https://www.ietf.org/how/
> meetings/102/
> * The *ANRW ’18* takes place in Montreal, Quebec, Canada, the venue of
> the IETF-102 meeting , on Monday, July 16, 2018.
> Paper submission deadline (extended)  April 23, 2018 *(really close!)*
> https://irtf.org/anrw/2018/
>
> ** 14th Asian Internet Engineering Conference *(AINTEC), Thailand, 12-14
> November 2018, (after IETF 103 https://www.ietf.org/how/meetings/103/
> also there)
> https://interlab.ait.ac.th/aintec2018/
>
>
>
> *Notes and links from IETF 101:*
>  * *The IETF 101 plenary: The Future of Internet Access *
> https://www.ietf.org/live/ietf101-techplenary/
> A panel of experts in community networks, the use of spectrum, and
> satellite access networks discussed recent developments in these areas and
> their implications for the Internet’s future development. Moderated
> by Jane Coffin, responsible for development strategy at the Internet
> Society.
>
> The slides:
> Go local: community networks (Leandro Navarro)
> <https://datatracker.ietf.org/meeting/101/materials/slides-101-ietf-sessb-go-local-community-networks-leandro-navarro-00>
> How To Connect Everyone (Steve Song)
> <https://datatracker.ietf.org/meeting/101/materials/slides-101-ietf-sessb-how-to-connect-everyone-steve-song-00>
> The Future is Up in the Sky (Jonathan Brewer)
> <https://datatracker.ietf.org/meeting/101/materials/slides-101-ietf-sessb-the-future-is-up-in-the-sky-jonathan-brewer-00>
>
> ** GAIA WG IETF 101 meeting*: (agenda and slides:
> https://datatracker.ietf.org/meeting/101/session/gaia )
>
> *Insights into RIFE field trial*
> *Dirk Trossen, RIFE Project*
> A description of the RIFE field trial, as part of the guifi.net network,
> of an ICN, DTN network
> *Connecting the edges. The UMOBILE project*
> *Sotiris Diamantopoulos, Research Associate, Athena Research Center*
> *PiCasso:  Information-Centric Edge Computing Platform for Community Mesh
> Networks*
> *Mesh Networking Experience:  qMp case*
> *Adisorn Lertsinsrubtavee & Mennan Selimi, Cambridge University*
> discovered highly skewed bandwidth distribution, reason: some users are
> changing transmission power/?? of their devices
> Distribute services to the edge with lightweight virutalization (Docker
> based) with the Picasso service. Automated decision about service location,
> monitoring system, smart forwarding.
> *Vassilis Chryssos, Administrator, Sarantaporo.gr <http://sarantaporo.gr/>*
> *"Empowering local communities to build, maintain and expand their
> community network"*
> vision: eradicate digital divide, give young ppl a motvation to stay in
> their region (by giving them opportunities)
> network: 24 backbones connecting 11 villages, 3 farms & 1 camp; 95 access
> points in the villages; >50 active community memebers (the villagers
> building & maintaining their network)
> Example: Workshop in Flamboro (for farmers, elderly ppl etc, mots >50 yrs
> old) on how to make an ethernet cable, what is a p2p link, how to
> troubleshoot their own network
> Participants gained awareness on privacy, personal data, surveillance
> possibilities by learning how the internet works
> The magic? Local riding club expanded the network on their own; older
> community members support new members, autonomously organize workshops,
> women participate, farmers use it for their work, collectively buy
> fertilizer; doctors use it for precriptions,
> A: through EU funding, ISOC(?)
>

reference to ISOC's grant to Sarantaporo.gr
<http://www.sarantaporo.gr/node/405>

> local people (node owners) contributing 60 €/year. Also voluntary work
> (everybody's volunteering).
> A: Hybrid model: ppl in athens cooperate with locals when there's a
> problem. Internet: Local university provides their internet
>
> A: As the community grows, more contributions are expected (individual
> contribs, fests), but they haven't solved the sust problem
>
> A: things they can't visualized, they can't comprehend. => visualize
> backbone using maps, don't overcomplicate things.
> A: Regarding "export" of the idea: Hasn't happened yet, but next(this?)
> summer, they'll migrate to a new village(? not sure if I caught that)
>

This summer we're visiting a village in Epirus region
<http://www.sarantaporo.gr/node/408> to transfer know-how and set up
together their first CN node

> Q: Gareth Thyson: Are there many participants or does the system rely on
> a few very engaged ppl? What do you do if these peolpe leave?
> A: We've worked w many ppl who have come & gone; we see that in each
> village there's 1-2 ppl championing the project and inspire others to join.
> If somebody leaves, someone ese will usually take over, but it takes a lot
> of community building effort.
>
> *Community Cellular Network:  Towards 5G*
> *Mohamed Kassem, University of Edinburgh, Scotland*
> but! universal internet is not just a problem of developing countries:
> rural areas in UK (for example) are often affected too
> one objective of 5G: close this gap. other ideas: google baloons,
> leveraging low frequencies (700 mHz), etc.
> New deployment model for the cellular net in rural areas simplicity, scalability,
> applicablility to new emerged services, cost efficient, adaptability
> selected area in scotland (60 Km) to assess whether TV Whitespace an be
> used to build low-cost middle mile infrastructure
> usually, availability is used as metric whether TVWS is usable. But this
> is often inaccurate/overly optimistic! => look at TVWS *usability* instead.
> Usability is a metric that denotes quality, not quantity
> Problem: TVWS spectrum is fragmented. For high capacity, the possible 6/8
> mHz channels aren't sufficient. Solution: aggregate too-small channels into
> usable ones
> A: In our analysis, we focus on the receiver side. it might be that
> channel is very interfered with on receiver,, which explains the
>
> *IoT Networks and TTN Community IoT*
> *Jon Brewer, NSRC*
> IoT protocols are designed with device & network constraints in mind: low
> poer/cpu/size; radio propagation issues, etc
> Unfortunately, wifi is still the most popular iot protocol. wifi devices
> are cheap, but problematic in terms of security, battery consumption...
> Enter IEEE 802.15.4(n): star/tree/mesh topologies, power saving, 128-bit
> encryption keys, PAN/LAN solution w/out mobility, can be set up by anyone.
> But! not low-cost because no economics of scale.
> Bad Stuff:
>
>    - - Lo-Fi, Motenio etc-- cheap toys run unencrypted serial across 433,
>    868, 915 MHz
>
>
>    - - sigfox-- low power, proprietary, limited to 140 12-byte msgs/day,
>    optional encryption, mobility possible (when channel persistent), only
>    sigfox can run rigfox network!
>
>
>    - - weightless/nbIoT ("5G")-- open standard, low power, public key
>    encrypted, mobility scaling, only mobile operators can operate it.
>
>
>    - - LTE-M ("5G")-- uses LTE bse stations, possibly periodic
>    transmissions, can only be run by mobile operators
>
>
>    - - LoRa/LoRaWAN-- bidirectional comms, star-only, multiple levels of
>    encryption, anyone can run a LoRaWAN network. The Thing network builds
>    cmmunity IoT networks all over the world
>
> Questions:
>     Jon, Cambridge: There's a cool measurement of IoT homes, alarming in
> terms of data (??)... If you run a lorawan network you'll find you're not
> alone. we found 12 in london last year, but there's an issue with networks
> coexisting.
> *Discussion of informational best practices document and next steps for
> GAIARG*
> *Chairs/All*
> _______________________________________________
> gaia mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/gaia
>
>

-- 

*Vassilis Chryssos*
Board Member / Administrator

*Sarantaporo.gr Non Profit Organization*
28 Karaiskaki str., 10554 Psirri, Athens, Greece
Tel: +30 211 8002730, Mob: +30 694 794 8786
Email: [email-masked], Web: www.sarantaporo.gr