Subject: [Gen-art] Gen-art review of draft-ietf-sieve-body-06.txt

From: Elwyn Davies <[email-masked]>
Date: Thu, 21 Jun 2007 23:52:03 +0100

I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-sieve-body-06.txt
Reviewer: Elwyn Davies
Review Date: 21 June 2007
IETF LC End Date: 13 June 2007
IESG Telechat date: (if known) -

Summary:
Ready for the IESG.  There are a couple of minor nits that 
can be fixed by the RFc Editor.

Aside: This is almost certainly irrelevant to this document but has any 
thought been given to how this will interact with email internationalization?

Comments:

Minor issues:
ss3 and 4 refer to 'matching text' but in practice the matches can be against 
arbitrary octet strings in content types that aren't text.  Use 'matching content' 
instead?

A pointer is given to the SIEVE base document, but I wonder if this document
should note that ABNF is used to specify syntax and provide the appropriate 
reference.

Editorial:
Section headings:  Require capitalization of most words.

It won't be new or proposed once this becomes an RFC...
Abstract: s/a new command/an additional command/
s1: s/The proposed "body" test/The "body" test defined in this document/

s3 heading: Maybe '3. "Body" Test' rather than '3. Test body'?

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 22 Jun 2007 11:05:43 +0100

> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Hi,
Thanks for the comments.

> Ready for the IESG.  There are a couple of minor nits that can be 
> fixed by the RFc Editor.
>
> Aside: This is almost certainly irrelevant to this document but has 
> any thought been given to how this will interact with email 
> internationalization?

By "this" do you mean Sieve in general?
I think email internationalization is something that needs to be tackled 
once Sieve WG recharters.

> Comments:
>
> Minor issues:
> ss3 and 4 refer to 'matching text' but in practice the matches can be 
> against arbitrary octet strings in content types that aren't text.  
> Use 'matching content' instead?

Sure.

> should note that ABNF is used to specify syntax and provide the 
> appropriate reference.

Yes.

> s3 heading: Maybe '3. "Body" Test' rather than '3. Test body'?

Yes, this seems reasonable.