Subject: Re: [Gen-art] Gen-ART review of draft-ietf-tsvwg-2960bis

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 01 Jun 2007 08:54:02 -0500

Randall Stewart wrote:
> Vijay:
> 
> Ok I have gone through all your comments and corrected
> them with two exceptions noted below..

Randall: Thanks; that was very kind of you.

> I will not change anything in section 5.1.2. There ARE implementation
> situations where the implementation (not the application) cannot
> control the source address. The wording here was added just due
> to such situations. In such a case the wording is valid.

OK.

> As to rfc3484, sctp had a document that discussed these issues
> long before that draft ever appeared.. we let the draft slip
> by the wayside long ago.. we have discussed revising it.. since
> you also have issues with src addr selection on v4 too.. (we actually
> had two documents).. bottom line is I think a separate document
> is probably appropriate to discuss such issues.

OK.

> If you want a specific wording change, I will make it.. but as
> I said I think you are better to hold your comments for the
> sockets api document... when it comes up :-D

I did not have a specific wording change; just some confusion
around this issue.  If the API document will shed some light
on it, then that will be fine.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
WWW:   http://www.alcatel-lucent.com/bell-labs

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Randall Stewart <[email-masked]>
Date: Fri, 01 Jun 2007 12:57:07 -0400

> on it, then that will be fine.

I think the sctp-socket document is much better for figuring
out how to program SCTP. In fact I give a 3 day seminar
on SCTP .. first day & 1/2 deep dark details.. last day and 1/2
programming sctp.. aka the sockets api.. complete with
6 programming assignments..

If your really interested I believe I can share the material
(we give it to customers and internal folks).. nothing secret
here :-D

R

-- 
Randall Stewart
NSSTG - Cisco Systems Inc.
803-345-0369 <or> 803-317-4952 (cell)