Subject: [Gen-art] (partial) review of draft-ietf-opsawg-oam-overview-05.txt

From: Francis Dupont <[email-masked]>
Date: Sat, 23 Jul 2011 23:44:19 +0200

I am the assigned Gen-ART reviewer for this draft. For background on 
Gen-ART, please see the FAQ at 
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments 
you may receive.

Document: draft-ietf-opsawg-oam-overview-05.txt
Reviewer: Francis Dupont
Review Date: 20110723
IETF LC End Date: 20110720
IESG Telechat date: unknown

Summary: Not Ready

Major issues: 4.1 page 13 explains the use of ICMP in Traceroute: this
is plainly wrong: ICMP can't be used in this way because no ICMP error
can be triggered by an ICMP. BTW:
 - traceroute uses UDP probes just for this reason
 - I put this as a major issue because this must not be published in
  a document from the IETF

Regards

[email-masked]

PS: I stopped the review at this point but I'll resume and send a full
review ASAP (I like the document, OAM is something really useful and
to try to organize it a great idea).

---

From: Tal Mizrahi <[email-masked]>
Date: Mon, 25 Jul 2011 16:28:24 +0300

Hi Francis,

Thanks for your feedback.
Since Traceroute is not a standard, but rather an application, it has several implementations.
Indeed, the UNIX implementation uses UDP messages - this is also described in RFC 2151 (informational).
The windows implementation of Traceroute, on the other hand, uses ICMP Echo messages, see:
http://technet.microsoft.com/en-us/library/bb491018.aspx

So I think maybe the draft should explain that Traceroute is an application that has more than one implementation, and that it can be implemented with either UDP or ICMP messages. Does this make sense?

Thanks.
Tal.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Saturday, July 23, 2011 2:44 PM
To: [email-masked]
Cc: [email-masked]
Subject: (partial) review of draft-ietf-opsawg-oam-overview-05.txt

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you may receive.

Summary: Not Ready

Major issues: 4.1 page 13 explains the use of ICMP in Traceroute: this is plainly wrong: ICMP can't be used in this way because no ICMP error can be triggered by an ICMP. BTW:
 - traceroute uses UDP probes just for this reason
 - I put this as a major issue because this must not be published in
  a document from the IETF

Regards

PS: I stopped the review at this point but I'll resume and send a full review ASAP (I like the document, OAM is something really useful and to try to organize it a great idea).

---

From: Francis Dupont <[email-masked]>
Date: Mon, 25 Jul 2011 20:34:12 +0200

In your previous mail you wrote:

   Since Traceroute is not a standard, but rather an application, it
   has several implementations.  Indeed, the UNIX implementation uses
   UDP messages - this is also described in RFC 2151 (informational).
   The windows implementation of Traceroute, on the other hand, uses
   ICMP Echo messages, see:
   http://technet.microsoft.com/en-us/library/bb491018.aspx
   
=> perhaps I over interpreted the first case of RFC 1812 4.3.2.7
but as there is no real and stable definition of what is an ICMP
error message (something fixed in ICMPv6) I am afraid there are
some router implementations which just never send an ICMP error
message at the result of receiving a ICMP Echo Request with TTL=1
(if you believe this should have been noticed there are so many
reasons to get partial results from traceroute/tracert...)

   So I think maybe the draft should explain that Traceroute is an
   application that has more than one implementation, and that it can
   be implemented with either UDP or ICMP messages. Does this make
   sense?
   
=> yes but if you detail the mechanism I really suggest to describe
the UDP version.

Thanks