Subject: [Gen-art] Gen-ART Telechat Review of draft-ietf-6man-flow-update-07

From: Pete McCann <[email-masked]>
Date: Wed, 13 Jul 2011 18:16:32 -0400

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document: draft-ietf-6man-flow-update-07
Reviewer: Pete McCann
Review Date: 2011-07-13
IETF LC End Date:
IESG Telechat date: 2011-07-14

Summary: One clarification needed

Major issues: None

Minor issues:

It isn't clear to me what the document means by "stateful" vs.
"stateless" assignment
of flow labels.  Approximating a uniform distribution with a hash
function or PRNG
requires some sort of state such as a seed or sequence number which is updated
after each assignment, yes?  Or were you referring to the statefulness
of intermediate
routers that identify a flow by port number and then remember the flow
label assignment
they chose?

Nits/editorial comments: None

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 14 Jul 2011 10:31:40 +1200

Pete,

On 2011-07-14 10:16, Pete McCann wrote:
> after each assignment, yes? 

No. In fact there's an example of a purely stateless algorithm that requires no
seed or sequence number in the Appendix of draft-ietf-6man-3697bis-06; there just
needs to be enough variability in some of the header fields (typically the destination
address and one of the port numbers).

> Or were you referring to the statefulness
> of intermediate

Not exactly - the real distinction is between scenarios where there is a signaling
process to set up a flow with a particular label (for example, Intserv/RSVP
is defined to be able to signal a flow label) and scenarios preferred by the WG
where there is no signaling and no pre-established state anywhere.

Would this change in  Section 2 be OK for you?

OLD:
   It is
   not made clear by the rule that there is an implied distinction
   between stateless models (in which case no assumption may be made)
   and stateful models (in which the router has explicit knowledge).

NEW:
   It is
   not made clear by the rule that there is an implied distinction
   between stateless models (in which there is no signaling, so no specific
   assumption about the meaning of the flow label value can be made)
   and stateful models (in there is signaling and the router has explicit
   knowledge about the label).

      Brian

---

From: Pete McCann <[email-masked]>
Date: Wed, 13 Jul 2011 20:23:58 -0400

>   knowledge about the label).

Yes, that clarifies things.  Thanks.

-Pete