Subject: [Gen-art] Gen-ART LC Review of draft-eggert-successful-bar-bof-06

From: Ben Campbell <[email-masked]>
Date: Wed, 7 Sep 2011 16:22:54 -0500

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-eggert-successful-bar-bof-06
Reviewer: Ben Campbell
Review Date: 2011-09-07
IETF LC End Date: 2011-09-08

Summary: This draft is nearly ready for publication as an informational RFC, but has some open issues

Major issues:

-- I share some of the concerns of other last call commenters, in that an RFC is written in stone. This draft is written in response to a current trend, and may make no sense, or worse, be interpreted very differently in future contexts. On the other hand, I agree the trend that it addresses needs to be, uhm, addressed. This might be fixable with a more strongly worded "scope of applicability" pointing this out. Or maybe an RFC is not the right approach--I'm not really sure what the right way to move forward is here.

-- Section 6 suggests side meetings should be (somehow "informally") covered by NOTE WELL. I think this is a very dangerous suggestion. The rest of the document suggests that a side meeting has no official standing. That seems to me to mean it's no different than a group of people who coincidentally participate in the IETF having a dinner or bar meeting on any subject at any time. Or a hallway conversation, for that matter. By the logic of this section, I can't really figure out how "informal" a meeting would need to be before it no longer fell under NOTE WELL.

In an informal meeting, the participants should be able to follow any IPR policy they like. I can even imagine an informal meeting covered by an NDA, where the participants want to decide if they want to have further discussions of a subject under IETSF IPR rules or not.

I think the best we can hope to do is suggest that side meeting organizers and participants be explicit with their expectations on IPR and confidentiality, so there is less chance for down-stream surprises. If we want something stronger than that, then we really need to create a new category of "official" meeting.

Minor issues:

-- section 1, 2nd to last paragraph:

Good luck in asking for a cultural change to behavior that is unofficial in the first place. I think we're better off clarifying the term people already use than trying to introduce a new one.

Nits/editorial comments:

-- section 3, 5th paragraph: "dialogs between two people, which is much more ineffective than a group discussion around a restaurant table."

I suggest s/"more ineffective"/"less effective"

---

From: Lars Eggert <[email-masked]>
Date: Fri, 9 Sep 2011 11:02:18 +0300

Hi,

thanks, Ben. We will incorporate most of your suggestions in the next revision. That said:

> I think the best we can hope to do is suggest that side meeting organizers and participants be explicit with their expectations on IPR and confidentiality, so there is less chance for down-stream s…

We actually ran this question past the IETF legal counsel before adding that section to the document. It was his stated opinion that the Note Well applies. I therefore don't see what we could do here.

Lars

---

From: Barry Leiba <[email-masked]>
Date: Fri, 9 Sep 2011 09:01:42 -0400

> -- Section 6 suggests side meetings should be (somehow "informally") covered
> by NOTE WELL. I think this is a very dangerous suggestion. The rest of the
> document suggests that a side meeting has no official standing. That seems to
> me to mean it's no different than a group of people who coincidentally participate
> in the IETF having a dinner or bar meeting on any subject at any time. Or a hallway
> conversation, for that matter. By the logic of this section, I can't really figure out how
> "informal" a meeting would need to be before it no longer fell under NOTE WELL.

This is truly a tricky point.  Often, organizers of these "bar BoFs"
make great effort to get an AD involved and attending, make it clear
that they're having this because their BoF proposal got in too late or
was denied, and/or talk about a proposed WG charter.  These side
meetings are often advertised during open area meetings and other
working-group sessions, and everyone is encouraged to attend.

In the first case, Note Well explicitly covers this ("The IESG, or any
member thereof on behalf of the IESG"); in the others, it does seem
like input to the IETF ("any statement made within the context of an
IETF activity"), if not unequivocally so, and it's certainly not
explicitly excluded ("Statements made outside of an IETF session,
mailing list or other function, that are clearly not intended to be
input to an IETF activity, group or function, are not IETF
Contributions in the context of this notice.")

I'd like to hear from Jorge on this, but my spider sense says that if
a meeting occurs during an IETF week, is open to all, and clearly
relates to current or proposed work for the IETF, the people who go
have a reasonable expectation of Note Well terms.

> I think the best we can hope to do is suggest that side meeting organizers
> and participants be explicit with their expectations on IPR and confidentiality,
> so there is less chance for down-stream surprises.

I think that's an excellent approach.  May I suggest some text?:

OLD
   Thus, the fact that a Contribution is made at one of the side
   meetings or other "unofficial" or "semi-official" events described in
   this document does not change or limit the applicability of the
   IETF's IPR rules.  If you have a question regarding the applicability
   of the IETF IPR rules in any specific context or to any specific
   activity, you should consult your attorney or make an inquiry to the
   IESG.

   Informally, the above makes it appropriate, in order to provide a
   pointer to the relevant policies, to announce the "Note Well" text
   [NOTEWELL] in all such meetings.

NEW
   Thus, a Contribution that is made at one of the side
   meetings or other "unofficial" or "semi-official" events described in
   this document could still be under the applicability of the
   IETF's IPR rules.  If you have a question regarding the applicability
   of the IETF IPR rules in any specific context or to any specific
   activity, you should consult your attorney or make an inquiry to the
   IESG.

   If a meeting occurs during an IETF week, is open to all, and clearly
   relates to current or proposed work for the IETF, those who attend
   will have a reasonable expectation that the IETF's rules apply.
   The organizers of these meetings are, therefore, strongly encouraged
   to make an explicit statement at the beginning of the meetings to
   announce whether or not they do apply (by using the "Note Well" text
   [NOTEWELL]).  If they do not apply, the announcement should
   specify what confidentiality and IPR terms are in effect.  In the absence
   of such a statement, attendees are encouraged to explicitly ask.

--
Barry

---

From: Ben Campbell <[email-masked]>
Date: Fri, 9 Sep 2011 08:29:27 -0500

> We actually ran this question past the IETF legal counsel before adding that section to the document. It was his stated opinion that the Note Well applies. I therefore don't see what we could do he…

Did the counsel describe the triggers that causes Note Well to apply in general? Because if it automatically applies to an unofficial side meeting, then it's hard for me to see where it _doesn't_ apply when 2 or more IETF participants have a conversation. For example:

---

From: Ben Campbell <[email-masked]>
Date: Fri, 9 Sep 2011 08:45:27 -0500

> working-group sessions, and everyone is encouraged to attend.

It seems like this draft discourages that sort of meeting in the first place, doesn't it?

> have a reasonable expectation of Note Well terms.

That does sound like something, that, by default falls into the "semi-official" language. But this draft encourages meetings that are not widely advertised, and open only to key participants. That likely means invitation only. That is. more on the "unofficial" side of the language. That's the part that triggers my concern.

>   of such a statement, attendees are encouraged to explicitly ask.

I like your proposed language better than the original, although I wonder if the IESG wants to be in the business of giving advice about IPR status. But I guess it all depends on the advice from counsel. I don't want to speculate on the nature of said advice--but I guess I'm looking for a way that someone could explicitly choose to have a meeting where Note Well did not apply. Otherwise we are likely to end up with yet another category of meetings, which look pretty much like side meetings except for the IPR rules.

---

From: Barry Leiba <[email-masked]>
Date: Fri, 9 Sep 2011 10:07:42 -0400

> It seems like this draft discourages that sort of meeting in the first place, doesn't it?

It does, but they will happen nonetheless.  The draft encourages
small, invited groups, but people *want* larger, open meetings, and
they'll do them.  I think it's important that we do what we can to get
people to make it clear what rules they're applying -- in that case,
and in all cases.

>>   of such a statement, attendees are encouraged to explicitly ask.
...
> but I guess I'm looking for a way that someone could explicitly choose to have a meeting
> where Note Well did not apply.

I agree, and I hope my suggested text says that.  If more needs to be
said, we (for some value of "we" that might mean "Lars and Gonzalo")
can take another stab.

Barry

---

From: Ben Campbell <[email-masked]>
Date: Fri, 9 Sep 2011 09:11:42 -0500

> said, we (for some value of "we" that might mean "Lars and Gonzalo")

Yes, sorry, I agree your text says that. My comment was meant to support it, not argue against it :-)

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 9 Sep 2011 10:36:16 -0500

Lars,

For what it's worth, I have the same question as Ben - if this guidance 
applies to the kinds of informal meetings in restaurants and bars that the 
IESG is encouraging, even if they aren't publicized and aren't open to the 
community, is there any way for two or more IETF participants to talk to 
each other, that's NOT under NOTE WELL?

I think it DOES make sense to say that the kinds of informal meetings the 
IESG is discouraging - in IETF meeting rooms, with agendas, mailing lists, 
presentations, attendee lists, and minutes - should include NOTE WELL 
notifications.

But if I was sitting next to Adam Roach on a plane headed for the IETF 
(which has happened before) when he was editor of GIN and I was chair of 
MARTINI (this last part did not), and we started talking about proposed 
changes to the GIN draft, is that covered?

Color me confused ...

Spencer

>>> -- Section 6 suggests side meetings should be (somehow "informally") 
>>> covered by NOTE WELL. I think this is a very dangerous suggestion. The 
>>> rest of the document suggests that a side meeting has no official 
>>> standing. That seems to me to mean it's no different than a group of 
>>> people who coincidentally participate in the IETF having a dinner or bar 
>>> meeting on any subject at any time. Or a hallway conversation, for that 
>>> matter. By the logic of this section, I can't really figure out how 
>>> In an informal meeting, the participants should be able to follow any 
>>> IPR policy they like. I can even imagine an informal meeting covered by 
>>> an NDA, where the participants want to decide if they want to have 
>>> further discussions of a subject under IETSF IPR rules or not.
>>>
>>> I think the best we can hope to do is suggest that side meeting 
>>> organizers and participants be explicit with their expectations on IPR 
>>> and confidentiality, so there is less chance for down-stream surprises. 
>>> If we want something stronger than that, then we really need to create a 
>>> new category of "official" meeting.
>>
>> We actually ran this question past the IETF legal counsel before adding 
>> that section to the document. It was his stated opinion that the Note 
>> Well applies. I therefore don't see what we could do here.
>>
>
> Did the counsel describe the triggers that causes Note Well to apply in 
> general? Because if it automatically applies to an unofficial side 
> meeting, then it's hard for me to see where it _doesn't_ apply when 2 or 
> more IETF participants have a conversation. For example:

---

From: Lars Eggert <[email-masked]>
Date: Fri, 9 Sep 2011 18:54:31 +0300

We need to run this past Jorge. The gist of that section of the text basically came from an email exchange we had. I'm not at all opposed to changing it, but if we change it, Jorge needs to OK it.

On 2011-9-9, at 18:36, Spencer Dawkins wrote:

> Lars,
> 
> For what it's worth, I have the same question as Ben - if this guidance applies to the kinds of informal meetings in restaurants and bars that the IESG is encouraging, even if they aren't publicized and aren't open to the community, is there any way for two or more IETF participants to talk to each other, that's NOT under NOTE WELL?
> 
> I think it DOES make sense to say that the kinds of informal meetings the IESG is discouraging - in IETF meeting rooms, with agendas, mailing lists, presentations, attendee lists, and minutes - should include NOTE WELL notifications.
> 
> But if I was sitting next to Adam Roach on a plane headed for the IETF (which has happened before) when he was editor of GIN and I was chair of MARTINI (this last part did not), and we started talking about proposed changes to the GIN draft, is that covered?
> 
> Color me confused ...
> 
> Spencer
>

---

From: John C Klensin <[email-masked]>
Date: Fri, 09 Sep 2011 17:55:26 -0400

--On Friday, September 09, 2011 10:07 -0400 Barry Leiba
<[email-masked]> wrote:

>> but I guess I'm looking for a way that someone could
>> explicitly choose to have a meeting where Note Well did not
>> apply.
> 
> I agree, and I hope my suggested text says that.  If more
> needs to be said, we (for some value of "we" that might mean
> "Lars and Gonzalo") can take another stab.

I think I disagree.  I don't know what a decision to "Not apply
the Note Well" or, more specifically, to exempt oneself from the
disclosure requirements of RFC 3979, 4879, and 5378, means and,
especially wrt the disclosure requirements, if I do understand,
I don't like it.  Let's see: "let's hold a bar bof and work
toward getting the IETF to consider adopting work that contains
submarine patents?"  If it is a closed meeting with only those
who are already party to the relevant IPR present, then I guess
we don't care but I also continue to not see why we need an IETF
discussion or guidance for such meetings.  If the organizers
want to involve others and get their support, suggestions, or
commitments without any obligation to disclose the IPR, then I
think the potential for abuse is just too large for the IETF to
be involved in that in any way (including, but not limited to,
making announcement channels available, assisting with
scheduling or space, or having WG Chairs, ADs, or IAB members
present in any capacity that might be interpreted by anyone as
associated with their IAB/IETF roles.

Again, I really don't care about secret meetings among friends.
But, as soon as the meeting is open, is announced openly in a WG
or area meeting or on an IETF-sponsored mailing list, or even
shows up on an IETF message board, then I think the disclosure
requirements apply

There is a separate issue in this, which is whether there are
activities that should require patent (and related IPR)
disclosures but that don't need to invoke the "Contributor"
(release of copyrights and permission for IETF reuse)
provisions.  Personally, I believe we ought to separate those
two, precisely to enable broad-ranging informal discussions in
preliminary or organizational meetings.  But that is not the way
the procedures are written today.  Today they appear, at least
to my not-a-lawyer reading, to be inseparable s.t. if on
applies, the other does too.  If people think that is wrong,
this type of document is not an appropriate (or even plausible)
place to fix it.

    john

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 09 Sep 2011 18:02:09 -0400

There seem to be at least two different dimensions here, probably more.
On the one hand, when I discuss with someone (in an airport, hotel, 
whatever) an idea for a protocol behavior, that does not consistute 
permission for them to submit an I-D (with or without my name on it) 
with thewords I speak to them.  if I send them an Email privately, not 
as part of a WG or design team effort, then no, I hav enot given them 
the right to use my words.

On the other hand, my personal feeling about such a conversation when I 
have had them and there were patent issues, I did feel it was incumbent 
upon me to say "I have filed for some relevant patents in this space." 
No, I do not have to file a formal disclosure with the IETF.  But it 
would be misleading not to mention that IPR issues exist.

Yours,
Joel

On 9/9/2011 5:55 PM, John C Klensin wrote:
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art
>

---

From: John C Klensin <[email-masked]>
Date: Fri, 09 Sep 2011 18:15:34 -0400

--On Friday, September 09, 2011 18:02 -0400 "Joel M. Halpern"
<[email-masked]> wrote:

> On the one hand, when I discuss with someone (in an airport,
> hotel, whatever) an idea for a protocol behavior, that does
> not consistute permission for them to submit an I-D (with or
> without my name on it) with thewords I speak to them.  if I
> send them an Email privately, not as part of a WG or design
> team effort, then no, I hav enot given them the right to use
> my words.
> 
> On the other hand, my personal feeling about such a
> conversation when I have had them and there were patent
> issues, I did feel it was incumbent upon me to say "I have
> filed for some relevant patents in this space." No, I do not
> have to file a formal disclosure with the IETF.  But it would
> be misleading not to mention that IPR issues exist.

If your second conversation is followed by either one of you
submitting anything to the IETF, getting involved with a
discussion on an IETF mailing list, then I think there is a
formal disclosure requirement.  If you think that is the
dividing line, then we pretty much agree.

However, my understanding today is that the "contribution" rules
and the "disclosure" rules set in at exactly the same point.  If
we, or others, want to set up two separate thresholds (as I
think your analysis implies), then someone needs to start
writing proposals.

    john

---

From: Barry Leiba <[email-masked]>
Date: Fri, 9 Sep 2011 19:16:50 -0400

> I don't like it.

I suspect we're more in agreement than not.  Any group that wants to
hold a meeting that's during the IETF week seems free to do this under
whatever rules they like.  The IETF can apply its rules when it's
asked to get involved.  So if we want to say that, for example, any of
the following things can only happen if the meeting is covered by BCP
78, then we can certainly say that:
* IETF leadership is asked to get involved.
* IETF meeting rooms are used.
* The organizers want to announce the side meeting in an IETF session.

But, realistically, we can't demand that a group of organizers abide
by BCP 78 just because they hold a meeting during the IETF week and
don't put bouncers at the door barring entry to the uninvited.  If
they want to spread the word by mouth and get 100 people there on
Wednesday evening in the lobby lounge or in a private room at a local
restaurant, I don't see that we can tell them what to do.

But we can, and should, make them aware of what people's expectations
will be, urge them to apply BCP 78, urge them to announce whatever
rules they are applying, and urge those who might attend to hold them
to such disclosure (and perhaps vote with their feet if they don't
like the terms).  And that's what I think Ben and I are saying.

Of course, this is all from people who are not part of the IETF's
legal counsel, and said counsel certainly has the real say in this.  I
would like to see them weigh in publicly, to eliminate speculation
from us dilettantes.

Barry