Subject: Re: [Gen-art] Note Well applicability to bar BOFs

From: Lars Eggert <[email-masked]>
Date: Fri, 9 Sep 2011 19:03:03 +0300

Hi, Jorge,

related to the ID on side meetings during the IETF week, during the gen-art review of this draft, Ben had the following question, and Spencer followed it up:

Ben said:
> -- Section 6 suggests side meetings should be (somehow "informally") covered by NOTE WELL. I think this is a very dangerous suggestion. The rest of the document suggests that a side meeting has no official standing. That seems to me to mean it's no different than a group of people who coincidentally participate in the IETF having a dinner or bar meeting on any subject at any time. Or a hallway conversation, for that matter. By the logic of this section, I can't really figure out how "informal" a meeting would need to be before it no longer fell under NOTE WELL.
> 
> In an informal meeting, the participants should be able to follow any IPR policy they like. I can even imagine an informal meeting covered by an NDA, where the participants want to decide if they want to have further discussions of a subject under IETSF IPR rules or not.
> 
> I think the best we can hope to do is suggest that side meeting organizers and participants be explicit with their expectations on IPR and confidentiality, so there is less chance for down-stream surprises. If we want something stronger than that, then we really need to create a new category of "official" meeting.

Spencer said:
> For what it's worth, I have the same question as Ben - if this guidance applies to the kinds of informal meetings in restaurants and bars that the IESG is encouraging, even if they aren't publicized and aren't open to the community, is there any way for two or more IETF participants to talk to each other, that's NOT under NOTE WELL?
> 
> I think it DOES make sense to say that the kinds of informal meetings the IESG is discouraging - in IETF meeting rooms, with agendas, mailing lists, presentations, attendee lists, and minutes - should include NOTE WELL notifications.
> 
> But if I was sitting next to Adam Roach on a plane headed for the IETF (which has happened before) when he was editor of GIN and I was chair of MARTINI (this last part did not), and we started talking about proposed changes to the GIN draft, is that covered?

Could you propose a rephrasing of the original text (see below) that would clarify the issues they have raised?

Thanks,
Lars

On 2011-2-28, at 19:33, Jorge Contreras wrote:
> Gonzalo -- thanks for the document context.  Here's my suggestion for
> Section 6:
> 
> "6.  Applicability of IPR Rules
> 
> The IETF's rules regarding intellectual property are set out in BCP 78 and
> 79.  Among other things, these rules provide that any "Contribution" to the
> "IETF Standards Process" (each as defined in the rules themselves) is
> licensed to the IETF Trust for the IETF's use in developing standards, and
> also requires disclosure of related patents and patent applications.  A
> "Contribution" is "any submission to the IETF intended by the Contributor
> for publication as all or part of an Internet-Draft or RFC and any statement
> made within the context of an IETF activity".  Thus, the fact that a
> Contribution is made at one of the BOFs or other "unofficial" or
> "semi-official" events described in this document does not change or limit
> the applicability of the IETF's IPR rules.   If you have a question
> regarding the applicability of the IETF IPR rules in any specific context or
> to any specific activity, you should consult your attorney or make an
> inquiry to the IESG."
> 
> Regards,
> Jorge

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 9 Sep 2011 17:34:51 +0100

I will strongly oppose the application of Note Well to bar BoFs. Bar BoFs are
(IMHO) outside the IETF process and do not constitute any part of it.

That we gently encourage people to have meetings in bars, restaurants, hotel
bedrooms, or saunas does not make them any more part of the IETF process.

When I talk to my friend in the corridor of an IETF gathering I am not covered
by the IPR rules. When I go to the bar and find I am redesigning IPv6 (again) I
am not covered by the IPR rules.

This is a Bad Idea. Please stop it!

Cheers,
Adrian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Lars
> Eggert
> Sent: 09 September 2011 17:03
> To: Jorge Contreras
> Cc: [email-masked]; [email-masked]
Review
> Team; IESG; Spencer Dawkins; Scott O. Bradner
> Subject: Re: Note Well applicability to bar BOFs
> 
> Hi, Jorge,
> 
> related to the ID on side meetings during the IETF week, during the gen-art
> review of this draft, Ben had the following question, and Spencer followed it
up:
> 
> Ben said:
> > -- Section 6 suggests side meetings should be (somehow "informally") covered
> by NOTE WELL. I think this is a very dangerous suggestion. The rest of the
> document suggests that a side meeting has no official standing. That seems to
me
> to mean it's no different than a group of people who coincidentally
participate in
> the IETF having a dinner or bar meeting on any subject at any time. Or a
hallway
> conversation, for that matter. By the logic of this section, I can't really
figure out
> how "informal" a meeting would need to be before it no longer fell under NOTE
> WELL.
> >
> > In an informal meeting, the participants should be able to follow any IPR
policy
> they like. I can even imagine an informal meeting covered by an NDA, where the
> participants want to decide if they want to have further discussions of a
subject
> under IETSF IPR rules or not.
> >
> > I think the best we can hope to do is suggest that side meeting organizers
and
> participants be explicit with their expectations on IPR and confidentiality,
so there
> is less chance for down-stream surprises. If we want something stronger than
> that, then we really need to create a new category of "official" meeting.
> 
> Spencer said:
> > For what it's worth, I have the same question as Ben - if this guidance
applies to
> the kinds of informal meetings in restaurants and bars that the IESG is
> encouraging, even if they aren't publicized and aren't open to the community,
is
> there any way for two or more IETF participants to talk to each other, that's
NOT
> under NOTE WELL?
> >
> > I think it DOES make sense to say that the kinds of informal meetings the
IESG is
> discouraging - in IETF meeting rooms, with agendas, mailing lists,
presentations,
> attendee lists, and minutes - should include NOTE WELL notifications.
> >
> > But if I was sitting next to Adam Roach on a plane headed for the IETF
(which
> has happened before) when he was editor of GIN and I was chair of MARTINI
> (this last part did not), and we started talking about proposed changes to the
GIN
> draft, is that covered?
> 
> Could you propose a rephrasing of the original text (see below) that would
clarify
> the issues they have raised?
> 
> Thanks,
> Lars
> 
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 09 Sep 2011 10:39:26 -0600

> am not covered by the IPR rules.

Actually, when you as an AD talk to your friend, doesn't Note Well
apply? Unless by "The IESG, or any member thereof on behalf of the IESG"
we understand that you're not always speaking "on behalf of the IESG"
(which would be a reasonable interpretation, IMHO).

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: <[email-masked]>
Date: Fri, 9 Sep 2011 12:58:10 -0400

I would argue that if the IETF has allocated an IETF meeting room during an IETF meeting week for a Bar BOF, then the Note Well should apply to that Bar BOF courtesy of the IETF's involvement (i.e., the multiple occurrences of "IETF" in this sentence).

Such a policy might also serve as a useful source of backpressure to the increasing number of Bar BOFs that are asking for IETF meeting rooms.

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
> Sent: Friday, September 09, 2011 12:39 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; 'Jorge Contreras'; 'Scott O.
> Bradner'; 'IESG'; 'Lars Eggert'
> Subject: Re: [Gen-art] Note Well applicability to bar BOFs
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 9 Sep 2011 18:58:33 +0100

> (which would be a reasonable interpretation, IMHO).

You mean, I hope, "when I talk as an AD to my friend".

Otherwise I am going to have to be very careful when I talk to my wife.

I wonder if Note Well applies to IESG breakfast? I have a patent on a way of eating eggs while reporting on hot spots. I am prepared to license it, but will not grant free use (unless someone has a patent on eating pain au chocloat while drinking coffee and reading email that they want to exchange with me).

A

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 9 Sep 2011 18:58:33 +0100

The IESG does not (any more, and in general) allocate meeting rooms for bar
BoFs.

But you may be right that if it does then the Note Well could be made to apply.

A

> From: [email-masked] [mailto:[email-masked]]
> Sent: 09 September 2011 17:58
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [Gen-art] Note Well applicability to bar BOFs
> 
> I would argue that if the IETF has allocated an IETF meeting room during an
IETF
> meeting week for a Bar BOF, then the Note Well should apply to that Bar BOF
> courtesy of the IETF's involvement (i.e., the multiple occurrences of "IETF"
in this
> sentence).
> 
> Such a policy might also serve as a useful source of backpressure to the
increasing
> number of Bar BOFs that are asking for IETF meeting rooms.
> 
> Thanks,
> --David
> > Cc: [email-masked]; [email-masked];
'Jorge
> Contreras'; 'Scott O.

---

From: Lars Eggert <[email-masked]>
Date: Fri, 16 Sep 2011 16:32:22 +0300

Hi, Jorge,

I haven't seen a response from you yet?

Thanks,
Lars