Subject: [Gen-art] Gen-ART review of draft-ietf-ccamp-attribute-bnf-02

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 17 Oct 2011 16:18:26 -0500

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-ccamp-attribute-bnf-02
Reviewer: Vijay K. Gurbani
Review Date: Oct-17-2011
IETF LC End Date: Not known.
IESG Telechat date: Oct-20-2011

Summary: This draft is ready as a Proposed Standard.

Major issues: 0
Minor issues: 2
Nits/editorial comments: 3

Minor:
* S2: In the phrase, "... implementations must be capable ..."
  is this a normative MUST?

* S3: In the phrase, "... implementations must be capable ..."
  is this a normative MUST?

Nits:
* Abstract: s/how LSP attribute are/how LSP attributes are/

* S1: "Two LSP Attributes related objects ..." --- This reads
  funny.  Did you mean "Two LSP Attribute related objects..."?
  This oversight, if indeed it is an oversight, is repeated else-
  where in the document as well.

  At other places (e.g., S3.2.1), you simply use "LSP Attribute object".
  So I am not sure which one is correct.

* S2.1: s/LSP attributed related objects/LSP attributes related objects/
   or maybe "LSP Attribute related objects"?

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Lou Berger <[email-masked]>
Date: Tue, 18 Oct 2011 17:56:13 -0400

Vijay,

Please see below.

>   is this a normative MUST?

These are both in text quoted from RFC5420, so the comment applies to
that RFC.  Clearly we can't change it in this document. (BTW usage of
'must' as in the English/informative usage is still legitimate.)

> * Abstract: s/how LSP attribute are/how LSP attributes are/

"LSP Attributes" is a term/name defined in RFC5420.

This does point out that in three places in the document, the following
is needed:
 s/LSP attributes/LSP Attributes

>   So I am not sure which one is correct.

good catch!  it should be:
s/LSP Attribute/LSP Attributes

>    or maybe "LSP Attribute related objects"?

another good catch:
 s/LSP attributed/LSP Attributes
> - vijay

Much thanks!

Lou

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 18 Oct 2011 18:38:39 -0500

On 10/18/2011 04:56 PM, Lou Berger wrote:
> These are both in text quoted from RFC5420, so the comment applies
> to that RFC.  Clearly we can't change it in this document.

Lou: Sure, that is understandable.

> (BTW usage of 'must' as in the English/informative usage is still
> legitimate.)

Indeed, however, the lower-case 'must' appeared in a cluster
containing other upper case (and normative) language, so I
just wanted to point it out in case this was an oversight.

> s/LSP Attribute/LSP Attributes
[...]
> s/LSP attributed/LSP Attributes

No problem.  Thank you for attending to my comments!

- vijay