Subject: [Gen-art] Gen-ART Telechat review: draft-ietf-tls-dtls-heartbeat-03.txt

From: Mary Barnes <[email-masked]>
Date: Fri, 28 Oct 2011 10:56:02 -0500

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/**area/gen/trac/wiki/GenArtfaq<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>
>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document: draft-ietf-tls-dtls-heartbeat-03.txt
Reviewer:  Mary Barnes
Review Date:  28 Oct 2011
IETF LC Date:  18 Oct 2011
IESG Telechat Date:  3 Nov 2011

Summary:  Ready with editorial comments

Editorial:

1) Section 2 (1st P, last sentence).  The following sentence needs some work
(there's a missing noun before the SHOULD) - I suggest something like the
following:
OLD:
If an endpoint has indicated peer_not_allowed_to_send and receives a
HeartbeatRequest message SHOULD drop the message silently and MAY
send an unexpected_message Alert message.

NEW:
If an endpoint that has indicated peer_not_allowed_to_send receives a
HeartbeatRequest message, the endpoint SHOULD drop the message silently and
MAY send an unexpected_message Alert message.

2) Section 3: Should the "has to be" in this sentence be a MUST?
   Whenever a HeartbeatRequest message is
   received, it has to be answered with a corresponding
   HeartbeatResponse message.

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 28 Oct 2011 18:12:14 +0200

Mary,

thank you very much for the review.
See my comments in-line.

Best regards
Michael

On Oct 28, 2011, at 5:56 PM, Mary Barnes wrote:

> < http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> 
> 1) Section 2 (1st P, last sentence).  The following sentence needs some work (there's a missing noun before the SHOULD) - I suggest something like the following:
> OLD:
> If an endpoint that has indicated peer_not_allowed_to_send receives a HeartbeatRequest message, the endpoint SHOULD drop the message silently and MAY send an unexpected_message Alert message.
I agree. I made the change in our CVS version, so the change will be
included in the next revision.
>    HeartbeatResponse message.
I think SHOULD is better since the next sentences describe exceptions.
I changed it to SHOULD in CVS. If this change is not OK for you,
please let me know.

Again: Thank you very much for the comments.

---

From: Mary Barnes <[email-masked]>
Date: Fri, 28 Oct 2011 11:15:52 -0500

Michael,

One response inline below [MB].

Thanks,
Mary.

On Fri, Oct 28, 2011 at 11:12 AM, Michael Tuexen <[email-masked]>wrote:

> > 1) Section 2 (1st P, last sentence).  The following sentence needs some
> work (there's a missing noun before the SHOULD) - I suggest something like
> the following:
> > OLD:
[MB] I think SHOULD is fine. [/MB]