Subject: Re: [Gen-art] Fwd: Russ Housley's Discuss on draft-ietf-storm-mpa-peer-connect-07:(with DISCUSS)

From: Elwyn Davies <[email-masked]>
Date: Wed, 28 Dec 2011 14:10:32 +0000

Hi, Russ.

I hope you have had a good Christmas break.

I responded to David Black's previous query about this on December 14
(see attached, copied to you at the time).  However...

I have just had a look at the -09 version provoked by David Harrington's
comments.  I think I may have been a little premature in signing off on
that version as the RTR frame discussion did still need improvement.
Verion -09 definitely fixes that issue IMO.  However, I think that the
note added to the end of Section 10 regarding the addition of further
'not-so-private' data perhaps needs another sentence about ordering, as
per my and David's comments.

Apart from that, I believe we are all done here - I have also reviewed
the IANA registries draft in the last couple of days.

Best wishes for the New Year.

Regards,
Elwyn

On Fri, 2011-12-23 at 13:17 -0500, Russ Housley wrote:
> Elwyn:
> 
> 
> Have your concerns been addressed.
> 
> 
> Russ
> 
> = = = = = = = = 
> 
> Discuss (2011-09-30) 
> 
> The Gen-ART Review by Elwyn Davies on 26-Sept-2011 raises some
>   concerns that deserve a response.  Please find the review at
>   http://www.ietf.org/mail-archive/web/gen-art/current/msg06754.html.
> 
> 
> 
> Begin forwarded message:
> 
> > From: "David Harrington" <[email-masked]>
> > 
> > Date: December 22, 2011 7:12:31 PM EST
> > 
> > To: "'Russ Housley'" <[email-masked]>
> > 
> > Subject: RE: Russ Housley's Discuss on
> > draft-ietf-storm-mpa-peer-connect-07:(with DISCUSS)
> > 
> > 
> > Hi Russ,
> >  
> > Can you check your DISCUSS on draft-ietf-storm-mpa-peer-connect?
> > I believe we have addressed all of Elwyn's concerns.
> > http://www.ietf.org/mail-archive/web/gen-art/current/msg06754.html.
> >  
> > Thanks, and have a Merry Christmas!
> > David Harrington
> > Director, IETF Transport Area
> > [email-masked] (preferred for ietf)
> > [email-masked]
> > +1 603 828 1401 (cell) 
> > 
> > 
> 
> 

Subject: Re: FW: Russ Housley's Discuss on draft-ietf-storm-mpa-peer-connect-07: (with DISCUSS)
From: Elwyn Davies <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked], [email-masked]
Date: Wed, 14 Dec 2011 00:36:23 +0000

Hi.

Yes, I believe that all is well now (with version -08 and the new
registries draft).  I think Russ can remove his DISCUSS as the
registries issue has been fixed.

It is possible that I failed to respond to a previous mail reporting the
fixes.  Since it isn't on the telechat agenda yet, I haven't been kicked
to rereview it although I did look at the new version a while ago.

Apologies for any holdup.

Regards,
Elwyn

On Tue, 2011-12-13 at 09:13 -0500, [email-masked] wrote:
> Elwyn,
> 
>  
> 
> Could you please take a look at the -08 version of
> draft-ietf-storm-mpa-peer-connect and let me know how much of your
> Gen-ART review comments have been addressed to your satisfaction.  If
> you’ve done this already, and I missed it, I apologize.
> 
>  
> 
> This is a bit peculiar, as I think Russ is holding a Discuss primarily
> on the need for the registries (the draft that creates the necessary
> registries is currently in IETF Last Call), but my AD (Dave
> Harrington) just requested a new version of the mpa-peer-connect draft
> based on your review?
> 
>  
> 
> Thanks,
> --David
> 
>  
> 
> From: arkady kanevsky [mailto:[email-masked]] 
> Sent: Friday, October 21, 2011 11:48 PM
> To: Russ Housley
> Cc: The IESG; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: Russ Housley's Discuss on
> draft-ietf-storm-mpa-peer-connect-07: (with DISCUSS)
> 
> 
>  
> 
> Russ and Elwyn,
> Thank you very much for very careful review.
> The updated document
> http://www.ietf.org/internet-drafts/draft-ietf-storm-mpa-peer-connect-08.txt addresses the comments and minor issues.
> 
> The biggest changes are complete rewrite of IANA consideration section
> with reference to new IANA RDDP document and related cleanup in the
> document, and addition of
> of a paragraph to Interoperability section:
> 
> A note for a potential future enhancements for connection
>    establishment negotiation: It is possible to further extend
>    formatting of private data of the MPA Request and Reply frames and
> to
>    use other bits from "Res" field to indicate that private data
>    formatting.
> 
> Again, thank you very much for your comments and recommendations.
> Arkady
> 
> On Fri, Sep 30, 2011 at 4:05 PM, Russ Housley <[email-masked]>
> wrote:
> 
> Russ Housley has entered the following ballot position for
> draft-ietf-storm-mpa-peer-connect-07: Discuss
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut
> this
> introductory paragraph, however.)
> 
> Please refer to
> http://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> 
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
> 
> 
>  The Gen-ART Review by Elwyn Davies on 26-Sept-2011 raises some
>  concerns that deserve a response.  Please find the review at
>  http://www.ietf.org/mail-archive/web/gen-art/current/msg06754.html.
> 
> 
> 
> 
> 
> 
> 
> 
> 
> -- 
> Cheers,
> Arkady Kanevsky
> 
>

---

From: <[email-masked]>
Date: Wed, 28 Dec 2011 10:44:33 -0500

Hi Elwyn,

Thanks for following up on this.  Regarding ordering of private data:

> However, I think that the

The text at the end of Section 10 is about possible future protocol enhancements -
e.g., if one or more of the Res (currently reserved) bits in the MPA header are
used to define future standard elements that are carried in the MPA "Private Data"
field (as was done in this draft for enhanced connection establishment data.  I
would prefer to defer any specification of ordering of future data additions to
the document that defines those additions.

For the current mpa-peer-connect draft, I believe the private data ordering
requirements are covered and clear - the enhanced RDMA connection establishment
data MUST come first.  Section 6 covers the MPA/TCP case;

   Private Data:  Unchanged from [RFC5044].  However, if the 'S' flag is
      set, Private Data MUST begin with enhanced RDMA connection
      establishment data (see Section 9).

The 'S' flag is the presence/absence flag for enhanced RDMA connection
establishment data, If the 'S' flag is clear, there's no enhanced RDMA
connection establishment data, and hence no ordering concern.

Section 7 covers the SCTP case (end of this paragraph):

   The Enhanced DDP stream session establishment follows the same rules
   as the standard DDP stream session establishment as defined in
   [RFC5043].  ULP-supplied Private Data MUST be included for Enhanced
   DDP Stream Session Initiate, Enhanced DDP Stream Session Accept, and
   Enhanced DDP Stream Session Reject messages, and MUST follow the
   enhanced RDMA connection establishment data in the DDP Stream Session
   Initiate and the Enhanced DDP Stream Session Accept messages.

Aside from enhanced RDMA connection establishment data, the only other data
that can be carried as Private Data is "ULP-supplied Private Data".

Thanks,
--David

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Elwyn Davies
> Sent: Wednesday, December 28, 2011 9:11 AM
> To: Russ Housley
> Cc: [email-masked]; General Area Review Team
> Subject: Re: [Gen-art] Fwd: Russ Housley's Discuss on draft-ietf-storm-mpa-peer-connect-07:(with
> DISCUSS)
> 
> Hi, Russ.
>

---

From: Elwyn Davies <[email-masked]>
Date: Thu, 29 Dec 2011 01:16:59 +0000

Hi, David.

I was thinking of adding to the note in s10 something like:
  
  If in future several of the "Res" field bits are in use, care must be
  taken to specify the layout of the private data area so that the
  correct data is associated with each option whichever combination of
  bits are set.

However, I supose this is really motherhood and apple pie.  I'll live
with what is there at the moment if you feel this is just too obvious.

Regards,
Elwyn

---

From: <[email-masked]>
Date: Wed, 28 Dec 2011 20:39:28 -0500

Hi Elwyn,

Yes, I do think that's reasonably obvious, e.g., as I'd expect a Gen-ART reviewer to flag that issue if it wasn't clear in a future specification ;-).  In addition, the proposed text does not allow for possible future uses of the Res bits that do not involve adding data to the Private Data area.

Thanks, --David +++ Sent from BlackBerry +++

----- Original Message -----
From: Elwyn Davies [mailto:[email-masked]]
Sent: Wednesday, December 28, 2011 08:16 PM
To: Black, David
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: RE: [Gen-art] Fwd: Russ Housley's Discuss on draft-ietf-storm-mpa-peer-connect-07:(with DISCUSS)

Hi, David.

Regards,
Elwyn

---

From: Elwyn Davies <[email-masked]>
Date: Thu, 29 Dec 2011 11:15:16 +0000

Hi, David.

OK.  Let's leave this up to David since he had a view on this also - not
sure if I have seen any responses to -09 from him.

Happy New Year.

Elwyn