Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-pwe3-mpls-tp-cv-adv-03

From: Meral Shirazipour <[email-masked]>
Date: Thu, 2 Jan 2014 21:55:37 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq .

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-ietf-pwe3-mpls-tp-cv-adv-03
Reviewer: Meral Shirazipour
Review Date: 2014-01-02
IETF LC End Date:  2014-01-16
IESG Telechat date: NA

Summary:
This draft is ready to be published as Standards Track RFC but I have some editorial comments (mostly nits).

Nits/editorial comments:
Nits:
-[Page 3] Introduction, line 4, "PW s"--extra space-->"PWs".

-[Page 3] Section 2, "types of CV been defined"--missing have-->"types of CV have been defined"

-[Page 4] Section 2.1 "It it isrecommended"--extra it and no space--->"It is recommended"

-[Page 4] Section 2.1, this statement is repeated twice, another time on the sentence above it:
"The Reserved field must be set to zeroes on transmit and ignored on receive.
"
-[Page 4], Table 1 "Signalling"--for consistency with the rest of the occurrences-->"Signaling"

-[Page 5], Section 2.4 "advertized"--more common-->"advertised"

-[Page 5], Section 2.4 missing "a" and "are":

old:
"and common set of proactive CV types advertized"

new:
"and a common set of proactive CV types are advertised"

-[Page 5], Section 2.4 missing "are" and "the"

old:
"
If multiple MPLS-TP CV types advertised by both PEs, then following list sorted in
descending priority order is used:
"
new:
"
If multiple MPLS-TP CV types are advertised by both PEs, then the following list sorted in
descending priority order is used:
"

General suggestion:
-
In the abstract something is missing to make it more suitable for standard track. Right now it only says "this document specifies how use of ABC affects XYZ".
Examples (to inspire from), Section 1 and 2 mention:

"
This document specifies how signaling
and selection processes are modified to ensure backward compatibility
and allow use of proactive CV-CC-RDI over MPLS-TP PWs.
"

and

"
This document introduces four
new CV types and, to accommodate them, a new VCCV Extended CV
parameter for PW Interface Parameters Sub-TLV is defined.
"

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research
www.ericsson.com

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 2 Jan 2014 22:56:20 +0000

Dear Meral,
many thanks for your kind consideration and thoughtful suggestions. I've updated text accordingly with exception of only one. Please check proposed minor changes below. Please let me know if you agree.

                Regards,
                                Greg

[...]

old:

new:
"and a common set of proactive CV types are advertised"
GIM>> "and a common set of proactive CV types that are advertised ..."

General suggestion:
-

"
This document specifies how signaling
and selection processes are modified to ensure backward compatibility
and allow use of proactive CV-CC-RDI over MPLS-TP PWs.
"
GIM>>
"This document specifies how signaling and selection processes for Pseudowire (PW) Virtual Circuit Connectivity Verification (VCCV) are modified to ensure backward compatibility and allow use of proactive Connectivity Verification (CV), Continuity Check (CC), and Remote Defect Indication (RDI) over MPLS Transport Profile (MPLS-TP) PWs."
and

"

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research
www.ericsson.com<http://www.ericsson.com>

---

From: Meral Shirazipour <[email-masked]>
Date: Fri, 3 Jan 2014 00:01:02 +0000

Hi Greg,
   Thank you for considering, it looks very good to me.

Best,
Meral

From: Gregory Mirsky
Sent: Thursday, January 02, 2014 2:56 PM
To: Meral Shirazipour; [email-masked]
Subject: RE: Gen-ART Last Call review of draft-ietf-pwe3-mpls-tp-cv-adv-03

Dear Meral,

                Regards,
                                Greg

[...]

old:

new:

General suggestion:
-

"

"

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 3 Jan 2014 00:08:14 +0000

Hi Meral,
just published the updated version.

                Kind regards,
                                Greg

From: Meral Shirazipour
Sent: Thursday, January 02, 2014 4:01 PM
To: Gregory Mirsky
Cc: [email-masked]
Subject: RE: Gen-ART Last Call review of draft-ietf-pwe3-mpls-tp-cv-adv-03

Hi Greg,

Best,
Meral

From: Gregory Mirsky
Sent: Thursday, January 02, 2014 2:56 PM
To: Meral Shirazipour; [email-masked]<mailto:[email-masked]>
Subject: RE: Gen-ART Last Call review of draft-ietf-pwe3-mpls-tp-cv-adv-03

Dear Meral,

                Regards,
                                Greg

[...]

old:

new:

General suggestion:
-

"

"

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research

Subject: New Version Notification - draft-ietf-pwe3-mpls-tp-cv-adv-04.txt
From: "[email-masked]" <[email-masked]>
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Date: Fri, 3 Jan 2014 00:06:57 +0000
List-Id: <[email-masked]>

A new version (-04) has been submitted for draft-ietf-pwe3-mpls-tp-cv-adv:
http://www.ietf.org/internet-drafts/draft-ietf-pwe3-mpls-tp-cv-adv-04.txt

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-ietf-pwe3-mpls-tp-cv-adv/

Diff from previous version:
http://www.ietf.org/rfcdiff?url2=draft-ietf-pwe3-mpls-tp-cv-adv-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

IETF Secretariat.

---

From: Meral Shirazipour <[email-masked]>
Date: Fri, 3 Jan 2014 17:44:24 +0000

Hi,
  Many thanks, looks great.

Best,
Meral

From: Gregory Mirsky
Sent: Thursday, January 02, 2014 4:08 PM
To: Meral Shirazipour
Cc: [email-masked]
Subject: RE: Gen-ART Last Call review of draft-ietf-pwe3-mpls-tp-cv-adv-03

Hi Meral,

                Kind regards,
                                Greg

From: Meral Shirazipour
Sent: Thursday, January 02, 2014 4:01 PM
To: Gregory Mirsky
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: Gen-ART Last Call review of draft-ietf-pwe3-mpls-tp-cv-adv-03

Hi Greg,

Best,
Meral

From: Gregory Mirsky

Dear Meral,

                Regards,
                                Greg

[...]

old:

new:

General suggestion:
-

"

"

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 3 Jan 2014 14:04:54 -0500

Meral,

Thanks for the review!

Greg,

It looks like most, but not all, of these comments were already caught
in -04. This is really up to Stewart, but IMHO, the remaining comments
can go in instructions to the RFC Editor, or wait for a revision
triggered by further IESG or IETF-wide review.

Cheers,
Andy

On Thu, Jan 2, 2014 at 4:55 PM, Meral Shirazipour
<[email-masked]> wrote:
> I am the assigned Gen-ART reviewer for this draft. For background on
> Gen-ART, please see the FAQ at
> http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq .
>
>
>
> In the abstract something is missing to make it more suitable for standard
> track. Right now it only says "this document specifies how use of ABC
> affects XYZ".
>