Subject: Re: [Gen-art] Gen-ART Telechat review of draft-ietf-avtcore-rtp-security-options-09.txt

From: Colin Perkins <[email-masked]>
Date: Sun, 12 Jan 2014 19:33:11 +0000

Hi,

Thanks, I incorporated changes to address these. For Section 2.1, I changed “protecting the RTP session and its RTP and RTCP traffic and the key-management protocol becomes important in which security statements one can do” to “protecting the RTP session (and hence the RTP and RTCP traffic) and the key-management protocol becomes important to determine what security claims can be made”. Hopefully this is clearer.

Cheers,
Colin

On 17 Dec 2013, at 07:25, Magnus Westerlund <[email-masked]> wrote:
> Thanks Suresh,
> 
> We will take your comment into account when we do the next revision.
> 
> Cheers
> 
> Magnus
> 
> On 2013-12-17 06:23, Suresh Krishnan wrote:
>> I have been selected as the General Area Review Team (Gen-ART) reviewer
>> for this draft (for background on Gen-ART, please see
>> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
>> 
>> Please wait for direction from your document shepherd or AD before
>> posting a new version of the draft.
>> 
>> Document: draft-ietf-avtcore-rtp-security-options-09.txt
>> Reviewer: Suresh Krishnan
>> Review Date: 2013/12/16
>> IESG Telechat date: 2013/12/19
>> 
>> Summary: This draft is ready for publication as an Informational RFC but
>> I do have a few comments that the authors may wish to consider.
>> 
>> Minor
>> =====
>> 
>> * Section 1
>> 
>> This sentence is a bit awkward
>> 
>> The IETF considers it important that protocols implement, and makes
>> available to the user, secure modes of operation
>> 
>> Suggest rewording to something like
>> 
>> The IETF considers it important that protocols implement secure modes of
>> operation and make them available to users.
>> 
>> * Section 2.1
>> 
>> I am not sure what this statement means. Can you please clarify?
>> 
>> "Here the combination of the security protocol protecting the RTP
>> session and its RTP and RTCP traffic and the key-management protocol
>> becomes important in which security statements one can do."
>> 
>> * Section 4.1.4
>> 
>> s/will be more relevant then/will be more relevant than/
>> 
>> This sentence is hard to read. Please consider rewording
>> 
>> "Commonly by provisioning the verifier with the public part of a root
>> certificate, this enables the verifier to verify a trust chain from the
>> root certificate down to the identity certificate."
>> 
>> 
>> Thanks
>> Suresh
>> 
>> 
> 
> 
> -- 
> 
> Magnus Westerlund
> 
> ----------------------------------------------------------------------
> Multimedia Technologies, Ericsson Research EAB/TVM
> ----------------------------------------------------------------------
> Ericsson AB                | Phone  +46 10 7148287
> Färögatan 6                | Mobile +46 73 0949079
> SE-164 80 Stockholm, Sweden| mailto: [email-masked]
> ----------------------------------------------------------------------
> 

-- 
Colin Perkins
http://csperkins.org/

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 14 Jan 2014 18:19:23 -0500

Hi Colin,
   Thanks for making the changes. I will look at the next rev when you 
publish it.

Thanks
Suresh

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 15 Jan 2014 09:55:23 +0100

>   Thanks for making the changes. I will look at the next rev when you

Thanks,

I will submit the revision now.

Cheers

Magnus

>> Thanks, I incorporated changes to address these. For Section 2.1, I
>> changed “protecting the RTP session and its RTP and RTCP traffic and
>> the key-management protocol becomes important in which security
>> statements one can do” to “protecting the RTP session (and hence the
>> RTP and RTCP traffic) and the key-management protocol becomes
>> important to determine what security claims can be made”. Hopefully
>> this is clearer.
>>
>> Cheers,
>> Colin
>>
>>

-- 

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------