Subject: [Gen-art] Gen-ART review of draft-ietf-rtcweb-data-channel-12

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 29 Oct 2014 15:15:48 -0500

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-rtcweb-data-channel-12
Reviewer: Vijay K. Gurbani
Review Date: Oct-29-2014
IETF LC End Date: Oct-23-2014
IESG Telechat date: Oct-30-2014

This document is ready as a Proposed Standard.

Major: 0
Minor: 1
Nits: 1

Minor: 1
- S3.1, U-C 1: Why is it important to specify tha "there may be no
  SRTP media channels, or all SRTP media channels may be inactive"?
  It seems to me that all you care about is data channels, not
  media channels.  As such, retaining the last phrase ("there may also
  be reliable data channels in use") suffices, no?

  (Same comment for S3.2, U-C 3).
  (Same comment for S4, Req. 1.  This makes me wonder if I am missing
   something germane here with respect to you listing the availability
   or unavailability of SRTP media streams/channels.  If so, please
   let me know.)

Editorial nits:
- S6.4, opening paragraph:
    s/One strong wish is/It is advantageous/

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: Jari Arkko <[email-masked]>
Date: Thu, 30 Oct 2014 13:02:36 +0200

Thanks for the review, Vijay. Authors/shepherds, do you have any responses to Vijay’s question below?

Jari

On 29 Oct 2014, at 22:15, Vijay K. Gurbani <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 30 Oct 2014 13:15:50 +0100

>> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
Thank you very much for the review.
>> media channels.  As such, retaining the last phrase ("there may also
Right. However, we wanted to make sure that there is no assumption
on the number of concurrent RTP flows. There are scenarios where
you will have no concurrent flow, scenarios where you have some,
but they are inactive, and also scenarios where you have concurrent
active RTP flows.
>> be reliable data channels in use") suffices, no?
We wanted to make clear that they might be reliable channels in
parallel to unreliable ones.
>> s/channels.  If so, please
No, I don't think you are missing anything. We just wanted to stress the
point that there should be no hidden assumptions.
Side note: There was a point of time where you could not set up a 
peer connection in a browser implementation which did not had at
least one media channel...
>>  s/One strong wish is/It is advantageous/
Fixed.

Please let me know if the above addresses your comment.

Best regards
Michael

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 30 Oct 2014 07:39:51 -0500

> but they are inactive, and also scenarios where you have concurrent

Michael: Thanks for the clarification.

In that case, perhaps a blanket statement outlining the above assumption
may suffice.  Something like a sentence in the beginning of S3.1:

   "The use cases below do not make any assumptions on the presence (or
    absence) of SRTP media sessions, nor do they make any assumptions
    on the state (active, inactive) of the SRTP sessions (if present)."

I will let you edit it as you see fit if you think it is worth adding
it in.  If not, no worries.

Cheers,

- vijay