Subject: Re: [Gen-art] Gen-ART review of draft-ietf-jose-json-web-signature-33

From: Jari Arkko <[email-masked]>
Date: Wed, 1 Oct 2014 23:45:57 +0300

Thanks for your review and re-review, Russ.

Jari

---

From: Mike Jones <[email-masked]>
Date: Tue, 14 Oct 2014 12:43:16 +0000

These comments have been addressed in the -34 draft, other than the one about "why is TLS required to fetch digitally signed X.509 certificates".  There still seems to be working group discussion on that topic and objections have been expressed to changing the semantics.  More discussion is probably needed on that topic.

                                                            Thanks again,

                                                            -- Mike

From: jose [mailto:[email-masked]] On Behalf Of Mike Jones
Sent: Tuesday, September 30, 2014 11:11 AM
To: Russ Housley; [email-masked]
Cc: IETF Gen-ART; IETF; [email-masked]
Subject: Re: [jose] Gen-ART review of draft-ietf-jose-json-web-signature-33

Thanks again for your comments, Russ.  I'm adding the working group to the thread so they're aware of them.  Responses are inline below...

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Russ Housley
Sent: Saturday, September 27, 2014 8:32 AM
To: [email-masked]<mailto:[email-masked]>
Cc: IETF Gen-ART; IETF
Subject: Gen-ART review of draft-ietf-jose-json-web-signature-33

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-ietf-jose-json-web-signature-33

Reviewer: Russ Housley

Review Date: 2014-08-24

IETF LC End Date: 2014-09-03

IESG Telechat date: 2014-10-02

Summary:  Ready.  Some issues could be resolved to improve the document.

Thank you for addressing my comments on -31.

Major Concerns:

- None.

Minor Concerns:

- Section 10.5 should state that validation of a MAC means provides

  corroboration that the message was generated by one of the parties

  that knows the symmetric MAC key.  This could potentially be many

  parties.

OK

- In Section 4.1.4, should the value match the subject key identifier

  if an X.509 certificate is used?

No, it's not expected that these values would match.  For instance, if a JWK contains both bare public key representation of a key and an X.509 representation of the same key, then the "kid" would be expected to match the "kid" in the JWK, which is likely unrelated to the subject key identifier value in the X.509 certificate.  (There's nothing preventing particular applications from using the subject key identifier as the "kid" value, but it's not a requirement, or even necessarily recommended.)

Also note that that certificate thumbprints can be used as identifiers for X.509 certifications, rather than Key ID values - something that's already supported in the spec.

- In Section 4.1.5, why is TLS required to fetch digitally signed

  X.509 certificates?

This question was explicitly discussed by the working group at IETF 87.  The discussion is recorded in the minutes<http://www.ietf.org/proceedings/87/minutes/minutes-87-jose> as follows:

If there is an x5u pointing to a certification issued by a major CA, is TLS required for the HTTP query used to retrieve this certificate?  TLS shouldn't be needed since the certificate is a signed object.  Therefore, the "MUST" use TLS for cert retrieval should be changed to "SHOULD".  This is an application decision.  Mike Jones doesn't want removal of TLS in the case where there's no external means to verify the retrieved key.  Matt Miller: agrees with the jku case, but argues that for x5u, there is a class of applications where it isn't known if the retrieved object is self-protecting (like a certificate) until after it is retrieved.  Even if the object appears to be self-protecting, if the retriever doesn't have a trusted root for that object, it might not be able to verify the protection anyhow.  So it use of TLS might still be preferable instead of having to potentially retrieve an object twice, once over HTTP and then over HTTPS.  Joe Hildebrand wanted to know what the upside of this proposal is.  Richard says it saves on TLS handshakes; Hildebrand envisions a world where TLS is ubiquitous.  Paul Hoffman said that a similar issue in DANE ended up being dropped after a couple of months of discussion.  Richard agreed to drop the TLS MUST to SHOULD proposal.

Russ is certainly right that for certs that chain back to a known root of trust, integrity protection isn't necessary.  It's also the case that this is not true of all certificates that might be used - especially self-signed certificates intended only to carry a key value.  One possibility is to say that TLS MUST be used unless the certificate chains back to a known trust root accepted by the application.  Of course, just requiring TLS is simpler. Do people in the working group want to re-open this issue or are people content with the current requirements?

                                                            -- Mike