Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-weirds-rdap-query-15

From: Brian E Carpenter <[email-masked]>
Date: Mon, 20 Oct 2014 13:09:46 +1300

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-weirds-rdap-query-15.txt
Reviewer: Brian Carpenter
Review Date: 2014-10-20
IETF LC End Date: 2014-10-24
IESG Telechat date: 2014-10-30

Summary:   Almost ready
--------

Major Issues:
-------------

Section 3.1.1 says:

  "The restricted
   rules to write a text representation of an IPv6 address [RFC5952] are
   not mandatory."

Why not make 5952 at least a SHOULD? Personally, I would make it a MUST. As 5952 itself states,
the ambiguity of the RFC 4291 format creates many problems. 5952 in any case requires that
"all implementations must accept and be able to handle any legitimate RFC 4291 format",
so making conformance with 5952 a SHOULD or MUST won't break anything.

Minor issues:
-------------

Section 3.1.1 says:

  "However, the zone id [RFC4007] is not appropriate in
   this context and therefore prohibited."

Agreed, but you probably also need to exclude the extended URI syntax for this [RFC6874],
since your base reference is the URI syntax [RFC3986] which is updated by 6874.
This is just for clarification, since 6874 does not change the ABNF production
for IPv6address.

"10.2.  Informative References

   [REST]     Fielding, R. and R. Taylor, "Principled Design of the
              Modern Web Architecture", ACM Transactions on Internet
              Technology Vol. 2, No. 2, May 2002."

The text in section 1.1 implies that this is "a doctoral dissertation". It isn't.

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 20 Oct 2014 12:20:24 +0000

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Sunday, October 19, 2014 8:10 PM
> To: [email-masked]; General Area
> Review Team
> Subject: Gen-ART Last Call review of draft-ietf-weirds-rdap-query-15
> 

Thanks for the feedback, Brian. I've asked Andy to review the comments above since they refer to objects that are primarily used by address registries.

> The text in section 1.1 implies that this is "a doctoral dissertation".

Thanks for catching that. I can change the reference to this (used in RFC 7252):

[REST]     Fielding, R., "Architectural Styles and the Design of
           Network-based Software Architectures", Ph.D. Dissertation,
           University of California, Irvine, 2000,
           <http://www.ics.uci.edu/~fielding/pubs/dissertation/
           fielding_dissertation.pdf>.

Scott