Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-karp-isis-analysis-04

From: Brian E Carpenter <[email-masked]>
Date: Sat, 13 Jun 2015 14:36:49 +1200

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-karp-isis-analysis-04.txt
Reviewer: Brian Carpenter
Review Date: 2015-06-13
IETF LC End Date: 2015-07-03
IESG Telechat date:

Summary:  Almost ready
--------

Minor Issue:
------------

> 3.2.  Key Management Protocols

I don't like the references to expired drafts. These drafts almost have
the flavour of normative references, since apparently they described
recommended mitigation techniques. If they matter, they should be
properly available.

draft-weis-gdoi-mac-tek-03
draft-yeung-g-ikev2-08
draft-hartman-karp-mrkmp-05

---

From: Uma Chunduri <[email-masked]>
Date: Mon, 29 Jun 2015 18:19:39 +0000

Hi Brian,

Thanks for your review (apologies for the delay from my side). 
Response i-line [Uma]:

--
Uma C.

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Friday, June 12, 2015 7:37 PM
To: [email-masked]; General Area Review Team
Subject: Gen-ART Last Call review of draft-ietf-karp-isis-analysis-04

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you may receive.

Summary:  Almost ready
--------

Minor Issue:
------------

> 3.2.  Key Management Protocols

I don't like the references to expired drafts. These drafts almost have the flavour of normative references, since apparently they described recommended mitigation techniques. If they matter, they should be properly available.
draft-weis-gdoi-mac-tek-03
draft-yeung-g-ikev2-08
draft-hartman-karp-mrkmp-05

[Uma]:  Sure. But to give a bit context quickly -

KARP WG started working on group keying protocol based on IKEv2 when I used these references. But, later scope is changed and this aspect didn't go forward as expected. 
So I would remove the references to draft-yeung-g-ikev2-08 and draft-hartman-karp-mrkmp-05.  However, though expired, I would like to keep the reference for
 draft-weis-gdoi-mac-tek-03 and  associated RFC 6407, so in future it can present a good reference to GDOI in this context.  Hope this is acceptable else I shall remove this too. 
Thank you.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 30 Jun 2015 08:31:55 +1200

Hi Uma,

See below...
> Thanks for your review (apologies for the delay from my side). 

Thanks for the answer. I am still a bit concerned that a reader will be
slightly confused, though. Can I suggest trying to rephrase the sentence
a bit, something like:

OLD:
   A mechanism,
   similar to as described in [I-D.weis-gdoi-mac-tek] can be used to
   distribute group keys to a group of ISes in Level-1 area or Level-2
   domain, using GDOI as specified in [RFC6407].

NEW:
   A mechanism is needed to distribute group keys to a group of ISes
   in a Level-1 area or Level-2 domain, using the Group Domain of
   Interpretation (GDOI) protocol as specified in [RFC6407]. An example
   policy and payload format was described in [I-D.weis-gdoi-mac-tek].

Regards
    Brian

---

From: Uma Chunduri <[email-masked]>
Date: Mon, 29 Jun 2015 20:38:21 +0000

Hi Brian,

Thanks for your consideration and for providing the modified text quickly.  That works and it's a great help.
Shall update this in the next version.
--
Uma C.

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Monday, June 29, 2015 1:32 PM
To: Uma Chunduri; [email-masked]; General Area Review Team
Subject: Re: Gen-ART Last Call review of draft-ietf-karp-isis-analysis-04

Hi Uma,

See below...
On 30/06/2015 06:19, Uma Chunduri wrote:
> So I would remove the references to draft-yeung-g-ikev2-08 and 
> draft-hartman-karp-mrkmp-05.  However, though expired, I would like to 
> keep the reference for

Thanks for the answer. I am still a bit concerned that a reader will be slightly confused, though. Can I suggest trying to rephrase the sentence a bit, something like:

OLD:
   A mechanism,

NEW:

Regards
    Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 30 Jun 2015 11:36:41 +1200

That looks fine (in the -06), thanks.

However, note that an IANA Considerations section is always required, even
if it says that no IANA action is necessary.

Regards
   Brian Carpenter

---

From: Uma Chunduri <[email-masked]>
Date: Mon, 29 Jun 2015 23:53:21 +0000

Hi Brian,

> However, note that an IANA Considerations section is always required, even if it says that no IANA action is necessary.

I removed this as per the guidance of Amanda (IANA).  I am not sure it's always required. Amanda, could you please confirm on this?

Thanks!

--
Uma C.

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Monday, June 29, 2015 4:37 PM
To: Uma Chunduri; [email-masked]; General Area Review Team
Subject: Re: Gen-ART Last Call review of draft-ietf-karp-isis-analysis-04

However, note that an IANA Considerations section is always required, even if it says that no IANA action is necessary.

Regards
   Brian Carpenter

On 30/06/2015 08:38, Uma Chunduri wrote:
>> draft-hartman-karp-mrkmp-05.  However, though expired, I would like 
>> to keep the reference for

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 30 Jun 2015 16:04:26 +1200

Some misunderstanding, I think.

  Checking nits according to http://www.ietf.org/id-info/checklist :
  ----------------------------------------------------------------------------

  ** The document seems to lack an IANA Considerations section.  (See Section
     2.2 of http://www.ietf.org/id-info/checklist for how to handle the case
     when there are no actions for IANA.)

Regards
   Brian