Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-homenet-prefix-assignment-06

From: Meral Shirazipour <[email-masked]>
Date: Thu, 11 Jun 2015 16:36:56 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq.

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-ietf-homenet-prefix-assignment-06
Reviewer: Meral Shirazipour
Review Date: 2015-06-11
IETF LC End Date:  2015-06-11
IESG Telechat date: NA

Summary:
This draft is ready to be published as Standards Track RFC.

Major issues:

Minor issues:

Nits/editorial comments:
I found the draft a bit hard to follow as the incentive was not clear at first.
A few sentences in abstract or introduction on 'why' we need this algorithm and what would the 'alternatives' be would be useful.
Right now it only says 'what' the algorithm does.

Best Regards,
Meral
---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: Pierre Pfister <[email-masked]>
Date: Fri, 12 Jun 2015 16:08:50 +0200

Hello Meral,

Thank you for this comment.

Indeed, sticking too hard to the specifications, I think I forgot to introduce the purpose first.

I therefore propose to add one sentence in the abstract:
 This document specifies a distributed algorithm for automatic prefix
    assignment.  Thus providing an alternative to manual or centralized
    prefix and address assignment techniques. […]

And add a new paragraph at the very beginning of the introduction:
   This document specifies a distributed algorithm for automatic prefix
   assignment.  The algorithm provides a generic alternative to
   centralized (human or software based) approaches for network prefixes
   and addresses assignment.  Although it does not require to be
   configured to operate properly, it supports custom configuration by
   means of variable priority assignments, and can therefore be used in
   fully autonomic as well as professionally managed networks.

   Given a set of delegated prefixes, Nodes may assign available
   prefixes to links they are directly connected to, […]

Do you think it helps ?

Do you think I should publish an update immediately or wait for other comments first ?

Thanks

- Pierre

> Le 11 juin 2015 à 18:36, Meral Shirazipour <[email-masked]> a écrit :
> 
> I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
>  
> www.ericsson.com <http://www.ericsson.com/>

---

From: Meral Shirazipour <[email-masked]>
Date: Fri, 12 Jun 2015 17:41:39 +0000

Hi,
  That is perfect, thank you. I think since the LC was June 11 you can publish a new version with any other comments you received from LC.

Best,
Meral

From: Pierre Pfister [mailto:[email-masked]]
Sent: Friday, June 12, 2015 7:09 AM
To: Meral Shirazipour
Cc: [email-masked]; [email-masked]
Subject: Re: Gen-ART Last Call review of draft-ietf-homenet-prefix-assignment-06

Hello Meral,

Do you think it helps ?

Thanks

- Pierre

Le 11 juin 2015 à 18:36, Meral Shirazipour <[email-masked]<mailto:[email-masked]>> a écrit :

Summary:

Major issues:

Minor issues:

Nits/editorial comments:

Best Regards,
Meral
---
Meral Shirazipour
Ericsson
Research
www.ericsson.com<http://www.ericsson.com/>

---

From: Pierre Pfister <[email-masked]>
Date: Mon, 15 Jun 2015 13:03:53 +0200

Hello Meral,

I pushed a new version with the proposed changes.

Thanks,

- Pierre

> Le 12 juin 2015 à 19:41, Meral Shirazipour <[email-masked]> a écrit :
> 
> Hi,
> Le 11 juin 2015 à 18:36, Meral Shirazipour <[email-masked] <mailto:[email-masked]>> a écrit :
>