Subject: [Gen-art] Last Call review of draft-ietf-sipcore-6665-clarification-00

From: Tom Taylor <[email-masked]>
Date: Wed, 17 Jun 2015 21:15:54 -0400

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document:  draft-ietf-sipcore-6665-clarification-00
Reviewer:  Tom Taylor
Review Date:      17 June 2015
IETF LC End Date: 17 June 2015
IESG Telechat date: 25 June 2015

Summary: This is a very short document expanding on a sentence in RFC 
6665 to make clear the requirements surrounding use of GRUUs in the SIP 
event framework. It is probably good to go except for a minor issue of 
terminology that needs clarification. The reviewer apologizes for not 
being current on that terminology if it is a matter of common usage.

Major issues: None.

Minor issues: The term "local target" is used in the text (and in RFC 
6665. RFC 3261 speaks of a remote target, but not a local one. In which 
document is "local target" defined?

Nits/editorial comments: None.

---

From: Jari Arkko <[email-masked]>
Date: Wed, 24 Jun 2015 18:13:50 -0300

Thanks for your review, Tom. Authors, is there an answer to Tom’s question?

jari

On 17 Jun 2015, at 22:15, Tom Taylor <[email-masked]> wrote:

> Summary: This is a very short document expanding on a sentence in RFC 6665 to make clear the requirements surrounding use of GRUUs in the SIP event framework. It is probably good to go except for a minor issue of terminology that needs clarification. The reviewer apologizes for not being current on that terminology if it is a matter of common usage.
> 
> Major issues: None.
> 
> Minor issues: The term "local target" is used in the text (and in RFC 6665. RFC 3261 speaks of a remote target, but not a local one. In which document is "local target" defined?
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Robert Sparks <[email-masked]>
Date: Wed, 24 Jun 2015 16:47:17 -0500

I'm not an author, but I am closely involved with the document and the 
base spec so  will jump in here anyhow in interest of timing.

>> Minor issues: The term "local target" is used in the text (and in RFC 6665. RFC 3261 speaks of a remote target, but not a local one. In which document is "local target" defined?
It's a well-known slight-typo that appears in several SIP documents at 
this point.
It should say "local contact" to reuse the terms from 3261 (and 5057), 
but it follows easily from context that "local target" is the dual of 
"remote target" (When A is in a dialog with B, A's remote target is B's 
local contact/local target, and vice-versa).

IMHO in this case, keeping with the words used in 6665 (local target) is 
the better thing to do.

RjS

---

From: Jari Arkko <[email-masked]>
Date: Wed, 24 Jun 2015 18:52:06 -0300

Thanks for the explanation, Robert!

On 24 Jun 2015, at 18:47, Robert Sparks <[email-masked]> wrote:

> I'm not an author, but I am closely involved with the document and the base spec so  will jump in here anyhow in interest of timing.
> 
>> On 17 Jun 2015, at 22:15, Tom Taylor
>> <[email-masked]>
>>  wrote:
>> 
>> 
> It's a well-known slight-typo that appears in several SIP documents at this point.
> It should say "local contact" to reuse the terms from 3261 (and 5057), but it follows easily from context that "local target" is the dual of "remote target" (When A is in a dialog with B, A's remote target is B's local contact/local target, and vice-versa).
> 
> IMHO in this case, keeping with the words used in 6665 (local target) is the better thing to do.
> 
> RjS
>>>