Subject: [Gen-art] Gen-ART Review of draft-ietf-tram-stun-path-data-03

From: Wassim Haddad <[email-masked]>
Date: Thu, 11 Feb 2016 15:09:58 -0800

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, 
please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>>

Document: draft-ietf-tram-stun-path-data-03
Reviewer:  Wassim Haddad
Review Date: 11 February 2016
IETF LC End Date: 11 February 2016
IETF Telechat Date: unknown

Summary:  This draft is ready for publication as proposed RFC

- Major Issues: None

- Minor Issues: None

Question: Would it make sense to highlight the mobility case (since the document explicitly mentions 3G, 4G, WiFi) in which case, applying the described mechanism would suggest to the mobile to use a different interface after attaching to a different network… 

Regards,

Wassim H.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 17 Feb 2016 12:09:21 -0600

Dear Authors,

On Thu, Feb 11, 2016 at 5:09 PM, Wassim Haddad <[email-masked]>
wrote:

> please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>
>
I haven't seen a response to Wassim's question - did I miss it?

Thanks,

Spencer

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 18 Feb 2016 07:24:31 +0000

Sorry missed replying to the question. Yes, the draft briefly discusses about it in the Introduction.
<snip>
   The technique described in this document can also be used with the
   ICE continuous nomination procedure explained in
   [I-D.uberti-mmusic-nombis<https://tools.ietf.org/html/draft-ietf-tram-stun-path-data-03#ref-I-D.uberti-mmusic-nombis>] which allows the application to pick
   better candidate pairs as and when they appear.  Hence, ICE endpoints
   will be capable of switching the application data to a candidate pair
   that becomes available later and offers better path characteristics.
</snip>
New candidate pairs appear because of availably of new interfaces.

-Tiru
From: Spencer Dawkins at IETF [mailto:[email-masked]]
Sent: Wednesday, February 17, 2016 7:09 PM
To: Wassim Haddad
Cc: gen-art; [email-masked]
Subject: Re: [Gen-art] Gen-ART Review of draft-ietf-tram-stun-path-data-03

Dear Authors,

On Thu, Feb 11, 2016 at 5:09 PM, Wassim Haddad <[email-masked]<mailto:[email-masked]>> wrote:

- Major Issues: None

- Minor Issues: None

Thanks,

Spencer

Regards,

Wassim H.