Subject: [Gen-art] Gen-ART review of draft-ietf-ecrit-held-routing-04

From: Jouni Korhonen <[email-masked]>
Date: Wed, 3 Feb 2016 15:31:24 -0800

I am the assigned Gen-ART reviewer for this draft. The General Area 
Review Team (Gen-ART) reviews all IETF documents being processed by the 
IESG for the IETF Chair. Please wait for direction from your document 
shepherd or AD before posting a new version of the draft. For more 
information, please see the FAQ at <​ 
http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

- Jouni

Summary:
	This draft is basically ready for publication, but has nits
  	that should be fixed before publication. The nits are only
  	editorial.

Comments:

I do have little expertise on ECRIT topics in general so bear with me.

* The I-D gives IDnits errors and stuff and those must be corrected.
   Specifically those that concern the abstract, updating RFCs and such.

* Starting from Section 1 (Intro) most of the acronyms are not expanded
   on the first use.. or at all in the document. Revisit all acronyms
   including HELD, LoST etc and expand them on the first use.

* The sentence on line 185 (IDnits) took me a while to parse ;) Maybe
   some rewording would make it a bit more readable.

* There is no reference to "forest guide". I would expect to see one
   and at least a note that it is a special instance of a LoST server.

* In Section 4 URN is written multiple times as "urn".

* On line 290 s/PSAPS/PSAPs

* On lines 304 and 310 s/section/Section

* On line 462 s/Layer 7/layer-7

---

From: Jari Arkko <[email-masked]>
Date: Thu, 4 Feb 2016 08:12:50 +0100

Thanks a lot for your review, Jouni!

I think the issues you mention are worth thinking about. Authors?

I have placed a no-objection position on the telechat tonight, but I’d prefer the authors respond to these comments in some way, and deal with the ones that you feel are necessary to be dealt with.

Jari

On 04 Feb 2016, at 00:31, Jouni Korhonen <[email-masked]> wrote:

> I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair. Please wait for direction from your document shepherd or AD before posting a new version of the draft. For more information, please see the FAQ at <​ http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> 
> 
> - Jouni
> 
> Summary:
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: James Winterbottom <[email-masked]>
Date: Thu, 4 Feb 2016 18:19:31 +1100

Thank you for your comments Jouni,

I am going through them now and will post any queries or clarifications shortly.

Cheers
James

> On 4 Feb 2016, at 10:31 am, Jouni Korhonen <[email-masked]> wrote:
>

---

From: James Winterbottom <[email-masked]>
Date: Thu, 4 Feb 2016 19:02:53 +1100

Hi Jouni,

Please see inline:

Assuming these changes are okay, I will re-issue once I have incorporated the other requested changes and comments.

Cheers
James

>  including HELD, LoST etc and expand them on the first use.
[AJW] Done!

>  some rewording would make it a bit more readable.
[AJW] Okay

Old "In countries amenable to the use of LoST and forest guides no public forest guides have been deployed.

Proposed “Even in countries amenable to the use of LoST and forest guides, no public forest guides have yet been deployed”.

>  and at least a note that it is a special instance of a LoST server.
[AJW] In the terms section I have added na explicit reference to RFC 5582 which defines the overall mapping architecture.

> 
> * In Section 4 URN is written multiple times as "urn”.
[AJW] Fixed

> * On line 290 s/PSAPS/PSAPs
[AJW] changed the text to read "It is important for devices and intermediaries to take all steps possible to ensure 
	   that emergency calls are routed to the correct PSAP.”

> * On lines 304 and 310 s/section/Section
[AJW] Fixed
> * On line 462 s/Layer 7/layer-7
[AJW] Fixed]

---

From: Jouni <[email-masked]>
Date: Thu, 4 Feb 2016 00:06:49 -0800

Hi,

Thanks for a quick reponse. OK with the proposed changes.

- Jouni

> On 04 Feb 2016, at 00:02, James Winterbottom <[email-masked]> wrote:
> 
> Hi Jouni,
> 
> Please see inline:
>