Subject: [Gen-art] Gen-ART telechat review for draft-ietf-mmusic-sdp-mux-attributes-14

From: Dan Romascanu <[email-masked]>
Date: Wed, 26 Oct 2016 12:59:06 +0300

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair. Please wait for direction from your
document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-mmusic-sdp-mux-attributes-14
Reviewer: Dan Romascanu
Review Date: 10/26/16
IETF LC End Date: 8/10/16
IESG Telechat date: 10/28/16

Summary:
Ready.

The more important issue in my initial review was clarified in draft-14.
Two minor issues were not, but these are not essential.

Major issues:

Minor issues:

1.       The use of B – ‘Both’ terminology used to indicate that an
attribute is specified S – Session Level and M – Medial Level (e.g. in
Section 5) may be confusing, as there is a third possible level SR – Source
Level. Actually S + M would probably be more clear.

2. Section 5.54 includes a note referring to the TBD content. ‘As per
section 9.1 of [I-D.ietf-mmusic-sdp-bundle-negotiation],  there exists no
publicly available specification that defines procedures for
multiplexing/demultiplexing fax protocols flows over a single 5-tuple.
Once such a specification is available, the multiplexing category
assignments for the attributes in this section could be revisited.’
Assuming the missing specification will be publicly available sometime in
the future – how will this information be added? Revise this RFC? The
question applies to other TBD marked in the ‘Mux Category’ column of the
tables in Section 5 (in 5.42, 5.44, …)

Nits/editorial comments:

Regards,

Dan

---

From: "Suhas Nandakumar (snandaku)" <[email-masked]>
Date: Wed, 26 Oct 2016 18:12:57 +0000

Hello Dan

  My apologies for missing on the updates. For each concern raised , here are my responses.

.1.       The use of B - 'Both' terminology used to indicate that an attribute is specified S - Session Level and M - Medial Level (e.g. in Section 5) may be confusing, as there is a third possible level SR - Source Level. Actually S + M would probably be more clear.

[Suhas] - As discussed in our earlier email , i will be updating the description of 'B' to imply the attribute applies to both Session and Media level

2.Section 5.54 includes a note referring to the TBD content. 'As per section 9.1 of [I-D.ietf-mmusic-sdp-bundle-negotiation],  there exists no publicly available specification that defines procedures for multiplexing/demultiplexing fax protocols flows over a single 5-tuple.  Once such a specification is available, the multiplexing category assignments for the attributes in this section could be revisited.' Assuming the missing specification will be publicly available sometime in the future - how will this information be added? Revise this RFC? The question applies to other TBD marked in the 'Mux Category' column of the tables in Section 5 (in 5.42, 5.44, ...)

[Suhas] Section 15.2 of the latest version does address how to deal with registry updates for the categories. Excerpt below

"

   Any future updates to the "Mux Category" column values needs to
   follow the existing registration policy of the affected table
   (Section 8.2.4.2 of [I-D.ietf-mmusic-rfc4566bis]).

   Also, the procedures from Section 8.2.4.1 of
   [I-D.ietf-mmusic-rfc4566bis] needs to be followed when assigning "Mux
   Category" value for the newly defined SDP attributes.

"

Please let me know your thoughts. I can produce a new version along wth IESG Evaluation comments next week.

Thanks

Suhas

________________________________
From: Dan Romascanu <[email-masked]>
Sent: Wednesday, October 26, 2016 2:59 AM
To: [email-masked]; [email-masked]
Subject: Gen-ART telechat review for draft-ietf-mmusic-sdp-mux-attributes-14

Summary:
Ready.

The more important issue in my initial review was clarified in draft-14. Two minor issues were not, but these are not essential.

Major issues:

Minor issues:

1.       The use of B - 'Both' terminology used to indicate that an attribute is specified S - Session Level and M - Medial Level (e.g. in Section 5) may be confusing, as there is a third possible level SR - Source Level. Actually S + M would probably be more clear.

2. Section 5.54 includes a note referring to the TBD content. 'As per section 9.1 of [I-D.ietf-mmusic-sdp-bundle-negotiation],  there exists no publicly available specification that defines procedures for multiplexing/demultiplexing fax protocols flows over a single 5-tuple.  Once such a specification is available, the multiplexing category assignments for the attributes in this section could be revisited.' Assuming the missing specification will be publicly available sometime in the future - how will this information be added? Revise this RFC? The question applies to other TBD marked in the 'Mux Category' column of the tables in Section 5 (in 5.42, 5.44, ...)

Nits/editorial comments:

Regards,

Dan

---

From: Dan Romascanu <[email-masked]>
Date: Wed, 26 Oct 2016 22:55:19 +0300

Hi Suhas,

The proposed edits would be fine with me. Thank you for addressing all my
concerns.

Regards,

Dan

On Wed, Oct 26, 2016 at 9:12 PM, Suhas Nandakumar (snandaku) <
[email-masked]> wrote:

> .1.       The use of B – ‘Both’ terminology used to indicate that an
> [Suhas] - As discussed in our earlier email , i will be updating the
> description of 'B' to imply the attribute applies to both Session and Media
> level
>
>
> 2.Section 5.54 includes a note referring to the TBD content. ‘As per
> [Suhas] Section 15.2 of the latest version does address how to deal with
> registry updates for the categories. Excerpt below
>
> "
>
> ------------------------------
> *From:* Dan Romascanu <[email-masked]>
> *Sent:* Wednesday, October 26, 2016 2:59 AM
> *To:* [email-masked]; draft-ietf-mmusic-sdp-mux-
> [email-masked]
> *Subject:* Gen-ART telechat review for draft-ietf-mmusic-sdp-mux-
> attributes-14
>
> Section 5) may be confusing, as there is a third possible level SR –
> Source Level. Actually S + M would probably be more clear.
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 27 Oct 2016 01:06:19 +0300

Dan, Suhas,

Thanks for the reviews and updates

Jari