Subject: [Gen-art] review of draft-ietf-roll-routing-dispatch-03.txt

From: Francis Dupont <[email-masked]>
Date: Wed, 26 Oct 2016 23:47:54 +0200

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-roll-routing-dispatch-03.txt
Reviewer: Francis Dupont
Review Date: 20161025
IETF LC End Date: 20161019
IESG Telechat date: 20161027

Summary: Ready

Major issues: None

Minor issues: None

Nits/editorial comments:
 - 1 page 3: wording:
   to much smaller values than the IPv6 maximum transmission unit (MTU)
   of 1280 bytes.
  this statement doesn't make sense without an extra word as "guaranteed"
  before "IPv6 maximum..."

 - 3.2.2 page 8 and 8 page 25: e.g. -> e.g.,

 - 4.3 page 10: please expand the first occurrence of the DODAG abbrev
  (DODAG is in the RFC-editor abbrev list but is not starred as well known.
   BTW RPL is in the same case but IMHO does not need expansion in the
   Abstract and the intro)

 - 4.3.1 page 10 figure 5: for consistency: Coalesced -> coalesced

 - 4.3.2 page 11: formally the 2 paragraphs beginning by If and Else
  should be indented (ask the RFC Editor to do that)

 - 6.3 page 21: spurious comma in [RFC6550],.

 - 9 page 25: I disagree a bit about decompression to be security neutral
  because an atatcket can use error propagation by a decompressor.
  Now if I understand well there should be a L2 security so attacks
  based on decompression are limited and anyway covered by compression
  RFC (6282)... So I leave this to the security directorate.

 - A.2 page 31: defiend -> defined

 - Authors' Addresses page 35: Please ask the RFC Editor to uniformize
  France/FRANCE case (or put FR :-).

Regards

[email-masked]

---

From: Jari Arkko <[email-masked]>
Date: Thu, 27 Oct 2016 01:07:44 +0300

Many thanks for your review, Francis!

Authors, do make a note of Francis’ comments.

Jari

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 27 Oct 2016 12:27:19 +0000

Dear Francis:

Under Jari 's heavy pressure -  ; )  - , I applied your recommendations and published.

URL:            https://www.ietf.org/internet-drafts/draft-ietf-roll-routing-dispatch-05.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-roll-routing-dispatch/
Htmlized:       https://tools.ietf.org/html/draft-ietf-roll-routing-dispatch-05
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-roll-routing-dispatch-05

Thanks for your careful review. I need to undertsadn better the attack you are referring too. 
Per your suggestion, let us work that out with the sec dir review.

Take care,

Pascal

-----Original Message-----
From: Francis Dupont [mailto:[email-masked]] 
Sent: mercredi 26 octobre 2016 23:48
To: [email-masked]
Cc: [email-masked]
Subject: review of draft-ietf-roll-routing-dispatch-03.txt

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

Summary: Ready

Major issues: None

Minor issues: None

Nits/editorial comments:
 - 1 page 3: wording:

Regards