Subject: [Gen-art] Gen-ART telechat review of draft-ietf-l3sm-l3vpn-service-model-17

From: Brian E Carpenter <[email-masked]>
Date: Fri, 21 Oct 2016 16:41:45 +1300

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair. Please wait for direction from your
document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-l3sm-l3vpn-service-model-17.txt
Reviewer: Brian Carpenter
Review Date: 2016-10-21
IETF LC End Date: 2016-10-11
IESG Telechat date: 2016-10-27

Summary: Almost ready
--------

Comments:
---------

Thanks for responding to my LC comments. I have not checked the details of the yang.

Minor Issues:
-------------

This is a point I missed originally but I mentioned it during the discussion:
The model says:

      | | |   | | +--rw match-flow
      | | |   | |   +--rw dscp?        inet:dscp
      | | |   | |   +--rw tos?         uint8

but tos was obsoleted when dscp was defined by RFC 2474. I don't think
you should include tos. You don't mention ECN, which are the two bits
from tos that are not included in dscp. Those bits are no good for flow
matching because they are variable.  If an operator tries to use the 8 TOS
bits for flow matching but a user supports ECN, the matching will not work
consistently. So I think it's misleading to include this.

---

From: <[email-masked]>
Date: Fri, 21 Oct 2016 07:51:26 +0000

Hi Brian,

I missed this point in my updates. Sorry for that, next version will take it into account.

Brgds,

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Friday, October 21, 2016 05:42
To: [email-masked]; General Area Review Team
Subject: Gen-ART telechat review of draft-ietf-l3sm-l3vpn-service-model-17

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair. Please wait for direction from your document shepherd or AD before posting a new version of the draft.

Summary: Almost ready
--------

Comments:
---------

Minor Issues:
-------------

but tos was obsoleted when dscp was defined by RFC 2474. I don't think you should include tos. You don't mention ECN, which are the two bits from tos that are not included in dscp. Those bits are no good for flow matching because they are variable.  If an operator tries to use the 8 TOS bits for flow matching but a user supports ECN, the matching will not work consistently. So I think it's misleading to include this.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.