Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-rtcweb-overview-18

From: Meral Shirazipour <[email-masked]>
Date: Fri, 17 Mar 2017 00:43:27 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.
For more information, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-rtcweb-overview-18
Reviewer: Meral Shirazipour
Review Date: 2017-03-16
IETF LC End Date:   2017-03-20
IESG Telechat date: 2017-04-13

Summary:
This draft is ready to be published as Standards Track RFC but I have comments.

Major issues:
Minor issues:
Nits/editorial comments:
-[Page 3] "an other hardware has"---->"and other hardware have"
-[Page 4], the word "subprotocol" was not clear to me. Would it be possible to add in parenthesis a few example for protocol and subprotocol?
-[Page 4], "an WebRTC"--->""a WebRTC"
-[Page 7], "Interactive Connectivty"--->"Interactive Connectivity"
-General: please spell out acronyms at first use
-General: the writing (or perhaps lack of punctuation) in this draft made it hard to read. Please consider reviewing it especially if the draft is intended as Standards Track.

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research
www.ericsson.com

---

From: Sean Turner <[email-masked]>
Date: Tue, 21 Mar 2017 18:11:48 -0400

> On Mar 16, 2017, at 20:43, Meral Shirazipour <[email-masked]> wrote:
> 

Harald and I (the shepherd) thank you for your review.

> Major issues:
> Minor issues:
> Nits/editorial comments:
> -[Page 3] "an other hardware has"---->"and other hardware have”
fixed
> -[Page 4], the word "subprotocol" was not clear to me. Would it be possible to add in parenthesis a few example for protocol and subprotocol?
Mostly talking about Websockets-related sub-protocols. XMPP and SIP are examples noted later. 
> -[Page 4], "an WebRTC"--->""a WebRTC”
fixed
> -[Page 7], "Interactive Connectivty"--->"Interactive Connectivity”
fixed
> -General: please spell out acronyms at first use
I caught a couple, but I’m sure I missed some.  I figured I let some go like “SDP Agent” in the terminology section because people can just as easily go there.  There’s also a lot in the RFC acronym list that don’t necessarily need to be expanded.
> -General: the writing (or perhaps lack of punctuation) in this draft made it hard to read. Please consider reviewing it especially if the draft is intended as Standards Track.
I’m going to leave this one to the RFC editor.  Every time I try to make something sound better they just do a better job.

PR can be found here:
https://github.com/rtcweb-wg/rtcweb-overview/pull/13/

spt

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 21 Mar 2017 23:24:19 +0000

Hi,
  Thank you.

Best,
Meral

> -----Original Message-----
> From: Sean Turner [mailto:[email-masked]]
> Sent: Tuesday, March 21, 2017 3:12 PM
> To: Meral Shirazipour <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: Re: Gen-ART Last Call review of draft-ietf-rtcweb-overview-18
> 
> 
> > I am the assigned Gen-ART reviewer for this draft. The General Area
> Review Team (Gen-ART) reviews all IETF documents being processed by the
> IESG for the IETF Chair.  Please treat these comments just like any other last
> call comments.
> > For more information, please see the FAQ at
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> >
> >
> > -[Page 4], the word "subprotocol" was not clear to me. Would it be possible
> to add in parenthesis a few example for protocol and subprotocol?
> I caught a couple, but I’m sure I missed some.  I figured I let some go like
> “SDP Agent” in the terminology section because people can just as easily go
> there.  There’s also a lot in the RFC acronym list that don’t necessarily need
> to be expanded.
> > -General: the writing (or perhaps lack of punctuation) in this draft made it
> hard to read. Please consider reviewing it especially if the draft is intended as
> Standards Track.
> I’m going to leave this one to the RFC editor.  Every time I try to make
> something sound better they just do a better job.
> 
> PR can be found here: