Subject: [Gen-art] Gen-ART Telechat Call review of draft-ietf-ipsecme-rfc7321bis-05

From: Meral Shirazipour <[email-masked]>
Date: Tue, 14 Mar 2017 20:22:28 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair. Please wait for direction from your document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-ipsecme-rfc7321bis-05
Reviewer: Meral Shirazipour
Review Date: 2017-03-14
IETF LC End Date: 2017-03-15
IESG Telechat date: 2017-03-16

Summary: This draft is ready to be published as Standards RFC, but I have some comments.

Major issues:
Minor issues:
Nits/editorial comments:
-[Page 4], "downgraded from MUST to MUST-". MUST- is defined later in the document. Perhaps a reference in the text should point to that section on p.5.
-[Page 7], "were not been mentioned"---->"have not been mentioned"
-[Page 7], "this document clarify"---->"this document clarifies"
-[Page 11], "that revisions of that"---->"that revisions of this"

-general, some acronyms are not spelled out...VPN, MTU..
-Tables P.5,6,8,9,10. Giving them a caption would make the document clearer.

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research
www.ericsson.com

---

From: Daniel Migault <[email-masked]>
Date: Tue, 14 Mar 2017 22:07:57 +0000

Hi Meral, 

Thank you for the review and your comments. As submission tool is closed until the next IETF, I have not been able to submit the updated version. This will be done as soon as the IETF starts. Please see inline my response.

Yours, 
Daniel

-----Original Message-----
From: Meral Shirazipour [mailto:[email-masked]] 
Sent: Tuesday, March 14, 2017 4:22 PM
To: [email-masked]; [email-masked]
Subject: Gen-ART Telechat Call review of draft-ietf-ipsecme-rfc7321bis-05

Major issues:
Minor issues:
Nits/editorial comments:

MGLT: 
Here is what I propose: 

OLD text:
"""
Unless there are strong security reasons, an algorithm is expected to be
   downgraded from MUST to MUST- or SHOULD, instead of MUST NOT.
"""

NEW text:
"""
Unless there are strong security reasons, an algorithm is expected to be
downgraded from MUST to MUST- or SHOULD, instead of MUST NOT 
(See Section 2 for a definition of the terminology).

"""

MGLT: corrected

MGLT: corrected

MGLT: corrected

MGLT: These are the acronyms I found, the following acronyms: UNSPECIFIED.  CPU IKEv2 IANA VPN PFS AEAD 
All have been spelled out except IANA and CPU and UNSPECIFIED.  I added a reference to RFC7296 at the first IKEv2 instance

-Tables P.5,6,8,9,10. Giving them a caption would make the document clearer

MGLT: I added the titles, but the output was pretty ugly (in my opinion) due to the postambules. As titles repeat the section title I preferred to remove the titles and let a note to the RFC editor to do what seems to him the most appropriated way to present the tables.

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 14 Mar 2017 22:10:39 +0000

Hi,
  thank you.

Best,
Meral

> From: Daniel Migault
> Sent: Tuesday, March 14, 2017 3:08 PM
> To: Meral Shirazipour <[email-masked]>; draft-ietf-
> [email-masked]; [email-masked]
> Subject: RE: Gen-ART Telechat Call review of draft-ietf-ipsecme-rfc7321bis-05
> 
> Hi Meral,
> 
> Thank you for the review and your comments. As submission tool is closed
> until the next IETF, I have not been able to submit the updated version. This
> will be done as soon as the IETF starts. Please see inline my response.
> 
> Yours,
> Daniel
> 
> I am the assigned Gen-ART reviewer for this draft. The General Area Review
> Team (Gen-ART) reviews all IETF documents being processed by the IESG for
> the IETF Chair. Please wait for direction from your document shepherd or AD
> before posting a new version of the draft.
> 
> For more information, please see the FAQ at
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> 
> -[Page 4], "downgraded from MUST to MUST-". MUST- is defined later in the
> document. Perhaps a reference in the text should point to that section on
> p.5.
> 
> MGLT:
> Here is what I propose:
> 
> OLD text:
> """
> downgraded from MUST to MUST- or SHOULD, instead of MUST NOT (See
> Section 2 for a definition of the terminology).
> 
> """
> 
> MGLT: These are the acronyms I found, the following acronyms:
> UNSPECIFIED.  CPU IKEv2 IANA VPN PFS AEAD All have been spelled out
> except IANA and CPU and UNSPECIFIED.  I added a reference to RFC7296 at
> the first IKEv2 instance
> 
> 
> MGLT: I added the titles, but the output was pretty ugly (in my opinion) due
> to the postambules. As titles repeat the section title I preferred to remove
> the titles and let a note to the RFC editor to do what seems to him the most
> appropriated way to present the tables.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 16 Mar 2017 09:25:34 +0900

Meral, Daniel — thanks.

Jari