Subject: [Gen-art] Genart last call review of draft-ietf-ospf-link-overload-11

From: Joel Halpern <[email-masked]>
Date: Thu, 04 Jan 2018 15:32:00 -0800

Reviewer: Joel Halpern
Review result: Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-ospf-link-overload-11
Reviewer: Joel Halpern
Review Date: 2018-01-04
IETF LC End Date: 2018-01-16
IESG Telechat date: 2018-01-25

Summary: This document is ready for publication as a Proposed Standard

Major issues:
    N/A; my concerns from earlier versions have been addressed.

Minor issues:
    I understand the WG likes using the term "overload" for a link being taken
    out of service.  I think people will learn what we mean.  I do wish we had
    not chosen to misuse the words in this fashion.  This is much more a
    graceful-link-close indication (or clsoe-pending indication) than it is an
    overload indication.

Nits/editorial comments:

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 5 Jan 2018 00:23:25 +0000

Hi Joel, 

>    graceful-link-close indication (or clsoe-pending indication) than it

I agree with this comment but I wasn’t sure we’d reach consensus on a
better alternative. However, after some though and consideration of
current OSPF router terminology, I’d propose we use the term
“Pending-Shutdown”. Does anyone not agree that this is a more appropriate
moniker for the TLV and state?

Thanks,
Acee

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 5 Jan 2018 02:26:49 +0000

> >    I understand the WG likes using the term "overload" for a link

> >being taken

> >    out of service.  I think people will learn what we mean.  I do wish

> >we had

> >    graceful-link-close indication (or clsoe-pending indication) than

> >it is an

> better alternative. However, after some though and consideration of current

> OSPF router terminology, I’d propose we use the term “Pending-Shutdown”.

> Does anyone not agree that this is a more appropriate moniker for the TLV

> and state?

[Les:] I agree with Joel's comment. The use of the term "overload" is unfortunate.

But "pending-shutdown" isn’t appealing to me because - at least in most use cases - you aren't actually going to shutdown the link. What you are going to do is make a link the "link of last resort".

This seems a better choice.

The suggestion from Shraddha that this term was borrowed from IS-IS isn't accurate. "overload" in IS-IS has a very different meaning - it indicates a node either has an incomplete LSDB or (a la RFC 3277<https://datatracker.ietf.org/doc/rfc3277/> )an incomplete forwarding plane.

The only use of "link overload" in IS-IS occurs in https://tools.ietf.org/html/draft-ietf-isis-reverse-metric-07#section-3.6 and this was added recently to support the (very useful) TE use case which was defined in https://tools.ietf.org/html/draft-ietf-ospf-link-overload-11 . When this was done the term "link-overload" was cut and pasted from the OSPF draft. I think this should also be changed in the IS-IS draft.

   Les

> _______________________________________________

> OSPF mailing list

> [email-masked]<mailto:[email-masked]>

> https://www.ietf.org/mailman/listinfo/ospf

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 5 Jan 2018 02:44:07 +0000

Hi Les,

From: "Les Ginsberg (ginsberg)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, January 4, 2018 at 9:26 PM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, "Joel M. Halpern" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Genart last call review of draft-ietf-ospf-link-overload-11

That is not the use case - you are going to take the link down. It is not going to be the "link of last resort”, it is the currently the “link of last resort” and will imminently be taken down.

Agreed.

Thanks,
Acee

   Les

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 5 Jan 2018 04:08:56 +0000

Hello,

May I suggest something more generic like “Maintenance Mode” or “Graceful Insertion/Removal (GIR) Mode” which could be defined so as to cover the multiple scenarios in question (e.g. pending shutdown, down for repairs, last resort due to poor link quality, etc.).

Thanks,
Ketan

From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: 05 January 2018 08:14
To: Les Ginsberg (ginsberg) <[email-masked]>; Joel Halpern <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [OSPF] Genart last call review of draft-ietf-ospf-link-overload-11

Hi Les,

Agreed.

Thanks,
Acee

   Les

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 5 Jan 2018 04:55:47 +0000

Acee -

From: Acee Lindem (acee)
Sent: Thursday, January 04, 2018 6:44 PM
To: Les Ginsberg (ginsberg) <[email-masked]>; Joel Halpern <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Genart last call review of draft-ietf-ospf-link-overload-11

Hi Les,

That is not the use case - you are going to take the link down. It is not going to be the "link of last resort”, it is the currently the “link of last resort” and will imminently be taken down.
[Les:] https://tools.ietf.org/html/draft-ietf-ospf-link-overload-11#section-2

<snip>
2.  Motivation

…
   4.  Allow the link to be used as last resort link to prevent traffic
       disruption when alternate paths are not available.
<end snip>

This is the real value of the protocol extension. If the intention was to take the link out of service the extension would not be worth much as the behavioral difference between (normal metric->max metric->down) vs (normal metric->down) is very small.
This is also consistent with my recollection of the service providers motivation when the early versions of isis-reverse-metric were presented. The question was asked “why don’t you simply take the link down?” and the response was “We don’t want to take the link down – we want it to be the link of last resort so that if all else fails we can still use the link to get to the node.”

(As an aside, if the idea was to more gracefully redirect traffic away from the link in preparation for taking the link down you would need to use a metric offset as the isis-reverse-metric draft does. Then you could direct traffic away from the link in incremental steps. I don’t mean to suggest this will be a common use case of reverse-metric – but it would at least be useful if the intent was to take the link down in a short while).

   Les

Agreed.

Thanks,
Acee

   Les

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 5 Jan 2018 04:56:42 +0000

Ketan –

“maintenance” I could live with.

“GIR” seems to not be generic enough.

   Les

From: Ketan Talaulikar (ketant)
Sent: Thursday, January 04, 2018 8:09 PM
To: Acee Lindem (acee) <[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]>; Joel Halpern <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: Genart last call review of draft-ietf-ospf-link-overload-11

Hello,

Thanks,
Ketan

From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: 05 January 2018 08:14
To: Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>>; Joel Halpern <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [OSPF] Genart last call review of draft-ietf-ospf-link-overload-11

Hi Les,

Agreed.

Thanks,
Acee

   Les

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 5 Jan 2018 13:19:49 +0000

It is not in “maintenance" mode yet as it is still being used. However, it is better than “overload”. “pending-maintenance” is a bit long which is why I suggested “pending-shutdown” since “shutdown” is term that vendors have used for eons to described an interface that is not in service.
Thanks,
Acee

From: "Les Ginsberg (ginsberg)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, January 4, 2018 at 11:56 PM
To: "Ketan Talaulikar (ketant)" <[email-masked]<mailto:[email-masked]>>, Acee Lindem <[email-masked]<mailto:[email-masked]>>, "Joel M. Halpern" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Genart last call review of draft-ietf-ospf-link-overload-11

Ketan –

   Les

To: Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>>; Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>>; Joel Halpern <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Hello,

Thanks,
Ketan

Hi Les,

Agreed.

Thanks,
Acee

   Les

---

From: Shraddha Hegde <[email-masked]>
Date: Fri, 5 Jan 2018 16:15:08 +0000

How about “graceful-link-shutdown” ?

Rgds
Shraddha

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Friday, January 5, 2018 6:50 PM
To: Les Ginsberg (ginsberg) <[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>; Joel Halpern <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Genart last call review of draft-ietf-ospf-link-overload-11

Ketan –

   Les

Hello,

Thanks,
Ketan

Hi Les,

The suggestion from Shraddha that this term was borrowed from IS-IS isn't accurate. "overload" in IS-IS has a very different meaning - it indicates a node either has an incomplete LSDB or (a la RFC 3277<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_rfc3277_&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=7GM8zN1-Ff2au_agmHAkiNYK2R5Aji-EjpyT8gmgRYU&s=769ndBiWrwubwBNccNtOnDuHr1yMD-W10WuEarCDNgI&e=> )an incomplete forwarding plane.

The only use of "link overload" in IS-IS occurs in https://tools.ietf.org/html/draft-ietf-isis-reverse-metric-07#section-3.6<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Disis-2Dreverse-2Dmetric-2D07-23section-2D3.6&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=7GM8zN1-Ff2au_agmHAkiNYK2R5Aji-EjpyT8gmgRYU&s=r_8muG61-ePlkCbqf7qIcHUPHGtjWf_JOH1UXH7lp8U&e=> and this was added recently to support the (very useful) TE use case which was defined in https://tools.ietf.org/html/draft-ietf-ospf-link-overload-11<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dospf-2Dlink-2Doverload-2D11&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=7GM8zN1-Ff2au_agmHAkiNYK2R5Aji-EjpyT8gmgRYU&s=umZHmgXp6i4i0PAyZbsDS0iorBurDZsFIyvaVVXEHb0&e=> . When this was done the term "link-overload" was cut and pasted from the OSPF draft. I think this should also be changed in the IS-IS draft.

Agreed.

Thanks,
Acee

   Les

> https://www.ietf.org/mailman/listinfo/ospf<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ospf&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=7GM8zN1-Ff2au_agmHAkiNYK2R5Aji-EjpyT8gmgRYU&s=N51dsQzqzgGoBY61VJtqkgGHlrNjgZT_-9g8G_pcOyE&e=>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 5 Jan 2018 16:46:39 +0000

Works for me.
Acee

From: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Date: Friday, January 5, 2018 at 11:15 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, "Les Ginsberg (ginsberg)" <[email-masked]<mailto:[email-masked]>>, "Ketan Talaulikar (ketant)" <[email-masked]<mailto:[email-masked]>>, "Joel M. Halpern" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Genart last call review of draft-ietf-ospf-link-overload-11

Rgds
Shraddha

To: Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; Joel Halpern <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Ketan –

   Les

Hello,

Thanks,
Ketan

Hi Les,

Agreed.

Thanks,
Acee

   Les

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 5 Jan 2018 17:52:03 +0000

I think the point here is that the link is not necessarily going to be shutdown in all cases.

For example, the operator needs to do some testing of the link. They set max-metric to divert traffic, then keep the link up so they can send OAM traffic over the link and try to determine what problems may exist.

It is a mistake to assume that this mechanism is always intended to be used as a precursor to link shutdown.

   Les

From: Acee Lindem (acee)
Sent: Friday, January 05, 2018 8:47 AM
To: Shraddha Hegde <[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>; Joel Halpern <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Genart last call review of draft-ietf-ospf-link-overload-11

Works for me.
Acee

Rgds
Shraddha

Ketan –

   Les

Hello,

Thanks,
Ketan

Hi Les,

Agreed.

Thanks,
Acee

   Les

---

From: <[email-masked]>
Date: Mon, 8 Jan 2018 13:39:29 +0000

From: Shraddha Hegde

Looks good to me.

Also, FYI, for BGP sessions, in the GROW WG we used the term “Graceful BGP session shutdown” and named the BGP community “GRACEFUL_SHUTDOWN” so this would align on the terminology.
https://tools.ietf.org/html/draft-ietf-grow-bgp-gshut-13

Best regards,
--Bruno

Rgds
Shraddha

Ketan –

   Les

Hello,

Thanks,
Ketan

Hi Les,

Agreed.

Thanks,
Acee

   Les

> https://www.ietf.org/mailman/listinfo/ospf<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ospf&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA…

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Pushpasis Sarkar <[email-masked]>
Date: Mon, 8 Jan 2018 22:52:26 +0530

Hi Joel et al,

+1 for 'graceful-link-shutdown'. Another possibility may be
'link-decommission'..

Thanks and regards
-Pushpasis

On Mon, Jan 8, 2018 at 7:09 PM, <[email-masked]> wrote:

> *From:* Shraddha Hegde
> *From:* Acee Lindem (acee) [mailto:[email-masked] <[email-masked]>]
> *Sent:* Friday, January 5, 2018 6:50 PM
> *To:* Les Ginsberg (ginsberg) <[email-masked]>; Ketan Talaulikar
> (ketant) <[email-masked]>; Joel Halpern <[email-masked]>;
> [email-masked]
> *Cc:* [email-masked]; [email-masked]; draft-ietf-ospf-link-overload.
> [email-masked]
> *Subject:* Re: Genart last call review of draft-ietf-ospf-link-overload-11
>
>
>
> It is not in “maintenance" mode yet as it is still being used. However, it
> is better than “overload”. “pending-maintenance” is a bit long which is why
> I suggested “pending-shutdown” since “shutdown” is term that vendors have
> used for eons to described an interface that is not in service.
>
> Thanks,
>
> Acee
>
>
>
> *From: *"Les Ginsberg (ginsberg)" <[email-masked]>
> *Date: *Thursday, January 4, 2018 at 11:56 PM
> *To: *"Ketan Talaulikar (ketant)" <[email-masked]>, Acee Lindem <
> [email-masked]>, "Joel M. Halpern" <[email-masked]>, "
> [email-masked]" <[email-masked]>
> *Cc: *OSPF WG List <[email-masked]>, "[email-masked]" <[email-masked]>, "
> [email-masked]" <draft-ietf-ospf-link-
> [email-masked]>
> *Subject: *RE: Genart last call review of draft-ietf-ospf-link-overload-11
>
>
>
> Ketan –
>
>
>
> *From:* Ketan Talaulikar (ketant)
> *Sent:* Thursday, January 04, 2018 8:09 PM
> *To:* Acee Lindem (acee) <[email-masked]>; Les Ginsberg (ginsberg) <
> [email-masked]>; Joel Halpern <[email-masked]>; [email-masked]
> *Cc:* [email-masked]; [email-masked]; draft-ietf-ospf-link-overload.
> [email-masked]
> *Subject:* RE: Genart last call review of draft-ietf-ospf-link-overload-11
>
>
>
> Hello,
>
>
>
> May I suggest something more generic like “Maintenance Mode” or “Graceful
> Insertion/Removal (GIR) Mode” which could be defined so as to cover the
> multiple scenarios in question (e.g. pending shutdown, down for repairs,
> last resort due to poor link quality, etc.).
>
>
>
> Thanks,
>
> Ketan
>
>
>
> *From:* OSPF [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Acee Lindem (acee)
> *Sent:* 05 January 2018 08:14
> *To:* Les Ginsberg (ginsberg) <[email-masked]>; Joel Halpern <
> [email-masked]>; [email-masked]
> *Cc:* [email-masked]; [email-masked]; draft-ietf-ospf-link-overload.
> [email-masked]
> *Subject:* Re: [OSPF] Genart last call review of
> draft-ietf-ospf-link-overload-11
>
>
>
> Hi Les,
>
>
>
> *From: *"Les Ginsberg (ginsberg)" <[email-masked]>
> *Date: *Thursday, January 4, 2018 at 9:26 PM
> *To: *Acee Lindem <[email-masked]>, "Joel M. Halpern" <[email-masked]>,
> "[email-masked]" <[email-masked]>
> *Cc: *OSPF WG List <[email-masked]>, "[email-masked]" <[email-masked]>, "
> [email-masked]" <draft-ietf-ospf-link-
> [email-masked]>
> *Subject: *RE: Genart last call review of draft-ietf-ospf-link-overload-11
>
>
>
> > >Minor issues:
>
> current
> But "pending-shutdown" isn’t appealing to me because - at least in most
> use cases - you aren't actually going to shutdown the link. What you are
> going to do is make a link the "link of last resort".
>
> That is not the use case - you are going to take the link down. It is not
> going to be the "link of last resort”, it is the currently the “link of
> last resort” and will imminently be taken down.
>
>
>
>
>
> The suggestion from Shraddha that this term was borrowed from IS-IS isn't
> accurate. "overload" in IS-IS has a very different meaning - it indicates a
> node either has an incomplete LSDB or (a la RFC 3277
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_rfc3277_&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=7GM8zN1-Ff2au_agmHAkiNYK2R5Aji-EjpyT8gmgRYU&s=769ndBiWrwubwBNccNtOnDuHr1yMD-W10WuEarCDNgI&e=>
> )an incomplete forwarding plane.
>
>
>
> The only use of "link overload" in IS-IS occurs in
> https://tools.ietf.org/html/draft-ietf-isis-reverse-metric-07#section-3.6
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Disis-2Dreverse-2Dmetric-2D07-23section-2D3.6&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=7GM8zN1-Ff2au_agmHAkiNYK2R5Aji-EjpyT8gmgRYU&s=r_8muG61-ePlkCbqf7qIcHUPHGtjWf_JOH1UXH7lp8U&e=>
> and this was added recently to support the (very useful) TE use case which
> was defined in https://tools.ietf.org/html/draft-ietf-ospf-link-overload-
> 11
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dospf-2Dlink-2Doverload-2D11&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=7GM8zN1-Ff2au_agmHAkiNYK2R5Aji-EjpyT8gmgRYU&s=umZHmgXp6i4i0PAyZbsDS0iorBurDZsFIyvaVVXEHb0&e=>
> . When this was done the term "link-overload" was cut and pasted from the
> OSPF draft. I think this should also be changed in the IS-IS draft.
>
>
>
> Agreed.
>
>
>
> Thanks,
>
> Acee
>
>
>
>    Les
>
>
>
> > Thanks,
>
> > Acee
>
> > >
>
> > >
>
> > >
>
> >
>
> > [email-masked]
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ospf&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=7GM8zN1-Ff2au_agmHAkiNYK2R5Aji-EjpyT8gmgRYU&s=N51dsQzqzgGoBY61VJtqkgGHlrNjgZT_-9g8G_pcOyE&e=>
>

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 8 Jan 2018 18:00:41 +0000

If the WG consensus is for “GLS” so be it…but I would like to reemphasize two things:

1)There are use cases where the intent is NOT to shutdown the link

2)Once the link is shutdown the extension is no longer used since there is no longer an adjacency – so to me it makes a lot more sense to pick a name which reflects how the link is to be used while it is still up.

   Les

From: Pushpasis Sarkar [mailto:[email-masked]]
Sent: Monday, January 08, 2018 9:22 AM
To: Bruno Decraene <[email-masked]>
Cc: Shraddha Hegde <[email-masked]>; Acee Lindem (acee) <[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>; Joel Halpern <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Genart last call review of draft-ietf-ospf-link-overload-11

Hi Joel et al,

+1 for 'graceful-link-shutdown'. Another possibility may be 'link-decommission'..

Thanks and regards
-Pushpasis

On Mon, Jan 8, 2018 at 7:09 PM, <[email-masked]<mailto:[email-masked]>> wrote:

From: Shraddha Hegde

Looks good to me.

Best regards,
--Bruno

Rgds
Shraddha

Ketan –

   Les

Hello,

Thanks,
Ketan

Hi Les,

Agreed.

Thanks,
Acee

   Les

Thank you.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 9 Jan 2018 15:59:50 +0000

Hi Pushpasis, Shraddha, et al,

From: Pushpasis Sarkar <[email-masked]<mailto:[email-masked]>>
Date: Monday, January 8, 2018 at 12:22 PM
To: Bruno Decraene <[email-masked]<mailto:[email-masked]>>
Cc: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>, Acee Lindem <[email-masked]<mailto:[email-masked]>>, "Les Ginsberg (ginsberg)" <[email-masked]<mailto:[email-masked]>>, "Ketan Talaulikar (ketant)" <[email-masked]<mailto:[email-masked]>>, "Joel M. Halpern" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, OSPF WG List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Genart last call review of draft-ietf-ospf-link-overload-11
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>, Pushpasis Sarkar <[email-masked]<mailto:[email-masked]>>, Hannes Gredler <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, Luay Jalil <[email-masked]<mailto:[email-masked]>>, Acee Lindem <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, Alvaro Retana <[email-masked]<mailto:[email-masked]>>, Deborah Brungard <[email-masked]<mailto:[email-masked]>>, Alia Atlas <[email-masked]<mailto:[email-masked]>>, Acee Lindem <[email-masked]<mailto:[email-masked]>>
Resent-Date: Monday, January 8, 2018 at 12:22 PM

Hi Joel et al,

+1 for 'graceful-link-shutdown'.

I think we are converging on this. I must admit that it is much better than “link-overload”. Although Les raises a good point that this behavior could be used for other use cases, subsequent discussions have indicated that these could be handled differently.

Another possibility may be 'link-decommission'..

This implies too much permanence. If you decommission something, you are more or less retiring It which is not this use case. This is more of giving the link a rest. Maybe we could use the there term “Link on Leave” or LOL state ;^).

Thanks,
Acee

Thanks and regards
-Pushpasis

From: Shraddha Hegde

Looks good to me.

Best regards,
--Bruno

Rgds
Shraddha

Ketan –

   Les

Hello,

Thanks,
Ketan

Hi Les,

Agreed.

Thanks,
Acee

   Les

---

From: Pushpasis Sarkar <[email-masked]>
Date: Thu, 11 Jan 2018 14:55:46 +0530

Hi Acee,

LOL.. Might as well be 'link-on-break'.. :)

Anyways graceful-link-shutdown seems to be the most agreed upon.

Thanks and regards,
-Pushpasis

On Tue, Jan 9, 2018 at 9:29 PM, Acee Lindem (acee) <[email-masked]> wrote:

> From: Pushpasis Sarkar <[email-masked]>
> Cc: Shraddha Hegde <[email-masked]>, Acee Lindem <[email-masked]>,
> "Les Ginsberg (ginsberg)" <[email-masked]>, "Ketan Talaulikar
> (ketant)" <[email-masked]>, "Joel M. Halpern" <[email-masked]>, "
> [email-masked]" <[email-masked]>, OSPF WG List <[email-masked]>, "
> [email-masked]" <[email-masked]>, "draft-ietf-ospf-link-
> [email-masked]" <[email-masked]>
> Resent-From: <[email-masked]>
> Resent-To: Shraddha Hegde <[email-masked]>, Pushpasis Sarkar <
> [email-masked]>, Hannes Gredler <[email-masked]>, <
> [email-masked]>, Luay Jalil <[email-masked]>, Acee Lindem <
> [email-masked]>, <[email-masked]>, Alvaro Retana <[email-masked]>,
> Deborah Brungard <[email-masked]>, Alia Atlas <[email-masked]>, Acee
> Lindem <[email-masked]>
> I think we are converging on this. I must admit that it is much better
> than “link-overload”. Although Les raises a good point that this behavior
> could be used for other use cases, subsequent discussions have indicated
> that these could be handled differently.
>
>
> This implies too much permanence. If you decommission something, you are
> more or less retiring It which is not this use case. This is more of giving
> the link a rest. Maybe we could use the there term “Link on Leave” or LOL
> state ;^).
>
> Thanks,
> Acee
>
>
> Thanks and regards
> -Pushpasis
>
>> It is not in “maintenance" mode yet as it is still being used. However,
>> it is better than “overload”. “pending-maintenance” is a bit long which is
>> why I suggested “pending-shutdown” since “shutdown” is term that vendors
>> have used for eons to described an interface that is not in service.
>>
>> Thanks,
>>
>> Acee
>>
>>
>>
>> [email-masked]" <
>> [email-masked]>
>> *To: *Acee Lindem <[email-masked]>, "Joel M. Halpern" <
>> [email-masked]>, "[email-masked]" <[email-masked]>
>> [email-masked]" <
>> [email-masked]>
>> was defined in https://tools.ietf.org/html/dr
>> aft-ietf-ospf-link-overload-11

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 11 Jan 2018 09:54:51 -0800

+1 on GLS, GS has well defined semantics, (L)ink describes the context 

Cheers,

Jeff

From: OSPF <[email-masked]> on behalf of Pushpasis Sarkar <[email-masked]>
Date: Thursday, January 11, 2018 at 01:25
To: "Acee Lindem (acee)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [OSPF] Genart last call review of draft-ietf-ospf-link-overload-11

Hi Acee,

Thanks and regards,

-Pushpasis

From: Pushpasis Sarkar <[email-masked]>
Date: Monday, January 8, 2018 at 12:22 PM
To: Bruno Decraene <[email-masked]>
Cc: Shraddha Hegde <[email-masked]>, Acee Lindem <[email-masked]>, "Les Ginsberg (ginsberg)" <[email-masked]>, "Ketan Talaulikar (ketant)" <[email-masked]>, "Joel M. Halpern" <[email-masked]>, "[email-masked]" <[email-masked]>, OSPF WG List <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Genart last call review of draft-ietf-ospf-link-overload-11
Resent-From: <[email-masked]>
Resent-To: Shraddha Hegde <[email-masked]>, Pushpasis Sarkar <[email-masked]>, Hannes Gredler <[email-masked]>, <[email-masked]>, Luay Jalil <[email-masked]>, Acee Lindem <[email-masked]>, <[email-masked]>, Alvaro Retana <[email-masked]>, Deborah Brungard <[email-masked]>, Alia Atlas <[email-masked]>, Acee Lindem <[email-masked]>
Resent-Date: Monday, January 8, 2018 at 12:22 PM

Hi Joel et al, 

 

Thanks,

Acee

Thanks and regards

-Pushpasis

 

From: Shraddha Hegde

Looks good to me.

Best regards,

--Bruno

Rgds

Shraddha

Thanks,

Acee 

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thursday, January 4, 2018 at 11:56 PM
To: "Ketan Talaulikar (ketant)" <[email-masked]>, Acee Lindem <[email-masked]>, "Joel M. Halpern" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: OSPF WG List <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Genart last call review of draft-ietf-ospf-link-overload-11

Ketan –

   Les

Hello,

Thanks,

Ketan

Hi Les, 

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thursday, January 4, 2018 at 9:26 PM
To: Acee Lindem <[email-masked]>, "Joel M. Halpern" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: OSPF WG List <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Genart last call review of draft-ietf-ospf-link-overload-11

 

The suggestion from Shraddha that this term was borrowed from IS-IS isn't accurate. "overload" in IS-IS has a very different meaning - it indicates a node either has an incomplete LSDB or (a la RFC 3277 )an incomplete forwarding plane.

Agreed. 

Thanks,

Acee 

   Les

 

 

_______________________________________________ OSPF mailing list [email-masked] https://www.ietf.org/mailman/listinfo/ospf

---

From: Shraddha Hegde <[email-masked]>
Date: Fri, 12 Jan 2018 02:50:58 +0000

OSPF WG,

WG consensus seems to be graceful-link-shutdown.
I’ll update the draft with graceful-link-shutdown and also add some text
Describing this mechanism can also be used when the real intent is not to shutdown
the link.

Let me know if there are any objections.

Rgds
Shraddha

From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
Sent: Monday, January 8, 2018 11:31 PM
To: Pushpasis Sarkar <[email-masked]>; Bruno Decraene <[email-masked]>
Cc: Shraddha Hegde <[email-masked]>; Acee Lindem (acee) <[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>; Joel Halpern <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Genart last call review of draft-ietf-ospf-link-overload-11

   Les

Cc: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>>; Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; Joel Halpern <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Hi Joel et al,

Thanks and regards
-Pushpasis

From: Shraddha Hegde

Looks good to me.

Also, FYI, for BGP sessions, in the GROW WG we used the term “Graceful BGP session shutdown” and named the BGP community “GRACEFUL_SHUTDOWN” so this would align on the terminology.
https://tools.ietf.org/html/draft-ietf-grow-bgp-gshut-13<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dgrow-2Dbgp-2Dgshut-2D13&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=j5OSxniUADg7fBg9lmrSvsTWGWY_VhCl-Ydi9t0XfFI&s=R0GJNP0TbKHBFiCCQKwDlB7YVSgmQsq4p7JvCtd_leM&e=>

Best regards,
--Bruno

Rgds
Shraddha

Ketan –

   Les

Hello,

Thanks,
Ketan

Hi Les,

Agreed.

Thanks,
Acee

   Les

Thank you.