Subject: [Gen-art] Genart telechat review of draft-ietf-kitten-rfc5653bis-06

From: Joel Halpern <[email-masked]>
Date: Tue, 02 Jan 2018 15:30:31 -0800

Reviewer: Joel Halpern
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair. Please wait for direction from your
document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-kitten-rfc5653bis-06
Reviewer: Joel Halpern
Review Date: 2018-01-02
IETF LC End Date: 2017-09-11
IESG Telechat date: 2018-01-25

Summary: This document is ready for publication as a Proposed Standard RFC

Major issues: None

Minor issues:
    Although ID-Nits does not complain about it, I can find no reference to
    RFCs 2119 or 8174.  Some of the uses of "must" int he document are along
    the lines of "inherently follows", which is not normative language.  But
    other uses are clearly normative in structure.   It is unclear why the
    reference to RFC 2119 was removed as part of this update.

Nits/editorial comments:

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 2 Jan 2018 19:38:09 -0600

Hi Joel,

>     reference to RFC 2119 was removed as part of this update.

Thanks for the review -- I'm a bit surprised that id-nits does not
complain about the omission.

I do not know why the -00 dropped that clause, but it does seem like
the current normal text citing 8174 should be added before
publication.

-Ben

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 2 Jan 2018 20:49:19 -0500

Thanks Ben.  That would be good.
Yours,
Joel

---

From: Weijun Wang <[email-masked]>
Date: Wed, 3 Jan 2018 10:40:23 +0800

Hi Joel and Ben

Author here.

I think I've removed the section because in fact none of the keywords appears as capitalized inside the original document. In fact, RFC 8174 has "that only UPPERCASE usage of the key words have the defined special meanings".

I assume I'll need to go through the document and make some UPPERCASE and some not, depending on the actual meanings.

Or, since this is a bis and changing the cases would be considered an re-intepretation of the whole document (which wasn't my goal), is it more reasonable to keep using RFC 2119 and leave all "must" and "required" in lowercase?

Thanks
Weijun

> On Jan 3, 2018, at 9:49 AM, Joel M. Halpern <[email-masked]> wrote:
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 2 Jan 2018 21:50:19 -0500

Personal opinion:
Given that to my reading "must" is used on the document in both the RFC 
2119 sense and in a conventional English language sense, it would be 
worth clarifying the intention.  As such, I think it would be better to 
use the 8174 reference and go through changing the right ones to upper case.

Yours,
Joel

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 2 Jan 2018 21:08:18 -0600

I am inclined to agree that it is better to change the right ones to
upper case -- we really don't have a good reason to still be
producing documents with this type of ambiguity anymore.

Once that is done we can decide whether the change is
substantial enough to require re-running the last call.

-Ben

---

From: Weijun Wang <[email-masked]>
Date: Wed, 3 Jan 2018 11:48:47 +0800

Thanks for the suggestion. I'll go through the doc and post another version.

--Weijun

> On Jan 3, 2018, at 11:08 AM, Benjamin Kaduk <[email-masked]> wrote:
>

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 23 Jan 2018 14:05:44 -0500

Joel, thanks for your review. I think the WG will need to review the changes to make sure people agree with which keywords become capitalized. I’m holding a DISCUSS about that.

Alissa

> On Jan 2, 2018, at 10:48 PM, Weijun Wang <[email-masked]> wrote:
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Weijun Wang <[email-masked]>
Date: Wed, 24 Jan 2018 07:43:22 +0800

I've uploaded an updated version at

  http://cr.openjdk.java.net/~weijun/rfc5653bis/draft-ietf-kitten-rfc5653bis-07.html

before submitting a new I-D draft. This page shows all keywords in color (gray for lowercase, red for uppercase), hopefully this will be easy for everyone to review.

Thanks
Weijun

> On Jan 24, 2018, at 3:05 AM, Alissa Cooper <[email-masked]> wrote:
>

---

From: Greg Hudson <[email-masked]>
Date: Fri, 26 Jan 2018 21:12:54 -0500

>   http://cr.openjdk.java.net/~weijun/rfc5653bis/draft-ietf-kitten-rfc5653bis-07.html

This is a great format for reviewing these changes; thanks for
generating it.

Line 416 does not capitalize "optional" in "optional services", but
lines 385 and 391 do.

Lines 422 and 424 should probably capitalize "should".  Line 429 should
probably capitalize "may".

At line 598, I would lean towards leaving "MUST" in lowercase as we are
describing an application requirement, not prescribing one.

Line 1174, I would leave "MAY" in lowercase.

Line 1129, "may" should probably be capitalized.

Line 1369, I would leave "MAY" alone as this seems more descriptive than
prescriptive.

Line 3221's use of "SHOULD" is prescriptive, but there's no other way to
request the default QOP.  So I would leave it lowercase (or change the
wording, but I'm not trying to open any more cans of worms).

---

From: Weijun Wang <[email-masked]>
Date: Sun, 28 Jan 2018 21:41:03 +0800

Hi Greg

Thank you so much for your careful review. All suggestions accepted.

> On Jan 27, 2018, at 10:12 AM, Greg Hudson <[email-masked]> wrote:
> 

Glad you like it. I have to do this to avoid words like the 2nd MAY in the 3rd paragraph on page 45.

> Line 1129, "may" should probably be capitalized.

1179?

Thanks
Weijun

---

From: Greg Hudson <[email-masked]>
Date: Sun, 28 Jan 2018 13:34:01 -0500

On 01/28/2018 08:41 AM, Weijun Wang wrote:>> Line 1129, "may" should
probably be capitalized.

No, that one looks okay.  I think I must have meant line 1229: "The
application may use byte arrays..."

---

From: Weijun Wang <[email-masked]>
Date: Mon, 29 Jan 2018 09:06:07 +0800

> On Jan 29, 2018, at 2:34 AM, Greg Hudson <[email-masked]> wrote:
> 

I see. Accepted.

Thanks
Weijun

---

From: Weijun Wang <[email-masked]>
Date: Mon, 29 Jan 2018 09:26:08 +0800

The HTML file updated in place.

Thanks
Weijun

> Line 1229, "may" should probably be capitalized.
>