Subject: [Gen-art] Genart last call review of draft-ietf-bfd-multipoint-active-tail-09

From: Linda Dunbar <[email-masked]>
Date: Thu, 28 Jun 2018 12:30:36 -0700

Reviewer: Linda Dunbar
Review result: Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-bfd-multipoint-active-tail-??
Reviewer: Linda Dunbar
Review Date: 2018-06-28
IETF LC End Date: 2018-06-18
IESG Telechat date: 2018-07-05

Summary: clear writing of the procedure.

Major issues: None

Minor issues: None

Nits/editorial comments:

Are End points that not responding considered "Inactive Tails"?  Does the
HeadEnd report the "Inactive Tails"?

Linda Dunbar

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 29 Jun 2018 09:45:02 -0700

Hi Linda,
thank you for the review and your kind words, much appreciated.

If an end-point during the p2mp BFD session never responded to the head's
multicast poll it is unknown to the head and cannot be reported as
"inactive tail". I can imagine that if the head has been given the list of
the tails, then the unresponsive end-point can be reported as "inactive
tails".

Regards,
Greg

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 29 Jun 2018 16:51:58 +0000

Greg,

Thanks for the reply.

It might be too late to ask this question, I am curious if the head-end is aware of the list of end points, what is wrong if they just use unicast BFD to each of them? Multicast-BFD seems requires more support of the network, isn’t it?

Linda

From: Greg Mirsky [mailto:[email-masked]]
Sent: Friday, June 29, 2018 11:45 AM
To: Linda Dunbar <[email-masked]>
Cc: [email-masked]; [email-masked]; IETF list <[email-masked]>; [email-masked]
Subject: Re: Genart last call review of draft-ietf-bfd-multipoint-active-tail-09

Hi Linda,

If an end-point during the p2mp BFD session never responded to the head's multicast poll it is unknown to the head and cannot be reported as "inactive tail". I can imagine that if the head has been given the list of the tails, then the unresponsive end-point can be reported as "inactive tails".

Regards,
Greg

On Thu, Jun 28, 2018 at 12:30 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
Reviewer: Linda Dunbar
Review result: Ready

Major issues: None

Minor issues: None

Nits/editorial comments:

Linda Dunbar

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 29 Jun 2018 10:17:00 -0700

Hi Linda,
thank you for the question. Always happy to discuss the technology.

If the head is required to know the state of the set of the tails, then
using p2p BFD session between the head and each of such tails may be the
right solution. But it may be challenging to ensure that the unicast path
from the head to each of the tails in that set is co-routed with the
multicast path used to transport the data. The use of p2mp BFD does ensure
that the BFD control packets transmitted by the head follow exactly the
same path as data packets of the monitored flow.

Regards,
Greg

On Fri, Jun 29, 2018 at 9:51 AM, Linda Dunbar <[email-masked]>
wrote:

> Greg,
>
>
>
> Thanks for the reply.
>
>
>
> It might be too late to ask this question, I am curious if the head-end is
> aware of the list of end points, what is wrong if they just use unicast BFD
> to each of them? Multicast-BFD seems requires more support of the network,
> isn’t it?
>
>
>
> Linda
>
>
>
> *From:* Greg Mirsky [mailto:[email-masked]]
> *Sent:* Friday, June 29, 2018 11:45 AM
> *To:* Linda Dunbar <[email-masked]>
> *Cc:* [email-masked]; [email-masked]; IETF list <[email-masked]>;
> [email-masked]
> *Subject:* Re: Genart last call review of draft-ietf-bfd-multipoint-
> active-tail-09
>
>
>
> Hi Linda,
>