Subject: [Gen-art] Genart last call review of draft-ietf-dcrup-dkim-crypto-12

From: Pete Resnick <[email-masked]>
Date: Mon, 11 Jun 2018 09:22:23 -0700

Reviewer: Pete Resnick
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-dcrup-dkim-crypto-12
Reviewer: Pete Resnick
Review Date: 2018-06-11
IETF LC End Date: 2018-06-12
IESG Telechat date: 2018-06-21

Summary: Nice simple document; Ready to go with nits.

Major issues:

None.

Minor issues:

None.

Nits/editorial comments:

Nit: You should update the 2119 template to the 8174 template.

Comment: If this kind of update is only going to happen every 6 or 7 years, I
guess it's fine, but all that this document really does is: - Trivially update
the ABNF - Add the algorithm to the registry - Update the normative
instructions to indicate that this new algorithm be used. That really could
have all be done with a registry update if the registry had a field for
normative instructions for use of the algorithm. I suppose it's no longer a big
deal to add one more document to the eight-odd-thousand RFCs, but still...

pr

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 20 Jun 2018 15:00:32 -0400

Pete, thanks for your review. I think the whole point of chartering DCRUP was to produce documents such as this.

John, thanks for updating to reference RFC 8174, although I agree with Adam that the boilerplate should match 8174.

Thanks,
Alissa

> On Jun 11, 2018, at 12:22 PM, Pete Resnick <[email-masked]> wrote:
> 
> Reviewer: Pete Resnick
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: "John R. Levine" <[email-masked]>
Date: 20 Jun 2018 15:38:24 -0400

> John, thanks for updating to reference RFC 8174, although I agree with Adam that the boilerplate should match 8174.

It's fixed in the copy I have here, waiting to see what other nits to 
fix show up in LC before posting the final.

By the way, there are comments in the XML pointing out the stuff to 
remove, which have been there all along.

R's,
John

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 21 Jun 2018 10:25:17 -0400

> On Jun 20, 2018, at 3:38 PM, John R. Levine <[email-masked]> wrote:
> 
> It's fixed in the copy I have here, waiting to see what other nits to fix show up in LC before posting the final.
> 
> By the way, there are comments in the XML pointing out the stuff to remove, which have been there all along.

Ok. I don’t read the XML when doing my IESG reviews.

Alissa

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 21 Jun 2018 15:30:08 +0100

Hi John,

> fix show up in LC before posting the final.

Please post a new revision. The document is approved pending a new revision (or an email from you saying that none is needed).

Thank you,
Alexey

---

From: "John R. Levine" <[email-masked]>
Date: 21 Jun 2018 11:43:52 -0400

> Please post a new revision. The document is approved pending a new revision (or an email from you saying that none is needed).

I posted -14 which I think addresses the comments.

Changed security section to point to 8032 for ed25519 rather than RSA.

Added a sentence noting the two independent signatures.

Fixed the MUSTard boiletplate.

Whew!

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly