Subject: [Gen-art] Genart last call review of draft-ietf-idr-bgp-prefix-sid-21

From: Peter Yee <[email-masked]>
Date: Wed, 13 Jun 2018 00:04:39 -0700

Reviewer: Peter Yee
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-idr-bgp-prefix-sid-21
Reviewer: Peter Yee
Review Date: 2018-06-12
IETF LC End Date: 2018-06-12
IESG Telechat date: Not scheduled for a telechat

Summary: This document is ready for publication, although there are a few nits
that should be corrected prior to publication.  I am not a routing expert, so I
cannot vouch for the correctness of this specification, but it otherwise
appears consistent and reflect s the many iterations it has undergone.

Major issues: None.

Minor issues: None

Nits/editorial comments:

General:

Expand uncommon acronyms on first use.  (See:
https://www.rfc-editor.org/materials/abbrev.expansion.txt.).  Acronyms need
expansion include: AS, ECMP, and EBGP.

Specific:

Page 3, 7th paragraph, last sentence: actually, this isn’t a complete sentence.
 I’m not sure what you wanted to do with the fragment.

Page 5, 2nd full paragraph, last sentence: change “prefix-SID” to “BGP
Prefix-SID” to make usage in the remainder of the document.

Page 7, Section 3.2, 2nd bullet item: insert “positive” before “multiple”.

Page 9, last paragraph, 1st sentence: delete “to”.

Page 12, 1st paragraph after the (unlabeled) Value/Type/Reference table, last
sentence: insert “ Prefix” before “-SID”.

Page 12, 2nd paragraph after the (unlabeled) Value/Type/Reference table, last
sentence: insert “ Prefix” before “-SID”.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 13 Jun 2018 14:08:31 +0000

Hi Peter, 
Thanks for thoroughly reviewing this document again and finding the nits. I incorporated all your comments other than adding "positive" as while it is more precise, it reads better without it and we don't want to imply that a TLV length could ever be negative. See attached diff. 
Thanks,
Acee 

On 6/13/18, 3:04 AM, "Peter Yee" <[email-masked]> wrote:

    Reviewer: Peter Yee

    

    
    Major issues: None.
    
    Minor issues: None
    
    Nits/editorial comments:
    
    General:

    Specific:

---

From: Peter Yee <[email-masked]>
Date: Wed, 13 Jun 2018 08:26:19 -0700

Acee,

I’m fine with leaving out positive. I was actually trying to cover the case where someone might interpret the TLV definition to allow zero SRGBs. It’s nonsensical, of course, to do so. 

                                -Peter

On Jun 13, 2018, at 7:08 AM, Acee Lindem (acee) <[email-masked]> wrote:

Hi Peter, 

   Reviewer: Peter Yee

   Major issues: None.

   Minor issues: None

   Nits/editorial comments:

   General:

   Specific:

<Diff draft-ietf-idr-bgp-prefix-sid-21.txt - draft-ietf-idr-bgp-prefix-sid-22.txt>