Subject: [Gen-art] Genart last call review of draft-ietf-pals-ethernet-cw-06

From: Brian Carpenter <[email-masked]>
Date: Mon, 11 Jun 2018 20:30:51 -0700

Reviewer: Brian Carpenter
Review result: Ready with Nits

Gen-ART Last Call review of draft-ietf-pals-ethernet-cw-06

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-pals-ethernet-cw-06.txt
Reviewer: Brian Carpenter
Review Date: 2018-06-12
IETF LC End Date: 2018-06-15
IESG Telechat date: 2018-06-21

Summary: Ready with nits
--------

Comments: 
---------

This (with RFC4928) is a wonderful example of why layer violations are a Bad Thing.

Nits:
-----

> 1.  Introduction
...
>   This document recommends the use of the Ethernet pseudowire control
>   word in all but exceptional circumstances.

That's wrong, it *mandates* this usage with a MUST (first paragraph of section 4).

> 3.  Background
...
>   A recent posting on the Nanog email list has highlighted this
>   problem:
>
>   https://mailman.nanog.org/pipermail/nanog/2016-December/089395.html

No, it's no longer recent. How about:

   For example, a posting on the Nanog email list highlighted this
   problem:

> 7.  Operational Considerations
>
>   CW presence on the PW is controlled by the configuration and may be
>   subject to default operational mode of not being enabled. 

That sentence is hard to parse. Try this:

   A configuration switch might determine whether the CW is used on the PW. 
   The default configuration might be to disable use of the CW.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 12 Jun 2018 13:50:51 -0400

Brian,

Thanks, your comments are much appreciated.

Cheers,
Andy

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 18 Jun 2018 13:44:41 -0400

Brian, thanks for your review. Andy, thanks for your response; hopefully it means Brian’s comments will be addressed? I have entered a No Objection ballot.

Alissa

> On Jun 12, 2018, at 1:50 PM, Andrew G. Malis <[email-masked]> wrote:
> 
> Brian,
> 
> On Mon, Jun 11, 2018 at 11:30 PM, Brian Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>>.
> 
> ....
> ....
> >   https://mailman.nanog.org/pipermail/nanog/2016-December/089395.html <https://mailman.nanog.org/pipermail/nanog/2016-December/089395.html>
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 18 Jun 2018 14:44:27 -0400

Alissa,

Yes, they will be. We were waiting for all LC comments to come in, and it
looks like we’ve reached the end of the LC period. We’ll check with Deborah
for guidance on when to update.

Cheers,
Andy

On Mon, Jun 18, 2018 at 1:44 PM, Alissa Cooper <[email-masked]> wrote:

> Brian, thanks for your review. Andy, thanks for your response; hopefully
> it means Brian’s comments will be addressed? I have entered a No Objection
> ballot.
>
> Alissa
>

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 19 Jun 2018 10:35:57 +0100

Hi Alissa

Yes, we will address all review comments that we receive.

- Stewart

On 18/06/2018 18:44, Alissa Cooper wrote:
> Brian, thanks for your review. Andy, thanks for your response; 
> hopefully it means Brian’s comments will be addressed? I have entered 
> a No Objection ballot.
>
> Alissa
>
>> On Jun 12, 2018, at 1:50 PM, Andrew G. Malis <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Brian,
>>
>> On Mon, Jun 11, 2018 at 11:30 PM, Brian Carpenter 
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>     <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq
>>     <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>>.
>>
>>     <https://mailman.nanog.org/pipermail/nanog/2016-December/089395.html>
>>
>> [email-masked] <mailto:[email-masked]>

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 21 Jun 2018 10:25:41 -0400

Thanks!

> On Jun 19, 2018, at 5:35 AM, Stewart Bryant <[email-masked]> wrote:
> 
> Hi Alissa
> 
>>> On Jun 12, 2018, at 1:50 PM, Andrew G. Malis <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Brian,
>>> 
>>> https://www.ietf.org/mailman/listinfo/gen-art <https://www.ietf.org/mailman/listinfo/gen-art>
>> 
>