Subject: [Gen-art] review of draft-ietf-ccamp-mw-yang-09.txt

From: Francis Dupont <[email-masked]>
Date: Tue, 02 Oct 2018 22:34:40 +0200

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-ccamp-mw-yang-09.txt
Reviewer: Francis Dupont
Review Date: 20180926
IETF LC End Date: 20181002
IESG Telechat date: unknown

Summary: Ready

Major issues: None

Minor issues: None

Nits/editorial comments: 
 The yang model mixes config, state and actions, not like the others
I know. But if the Yang experts have no concern I have none too...

 - 4 page 7: I notices the date of the model is 2018-06-30 when
  it was modified the 2018-08-31. I don't know the rule, perhaps
  the date is updated just before publication? Not an issue by itself.

 - action manual-switch-working page 30 and many others: please add a
  space before '{'.

 - A.1 page 46: the JSON is not valid (even it is readable) and I am afraid
  it is really JSON and not something JSON like. In detail:
   // does not begin comments in JSON (there are no comments in fact
   in JSON so IMHO it is not a real problem :-)
   extra commas (more an issue)

 - A.1 page 46: please add a space in "single":{

 - same comments about A.2 pages 47 and 48, and A.3 pages 48-50
  (with BTW two "single":{)

 - B page 50: Spain (ESP) -> Spain

Regards

[email-masked]

---

From: Jonas Ahlberg <[email-masked]>
Date: Wed, 3 Oct 2018 11:22:21 +0000

Hi Francis,

Thanks for your review.

We have now submitted a new version of the draft with the following changes that we hope address your feedback :
- The date of the models have been updated to the same date as the draft
- There is now a single space before all "{" in the draft
- the comments have been removed from the JSON examples. The description leaf is enough to explain what the entry refers to.
- I've tried to correct the usage of commas in the JSON examples. Please let me know if it's still not fully correct.
- "(ESP)" is removed
- " Maintained by IANA?: N" has been added for all modules in the IANA considerations, according to earlier feedback from IANA

Regards
JonasA

------------------------------
A new version of I-D, draft-ietf-ccamp-mw-yang-10.txt has been successfully submitted by Jonas Ahlberg and posted to the IETF repository.

Name:		draft-ietf-ccamp-mw-yang
Revision:	10
Title:		A YANG Data Model for Microwave Radio Link
Document date:	2018-10-03
Group:		ccamp
Pages:		51
URL:            https://www.ietf.org/internet-drafts/draft-ietf-ccamp-mw-yang-10.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-ccamp-mw-yang/
Htmlized:       https://tools.ietf.org/html/draft-ietf-ccamp-mw-yang-10
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-mw-yang
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-mw-yang-10

----------------------------------

-----Original Message-----
From: Francis Dupont <[email-masked]> 
Sent: den 2 oktober 2018 22:35
To: [email-masked]
Cc: [email-masked]
Subject: review of draft-ietf-ccamp-mw-yang-09.txt

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

Summary: Ready

Major issues: None

Minor issues: None

Nits/editorial comments: 
 The yang model mixes config, state and actions, not like the others I know. But if the Yang experts have no concern I have none too...

Regards