Subject: general question

From: Gazzella <[email-masked]>
Date: Mon, 10 Sep 2001 16:39:31 +0200

Hi all,
i am a student.
What is the method proposed for a host to figure out its actual physical
location?
What is a general positioning network architecture?
thank you

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 10 Sep 2001 10:57:40 -0400

The charter states we don't worry about that.
The answer is, there are quite a few methods,
any of which will work:

1. GPS
2. Triangulation of a radio transmitter
3. Dead reckoning
4. Others too numerous to mention

A combination may often be used.

Interestingly, there are plenty of uses where
the thing we want to find the location of doesn't
actually move.  The one of interest to me is
a telephone.  Most phones don't move.  An office
phone "might" move, but the socket it is plugged
to in the wall doesn't (don't mean to imply
"EVER" here).  I want the geopriv object to
work in that case -- the location might be
manually entered in such a case.

Of course, we get to an old issue with reporting
location - in what form?  Many times, people
assume that it's lat/lon/altitude, but often
we want country/state/county/city/street/building/
floor/room.  You can translate from one to the other
with a database.  

What does this mean to geopriv?

 - the object has to work with a wide variety of
location determination mechanisms, including
manually entered.

 - the object has to work with stationary objects

 - The object has to support both ways of representing
location simultaneously (that is, both representations
may be in a single report)

 - There has to be a way to support a translator as an
independent entity in the path from producer to
consumer.

 - The object has to have some flags that tell you what
the original format was, and identifier of 
who translated it.

Brian

> -----Original Message-----
> From: Gazzella [mailto:[email-masked]]
> Sent: Monday, September 10, 2001 10:40 AM
> To: [email-masked]
> Subject: general question
> 
> 
> Hi all,
> i am a student.

---

From: Bill Manning <[email-masked]>
Date: Mon, 10 Sep 2001 08:39:28 -0700 (PDT)

Figuring out "where" something is (and "recording" that data) is fairly
straightforward.  The tough part is what friend Bush has been trying to
hammer home (and its showing up in other places as well.. provreg for
example) which is:

Who gets to know (and to what precision) which attributes about "where"
the object of desire "is"?   For the properly paranoid, that means each
object of desire (OOD) needs to "know" about everything that might want
to find out "where" it is, attach a policy to it so it knows what and 
how much info to release to the querier.  This might be too much state to
keep.

While it may be too much to have the protocol make the presumption that 
any OOD can be located to an arbitrary degree of precision, it is overkill
(IMHO) to require the OOD to keep an arbitrary number of policies about
who gets to know what and to to a given degree of precision. 

Finding that middle ground will be tough.  And when "rough consensus" is
reached, it will be, at best, an 80% solution; i.e. no one will like it.

--bill

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 10 Sep 2001 18:14:43 -0400

There are such formats

Brian

> From: Adam Shostack [mailto:[email-masked]]
> Sent: Monday, September 10, 2001 6:07 PM
> To: Rosen, Brian
> Cc: 'Bill Manning'; [email-masked]; [email-masked]
> Subject: Re: general question
> 
> 
> On Mon, Sep 10, 2001 at 05:51:52PM -0400, Rosen, Brian wrote:
> > > In anycase,
> > > Ok.  The OOD has what attributes wrt the "geo" component 
> of geopriv?
> > > 
> > > 	lat/log/alt
> > > 	vector/velocity
> > > 	mass/"size"
> > Need the other form:
> > planet/country/state/county/city/street/building/floor/room
> > Need both in the report, plus a flag that tells if one value
> > was translated into the other, and another field for who did the
> > translation.
> 
> I thought that we were supposed to select an existing format, not
> create a new one?
> 
> Adam
> 
> -- 
> "It is seldom that liberty of any kind is lost all at once."
> 					               -Hume
> 
>