Subject: [Geopriv] RE: draft-ietf-geopriv-radius-lo-01.txt - CDMA operator-name prefix

From: [email-masked]
Date: Thu, 25 Nov 2004 08:37:46 +0200

Hi,

Comments inline.

/Jouni

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Jari Arkko
> Sent: 24. marraskuuta 2004 22:11
> To: Joel M. Halpern
> Cc: [email-masked]; [email-masked]
> Subject: Re: draft-ietf-geopriv-radius-lo-01.txt - CDMA 
> operator-name prefix
> 
> Jari Arkko wrote:
> 
> > The GSM prefix appears to have the same issue. I know
> > there are GSM operator codes (MNCs) but the document
> > does not refer to them, but some notion of a text based
> > identity. I'm not sure if the GSMA is keeping a registry
> > of the text based identities as well. In any case a
> > reference to the registry/allocation responsible would
> > be needed.
> 
> I did some further digging... there *is* a TADIG naming system
> for all operators, see:
> 
>    http://www.gsmworld.com/about/structure/tadig.shtml
> 
> Its defined by GSMA. But I'm still searching for a good reference
> that could be put to the document, however.

The TADIG code (for GSM: prefix) mentioned in the current draft
is defined in GSM Association Permanent Reference Document TD.13.
(GSMA PRD TD.13). 

"The TADIG Code shall consist of 2 fields, with a total length
 of 5 characters consisting of a 3-character country code and a
 2-character operator (or company) ID."

The code is available for anyone for 100£ yearly fee.

> 
> --Jari
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://psg.com/lists/radiusext/>
> 

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 25 Nov 2004 11:16:41 -0500

These codes are being normatively referenced in an IETF standard.
It is very unusual for the IETF to reference in such a fashion a document 
that is not publicly and freely available.  The IETF is not usually 
interested in defining a name space that can only be referenced and 
understood by a proprietary community.  (Being assigned by a specific 
community is fine, and in fact frequently necessary for name spaces.)

This leads to several obvious questions:
1) Is there actually a need for any name spaces other than realm?  All CDMA 
and GSM operators have dedicated names suitable for use as REALMS.
2) If it is important to use other name spaces, then an explanation of why 
it is needed ought to be included.  And the community that wants their name 
space useable ought to make their registry publicly readable.
3) At the very least, it is necessary to explicitly and normatively 
reference the GSM Association Permanent Reference Document.

Yours,
Joel M. Halpern