Subject: [Geopriv] draft-ietf-geopriv-radius-lo-01.txt - CDMA operator-name prefix

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 18 Nov 2004 16:46:41 -0500

Description of issue: Operator-Name prefix defined without usage
Submitter name: Joel M. Halpern
Submitter email address: [email-masked]
Date first submitted: 18-November-2004
Reference:
Document: draft-ietf-geopriv-radius-lo-01.txt
Comment type: T
Priority: 2
Section: 5.1
Rationale/Explanation of issue:  The operator prefix CDMA is defined, but 
never user
Length description of problem:
     The CDMA operator-name prefix is listed as a valid prefix in section 
5.1.  However, no definition is included as to what names may use such a 
prefix or how they should use it.

Requested change:
     Either describe who allocates "CDMA" operator names, and how such 
names are allocated, ore remove the name

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Jari Arkko <[email-masked]>
Date: Wed, 24 Nov 2004 21:34:37 +0200

Joel M. Halpern wrote:
> Rationale/Explanation of issue:  The operator prefix CDMA is defined, 
> but never user

The GSM prefix appears to have the same issue. I know
there are GSM operator codes (MNCs) but the document
does not refer to them, but some notion of a text based
identity. I'm not sure if the GSMA is keeping a registry
of the text based identities as well. In any case a
reference to the registry/allocation responsible would
be needed.

The REALM prefix is the only one that does not have an
issue, although I'm not sure the text for that is
100% accurate either. How about

   REALM can be used by any domain name acquired from IANA.

=>

   The right to use of REALM with a specific name is
   obtained coincident with acquiring the rights to use the
   particular Fully Qualified Domain Name (FQDN). Using
   a REALM name without ownership of the supplied FQDN
   creates the possibility of conflict and is therefore
   discouraged.

--Jari

---

From: Jari Arkko <[email-masked]>
Date: Wed, 24 Nov 2004 22:10:30 +0200

> reference to the registry/allocation responsible would

I did some further digging... there *is* a TADIG naming system
for all operators, see:

   http://www.gsmworld.com/about/structure/tadig.shtml

Its defined by GSMA. But I'm still searching for a good reference
that could be put to the document, however.

--Jari