Subject: [Geopriv] Dynamic response?

From: "YANHAO WU" <[email-masked]>
Date: Thu, 12 May 2005 17:52:58 +0200

Hi All,
Geographic information disclosure depand on who is requesting and why he/she is questing. Dynamic response might be better than rule enforcement. Real-time authorization will provide a means for users to decide dymanicly how much detail(eg. street-level) and how long(eg. 2 hours) and frequence(eg. notify once/1 minute ) they want to reveal their locaiton information.

For instance, as regarding geographic information disclosure, Bob's willingness to reveal his information primarily depends on the social relationships between him and Alice, and why Alice is requesting. Responses might be quite different if Caro want to request bob's location information.  Or even Alice request with a different reason.

Step 1 |----Subscribe----->|----Subscribe------>| Request state subscription
Step 2 |<-------202---------|<--------202--------| 
Step 3 |<-------------NOTIFY (pending)----------| authorization(interact with user)
Step 4 |---------------------200------------------>| Acknowledge notifying

SIP authorization mechnism with 202 response provide a way to communicate with user in real time. 
I don't know if common-policy and geopriv-policy can provide a real time interaction with users for them to decide dynamicaly?
Can some one help to clear this issue for me? thanks!

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Tschofenig Hannes
Sent: Tuesday, May 10, 2005 10:15 PM
To: 'YANHAO WU'; [email-masked]
Subject: AW: [Geopriv] a usage of SIP for privacy concerned LBS

hi, 

i quickly went through the text you have provided with the attachment. 
why don't you just use a combination of 
- common-policy:
http://www.ietf.org/internet-drafts/draft-ietf-geopriv-common-policy-04.txt 
- geopriv-policy:
http://www.ietf.org/internet-drafts/draft-ietf-geopriv-policy-05.txt
- pdif-lo:
http://www.ietf.org/internet-drafts/draft-ietf-geopriv-pidf-lo-03.txt
- sip+lo:
http://www.softarmor.com/wgdb/docs/draft-polk-sipping-location-requirements-
01.txt

ciao
hannes

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] 
> [mailto:[email-masked]] Im Auftrag von YANHAO WU
> Gesendet: Donnerstag, 5. Mai 2005 09:31
> An: [email-masked]
> Betreff: [Geopriv] a usage of SIP for privacy concerned LBS
> 
> 
> Hi
>  All, have a look of attachment. Please give me some suggestions. 
>  Subscriber (Alice)     SIP Proxy             Notifier (Bob)
>  Step 1 |----Subscribe----->|----Subscribe------>| Request state
> subscription
>  Step 2 |<-------202----------|<--------202-----------| plausible
> deniability "pending"
>  Step 3 |<-------------NOTIFY (pending)-----------| Waiting for
> authorization
>  Step 4 |----------------------200--------------------->| Acknowledge
> notifying
>  Step 5 |<-------------NOTIFY (active)-------------| Notify geographic
> information
>  Step 6 |----------------------200--------------------->| Acknowledge
> notifying
>    PUA (Alice)          SIP Proxy           Watcher (Hospital)     
>  Step 7 |------Publish------->|                              | update
> emergency information
>  Step 8 |<-------200----------|                              |
> Acknowledge publication
>  Step 9 |                            |----------Notify------>| Inform
> emergency information
>  Step10 |                           |<---------200----------|
> Acknowledge notifying
> 
> Alice sends SUBSCRIBE Request to Bob asking for his geographic
> information. Notifier reply 202 Response indicates that the 
> subscription
> has been understood, and that an authorization needs to be 
> taken by Bob.
> Bob authorizes the Request and decided to reveal his "City" level
> geographic information to Alice.
> When Alice encounters an emergency situation, Presence User 
> Agent (PUA)
> publishes her geographic information to SIP proxy, and SIP Proxy
> notifies hospital.

Wilson.Wu
Department of Computer Science 
University of the Western Cape 
Private Bag X17 
Bellville 7535
South Africa 

Emai:[email-masked]
Tel.+27 (0)21 959-2406
Fax.+27 (0)21 959 3006 
Mob.+27 (0)72 571 6932

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 12 May 2005 11:06:42 -0500

One concern is that geopriv is not a real time protocol, so it is limited 
to other mechanisms for account for that capability, just as SIP itself 
cannot adjust a codec due to a bandwidth constraint in the network.

Thus I believe Bob's UA must make use of multiple means at his disposal to 
achieve the desired outcome.

As the author of the SIP Location ID listed below (which is about to be 
moved into the SIP WG, btw), I offer to you to read and comment on it this 
summer when I fill out the SUB/NOT section more fully.

At 05:52 PM 5/12/2005 +0200, YANHAO WU wrote:
>Hi All,
>Geographic information disclosure depand on who is requesting and why 
>he/she is questing. Dynamic response might be better than rule 
>enforcement. Real-time authorization will provide a means for users to 
>decide dymanicly how much detail(eg. street-level) and how long(eg. 2 
>hours) and frequence(eg. notify once/1 minute ) they want to reveal their 
>locaiton information.
>
>For instance, as regarding geographic information disclosure, Bob's 
>willingness to reveal his information primarily depends on the social 
>relationships between him and Alice, and why Alice is requesting. 
>Responses might be quite different if Caro want to request bob's location 
>information.  Or even Alice request with a different reason.
>
>I don't know if common-policy and geopriv-policy can provide a real time 
>interaction with users for them to decide dynamicaly?