Subject: RE: [Geopriv] Dynamic response?

From: "James M. Polk" <[email-masked]>
Date: Thu, 12 May 2005 17:06:25 -0500

At 03:33 PM 5/12/2005 -0400, Avi Lior wrote:
>Isnt the trend today to store the policy of "who can access what
>information" in the network?

the user is a rulemaker in Geopriv, but the user may not be the only 
rulemaker [see RFC 3693]

>It seems to me that asking the user or the user's device for that kind of
>policy the wrong thing to do.

do you want Verizon or AT&T or BT decided who has authorization for your 
location information, deciding the resolution of that information as well?

If you do, not all of us share this opinion

>Avi
>
> > -----Original Message-----
> > From: YANHAO WU [mailto:[email-masked]]
> > Sent: Thursday, May 12, 2005 11:53 AM
> > To: [email-masked]; [email-masked]
> > Subject: [Geopriv] Dynamic response?
> >
> >
> > Hi All,
> > Geographic information disclosure depand on who is requesting
> > and why he/she is questing. Dynamic response might be better
> > than rule enforcement. Real-time authorization will provide a
> > means for users to decide dymanicly how much detail(eg.
> > street-level) and how long(eg. 2 hours) and frequence(eg.
> > notify once/1 minute ) they want to reveal their locaiton information.
> >
> > For instance, as regarding geographic information disclosure,
> > Bob's willingness to reveal his information primarily depends
> > on the social relationships between him and Alice, and why
> > Alice is requesting. Responses might be quite different if
> > Caro want to request bob's location information.  Or even
> > Alice request with a different reason.
> >
> > Step 1 |----Subscribe----->|----Subscribe------>| Request
> > state subscription Step 2 |<-------202---------|<--------202--------|
> > Step 3 |<-------------NOTIFY (pending)----------|
> > authorization(interact with user) Step 4
> > |---------------------200------------------>| Acknowledge notifying
> >
> > SIP authorization mechnism with 202 response provide a way to
> > communicate with user in real time.
> > I don't know if common-policy and geopriv-policy can provide
> > a real time interaction with users for them to decide
> > dynamicaly? Can some one help to clear this issue for me? thanks!
> >
> >
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Tschofenig Hannes
> > Sent: Tuesday, May 10, 2005 10:15 PM
> > To: 'YANHAO WU'; [email-masked]
> > Subject: AW: [Geopriv] a usage of SIP for privacy concerned LBS
> >
> >
> > hi,
> >
> > i quickly went through the text you have provided with the
> > attachment.
> > why don't you just use a combination of
> > - common-policy:
> > http://www.ietf.org/internet-drafts/draft-ietf-geopriv-common-
> > policy-04.txt
> > - geopriv-policy:
> > http://www.ietf.org/internet-drafts/draft-ietf-geopriv-policy-05.txt
> > - pdif-lo:
> > http://www.ietf.org/internet-drafts/draft-ietf-geopriv-pidf-lo-03.txt
> > - sip+lo:
> > http://www.softarmor.com/wgdb/docs/draft-polk-sipping-location
> > -requirements-
> > 01.txt
> >
> > ciao
> > hannes
> >
> >
> > > -----Ursprüngliche Nachricht-----
> > > Von: [email-masked]
> > > [mailto:[email-masked]] Im Auftrag von YANHAO WU
> > > Gesendet: Donnerstag, 5. Mai 2005 09:31
> > > An: [email-masked]
> > > Betreff: [Geopriv] a usage of SIP for privacy concerned LBS
> > >
> > >
> > > Hi
> > >  All, have a look of attachment. Please give me some suggestions.
> > >  Subscriber (Alice)     SIP Proxy             Notifier (Bob)
> > >  Step 1 |----Subscribe----->|----Subscribe------>| Request state
> > > subscription  Step 2
> > |<-------202----------|<--------202-----------|
> > > plausible deniability "pending"
> > >  Step 3 |<-------------NOTIFY (pending)-----------| Waiting for
> > > authorization
> > >  Step 4 |----------------------200--------------------->|
> > Acknowledge
> > > notifying
> > >  Step 5 |<-------------NOTIFY (active)-------------| Notify
> > geographic
> > > information
> > >  Step 6 |----------------------200--------------------->|
> > Acknowledge
> > > notifying
> > >    PUA (Alice)          SIP Proxy           Watcher (Hospital)
> > >  Step 7 |------Publish------->|
> >  | update
> > > emergency information
> > >  Step 8 |<-------200----------|                              |
> > > Acknowledge publication
> > >  Step 9 |
> > |----------Notify------>| Inform
> > > emergency information
> > >  Step10 |                           |<---------200----------|
> > > Acknowledge notifying
> > >
> > > Alice sends SUBSCRIBE Request to Bob asking for his geographic
> > > information. Notifier reply 202 Response indicates that the
> > > subscription has been understood, and that an authorization
> > needs to
> > > be taken by Bob.
> > > Bob authorizes the Request and decided to reveal his "City" level
> > > geographic information to Alice.
> > > When Alice encounters an emergency situation, Presence User
> > > Agent (PUA)
> > > publishes her geographic information to SIP proxy, and SIP Proxy
> > > notifies hospital.
> >
> >
> > Wilson.Wu
> > Department of Computer Science
> > University of the Western Cape
> > Private Bag X17
> > Bellville 7535
> > South Africa
> >
> > Emai:[email-masked]
> > Tel.+27 (0)21 959-2406
> > Fax.+27 (0)21 959 3006
> > Mob.+27 (0)72 571 6932
> >
> > _______________________________________________
> > Geopriv mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/geopriv
> >
>
>_______________________________________________
>Geopriv mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/geopriv

cheers,
James

                                 *******************
                 Truth is not to be argued... it is to be presented.

                      Alas, few *truths* exist without the math.

                             ...all else is a matter of perspective

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Carl Reed OGC" <[email-masked]>
Date: Fri, 13 May 2005 08:40:04 -0600

By way of some additional input, I have recently attended two conferences on 
location, mobile wireless, and business intelligence. I was able to listen 
to presentations by some major carriers (Sprint, Verizon, etc) about their 
location service and mobile wireless applications. In every case, they 
provide an opt-in capability. No location information is provided unless the 
user opts-in. If the user opts-in, they can then further select which LS 
options they wish to subscribe to, such as a friend finder. These carriers 
are very sensitive to the issue of privacy (although they did not address 
the issue of security in their presentations) and appear to be abiding by 
the privacy manifesto for use and distribution of location information 
developed by LIF (Now part of OMA). Even so, this does not solve the issue 
of authorization (digital rights) farther down the value chain. I should 
also let this group know that for over a year the OGC has had a very active 
Geo Digital Rights Management Working group. This WG is more focused on 
"traditional" content (copyright, authorization, licensing, etc) than on 
location payloads generated in the mobile wireless world. However, I suspect 
their work is very germane to the ongoing work of GeoPriv and visa-a-versa.

Cheers

Carl

----- Original Message ----- 
From: "James M. Polk" <[email-masked]>
To: "Avi Lior" <[email-masked]>; "YANHAO WU" 
<[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Thursday, May 12, 2005 4:06 PM
Subject: RE: [Geopriv] Dynamic response?