Subject: RE: [Sip] RE: [Geopriv] teasing apart: http as a GEOPRIV usingprotocol

From: Jeroen Van Bemmel <[email-masked]>
Date: Sat, 29 Jul 2006 16:22:05 +0200

Could be, but that would mean the UA is forced to "publish" a location object to a server each time it wants to convey it

By putting the expiration time in the URL, it can reuse the same object each time, offering a different "view" on it to each conveyee. When the location is constant or one of a set of common places (for example, "at home"), this can be  more convenient

The UA could even encrypt its actual location in the URL, and have the server generate a PIDF-LO with that data. Then you have a snapshot by reference, without being concerned about state on the server, but with additional access control possibilities

Regards,

Jeroen

-----Oorspronkelijk bericht -----
Van: "Winterbottom, James" <[email-masked]>
Aan: "Jeroen Van Bemmel" <[email-masked]>; "Ted Hardie" <hardie@qualcommcom>; "Dawson, Martin" <[email-masked]>; "Andrew Newton" <[email-masked]>; "IETF SIP List" <[email-masked]>; "GEOPRIV" <[email-masked]>
Verzonden: 29-7-06 12:40
Onderwerp: RE: [Sip] RE: [Geopriv] teasing apart: http as a GEOPRIV usingprotocol

Isn't the limited concent component covered by common policy in the form of a rule validity period?

________________________________

From: Jeroen Van Bemmel [mailto:[email-masked]]
Sent: Fri 28/07/2006 5:01 PM
To: Ted Hardie; Dawson, Martin; Andrew Newton; IETF SIP List; GEOPRIV
Subject: RE: [Sip] RE: [Geopriv] teasing apart: http as a GEOPRIV usingprotocol

Hi Ted,

At what scale do you expect this to work? If the location server is required to have a trust relation with everyone I might want to share my location with, it won't work for the Internet.

For that, I think something like trait based authorization is needed: a URL that encodes my consent for you to retrieve my location, for a limited period

Regards,
Jeroen

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Winterbottom, James" <[email-masked]>
Date: Sat, 29 Jul 2006 17:30:22 -0500

Jeroen,
 
I think you are coming from a slightly different premise to me. I am not of the opinion that the Target always knows where it is, sure it can ask, but there are circumstances where A) it is not capable of asking, B) doesn't want to ask it is happy for certain other entities just to know when they ask. I don't believe that in either of these cases that the UA has to publish a PIDF-LO at all.
 
It simply tells a local server (the thing that the URI points to) not to release the location information to anyone but but X, and only if X asks for it within Y. The local server is able to determine location, and it is my view that the server can generate a PIDF-LO using an unlinked pseudonym as the entity identifier, RFC-4119 gives us defaults for all other parts we need. In this way I have the same URI for everbody, but I can restrict how long it is valid for anyone person.
 
Cheers
James

From: Jeroen Van Bemmel [mailto:[email-masked]]
Sent: Sat 29/07/2006 9:22 AM
To: Winterbottom, James; Ted Hardie; Dawson, Martin; Andrew Newton; IETF SIP List; GEOPRIV
Subject: RE: [Sip] RE: [Geopriv] teasing apart: http as a GEOPRIV usingprotocol

Regards,

Jeroen

-----Oorspronkelijk bericht -----
Van: "Winterbottom, James" <[email-masked]>
Aan: "Jeroen Van Bemmel" <[email-masked]>; "Ted Hardie" <hardie@qualcommcom>; "Dawson, Martin" <[email-masked]>; "Andrew Newton" <[email-masked]>; "IETF SIP List" <[email-masked]>; "GEOPRIV" <[email-masked]>
Verzonden: 29-7-06 12:40
Onderwerp: RE: [Sip] RE: [Geopriv] teasing apart: http as a GEOPRIV usingprotocol

Hi Ted,

Regards,
Jeroen

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]