Subject: [Geopriv] Identifier formats in draft-winterbottom-geopriv-held-identity-extensions

From: Richard Barnes <[email-masked]>
Date: Tue, 17 Jun 2008 14:35:21 -0400

James,

I recall that you had said in Dallas that the IP and MAC addresses are 
specified in draft-winterbottom-geopriv-held-identity-extensions to be 
formatted as URNs because of the constraint in RFC 4479 that device 
identifiers need to be URNs.  I have a couple of questions about that 
reasoning:

1. Is this document even necessarily related to the presence data model? 
  The identifier in the request doesn't need to be the same as the 
device ID (otherwise the non-URI identifiers would be worthless).

2. Even if these identifiers are going to become device IDs, why are 
IP/MAC specified as URNs and not the other IDs (e.g., IMEI)?

3. Even if there's a rationale for IP addresses to be expressed as URNs, 
I don't think IP addresses should be used for device IDs anyway. 
According to the presence data model, a device ID is "a globally and 
temporally unique identifier for the device".  IP addresses don't meet 
this criterion.

Cheers,
--Richard

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: Richard Barnes <[email-masked]>
Date: Tue, 17 Jun 2008 14:38:48 -0400

One more question:

4. The text gives examples of <uri> elements with "type" attributes 
("gruu" and "aor"), but does not create a registry for URI types. 
Should a registry be added?

--Richard

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 17 Jun 2008 15:02:50 -0500

Hi Richard,

Some answers inline.

Cheers
James

-----Original Message-----
From: Richard Barnes [mailto:[email-masked]]
Sent: Tue 6/17/2008 1:35 PM
To: Winterbottom, James
Cc: 'GEOPRIV'
Subject: Identifier formats in draft-winterbottom-geopriv-held-identity-extensions
 
James,

[AJW] It is true that they don't have to be, but where they can be doesn't it make sense to specify them in the same form?

[AJW] My thought here was that IMEI is more likely to be a helper identifier, but you are right that it could be defined as a URN, perhaps a "typed" telURI could do the same thing.

[AJW] My read of this is that the identifier needs to be unique within a given period, rather than unique for the device through all time. In which case I think an IP address is often going to be okay, certainly there will be some deployments where this is not the case.

Cheers,
--Richard

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 17 Jun 2008 15:03:18 -0500

Yes it should, thanks for catching that.

-----Original Message-----
From: Richard Barnes [mailto:[email-masked]]
Sent: Tue 6/17/2008 1:38 PM
To: Winterbottom, James
Cc: 'GEOPRIV'
Subject: Re: [Geopriv] Identifier formats in	draft-winterbottom-geopriv-held-identity-extensions
 
One more question:

--Richard