Subject: [Geopriv] Examples in HELD drafts

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 7 Jul 2008 21:14:57 -0500

Hi Hannes, Mary,

With the introduction of the held: URI, the standard examples for dereference need to be changed subtly.  Previously, HTTP URIs were used, which allows for relative URIs in the request:

  POST /location/213508923456 HTTP/1.1
  Host: lis.example.com

However, the held: URI changes all this.  The URI in the above example implies an HTTP URI, so the HTTP server would potentially report the wrong URI (if that were necessary).  HTTP servers are required to support absolute URIs, so we should be showing examples that include the new URI.

  POST held://lis.example.com:80/location/213508923456 HTTP/1.1

I've checked that this works in several server implementations - most even break the URI down to its components as if it were an HTTP URI.  Some clients don't offer a means to put an absolute URI in, but it's not insurmountable.

The examples in the HELD and deref drafts should be updated.  I'm sure that I've made this comment before, so my apologies if this was already planned.

Cheers,
Martin

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 08 Jul 2008 23:12:24 +0300

Is this roughly correct?
http://www.shingou.info/svn/draft-winterbottom-geopriv-held-http-using-protocol/draft-winterbottom-geopriv-deref-protocol-02.txt

Ciao
Hannes