Subject: Re: [Geopriv] Fwd: GEOPRIV Interim Meeting, June 12, 2008

From: "Roger Marshall" <[email-masked]>
Date: Wed, 9 Jul 2008 11:44:46 -0700

James/Robert:
As we discussed at the geopriv interim (hallway), while I don't prefer
relative timestamps (e.g., number of seconds) for how long a l-uri is
good for, (I had made the argument in favor of an unambiguous expiry
time based on some referenced (zulu) timestamp), given no other
discussion for or against - I don't want to hold this draft
(*dhcp-lbyr-uri) up over this issue.  So, I withdraw any objection to
the timestamp as already proposed by James.

-roger marshall.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of James M. Polk
> Sent: Friday, May 16, 2008 12:09 PM
> To: Robert Sparks
> Cc: GEOPRIV
> Subject: Re: [Geopriv] Fwd: GEOPRIV Interim Meeting, June 12, 2008
> 
> At 01:49 PM 5/16/2008, Robert Sparks wrote:
> >If it's really that small, we should be able to put it down 
> before the 
> >end of next week on list I would hope.
> >
> >James is proposing the document carry only a relative time vs an 
> >absolute time. If that's a complete description of the issue, then 
> >someone that feels strongly that it should be an absolute 
> time please 
> >respond with why.
> >
> >James - I didn't follow this sentence:
> >
> >>   I'd really like to understand why
> >>the L-URI simply error a request once it is no longer valid.
> 
> This means: I don't understand why a URI needs to be tracked 
> as far as whether it is valid or not (i.e., the possessing of 
> the URI).  I think along the lines of whether or not the 
> location (by-value) is valid or has timed-out (similar to how 
> the PIDF-LO <retention-expiry> element will be used), but 
> this absolute timer suggestion has to do with whether a 
> reference is still valid (based solely on the timing of the 
> indicator on the URI). And I don't understand why this is an issue.
> 
> With that said, I have no problems including a valid-for time 
> in seconds the URI should be considered good (it's only 2 
> bytes).  Roger's suggestion that a GMT-style timer be placed 
> in the Option more than doubles the size of the Option, and I 
> don't know if it really does any good.  DHCP Option refresh 
> is a local policy decision, and there will not be any great 
> delay (likely <1 sec.) in delivering the Option to the 
> endpoint (from the server).
> 
> -00 already has the valid-for field in seconds, and I want to 
> know why it should be changed to Roger's suggestion.
> 
> (I'm not really picking on Roger, but it is his suggestion to 
> change this field without any corroboration this is needed).
> 
> Have I made this clearer or made it worse?
> 
> ;-)
> 
> James
> 
> 
> 
> >RjS
> >
> >On May 16, 2008, at 1:41 PM, James M. Polk wrote:
> >
> >>Robert
> >>
> >>Can I ask that
> >>http://www.ietf.org/internet-drafts/draft-ietf-geopriv-dhcp-
> lbyr-uri-o
> >>ption-00.txt
> >>be added to the interim discussion?
> >>
> >>I believe the only remaining open item is the format of the timing 
> >>field (whether it is given in 'seconds remaining' that a 
> L-URI is to 
> >>be considered valid, or with an absolute time (GMT style) 
> that a L-URI 
> >>is to be considered valid).
> >>
> >>I haven't been able to get enough responses to this issue - 
> other than 
> >>from Roger - about this item.  I'd really like to 
> understand why the 
> >>L-URI simply error a request once it is no longer valid. Meaning, I 
> >>guess I don't understand why this needs to be an absolute time at 
> >>all...
> >>
> >>I hope this discussion will not take very long (as in <15 minutes).
> >>
> >>Once this issue is resolved, I think I'll be asking for 
> publication, 
> >>and having that done before Dublin will be beneficial.
> >>
> >>Let me know
> >>
> >>James
> >>
> >>
> >>At 01:18 PM 5/16/2008, Robert Sparks wrote:
> >>>In case you missed this in the planning thread, or don't watch
> >>>ietf- announce:
> >>>
> >>>IMPORTANT:
> >>>if you are planning to attend and haven't told me, please 
> do so now.
> >>>I need an accurate headcount.
> >>>
> >>>
> >>>Begin forwarded message:
> >>>>From: IESG Secretary
> >>>><<mailto:[email-masked]>[email-masked]>
> >>>>Date: May 12, 2008 5:45:01 PM CDT
> >>>>To: <mailto:[email-masked]>[email-masked]
> >>>>Subject: GEOPRIV Interim Meeting, June 12, 2008
> >>>>
> >>>>The IETF GEOPRIV WG is holding an Interim meeting June 12th in 
> >>>>Dallas.
> >>>>Please see the geopriv mailing list for more details on 
> location and 
> >>>>draft agenda.
> >>>>_______________________________________________
> >>>>IETF-Announce mailing list
> >>>><mailto:[email-masked]>[email-masked]
> >>>>https://www.ietf.org/mailman/listinfo/ietf-announce
> >>>
> >>>
> >>>
> >>>We will meet here:
> >>>
> >>>Tekelec
> >>>17210 Campbell Road
> >>>Suite 250
> >>>Dallas, TX 75252-4203
> >>>
> >>><<http://maps.google.com/maps?q=17210+Campbell+Rd,+dallas,+
tx,+75252&
> >>>hl=en
> >>> 
> >http://maps.google.com/maps?q=17210+Campbell+Rd,+dallas,+tx,+75252&
> >>> >hl=en >
> >>>
> >>>Some hotels near this office can be found here:
> >>><<http://www.nostrum.com/~rjsparks/hotels.html>http://www.n
ostrum.com
> >>>/~rjsparks/hotels.html
> >>> >
> >>>
> >>>The current agenda is
> >>>
> >>>9:00-10:30lis-discovery
> >>>10:30-12:00 HELD Identity extensions
> >>>1:00-2:30HELD Context management extensions 2:30-4:00Dereferencing
> >>>
> >>>_______________________________________________
> >>>Geopriv mailing list
> >>>[email-masked]
> >>>https://www.ietf.org/mailman/listinfo/geopriv
> >>
> >>_______________________________________________
> >>Geopriv mailing list
> >>[email-masked]
> >>https://www.ietf.org/mailman/listinfo/geopriv
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv
> 

CONFIDENTIALITY NOTICE: The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please notify the sender immediately, and delete it and all attachments from your computer and network.

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 09 Jul 2008 15:30:02 -0500

Thank you Roger

James

At 01:44 PM 7/9/2008, Roger Marshall wrote:
>tx,+75252&> >>>hl=en
>CONFIDENTIALITY NOTICE: The information contained in this message 
>may be privileged and/or confidential. If you are not the intended 
>recipient, or responsible for delivering this message to the 
>intended recipient, any review, forwarding, dissemination, 
>distribution or copying of this communication or any attachment(s) 
>is strictly prohibited. If you have received this message in error, 
>please notify the sender immediately, and delete it and all 
>attachments from your computer and network.