Subject: [Geopriv] Strawman charter

From: Robert Sparks <[email-masked]>
Date: Wed, 16 Jul 2008 13:52:18 -0500

Folks -

GEOPRIV has covered a lot of ground since its inception. We're getting
stuff done and (as sluggish as it sometimes feels) beginning to build up
some speed.

It would be a good time to reflect on the charter and make sure its
in proper shape to guide our work going forward.

Below is a strawman proposal to stimulate conversation.
Please send comments to the list

RjS

----------

The IETF has recognized that applications requiring geopraphic
and civil location information about resources and entities
are emerging, and that the representation and transmission
of that information has significant privacy and security
implications. We have created a suite of protocols that
allow such applications to represent and transmit such
location objects and a to allow users to express policies
on how these representations are exposed and used.
The IETF has also begun working on creating applicaitons
that use these capabilities, in general real-time
communication, emergency services, and other areas.

The GEOPRIV working group is chartered to continue
to analyse the authorization, integrity, and privacy
requirements that must be met when these representations
of location are created, stored, and used. The group will
create and refine mechanisms for the transmission of these
representations that address the requirements that have
been identified.

The working group will work with other IETF working groups
and other standards development organizations that are
building applications using these mechanisms to ensure
that the requirements are well understood and met, and
that no additional security or privacy issues related
to location are left unaddred as these mechanisms are
incorporated into other protocols.

It remains a goal of the GEOPRIV working group to
deliver specifications of broad applicability that
will become mandatory to implement for IETF protocols
that are location aware.

This working group will not develop location-determining technology.

This working group will not develop location-determining
technology. However, the IETF acknowledges that information
used in the location-determination process may need to be
carried over the Internet. Where necessary, this working group
will develop a extensions to IETF protocols to encode
location-determination data structures defined elsewhere.
This working group will not develop technologies to directly
address any particular regulatory requirements (e.g. E.911).
The group will coordinate with any other IETF entities that
are working on those problems to ensure the technologies created
here meets that entities needs and that the authorization,
integrity, and privacy requirements on the mechanisms provided
by these techbologies continue to be met.

This working group is tasked with several immediate high-level
goals, as reflected in the milestones. These include

* Completion of layer-7 location conveyance protocol
* Providing a Location Information Server discovery protocol
* Providing an analysis of proposed migration technologies
   used to bring location-aware applications into the existing
   Internet environment. Specifically, this analysis will
   explore the restrictions or additional mechanisms that
   would need to exist to ensure the above authorization,
   integrity, and privacy requirements are met if a third
   party were allowed to obtain location on behalf of an end-user.

Goals and Milestones

Done Discuss initial geopriv scenarios and application requirements i- 
d's
Done Discuss initial geographic location privacy and security  
requirements i-d.
Done Initial i-d on geographic information protocol design, including  
privacy
      and security techniques.
Done Review charter and initial i-ds with AD, and have IESG consider
      rechartering if necessary.
Done Submit geopriv scenarios and application requirements to IESG for
      publicaiton as Informational RFCs
Done Submit security/privacy requirements I-D to IESG for publication as
      Informational RFC.
Done Submit PIDF-LO basic geopriv object draft as a PS
Done Initial Common Rules base object draft
Done Initial Common Ruels GEOPRIV object draft
Done Submit DHCP Civil draft as a PS
Done     Resubmit Conveying Location Objects in RADIUS and Diameter to  
the IESG
          for publication as PS
Done     Submit Additional Civic PIDF-LO types (updating 4119) to the  
IESG for
          publication as PS
Done     Submit minimal HTTP based protocol satisfying baseline  
requirements
          specified in the Layer 7 Location Conveyance Protocol Problem
          Statement and Requirements to the IESG for publication as PS
Done     Submit PIDF-LO Usage Clarifications and Recommendations  
(updating
          4119) to the IESG for publication as PS

Aug 2008 Submit Recommendations for Retransmission in SIP Location  
Conveyance
          to the IESG for publication as Informational

Aug 2008 Submit Layer 7 Location Conveyance Protocol Problem Statement  
and
          Requirements to the IESG for publication as Informational

Sep 2008 Resubmit Geolocation Policy to the IESG for publication as PS

Sep 2008 Submit a LIS Discovery Mechanism to the IESG for publication  
as a PS

Nov 2008 Submit recommendations for representing civic addresses in  
PIDF-LO
          to the IESG for publication as BCP

Nov 2008 Submit Requirements for Location by Reference Protocols to  
the IESG
          for publication as Informational

Dec 2008 Submit an update to RFC3825 separating hiding and bounding  
goals to
          the IESG for publication as PS

Jan 2009 Submit a Document Format for Filtering and Reporting PIDF-LO  
Location
          Notifications to the IESG for publication as PS

Feb 2009 Submit an update to the GEOPRIV Requirements and Threat  
Analysis
          documents to the IESG for publication as Informational

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 16 Jul 2008 16:49:47 -0500

Hi Robert,

I would like to see some additional words put around :

"This working group will not develop location-determining technology."

I believe that we need to provide a framework that will support the exchange of messages between an end-point and a LIS to better enable location-determination.

I also think that we need to provide a document that allows an end-point to provide identifiers beyond just IP address.
And yes, I am going to open the OBO can of worms again because these are going to be the early deployments and we need to support them with as reasonable way to to do this as is possible.

Cheers
James

-----Original Message-----
From: [email-masked] on behalf of Robert Sparks
Sent: Wed 7/16/2008 1:52 PM
To: GEOPRIV
Subject: [Geopriv] Strawman charter
 
Folks -

RjS

----------

Goals and Milestones

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 16 Jul 2008 16:57:54 -0500

Hi Robert,

Also, maybe I am blind, but PIDF-LO profile doesn't seem to be in the list of milestones below and this has been waiting on AD actions since February.

Cheers
James

-----Original Message-----
From: [email-masked] on behalf of Robert Sparks
Sent: Wed 7/16/2008 1:52 PM
To: GEOPRIV
Subject: [Geopriv] Strawman charter
 
Folks -

RjS

----------

Goals and Milestones

---

From: Robert Sparks <[email-masked]>
Date: Wed, 16 Jul 2008 17:01:29 -0500

This one:?

>          4119) to the IESG for publication as PS

we have submitted it to the IESG...

RjS

On Jul 16, 2008, at 4:57 PM, Winterbottom, James wrote:

>
> Hi Robert,
>
> Also, maybe I am blind, but PIDF-LO profile doesn't seem to be in  
> the list of milestones below and this has been waiting on AD actions  
> since February.
>
> Cheers
> James
>
>

---

From: Robert Sparks <[email-masked]>
Date: Wed, 16 Jul 2008 17:05:37 -0500

Note that that sentence actually happened twice in what I sent.
The one in isolation should be deleted - the copy that was intended
to be there is the one at the beginning of the next paragraph. If you
could, propose text in that context.

RjS

On Jul 16, 2008, at 4:49 PM, Winterbottom, James wrote:

> I believe that we need to provide a framework that will support the  
> exchange of messages between an end-point and a LIS to better enable  
> location-determination.
>
> I also think that we need to provide a document that allows an end- 
> point to provide identifiers beyond just IP address.
> And yes, I am going to open the OBO can of worms again because these  
> are going to be the early deployments and we need to support them  
> with as reasonable way to to do this as is possible.
>
> Cheers
> James
>
>
>

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 16 Jul 2008 18:09:38 -0500

That is 2 for 2 now, I think I am going to go back to bed.
Thanks Robert, the text you have quite adequately addresses my request.

Cheers
James

> From: Robert Sparks [mailto:[email-masked]]
> Sent: Thursday, 17 July 2008 8:06 AM
> To: Winterbottom, James
> Cc: GEOPRIV
> Subject: Re: [Geopriv] Strawman charter
> 
------------------------------------------------------------------------
> ------------------------
------------------------------------------------------------------------
> ------------------------

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 16 Jul 2008 18:07:29 -0500

Sorry for being blind... 

> Sent: Thursday, 17 July 2008 8:01 AM
> To: Winterbottom, James
> Cc: GEOPRIV

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Thu, 17 Jul 2008 11:05:40 +0300

Hi Robert, 

Thanks for putting this together. A few minor comments below:

[hannes] I suspect you are talking about this document:
http://tools.ietf.org/html/draft-wolf-civicaddresses-austria-01

Nov 2008 Submit Requirements for Location by Reference Protocols to the
IESG
          for publication as Informational

[hannes] This is
http://tools.ietf.org/html/draft-ietf-geopriv-lbyr-requirements but why
do we need to wait till November? Why cannot we ship this right now?

[hannes] I guess this is based on
http://tools.ietf.org/wg/geopriv/draft-ietf-geopriv-binary-lci/. 
Maybe you want to pick a new editor to make sure that it does not take
years to get finished. 

[hannes] I guess a starting point is
http://tools.ietf.org/id/draft-barnes-geopriv-lo-sec-03.txt. Right? 

I was also hoping to see the following documents on the charter as well:
*
http://tools.ietf.org/id/draft-winterbottom-geopriv-deref-protocol-02.tx
t
*
http://tools.ietf.org/html/draft-winterbottom-geopriv-held-identity-exte
nsions-06.txt
Since I got the impression that the working group wanted them, per
discussions at past IETF meetings. 

I also believe that this document is a fairly small extension that might
be useful in context of the filters draft and the recently published
ECRIT eCall document. We gave a presentation about it already but we
only heard -- sounds good; we will consider it when we recharter. 
http://tools.ietf.org/html/draft-singh-geopriv-pidf-lo-dynamic-03.txt 

Ciao
Hannes

---

From: John Schnizlein <[email-masked]>
Date: Thu, 17 Jul 2008 07:43:16 -0400

This ad hominem attack is completely uncalled for.

John

On 2008Jul17, at 4:05 AM, Tschofenig, Hannes (NSN - FI/Espoo) wrote:
> ...
> goals to the IESG for publication as PS
>

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Thu, 17 Jul 2008 15:02:29 +0300

With HELD an independent person, namely Mary, was selected to edit the
document because of the history of the work. 
 
I do wonder whether this would be appropriate for the revision of RFC
3825 as well; again because of the history of the work. 
 
... and to avoid that question: I do NOT volunteer for that job. 

Luckily not all the documents in GEOPRIV are so controversial and have
such an unfortunate history.

________________________________

	From: ext John Schnizlein [mailto:[email-masked]] 
	Sent: 17 July, 2008 14:43
	To: Tschofenig, Hannes (NSN - FI/Espoo)
	Cc: Cullen Jennings; ext Robert Sparks; GEOPRIV
	Subject: Re: [Geopriv] Strawman charter

	John

	On 2008Jul17, at 4:05 AM, Tschofenig, Hannes (NSN - FI/Espoo)
wrote:

		...
		Dec 2008 Submit an update to RFC3825 separating hiding
and bounding
		goals to the IESG for publication as PS

http://tools.ietf.org/wg/geopriv/draft-ietf-geopriv-binary-lci/. 
		Maybe you want to pick a new editor to make sure that it
does not take
		years to get finished.

---

From: "Dawson, Martin" <[email-masked]>
Date: Thu, 17 Jul 2008 08:12:48 -0500

See - that's not ad hominem. It might have been sarcasm... but I guess
only Hannes can know that.

Ad hominem is when you invoke something personal to apparently discredit
an argument - generally when it's quite irrelevant. Like when a
proposition from me is objected to on the basis that I'm a "legacy"
guy... whatever that's supposed to mean.

Cheers,

Martin

From: [email-masked] [mailto:[email-masked]] On
Behalf Of John Schnizlein
Sent: Thursday, 17 July 2008 9:43 PM
To: Tschofenig, Hannes (NSN - FI/Espoo)
Cc: GEOPRIV
Subject: Re: [Geopriv] Strawman charter

John

	...
	Dec 2008 Submit an update to RFC3825 separating hiding and
bounding
	goals to the IESG for publication as PS

	Maybe you want to pick a new editor to make sure that it does
not take
	years to get finished.