Subject: [Geopriv] FW: I-D Action:draft-rosen-geopriv-prefix-00.txt

From: "Brian Rosen" <[email-masked]>
Date: Fri, 3 Jul 2009 15:37:59 -0400

You may recall that I started an email thread on this subject: adding
prefixes to street names and house numbers where we currently can support
only a suffix.

Your comments would be welcome.

Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of [email-masked]
Sent: Friday, July 03, 2009 3:30 PM
To: [email-masked]
Subject: I-D Action:draft-rosen-geopriv-prefix-00.txt 

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title           : Prefix elements for Road and House Numbers in
PIDF-LO
	Author(s)       : B. Rosen
	Filename        : draft-rosen-geopriv-prefix-00.txt
	Pages           : 4
	Date            : 2009-07-03

RFC4119 updated by RFC5139 defines suffixes for street names and house
numbers, but does not define prefixes.  Both occur regularly in addresses
and CAtypes are needed for them.  This memo defines STP Street Prefix and
HNP house number prefix CAtypes.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-rosen-geopriv-prefix-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 5 Jul 2009 18:43:59 -0500

Hi Brian,

To accommodate an XML representation you will need to define a new namespace and a different XML schema.

--Martin

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Brian Rosen
> Sent: Saturday, 4 July 2009 5:38 AM
> To: [email-masked]
> Subject: [Geopriv] FW: I-D Action:draft-rosen-geopriv-prefix-00.txt
> 
------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 6 Jul 2009 10:28:56 -0400

This simply adds a couple of new CAtypes.  It doesn't break anything.

I noticed that revised civic redefined the namespace.  Why would we not do the same thing here?

Brian

> From: Thomson, Martin [mailto:[email-masked]]
> Sent: Sunday, July 05, 2009 7:44 PM
> To: Brian Rosen; [email-masked]
> Subject: RE: [Geopriv] FW: I-D Action:draft-rosen-geopriv-prefix-00.txt
> 
> Hi Brian,
>

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 6 Jul 2009 10:37:44 -0400

This is wrong.  I'll create a new namespace.

If we like both this and interior, perhaps we should combine them just to
avoid two new namespaces.

Brian

> Sent: Monday, July 06, 2009 10:29 AM
> To: 'Thomson, Martin'; [email-masked]
> Subject: Re: [Geopriv] FW: I-D Action:draft-rosen-geopriv-prefix-00.txt
> 
> > > and CAtypes are needed for them.  This memo defines STP Street
> Prefix
> > > and
> > ---------------------------------------------------------------------
> --
> > -------------------------
> > ---------------------------------------------------------------------
> --
> > -------------------------
> > [mf2]
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: [email-masked]
Date: Mon, 6 Jul 2009 12:33:16 -0400 (EDT)

Brian -

I am guessing that this discussion is being coordinated with the address
discussions in NENA for NG 911?

Thanks

Carl

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 6 Jul 2009 17:51:34 -0500

Revised civic did not "redefine" the namespace.  It defined a new one.  There's a significant difference.

You are welcome to do a carte blanche replacement, but you could just as easily define a new namespace for the additions that you're making.  That would have the added benefit of not affecting existing software.

> From: Brian Rosen [mailto:[email-masked]]
> Sent: Tuesday, 7 July 2009 12:29 AM
> To: Thomson, Martin; [email-masked]

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 6 Jul 2009 13:33:45 -0400

Yes, indeed.

They came out of coordination between the FGDC federal addressing standard
(which was originally the URISA standard) and reconciling PIDF-LO to that
standard.  They faced many of the same issues we have using PIDF for U.S.
addresses in general, and the problem of addressing interior spaces.

Brian

> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, July 06, 2009 12:33 PM
> To: Brian Rosen
> Cc: [email-masked]