Subject: [Geopriv] [geopriv] #13: registry for "crs" parameter

From: "geopriv issue tracker" <[email-masked]>
Date: Wed, 29 Jul 2009 13:41:20 -0000

#13: registry for "crs" parameter
----------------------------------------+-----------------------------------
 Reporter:  [email-masked]  |       Owner:     
     Type:  defect                      |      Status:  new
 Priority:  minor                       |   Milestone:     
Component:  geo-uri                     |     Version:     
 Severity:  Active WG Document          |    Keywords:     
----------------------------------------+-----------------------------------
 Currently, there is just one value for the "crs" paramter of the geo URI
 specified ("wgs84"), which is also the default value to assume of the
 parameter is not given.

 Q1) Shall the draft specify an IANA registry for the values of the "crs"
 parameter?

 Q2) if yes, what are the actions required to add a value to this registry?

 Suggestion by the author is "Yes, if there is the decision that there
 should be a URI parameter registry, and the required action is "standards
 action".

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/geopriv/trac/ticket/13>
geopriv <http://tools.ietf.org/geopriv/>

---

From: Richard Barnes <[email-masked]>
Date: Wed, 29 Jul 2009 15:53:35 +0200

>  Q1) Shall the draft specify an IANA registry for the values of the "crs"

Yes.

>  Q2) if yes, what are the actions required to add a value to this registry?

Specification Required

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 29 Jul 2009 17:59:51 -0500

>>  Q2) if yes, what are the actions required to add a value to this registry?

if the answer is yes to any of the above, there has to be a registry.

however, I think what Alexander wants is to NOT USE the datum 
identification of "WGS84", but instead specify one meaning 
"CRS:4326", and another meaning "CRS:4979".

>_______________________________________________
>Geopriv mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 30 Jul 2009 04:04:38 -0500

I take a different perspective.  I take this to mean:

If crs=wgs84 :
 ...and there are three values: 4979,
 ...and there are two values: 4326,
 ...else, it's not valid.

New definitions might do the same, or they can be constrained to only one or other.

Currently, the draft only supports the creation of a new CRS code if it is of dimension 2 or 3.  That's OK with me.

On the actual issue: we probably have to create the registry, and standards action is good.

--Martin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of James M. Polk
> Sent: Thursday, 30 July 2009 1:00 AM
> To: Richard Barnes; [email-masked]
> Cc: [email-masked]
> Subject: Re: [Geopriv] [geopriv] #13: registry for "crs" parameter
> 

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]