Subject: [Geopriv] FW: I-D Action:draft-rosen-geopriv-pidf-interior-00.txt

From: "Brian Rosen" <[email-masked]>
Date: Fri, 3 Jul 2009 15:40:25 -0400

Some time ago, I pointed out that the BLD/FLR/ROOM interior location CAtypes
don't work for lots of locations like airports.  This draft proposes a much
more extensible way to describe interior location.

I note that there is explicitly NOT a registry of names.  Whatever the local
signage and/or drawings or other ways people know how to find particular
interior spaces is what would be used with this element.

Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of [email-masked]
Sent: Friday, July 03, 2009 3:30 PM
To: [email-masked]
Subject: I-D Action:draft-rosen-geopriv-pidf-interior-00.txt 

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title           : Interior Location in PIDF-LO
	Author(s)       : B. Rosen
	Filename        : draft-rosen-geopriv-pidf-interior-00.txt
	Pages           : 6
	Date            : 2009-07-03

RFC5139 defines explicit tags for interior building location such as "BLD"
(building), "UNIT", "ROOM".  There is wide variation in how interior spaces
are named, and the rigid element names provided do not allow accurate
representation of interior spaces that don't use the element tags defined.
This memo provides an alternative mechanism that provides an extensible
flexible way to name spaces in any kind of addressible location.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-rosen-geopriv-pidf-interior-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 5 Jul 2009 18:45:40 -0500

Hi Brian,

Replacing or changing the definition of an existing schema has fairly serious ramifications for implementations.  Please define a new schema and namespace for these elements.

--Martin

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Brian Rosen
> Sent: Saturday, 4 July 2009 5:40 AM
> To: [email-masked]
> Subject: [Geopriv] FW: I-D Action:draft-rosen-geopriv-pidf-interior-
> 00.txt
> 
------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 6 Jul 2009 10:36:33 -0400

Yeah, I need a new namespace for this one:

urn:ietf:params:xml:ns:pidf:geopriv10:interiorCivic

maybe?

Brian

> From: Thomson, Martin [mailto:[email-masked]]
> Sent: Sunday, July 05, 2009 7:46 PM
> To: Brian Rosen; [email-masked]
> Subject: RE: [Geopriv] FW: I-D Action:draft-rosen-geopriv-pidf-
> interior-00.txt
> 
> Hi Brian,
> 
> Replacing or changing the definition of an existing schema has fairly
> serious ramifications for implementations.  Please define a new schema
> and namespace for these elements.
> 
> --Martin
> 
> > don't work for lots of locations like airports.  This draft proposes
> a
> > much
> > I note that there is explicitly NOT a registry of names.  Whatever
> the
> > local
> > http://www.ietf.org/internet-drafts/draft-rosen-geopriv-pidf-
> interior-
> > 00.txt
> >