Subject: [Geopriv] a quick and dirty geo: URI to Google Maps resolver

From: Ivan Shmakov <[email-masked]>
Date: Tue, 28 Jul 2009 20:20:42 +0700

I've written a quick and dirty geo: URI to Google Maps
	``resolver.''  The resolver currently supports only 2D
	coordinates, and the following URI parameters:

	* crs= -- the only allowed value is `wgs84', which is also the
	  default;

	* crsURI= -- the values are expected to be URNs of the form:

urn:ogc:def:crs:epsg::NUMBER

	  where NUMBER is sought in a local `epsg' file (as of PROJ.4,
	  4.4.9d debian 2);

	* dX=, dY= -- the values are positive floating-point numbers
	  giving the uncertainty of the X and Y values, respectively,
	  using the units of the selected CRS; the Y value for the
	  default `wgs84' CRS is latitude.

	At the moment, the uncertainty given for a non-WGS 84 CRS
	location will be silently ignored.  (I hope to fix that soon.)

	Consider, e. g.:

	* the uncertainty maps to scale:

http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh/geo:53,84?dX=1&dY=1
http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh/geo:53.4,83.75?dX=0.1&dY=0.1
http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh/geo:53.36,83.75?dX=0.01&dY=0.01

	* UTM 44N (EPSG 24344) coordinates are also supported:

http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh/geo:5915572,683169?crsURI=urn:ogc:def:crs:epsg::24344

-- 
FSF associate member #7257

---

From: Ivan Shmakov <[email-masked]>
Date: Thu, 30 Jul 2009 12:44:35 +0700

>>>>> Ivan Shmakov <[email-masked]> writes:

 > ``resolver.''

	The source is now available at:

http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh

[...]

 > http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh/geo:53.36,83.75?dX=0.01&dY=0.01

	The geo: URI parsing was fixed; these should now be:

http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh/geo:53,84;dX=1;dY=1
http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh/geo:53.4,83.75;dX=0.1;dY=0.1
http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh/geo:53.36,83.75;dX=0.01;dY=0.01

 > http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh/geo:5915572,683169?crsURI=urn:ogc:def:crs:epsg::24344

http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh/geo:5915572,683169;crsURI=urn:ogc:def:crs:epsg::24344

	This revision also adds support for ``debug mode'', e. g.:

http://theory.asu.ru/~ivan/geo-uri/geo-uri.sh/geo:5915572,683169;crsURI=urn:ogc:def:crs:epsg::24344?debug=yes