Subject: [Geopriv] location quality should be in the PIDF

From: "Brian Rosen" <[email-masked]>
Date: Wed, 15 Jul 2009 09:54:08 -0400

draft-thomson-geopriv-location-quality proposes to add quality requirements
to a HELD request, and quality "results" to a HELD response.

Taking the response first, I don't think it is appropriate to return the
quality of the PIDF in something other than a PIDF.  In particular, if I
convey the PIDF to some other entity, that entity needs to know what the
quality of the result is.

I think inferring quality by, for example, returning a circle with a radius
rather than a point with uncertainty and confidence is wrong.  The PIDF
should return the point, and express the quality.  I want to add elements to
PIDF to express the quality of the data provided.

Turning to the request, I would like the ability for the SIP presence
mechanism to be able to request a specific quality.  One way to do that is
to specify the quality with a filter.  We've been having a discussion on
this point.  In this email, I'm expressing support for that notion, using
common syntax between a HELD request and a SIP Presence subscription: I want
to define an XML namespace used to request location quality, which can be
used in a HELD request (including a deref request) and a SIP Presence
filter, with the same syntax and semantics.

Brian

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 15 Jul 2009 20:05:26 -0500

PIDF-LO already includes measures of quality.  They just aren't simple enough for you.

I've described how to simplify quality in the uncertainty draft.  Enough for most folks.  There's an implementation of this simplification that you can feed a PIDF-LO here: 

  <http://held-location.sourceforge.net/held_js/pidflo.html>

If you want to simplify them, then you need to be willing to pay the price.  Primarily, that's a price in degradation of accuracy, which can be significant.  Something that you've been a strong opponent of in the past.

To give you an idea, compare the area of the arc band with the circle here: 

  <http://held-location.sourceforge.net/held_js/pidflo.html#deref=test%2Farcband.xml>

(IE doesn't show the shapes, sorry.  I got sick of wrestling with VML.)

Richard and I discussed the idea of a scaled complexity model for PIDF-LO last meeting.  All the way from the full GML schema, through RFC 5491, to point and radius (Circle), to merely point.  What you want is to shift one on the scale towards simplicity.  That's possible, but we'd need to resolve a few questions:

 - how does an LS decide to simplify?
 - can simple and complex representations co-exist?
 - can a client request simplification?

In terms of the request, that XML definition already exists in the location-quality draft.  The "results" are entirely optional, they only provide information that the recipient is already able to determine for themselves.  This follows the pattern already adopted in other systems.  The "results" are an alternative to the simplification option that could disappear if the above were resolved.

--Martin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Brian Rosen
> Sent: Wednesday, 15 July 2009 11:54 PM
> To: [email-masked]
> Subject: [Geopriv] location quality should be in the PIDF
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]