Subject: [Geopriv] geopriv-arch AUTH48

From: Alissa Cooper <[email-masked]>
Date: Fri, 8 Jul 2011 18:31:39 +0100

draft-ietf-geopriv-arch-03 is in AUTH48 and the authors have suggested a slight change to some normative language in section 4.2.4. Here is the section:

An LS that receives Rules exclusively through LOs MUST examine the
   Rules that accompany a given LO in order to determine how the LS may
   use the LO (if any Rules are included by reference, the LS SHOULD
   attempt to download them).  If the LO includes no Rules that allow
   the LS to transmit the LO to another entity, then the LS MUST NOT
   transmit the LO.  If the LO contains no Rules at all (if it is in a
   format with no Rules syntax, for example), then the LS MUST delete it
   (emergency services provide an exception in that Rules can be
   implicit; see [15]).  If the LO included Rules by reference, but
   these Rules were not obtained for any reason, the LS MUST NOT
   transmit the LO and MUST delete it.

Here is the suggested change:

OLD:
If the LO included Rules by reference, but
 these Rules were not obtained for any reason, the LS MUST NOT
 transmit the LO and MUST delete it.

NEW:
If the LO included Rules by reference, but
these Rules were not obtained for any reason, the LS MUST NOT
transmit the LO and MUST adere to the provided value in the retention-expires field.

The change has been proposed to clarify that 
a) if the LS does not want to re-transmit location information then it does not immediately have to delete 
the received location object but instead looks at the retention-expires field only.
b) if the LS wants to transmit location information it is not allowed to do so. The retention-expires field would also give guidance on how long it is permitted to keep the location.

Since this is a change to normative language, if folks have objections to it we're requesting that they send them to the list by next Wednesday, July 13.

Thanks,
Alissa

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 08 Jul 2011 13:07:28 -0500

At 12:31 PM 7/8/2011, Alissa Cooper wrote:
>draft-ietf-geopriv-arch-03 is in AUTH48 and the authors have 
>suggested a slight change to some normative language in section 
>4.2.4. Here is the section:
>

this change is ok by me

James

>b) if the LS wants to transmit location information it is not 
>allowed to do so. The retention-expires field would also give 
>guidance on how long it is permitted to keep the location.
>
>Since this is a change to normative language, if folks have 
>objections to it we're requesting that they send them to the list by 
>next Wednesday, July 13.
>
>Thanks,
>Alissa
>
>
>
>_______________________________________________
>Geopriv mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/geopriv

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 8 Jul 2011 15:10:57 -0400

Fine with me.

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 8 Jul 2011 22:14:58 +0300

Fine for me.

---

From: "Richard L. Barnes" <[email-masked]>
Date: Fri, 8 Jul 2011 15:32:17 -0400

+1

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 11 Jul 2011 09:31:25 +0800

Yeah.  Much better in fact.

On 2011-07-09 at 05:32:17, Richard L. Barnes wrote:
> suggested a slight change to some normative language in section 4.2.4.
> Here is the section:
> >>
> >> Rules that accompany a given LO in order to determine how the LS 
> >> may use the LO (if any Rules are included by reference, the LS 
> >> SHOULD attempt to download them).  If the LO includes no Rules that 
> >> allow the LS to transmit the LO to another entity, then the LS MUST 
> >> NOT transmit the LO.  If the LO contains no Rules at all (if it is 
> >> in a format with no Rules syntax, for example), then the LS MUST 
> >> delete
> it
> >> If the LO included Rules by reference, but these Rules were not 
> >> obtained for any reason, the LS MUST NOT transmit the LO and MUST 
> >> delete it.
> >>
> >> NEW:
> >> If the LO included Rules by reference, but these Rules were not 
> >> obtained for any reason, the LS MUST NOT transmit the LO and MUST 
> >> adere to the provided value in the retention-expires field.
> >>
> >> a) if the LS does not want to re-transmit location information then 
> >> it does not immediately have to delete the received location object
> but instead looks at the retention-expires field only.
> allowed to do so. The retention-expires field would also give guidance 
> on how long it is permitted to keep the location.
> >>

---

From: "Carl Reed" <[email-masked]>
Date: Mon, 11 Jul 2011 11:05:23 -0600

Also +1

Carl

----- Original Message ----- 
From: "Richard L. Barnes" <[email-masked]>
To: "Hannes Tschofenig" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, July 08, 2011 1:32 PM
Subject: Re: [Geopriv] geopriv-arch AUTH48

>>> draft-ietf-geopriv-arch-03 is in AUTH48 and the authors have suggested a 
>>> slight change to some normative language in section 4.2.4. Here is the 
>>> section:
>>>
>>> b) if the LS wants to transmit location information it is not allowed to 
>>> do so. The retention-expires field would also give guidance on how long 
>>> it is permitted to keep the location.
>>>
>>> Since this is a change to normative language, if folks have objections 
>>> to it we're requesting that they send them to the list by next 
>>> Wednesday, July 13.
>>>
>>> Thanks,
>>> Alissa
>>>
>>>
>>>