Subject: [Geopriv] comments on draft-ietf-geopriv-relative-location

From: Kipp Jones <[email-masked]>
Date: Tue, 31 Jul 2012 19:07:53 -0500

Can you clarify the situation described on page 7, section 4.1 wrt dynamic location information.  I'm not sure I quite get how the dynamic information modifies the coordinate system.  In particular, how do the <speed> and <heading> change the coordinate system?  It seems these would only affect things that were measured over time, not at a point in time.

Section 4.11.2.1, page 21.  wrt the 3rd coordinate in the map offset, I assume the origin and orientation of the 3rd dimension are left purposefully vague?  Is there any guidance on how that should be understood?  Seems like generally you could assume the 3rd dimension is vertical and positive would indicate 'up' with a value of 0 being the 'bottom' of the map.

Section 4.11.2.2, page 21, first paragraph, 3rd sentence should read "...sum of the orientation field..."

Other than that, great stuff, I'm all for it!

Cheers,

Kipp
..............................................
Kipp Jones
Chief Architect/Privacy Czar
[email-masked]<mailto:[email-masked]>
m: 404.213.9293 | @skykipp

---

From: "Carl Reed" <[email-masked]>
Date: Tue, 31 Jul 2012 19:22:12 -0600

Kipp -

Perhaps some terminology issues.

>From ISO 19111: Spatial Referencing by Coordinates (this document was written by OGC Members who happen to be geodesists). 

coordinate system
set of mathematical rules for specifying how coordinates are to be assigned to points

So, based on this definition, the coordinate system can be dynamic and change over time or change based on the current gravimetric model of the earth or some other factors. One issue to consider is whether an object exists in the traditional earth centric Cartesian space or in some other space.

A Coordinate Reference System (CRS) is a “coordinate system which is related to the real world by a datum”.

The CRS should not change for an object over time or movement.

Now, there is also the concept of spatial reference systems which can definitely change as an object moves through space. For example, a human outside a building may be located using latitude/longitude (say as described by EPSG 4326). The mobile human then moves into a building and their spatial reference system totally changes – go 15 feet right to the 3rd elevator and go up 4 floors etc. There is also standards work in the realm of SRS.

I know I am not answering your question on CS – that will be up to the authors.

Cheers

Carl Reed, PhD
CTO
OGC

From: Kipp Jones 
Sent: Tuesday, July 31, 2012 6:07 PM
To: GEOPRIV WG 
Subject: [Geopriv] comments on draft-ietf-geopriv-relative-location

Cheers,

Kipp

.............................................. 
Kipp Jones
Chief Architect/Privacy Czar
[email-masked]
m: 404.213.9293 | @skykipp

--------------------------------------------------------------------------------
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv