Subject: Re: [Geopriv] Geopriv Digest, Vol 102, Issue 8, message 1 & 3

From: Matt Lutze <[email-masked]>
Date: Mon, 12 Nov 2012 12:32:40 -0500

Good day,

I have a comment and a few observations, if I may expose my ignorance to ask them (and apologize if the topics have already been discussed):

First, the comment:

>> IP addresses identify a device and it's location on the Internet, not it's 
>> geographical location (although there is some correlation, assuming no 
>> tunnels), or the person who is using it.
> 
> Sounds very reasonable and I totally agree .. but don't we use IP address to determine geographic locations? Isn't that what google, youtube and other big names use to determine locations? 

Outside of generally looking at an IP address to guess at a host's regional location, I would posit that services today determine location by asking a device to allow the service to use an Application layer method for location detection—accessing a GPS and/or Wi-Fi radio on the device.  

A few observations:

The arguments for this extension seem to generally be focused on providing services that may require or be preferred to have different policies and implementations for the various higher level services that actually need them. Another way, it would seem to me that a router using GPS to indicate its physical location will use that differently than a mobile device replying with its location to a web application. 

Particularly, implementing GPS as an extension of IP means that special considerations needed by an upper level protocol—perhaps setting a TTL for the location, or specifying a quality or resolution—would all have to be supported in IP, unnecessarily increasing the complexity of the extension in a protocol whose paramount strength is its simplicity. Ammar, is illustrated by the arguments you make in message 3 below—periodicity of updates should be a function of the application layer protocol, not IP. 

Further, given the notion that the IP header "should" be stripped from a datagram before the payload is passed up to higher level protocols, I would find it more logical that the GPS location be implemented in the final protocol and not require the fuzzy layer boundary violations this would imply. 

Generally, I think my resistance is that IP is supposed to handle internetwork addressing. Relaying a GPS location doesn't immediately correlate with the purpose of providing a device with an address, or servicing that address, and so it seems to me that GPS location doesn't belong. 

An HTTP-GPS, ICMP-GPS, etc., extension would seem the appropriate implementation. 

Respectfully,
Matt Lutze

On Nov 12, 2012, at 6:17 AM, [email-masked] wrote:
> 
> 
> Message: 1
> Date: Mon, 12 Nov 2012 11:42:27 +0300
> From: "Ammar Salih" <[email-masked]>
> To: "'Mark Smith'" <[email-masked]>
> Cc: [email-masked], 'Eitan Adler' <[email-masked]>,
> 	[email-masked]
> Subject: Re: [Geopriv] Adding GPS location to IPv6 header
> Message-ID: <[email-masked]>
> Content-Type: text/plain;	charset="UTF-8"
> 
>> IP addresses identify a device and it's location on the Internet, not it's 
>> geographical location (although there is some correlation, assuming no 
>> tunnels), or the person who is using it.
> 
> Sounds very reasonable and I totally agree .. but don't we use IP address to determine geographic locations? Isn't that what google, youtube and other big names use to determine locations? 
> 
> 
>> There is a Geolocation API for web browsers, perhaps it could be 
>> generalised to suit other applications.
> 
>> http://dev.w3.org/geo/api/spec-source.html
> 
> This is exactly what I am talking about, too many applications for the same purpose, we need one lower layer mechanism to unify all of them and make integration more flexible and compatible.
> 
> 
>> To identify people, to then determine their attributes (e.g. their 
>> preferred language), you have to use "attributes" of them, not the machine 
>> they're currently using or where it is located on the Internet e.g. what 
>> they know, what they are or what they have.
> 
> This is how the majority of Internet work today, based on IP address, I gave google as an example, plus language is not the only benefit, how about other benefits, like Ads and commercials, I mentioned an example of getting Ads of restaurants in my city instead of getting Ads about all restaurants in country. 
> 
> 
> Ammar
> 
> […]

> ----- Original Message -----
> 
> Message: 2
> Date: Mon, 12 Nov 2012 10:11:21 +0000
> From: Robin Wilton <[email-masked]>
> To: Ammar Salih <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, Eitan Adler
> 	<[email-masked]>,	Mark Smith <[email-masked]>,
> 	"[email-masked]" <[email-masked]>
> Subject: Re: [Geopriv] Adding GPS location to IPv6 header
> Message-ID: <[email-masked]>
> Content-Type: text/plain;	charset=utf-8
> 
> Coming to this quite late in the discussion, here's my 2?, in case it helps provide a relatively disinterested (but not *un*-interested) summary so far:
> 
> - The benefits expected from the proposed enhancement seem very hard for the mailing list to pin down and express (some are disputed as benefits, while others are acknowledged, but minor...).
> 
> - Some use-cases have been described, but I think it would be fair to say that none of them describes an absolute "can't live without it" need for the enhancement. Most of the claimed benefits seem to be realisable by other means, potentially for less effort.
> 
> - The people who would have to do the work to implement and deploy the enhancement are not the ones who would get the direct benefit - which makes it hard to build a rationale for doing it.
> 
> From an identity, privacy an policy perspective, there's also this: any time you have something which builds identity (and for the sake of this discussion I'm going to treat 'long-term and relatively accurate data about location' as a form of identity) into the online infrastructure, there is often some claimed benefit from it, but there is also a corresponding drawback in terms of privacy and security. 
> 
> For instance, copyright law enforcement has been cited as one possible use of the location data - but actually, GPS precision is almost certainly excessive for this purpose, given that copyright regimes apply at the level of the nation state, not the GPS co-ordinate... And once the data is in the header, it will get used for whatever purpose people can find to exploit or monetize it. It is by no means certain that all those purposes will be in the interests of the end user,
> 
> For example, 'language preference expression' may seem like a neutral enough goal, but then we should also consider - what happens if the technical infrastructure starts to identify you specifically as a Bosnian Muslim, or as an Arab Israeli, or as a Kurd living in Turkey... 
> 
> As I say, these are just my thoughts as someone coming late to the discussion and with no particular 'investment' in it to pursue... hope this is useful, though.
> 
> Yrs.,
> 
> Robin
> 
> 
> 
> 
> Robin Wilton
> 
> Technical Outreach Director - Identity and Privacy
>>> 
>>> --

[…]

> Message: 3
> Date: Mon, 12 Nov 2012 14:17:36 +0300
> From: "Ammar Salih" <[email-masked]>
> To: "'Robin Wilton'" <[email-masked]>
> Cc: [email-masked], 'Eitan Adler' <[email-masked]>,	'Mark
> 	Smith' <[email-masked]>, [email-masked]
> Subject: Re: [Geopriv] Adding GPS location to IPv6 header
> Message-ID: <[email-masked]>
> Content-Type: text/plain;	charset="UTF-8"
> 
> Robin,
> 
>> Coming to this quite late in the discussion, here's my 2?, in case it 
>> helps provide a relatively disinterested (but not *un*-interested) summary 
>> so far:
> 
> I am happy to hear from all of you guys, your notes are highly appreciated! 
> 
>> From an identity, privacy an policy perspective, there's also this: any 
>> time you have something which builds identity (and for the sake of this 
>> discussion I'm going to treat 'long-term and relatively accurate data 
>> about location' as a form of identity) into the online infrastructure, 
>> there is often some claimed benefit from it, but there is also a 
>> corresponding drawback in terms of privacy and security. 
> 
>> For instance, copyright law enforcement has been cited as one possible use 
>> of the location data - but actually, GPS precision is almost certainly 
>> excessive for this purpose, given that copyright regimes apply at the 
>> level of the nation state, not the GPS co-ordinate... And once the data is 
>> in the header, it will get used for whatever purpose people can find to 
>> exploit or monetize it. It is by no means certain that all those purposes 
>> will be in the interests of the end user.
> 
> User should have the option of not sending location update by setting all zeros in the location field, telling the ISP routers not to do so as well, in that case the user protects his/her privacy but loses the benefits of location-based services .. and if you choose to let the ISP routers to tag your packets with location updates then it will not be very accurate, it will be based on your physical connection like mobile tower your connected to, or even less accurate like the city (or even country) your are connecting from. In a way that allows the implementation of copyright law without compromising the privacy.
> 
> 
>> For example, 'language preference expression' may seem like a neutral 
>> enough goal, but then we should also consider - what happens if the 
>> technical infrastructure starts to identify you specifically as a Bosnian 
>> Muslim, or as an Arab Israeli, or as a Kurd living in Turkey... 
> 
> technical infrastructure can do much more if they have bad intents, they can simply identify Muslims, Arabs, Kurds based on destinations (like Islamic websites or VoIP calls with area code) so it's not only source, in fact they can do layer-7 classification and marking based on the actual content of each packet - unless your data are encrypted, and get much more information than your physical location... again it's users option to set the location to all zeros.
> 
>> As I say, these are just my thoughts as someone coming late to the 
>> discussion and with no particular 'investment' in it to pursue... hope 
>> this is useful, though.
> 
> I would like to thank you very much, your professional points will defiantly add more value to the draft.
> 
> 
> […]
> 
> End of Geopriv Digest, Vol 102, Issue 8
> ***************************************

---

From: "Carl Reed" <[email-masked]>
Date: Mon, 12 Nov 2012 11:31:21 -0700

Also perhaps exposing my ignorance (not about geo but about IPv6), but what about the location option to DHCP?

“Dynamic Host Configuration Protocol Options for Coordinate-Based Location Configuration Information” [RFC 6225]

This document specifies Dynamic Host Configuration Protocol options
   (both DHCPv4 and DHCPv6) for the coordinate-based geographic location
   of the client. Why not leverage existing work that has been harmonized with location encodings and abstract models used in the IETF, ISO, JTC1, OASIS, and the OGC?

Cheers

Carl

From: Matt Lutze 
Sent: Monday, November 12, 2012 10:32 AM
To: [email-masked] 
Subject: Re: [Geopriv] Geopriv Digest, Vol 102, Issue 8, message 1 & 3

Good day,

First, the comment:

A few observations:

Respectfully,
Matt Lutze

  Message: 1

  Ammar

  […]

  ----- Original Message -----

  Message: 2

  Yrs.,

  Robin

  Robin Wilton

      --

[…]

  Message: 3

  Robin,

    so far:

    this is useful, though.

  […]

--------------------------------------------------------------------------------
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: Kipp Jones <[email-masked]>
Date: Mon, 12 Nov 2012 13:22:42 -0600

Just a minor point, but has anybody considered how many routers buried deep in building infrastructure can actually receive a reliable GPS signal?

If geolocation is the intent, I would suggest using a technology agnostic moniker rather than GPS to indicate that intent.

Kipp

Sent from my iPhone

On Nov 12, 2012, at 1:31 PM, "Carl Reed" <[email-masked]<mailto:[email-masked]>> wrote:

   of the client.

Why not leverage existing work that has been harmonized with location encodings and abstract models used in the IETF, ISO, JTC1, OASIS, and the OGC?

Cheers

Carl

From: Matt Lutze<mailto:[email-masked]>
Sent: Monday, November 12, 2012 10:32 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Geopriv] Geopriv Digest, Vol 102, Issue 8, message 1 & 3

Good day,

First, the comment:

A few observations:

Respectfully,
Matt Lutze

On Nov 12, 2012, at 6:17 AM, [email-masked]<mailto:[email-masked]> wrote:

Message: 1
Date: Mon, 12 Nov 2012 11:42:27 +0300
From: "Ammar Salih" <[email-masked]<mailto:[email-masked]>>
To: "'Mark Smith'" <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>, 'Eitan Adler' <[email-masked]<mailto:[email-masked]>>,
[email-masked]<mailto:[email-masked]>
Subject: Re: [Geopriv] Adding GPS location to IPv6 header
Message-ID: <[email-masked]<mailto:[email-masked]>>
Content-Type: text/plain; charset="UTF-8"

Ammar

[…]

----- Original Message -----

Message: 2
Date: Mon, 12 Nov 2012 10:11:21 +0000
From: Robin Wilton <[email-masked]<mailto:[email-masked]>>
To: Ammar Salih <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Eitan Adler
<[email-masked]<mailto:[email-masked]>>, Mark Smith <[email-masked]<mailto:[email-masked]>>,
"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Geopriv] Adding GPS location to IPv6 header
Message-ID: <[email-masked]<mailto:[email-masked]>>
Content-Type: text/plain; charset=utf-8

Yrs.,

Robin

Robin Wilton

--

[…]

Message: 3
Date: Mon, 12 Nov 2012 14:17:36 +0300
From: "Ammar Salih" <[email-masked]<mailto:[email-masked]>>
To: "'Robin Wilton'" <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>, 'Eitan Adler' <[email-masked]<mailto:[email-masked]>>, 'Mark
Smith' <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Subject: Re: [Geopriv] Adding GPS location to IPv6 header
Message-ID: <[email-masked]<mailto:[email-masked]>>
Content-Type: text/plain; charset="UTF-8"

Robin,

[…]

________________________________
_______________________________________________
Geopriv mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/geopriv
_______________________________________________
Geopriv mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/geopriv