Subject: [Geopriv] draft-jones-geopriv-sigpos-survey-01 section-10

From: Martin Thomson <[email-masked]>
Date: Wed, 7 Nov 2012 15:15:29 -0500

I see that this is largely cribbed from HELD.

We made a number of choices for HELD that were  ...special.  These
were as a consequence of the source address validation that is
required by the protocol.  These considerations should not apply to
this application.  Copying HELD is not appropriate.

--Martin

---

From: "Richard L. Barnes" <[email-masked]>
Date: Wed, 7 Nov 2012 15:20:12 -0500

Yeah, this section is pretty pro-forma.

Honestly, I think it can be safely deleted.  Adam commented at IETF84 that he expected some protocol aspect to this, but it seems to me that (1) we have tons of ways to pass around XML documents, and (2) we don't really know right now which one of those will make sense in a larger system.  So it's fine to focus this on the XML syntax, and that can drop into transports later. 

On Nov 7, 2012, at 3:15 PM, Martin Thomson <[email-masked]> wrote:

> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv

---

From: "John Pickens (jopicken)" <[email-masked]>
Date: Wed, 7 Nov 2012 20:22:03 +0000

Also noticed the three tiers of metadata, including "rights", and "hardware".  These elements seem out of scope.  

J

---

From: Martin Thomson <[email-masked]>
Date: Wed, 7 Nov 2012 15:25:31 -0500

I was going to make exactly the same comment.  While context is
valuable, I don't see a need for the definition of a protocol.

---

From: Kipp Jones <[email-masked]>
Date: Wed, 7 Nov 2012 16:27:12 -0500

Fair enough, thanks for the feedback...happy to proceed without it.

Kipp